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About this manual

About this manual

This is the Reference manual for EM 2040 for the Seafloor Information System (SIS).

The purpose of this manual
The purpose of this reference manual is to provide full description of the procedures and
parameters required to allow for safe and efficient use of SIS, as well as a thorough
understanding of the system parameters and adjustments.
Note

The SIS Operator Manual is identical to the six first chapters of the SIS Reference
Manual.
Please note that examples or illustration from a different echo sounder than yours may
be given within this manual. This will however not be the case for the installation and
runtime parameter descriptions applicable to your echo sounder.

Contents
• SIS system description on page 15 – gives a brief and general description of SIS

and it's use
• Graphical user interface on page 25 – description of the SIS user interface
• Windows and views on page 55 – presents all available SIS frames and their purposes
• The menu system on page 103 – presents the SIS menus
• Operational procedures on page 108 – contains detailed description on how to carry

out different common SIS operations
• Parameter references on page 209 – contains detailed description of all parameter

settings available from the frames and menus in SIS, including description of all EM
specific runtime and installation parameters

• SIS utilities on page 394 – contains description of added functionality that comes
with SIS

• Technical references on page 486 – in depth information about SIS
• Datagram and file formats on page 529 – contains file and datagram formats used

in SIS

Software version
This manual complies to SIS software version 4.0.
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Registered trademarks

Windows®, Windows XP®, and Windows® 7 are either registered trademarks, or
trademarks of Microsoft Corporation in the United States and/or other countries.

EM® is a registered trademark of Kongsberg Maritime AS in Norway and other countries.

References

Refer to the following manuals for additional information about SIS. These
manuals are available through SISHelp. Press the Windows Start button, select All
Programs→SIS→SISHelp to access relevant SIS documents. The documents are also
enclosed on your SIS installation DVD.

The documents provided are (document numbers in brackets):
• SIS Operator manual [164709]
• SIS Reference manual for EM 2040 [342682] – this manual
• EM Series datagram formats [160692]
• Software installation procedure [164891]
• SIS software release note [164890]

Support

Support Hydrography/Naval: km.hs@kongsberg.com

24 hrs support telephone: +47 99 20 38 01

All Kongsberg Maritime products (24 hours): +47 815 35 355

E-mail: km.support@kongsberg.com
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SIS system description

Topics
• Basic description on page 15
• SIS system information on page 16
• SIS licences on page 16
• System drawing on page 17
• SIS system overview on page 18
• SIS operational principles on page 21
• SIS as a controller on page 22

Basic description
Seafloor Information System (SIS) is a real time software designed to be the user
interface and real time data processing system for hydrographic instruments produced
by Kongsberg Maritime AS. Today the echo sounders EM 3002, EM 3001, EM 3000,
EM 2040, EM 2040C, EM 2000, EM 1002, EM 710, EM 302, EM 300, EM 122, EM
121A, EM 120, ME70/BO, EA 400 and EA 600 are supported. SIS is included on all
deliveries of multibeam echo sounders from Kongsberg Maritime. The main task for
SIS is to be an intuitive and user friendly interface for the surveyor, providing the
functionality needed for running a survey efficiently.

SIS operates under the Windows operating system, and is compatible with the HWS
(Hydrographic Work Station) operator PC hardware. Up to four screens can be used on
one HWS, and SIS can also show geographical displays on several remote PCs in the
network.

The Kongsberg Maritime echo sounders are complete systems. All necessary sensor
interfaces, data displays for quality control and sensor calibration, seabed visualization,
and data logging are standard parts of the systems, as is integrated seabed acoustical
imaging capability (sidescan).
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SIS system information
Operating systems supported:
• Windows XP™
• Windows 7™
Hardware supported:
• HWS
• 1 or 2 displays, optional 4 displays if a second video card is installed
Licence control:
• By dongle connected to USB port
Options/versions:
• Basic version – Instrument control
• Multibeam echo sounder support
• Real time data cleaning
• Water column imaging
• SIS Objects

C-Map installation notes
• C-Map is NOT automatically installed.
• To install C-Map, launch InstallCMAP from the Windows Start button, then select

→Programs→SIS→InstallCMAP and follow the instructions.
• All menu items and the option to load C-Map charts in the Geographical display is

enabled only when C-Map is installed and the file enableCMAP.bat in the SIS/bin
folder has been run.

SIS licences
The SIS software is subject to license control. Licensing of SIS is controlled by a HASP
dongle. This dongle is programmed according to what SIS version has been purchased.
The control part of SIS is unlicensed. This version gives access to the following
applications:
• Installation and runtime parameters
• Start/stop logging
• Survey administration
• New survey
• Messages, Beam intensity, Cross track, Time series, Seabed image, Numerical display

and Water column windows
An unlicensed version of SIS will also work as an interface to third party software.
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System drawing
The figure below shows the principle drawing of the hardware setup with the SIS
software package, integrated with single beam or multibeam echo sounder systems.

Figure 1 Principle drawing, hardware setup with SIS
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SIS system overview
The main task of SIS is to be a logical and user friendly interface for the surveyor,
providing required functionality for running a survey efficiently.
Advanced features of SIS are:
• Control of several instruments simultaneously, both single- and multibeam echo

sounders
• Screen layout with up to seven simultaneous display windows defined by the user
• Real time data cleaning of bathymetric data
• Enhanced functions for visual and automated data quality control
• Graphical displays for sound speed at sonar head and sound speed profile
• Built in health tests of the multibeam echo sounder and continuous monitoring the

quality of input data. Error situations are logged, and user notifications are given
advising what action to take.

• High resolution seabed image mosaic can be viewed in the Geographical view
• Unique features for plotting of scaled maps in size up to A0
• Imaging of acoustic reflectors in the water column (fish, biomass, etc.)
• Real time computation of the mean sea level using a geoid model
• Real time compensation for tide
• Fully operational when echo sounder is mounted on ROV/AUV
• Post processing of GNSS raw position data using Precise Point Positioning

Basic version – Instrument control
With the basic/instrument control version of SIS you can select which instrument to
operate, turn it on/off, store data on/off, change setup and operating parameters and
export data. There are graphical windows for quality checking of sensor input and the
data produced. Sound speed at sonar head and sound speed profile input are interfaced
and handled correctly in real time.
Multibeam echo sounders have built-in tests which can be activated to verify that the
hardware is working correctly. In addition SIS constantly monitors input data to ensure
the data quality. Error situations are logged and user notifications are given with advice
of what action the operator should take.

Multibeam echo sounder support
Licensed multibeam support gives access to:
• More QA views for the multibeam data
• System calibration
• Visualisation of high resolution seabed backscatter data
• Visualisation of seabed imagery date in the Geographical view
• Plotting of survey results with full plotter resolution
• Support for remote Helmsman Display, connected via Ethernet
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Geographical window

The Geographical window can display a terrain model in 2D and 3D mode. In 2D mode
background maps can be displayed (DXF, C-MAP, KSGPL ascii files, GeoTIFF are
supported), planned survey lines, a user defined vessel symbol, raw (limited) soundings
and gridded (unlimited) terrain model. In 3D mode the seafloor surface can be viewed
from different angles and in different resolutions, the light source can be shifted, and the
surface can be rotated around all axis to obtain the best view.

The Geographical window can be zoomed and panned, and it can be set to follow the
ship’s position automatically.

Grid model from previous surveys can be imported and used as background information
or used for comparison purposes.

A planning module makes it possible to define and edit planned lines, make parallel
lines, define survey regions, etc. Plans can be imported and exported between systems.

Singlebeam echo sounder support

EA singlebeam echo sounders, from version 2.4.0.0 and onwards, have the ability to be
used in a SIS compatible mode of operation. This will enable the EA echo sounder to be
integrated in the SIS topside environment for control, display and data logging purposes.

From the SIS point of view an EA in SIS operational mode will behave as a traditional
EM echo sounder except for some operational restrictions and a different data logging
format.

An EA in SIS operational mode will broadcast it’s presence on the network using port
1999. When detected by SIS it will be named EA600 and it can be started by SIS in the
same manner as used for the EM range of echo sounders.

Only a small number of the different SIS information display frames will be active for
the EA echo sounder. Most noteworthy, no installation and runtime parameter settings
are currently available for this echo sounder. The numerical display will have a restricted
function mainly showing position information, speed and depth. The major display for
the EA operation in SIS will be the Geographical view frame. It is used to present the
depth information in gridded format based on the logged data. The ship’s position will
be shown as a cross, as no heading is currently available in the EA position datagram.

The pinging and logging operation is controlled by the standard SIS buttons used for
this purpose. The data being sent from the EA echo sounder, and logged by SIS, is
processed data (i.e. not raw data).

Real time data cleaning

SIS includes highly efficient algorithms for automatic flagging of soundings which
should be eliminated from the survey. The soundings are not removed, simply flagged as
invalid so it is always possible to reverse the decision easily. For the majority of user
needs, this processing will be satisfactory so that further processing is made either not
necessary or at least substantially reduced.
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The terrain model is generated in real time from input of all soundings available in
one area, not just the current soundings, but all previous soundings in that area. The
processing algorithm automatically chooses the best cell size, and then defines a curved
surface through the majority of the soundings in that cell. This adaptive approach makes
the processing very robust and “clouds” of invalid soundings (like schools of fish) can
be flagged invalid automatically.

The gridding algorithm updates a multi-resolution display grid which makes it possible
to select a grid with the best fit resolution to the selected map scale. Large areas can
then be displayed with low resolution, but still important details can be shown. SIS
can quickly zoom to smaller areas and display the terrain in full detail, even down to
every single depth point.

Water column imaging

Some multibeam echo sounders, depending on model and purchased options, have
built-in support for imaging of acoustic reflectors also in the water column. Such
reflectors are for example fish or other biomass, but can also be submerged buoys
or moorings.

Seabed image

SIS provides three views of seabed image data from multibeam echo sounders. In the
first view, the user is presented with a classical time/across window where all seabed
image is displayed along a time-axis. Second, in the Geographical window the user can
see a low resolution seabed image mosaic by simply displaying reflectivity per display
cell. Third, in Geographical window the user can call for a high resolution seabed image
mosaic image to be displayed on top of the terrain. The resolution is typically 9 to 25
times higher than the maximum resolution of the bathymetric data.

GPS RTK and tide input

SIS provides users of GPS RTK systems to use geoid models in real time. The distance
from the vertical reference to the seafloor, the distance from the geoid to the seafloor,
and the distance from the ellipsoid to the seafloor are all calculated in real time. This
eliminates heave and tide effects in the data in real time. Tide input can also be used
in real time, either predicted tide from ascii files, or tide input from serial lines or
network interfaces.

ROV operations

ROV operations are also supported in SIS. The depth of the ROV can be given to the
echosounder in real time, and SIS will create a terrain model from the data collected
by the ROV. Displays like Crosstrack and Waterfall are also useful when running an
ROV survey.

20 342682/D



SIS system description

SIS Objects
An addition to SIS makes it possible to add markers during survey. The user can define
a set of lines, points, images and text to be displayed, and then the user can add such
objects during survey. Such markers can be bouys, wreaks, shoals, coastlines, dryfall,
etc. These objects can be exported to xml-files, and they can be read and displayed
as background information later.

Precise Point Positioning in SIS
SIS integrates logging of raw GNSS observations from the Seapath 300 system. This
data can be post-processed by applying more precise GNSS clock and orbit information
to give very precise positions, typically in the sub-decimetre range, without use of GPS
reference signals. This utilizes the TerraPOS software (by TerraTec) to compute the high
accuracy position data. The process is highly automated in SIS and easy to use.

SIS operational principles
Note

The SIS software is used by single beam or multibeam echo sounders. When you run
a survey, you can log data from more than one system at a time. This implies that not
all information herein will be relevant for all systems. This is further explained in the
following.

SIS is operated in Online or Offline mode.
• The Online mode is used during the survey. The application is used to control the

(multibeam) echo sounder, to store the data, and to present various views of the data
for quality assurance.

• The Offline mode is used after the survey has been completed, and the data is stored
on disk. The application is used to view the results of the survey.

The standard SIS application will generate full documentation of the survey results, and
provide output for survey statistics, contour charts, illuminated plots etc. For some
purposes this may be sufficient, but normally additional SIS post-processing packages
available are used for data cleaning, image processing and final chart production.

Parameter settings
There are a number of parameters that must be set. These are:
• Installation parameters for setting up e.g. communication, information related to the

physical installation of the sensors and calibration results
• Runtime parameters for setting e.g. the operational modes of the multibeam echo

sounder, sound speed profiles and data cleaning
• Survey parameters for setting e.g. projection, background data and administration

of the survey data
Some parameters need starting values depending on type of operation and water depth.
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You may start SIS by loading a predefined set of parameters, stored in a database, and
then modify some of the individual parameters observing the effect on the displayed
data. The modified parameters, including all the remaining parameters, can then be
stored as a user specified set-up.

All parameters, as well as all the survey information, are stored in a database. The
raw data is stored to disk.

You may wish to optimize system performance by adjusting parameters in the system.
When the results are as desired, the current parameters set may be stored in the database
for later retrieval.

Survey handling

Every echo sounder logs data to a survey. If no survey is defined, data will be logged to
a predefined “fallback” survey.

Note

We strongly advise you to define your own default surveys. A default survey contains
information about where to store the raw and processed data on the disks, what
projection to use, coastlines to display etc.

When you create a new survey, you can use a default survey as a template for the new
survey. This may save a lot of parameter definitions, and make life a lot easier for the
surveyor.

More information
• Operational procedures on page 108
• Parameter references on page 209

SIS as a controller
This manual also describes the use of SIS as an interface between Kongsberg Maritime’s
multibeam echo sounders and third party data acquisition software packages. The two
third party software packages that has been tested and verified by Kongsberg are at
this moment HYPACK ® and QINSy ®. When SIS is working as a controller, the full
SIS functionality is not needed.

An unlicensed version of SIS will work as a controller. The purpose of this is as follows:
• Provide installation parameters needed by the Processing Unit in real time
• Provide runtime parameters (ping rate, coverage etc.)
• Operation and activation of the echo sounder
• Export of echo sounder datagrams to the third party software package
• Data logging in Kongsberg format
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The data logging mentioned above is only provided for testing and debug in case of
equipment problems.
In the case of using SIS as a controller all installation settings have to be set correctly
inside the controller. In addition, position, heading and attitude must be interfaced to
the processing unit.
When SIS operates as a controller, the following will not be a part of the controller and
have to be handled by the third party software:
• Installation parameters to calculate the correct depths (not needed by the sounder

in real-time)
• Calibration
• Quality control of the data
• Data logging for daily operation
• Data cleaning and post-processing
• Creation of digital terrain models (DTM), charts, printouts etc.
The installation values needed in the controller will only be the one needed by the
echo sounder itself to export quality data to third party software. Example: If the
echo sounder is roll stabilized, it needs roll data, correct installation angles for motion
sensor and sonar head.

HYPACK®
The Hypack software package will treat the echo sounder as a separate sensor and provide
the drivers for interfacing. The motion data needed for correction of the echo sounder
data is read from the network (provided by the sounder) together with the range data. The
position is interfaced and logged by Hypack in a standard way (read from serial line).
Note

The motion data provided by the echo sounder is moved from it’s initial position to the
location of the echo sounder. This is done inside the echo sounder Processing Unit.

QINSy ®
Qinsy read the echo sounder range datagrams from the network and all other sensors are
interfaced by Qinsy directly. In other words, position and attitude data is interfaced to
a serial line directly on the Qinsy PC. To provide correct timing of depths and attitude
data the Qinsy PC and the Processing Unit need to be synchronized. This is done by
connecting a 1PPS cable from the position system to the echo sounder Processing Unit
as well as to the Qinsy PC itself. In addition ZDA clock datagrams has to be provided
to the two units. If the echo sounder is roll stabilized then roll data has to be sent
to the Processing Unit.
Note

For detailed information on the setup of software from Hypack or Qinsy, refer to the
manufacturer’s documentation.
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Note

Data logged in the Kongsberg format has been time tagged in the Processing Unit of
the echo sounder. This means that the time tagging is accurate and reliable. If other
logging systems are used, the time tagging of the data is the responsibility of that logging
software if they bypass these files.
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Graphical user interface

This section contains description of the graphical user interfaces and the parameters
related to setting up the appearance of SIS.

Topics
• The application window on page 25
• SIS frames on page 27
• Toolbars on page 33
• View menu on page 38
• Keyboard and mouse operations on page 43
• Hotkeys on page 46
• File storage locations used by SIS on page 47
• Common display buttons on page 48

The application window
All interactions with SIS take place via a windows based interface on the Operator
Station.

When you launch SIS, the application window opens containing several frames that can
be set up. Available options will depend on what instrument you are using.

The SIS application window appears below. A description of its parts follows.
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Figure 2 The SIS application window

Description of the SIS application window
A Frame settings
B Active grid
C Rescan button
D Sonar systems detected, but not started.
E Current sonar system
F Status lamps for current sonar system
G Water Column Logging (WCL) status button
H Raw data logging status
I Pinging status
J Line counter
K Line number
L Time to line shift
M Current survey name
N Main menu
O Main toolbar
P Frame toolbar
Q Available frames
R Status bar
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SIS defines a screen layout with up to seven simultaneous display windows (or frames).
The boundaries between the frames can be shifted so that the frame sizes are adjusted
to the user needs, but the system will make sure that no display frame is ever hidden
behind another one. The information contents of each display frame can be changed
according to the needs.
SIS has many windows, but there are always seven frames. You can choose from a list of
windows for each frame, and you can save and read your own set up.
The frames are designed so that they will never overlap. This makes it impossible to
hide one window behind another. You can change the size of the frames by moving
the slide-bars. The four frames on the left are separated by three slide-bars which can
be moved up and down, and the two frames in the middle are also separated with a
slide-bar. There is also a slide-bar to the left of the four frames, and there is a slide-bar
at the frame to the right.
The menu bar at the top contains common actions such as save/read settings, exit etc.
The next menu bar contains basic controls for all echo sounders. There are drop-down
lists for surveys and survey settings, and for detected echo sounders and the echo sounder
currently being operated. There are also control buttons to rescan for echo sounders,
start/stop logging or pinging and line counting. Status lamps indicates hardware status
for multibeam echo sounders.
In addition to the seven frames in the SIS main layout, up to five additional SIS frame can
be opened in separate “tear-off” windows. See Tear-off windows on page 39 for details

SIS frames
The various windows available in SIS are:
• Beam intensity
• Calibration
• Colour coded depth
• Cross track
• Geographical
• Helmsman Display
• Installation parameters
• Message service
• New survey
• Numerical display
• Planning module
• PU sensor status
• Runtime parameters
• Runtime Parameters Mini
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• Scope display
• Seabed image
• Sensor Layout
• Sound velocity profile
• Stave display
• Survey administration
• Time series
• Waterfall
• Water column
• Empty frame
Each frame is briefly explained in the following. For detailed description of each of
the available frames, please see
• Windows and views on page 55
• Frame toolbars parameters on page 209

Figure 3 Example of SIS frame setup

Geographical
The Geographical window is used to display all geographical data such as:

28 342682/D



Graphical user interface

• DXF files
• Terrain models generated form ASCII xyz files
• Terrain models from surveys
• Geographical net (geographic and projection net)
• Other kinds of background data from ASCII-files
• Depth difference in each grid cell
• Number of points inside each grid cell
• Display of seabed imagery data generated by the GridEngine
• C-MAP background maps
It is possible to display several terrain models at the same time, both the terrain model
that is being generated by the current survey and terrain models generated from previous
surveys. If the data is in ASCII xyz-files, a terrain model can be generated and displayed
as background data.
The Geographical window uses OpenGL for smooth rendering. This means that all views
are 3D enabled and can be rotated in any direction.
SIS uses projection coordinates to display the data. The projection is set from the New
survey or Survey administration frames. You can define your own projection or choose
from a wide range of predefined projections. A 7-parameter datum transformation is
also available.
The Geographical window can display a lot of different information. You can select
from a long list of features what to display.
Note that the terrain model can be display with various depth values:
• Z – the distance from the surface to the seafloor
• Zt – tide corrected depth using a tide file
• Zv – tide corrected depth based on GPS observations and a geoid model
• Zg – the distance from the sea floor to the geoid
• Zr – the distance from the sea floor to the ellipsoid
For each grid cell you can choose if you want to see the minimum, median or maximum
depth.

Note

SIS calculates the median depth, not the mean depth for each cell. The mean depth is
an artificial depth which has not been observed, whilst the median is a real, quality
controlled observed depth.

Beam intensity
The Beam intensity window shows the signal strength for each beam. Blue means
amplitude detection and red is phase detection. Green indicates the quality for each
measurement.
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Cross track

The Cross track window shows the depth from each beam. The x-axis can either be
meters or beams. Blue is amplitude detection and red is phase detection.

Seabed image

The Seabed image window logs seabed image data. The resolution in across direction
depends upon the size of the window, the width of the swath and the resolution of the
sonar. In the across direction a grid will be created to give the highest possible resolution
in the window, and then each and every ping is stacked on top of each other.

Numerical display

The Numerical display window shows a list of current value of 36 different parameters.
The parameters to show can be selected from a comprehensive list of available
parameters.

Some of the parameters will give indication if the value exceed given limits by changing
the background to yellow (warning) or red (error). This makes it possible to easily
discover if there is a problem with some parts of the equipment. All exceptions are
logged by Message service.

Message service

All messages from SIS are stored in the SIS database, SISDB. You can open theMessage
service window to see all messages that have been generated, and when they arrived. It is
possible to mask certain types of messages and write these to a file. You can also choose
a time frame to display the messages from.

Helmsman Display

The Helmsman Display window is usually used together with the Planning module.

When you have selected a planned line for surveying, the Helmsman Display window
will show guidance information to the helmsman, such as position, depth, speed, course,
cross track distance from planned line (XTE), etc.

There is also a history of XTE and a graphic presentation of the XTE and you can choose
which of these parameters to display.

Colour coded depth

The Colour coded depth window shows the depth from each beam. The y-axis is always
time and the x-axis is always beam number.

New survey

In the New survey window parameters defining a new surveys are created, including
survey name, projection, background data, storage location, etc.

30 342682/D



Graphical user interface

Survey administration

In the Survey administration window you can define survey parameters, such as
projection, background data to display and where to store the survey data on disk.
Normally, the default set-up can be used.

Planning module

The Geographical window can be set in Planning mode. From the Planning module
survey lines can be created, survey areas can be defined and filled with parallel lines etc.
You can save the planned lines to a planned job, and read a planned job from disk.

Time series

The Time series window is used to display different kinds of time series. Normally heave,
roll and pitch from the active sensor is displayed. The following can also be displayed:
• Depths and backscatter from four beams selected by the user
• Depth below the water surface for the most vertical beam
• Depth and backscatter of the centre beam
• Single beam and multibeam depths for comparison
• Height
• Heave, roll and pitch from active and/or inactive motion sensor

Waterfall

TheWaterfall window is fully implemented with 3D capabilities. You can zoom, pan and
rotate freely in 3D, and the z-axis can be exaggerated to see small objects better.

Water column

TheWater column window shows a graphical representation of the beam formed data
for the entire water column for each beam. This window is only available for echo
sounders with water column capabilities.

Sound velocity profile

SIS uses the depths generated in the Processing Unit. This means that the depths have
already been corrected for sound speed profile. The current sound speed profile used by
the Processing Unit is shown in the Sound velocity profile window.

Scope display

The Scope display window can be used to investigate the receiver echo data. It is mainly
used for test purposes. The data is not logged. This window is available for multibeam
echo sounders.
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Stave display

The Stave display window shows a graphical representation of the signal level of all of the
receiver elements (i.e. staves). This can be helpful for debug and for performance checks
(display of interference signals, air bubbles, saturation, etc.) The data is not logged. This
window is available for multibeam echo sounders with stave display capabilities.

Installation parameters

The Installation parameters window is used to set fixed installation parameters, including
communication parameters to external sensors, installation offset angles and locations,
calibration results, etc. These parameters are normally set only once. The parameters can
not be modified during operation.

Built In Self Tests (BIST) are run from here.

Runtime parameters

The Runtime parameter window contains parameters that can be changed during
operation, including mode of operation, sound speed profile and filter settings.

In addition you may set the parameters employed by the Real Time Data Cleaning
module.

Calibration

In the Calibration window you will be presented to a cross-section of the data from the
selected survey lines. The Geographical window must be set in calibration mode (C),
the survey lines to use (at least two) for the calibration must be selected and a corridor
along or across these survey lines must be defined. Then the pitch, roll, heading and time
offsets can be altered to visually see the impact on the data in the defined corridor.

When new offsets are obtained these must be entered into the installation parameters.

PU sensor status

Note

The PU – Processing Unit may be a separate hardware unit or an integrated part of the
TRU – Transceiver Unit cabinet, depending on echo sounder system.

For SIS it makes no difference whether the communication is with a PU or a PU inside a
TRU. The term PU is used in this manual.

The PU sensor status window shows how the PU’s input sensors are set up. If any signal
is missing, this is indicated by changed colour.

Runtime parameters Mini

The Runtime parameters Mini window is a subset of the Runtime parameters menu with
the most commonly altered parameters in a small window.
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Sensor layout
The Sensor layout window, display all defined sensors position in a 3D display. This
window will give you an indication if the installation parameters are entered incorrectly.

Related topics
• Tear-off windows on page 39
• Windows and views on page 55

Parameter references
• Frame toolbars parameters on page 209

Toolbars
SIS has two types of toolbars. The Main toolbar is common for all frames. Each frame
also has its own individual toolbar.

Main toolbar
TheMain toolbar is located just below the Main menu. It contains several buttons and
combo boxes.

Figure 4 Main toolbar

A Settings: You can select different display settings from this combo box. Choose
between standard settings or create your own by selecting Save Settings As... in
the File menu.

B Active survey: Select the active survey. All surveys are listed, both the surveys you
log on and the ones imported. You can only calibrate the active survey.

C Rescan: Press the Rescan button, and the program will scan for available echo
sounders on the network. If for some reason contact with the echo sounder is lost, it
is not necessary to shut down and restart SIS.

D Echo sounders - not started: This combo box displays all the echo sounders SIS has
detected on the network at start-up time or when doing a rescan. All multibeam echo
sounders announce themselves on the network when they are active, and SIS will
detect them automatically. Select the echo sounder you want to start from this list.

E Current echo sounder: This combo box displays which echo sounder is currently
being operated. You must choose one at the time when setting the installation and
runtime parameters for the echo sounder. Select the echo sounder you want to
change parameters for from this list.
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F Status lamps: These lamps are for multibeam echo sounders only and applies to
current echo sounder.
• Lamp 1: PU/TRU status (Processing Unit/Transceiver Unit)
• Lamp 2: BSP status (Beamforming and Signal Processing)
• Lamp 3: SH status (Sonar Head)
While logging, the lamps will be continuously updated.
Green Orange Red Grey

OK Warning Error Connected hardware is
not in use

Tip

The 8 last echo sounder originated warning/error messages are displayed as tool
tip when cursor is hovering above the PU, BSP and SH status buttons. The list is
only displayed when they indicate warning or error conditions in the echo sounder
(yellow and red lamps respectively). The messages are numbered with the newest
on top.

G WCL: TheWCL button is used for controlling the water column logging as well as
showing the current water column log status.
By pressing the WCL button the water column logging operation is enabled or
disabled. Water column logging is enabled when the button is in the down position.
The actual water column logging is controlled by the standard Logging button.
The WCL button turns green when the logging is active and red when logging is
enabled, but suspended (i.e. off).
The WCL button is always displayed, but is only active for echo sounders with
water column capabilities.

H Pinging: Press this button to start and stop pinging. Start pinging to activate the
echo sounder (i.e. sending sound into the water). The colour of the button is green
while pinging and red when pinging is off.
The text in the button reflects the current status.

I Logging: Press this button to start and stop logging. Start logging to write data to
disk. The colour of the button is green while logging and red when logging is off.
The text in the button reflects the current status.
Note

If pinging is Off when logging is turned On, pinging will automatically be turned On.
If logging is On and pinging is turned Off logging will automatically be turned Off.

J The Line cnt button is used to create a new line without stopping the logging and
then starting it again. The line count is incremented by one when button is pressed.

K Line counter: The text field displays the line count for the currently selected echo
sounder. The line count is cyclic between 1 and 9999. It is possible to enter a line
number manually.
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If logging is Off the line count is for the next line started. If logging is On the count
is for the current line.

L Remaining time: This field shows the remaining time to log in the current line, i.e.
the time before a new line is started. The time unit is in minutes. (When 1 minute is
displayed this indicates less than 1 minute logging remaining.)

M Current survey: This combo box displays the current survey name. You can select
all surveys for the current echo sounder from this combo box. When selecting
another survey, SIS will change to that survey and start logging to that survey when
this is enabled.
This combo box is disabled when SIS is logging.

Related topics
• Frame toolbars on page 35
• Echo sounder – Not started list on page 35
• Current echo sounder on page 36
• Line counter toolbar set on page 37

Frame toolbars
All frames have their own toolbar. On these toolbars there can be several buttons or just
the Frames button. The most frequent buttons are:
A Show/hide: Press this button to open the Show/hide dialogue box.
B Annotation colours: Press this button to open the Annotation colours dialogue box.
C Dynamic colours: Press this button to open the Dynamic colours dialogue box. The

dialogue box will only be launched if at least one or more surveys are loaded.
D Frame selection button: Press this button to select the content you want in that

specific window frame.

Figure 5 Example of a frame toolbar

The most common buttons are described in Common display buttons on page 48.

Special buttons for each frame are described in Windows and views on page 55

Echo sounder – Not started list
The Not started list will be displayed in a combo box found in the main toolbar.
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The list contains all non-started echo sounders detected by SIS on the
network. The list is linked to the autostart mechanism.
The combo box will only be displayed in two cases:
1 When echo sounders are detected by the system for the first time.

2 When the detected echo sounders differs from the set of echo sounders started in the
previous SIS session. That is, if echo sounders have been added or removed from
the network, and the autostart mechanism therefore is not activated.

In any other circumstance the autostart mechanism will start the echo sounders
automatically and the combo box will be empty and not visible.

Note

The Autostart of the echo sounder can be disabled/enabled under Display found by
selecting Tools→Custom...→Set parameters.

When you select an echo sounder from the list, you start the echo sounder and it will
disappear from the list.
If automatic self test at startup is selected the BIST page will be displayed in a tear off
window and the Run all BISTs sequence will be automatically started. This sequence
can be cancelled at any stage by pressing the Quit button in the pop-up window that is
displayed. When cancelling, the current test must run to completion before the sequence
halts.

Note

If for any reason an echo sounder fails during start (BIST, Built-In Self Test, 99 failure)
the echo sounder will remain in the list and the combo box will still be visible. The
reason for this is to allow you to correct the problem and try a rescan.

If the licensing allows for only one started echo sounder, the combo box will be removed
as soon as the start has been performed with a positive result.
If the licensing allows for several started echo sounders, the combo box will be removed
only when the list is empty, i.e. when all echo sounders has been started.

Related operational procedures
• How to start pinging on page 160
• How to start the echo sounder on page 154

Parameter references
• Display on page 339

Current echo sounder
Current echo sounder gives you a list of the all echo sounders and other instruments that
are connected to the SIS software. Only the current echo sounder is visible in the text
field. Press the arrow to see the entire list or click in the text field.
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Select an echo sounder from the list. This echo sounder is now
available for configuration. Each echo sounder is identified by name
and serial number and all displayed frames will be updated to show
the information from this unit, if applicable. Only one echo sounder
can be selected as current at any given instance, i.e. you can configure

only one echo sounder at a time and you can see data (for example beam intensity, cross
track, numerical data, etc.) only from this current unit.

Related operational procedures
• How to start pinging on page 160
• How to start the echo sounder on page 154
• How to interface a singlebeam echo sounder in SIS on page 156
• How to start and stop logging – Alternative 1 on page 169
• How to start and stop logging – Alternative 2 on page 169
• How to save data on page 169
If you want to add instruments without a PU (Processing Unit/Rack) to the list, use the
External sensors and Instrument combinations found on the Tools menu.
If you want to remove instruments without a PU (Processing Unit/Rack) from the list,
use the Remove instruments found on the Tools menu.

Parameter references
• External sensors on page 371
• Instrument combinations on page 377
• Remove instruments on page 378

Line counter toolbar set

The Line counter button and Line counter text field are found in the toolbar.
The Line counter text field displays the line number for the currently selected echo
sounder. The count is cyclic between 1 and 9999.
When the Line counter is pressed, the line count is incremented by one for all active,
logging echo sounders and not only for current echo sounder.
Note

If current echo sounder is not logging, nothing happens when the line counter button is
pressed.

The line count for an echo sounder can also be incremented by three other mechanisms
in addition to using the line counter button:
1 The line count is incremented each time logging stops showing the next line to be

logged. Only the count for the handled (current) echo sounder is affected.

342682/D 37



Seafloor Information System

2 To avoid very large log files (.all-files) the counter for all active echo sounders are
incremented automatically every 30 minutes. This can be configured from the Main
menu; Tools→Custom...→Set parameters. This, however, only happens when the
counter has not been incremented by other means within the last 30 minutes, i.e. by
pressing the line counter button or by stopping and starting logging.

3 The line counter may be manually edited, when not logging. The edited value is
for the next logged line.

Note

If several echo sounders are used and the line count initially is the same for all, it’s
important to notice that the counts may deviate after a while. This is due to the above
described behaviour.

Related operational procedures
• How to start the echo sounder on page 154
• How to start and stop logging – Alternative 1 on page 169
• How to start and stop logging – Alternative 2 on page 169
• How to save data on page 169

View menu
The View drop-down menu gives you the following choices:
• Tear-off windows on page 39
• Icons on page 40
• C-MAP detail level on page 41
• Colour palette on page 41
• Status bar on page 42
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Tear-off windows
Tear-off windows are accessed from the View menu.

It is possible to open any additional SIS frame in separate "tear-off" windows by
selecting it from the View→Tear Off menu.
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If the selected frame is already open in another window, the frame will be moved to the
new tear-off window, and the other window will be emptied.

It is possible to have multiple tear-off windows open at the same time, a maximum of
five tear-off windows are allowed. However, it is important to note that each open frame
requires some processing power, so you may overload the system by opening too many
windows at the same time. It is recommended to monitor the CPU load. If the CPU load
remains near 100% for any length of time, you may have to close one or more of the
tear-off windows. Frames with high CPU load include the Geographical, Water Column,
Stave Display, Seabed Image and (to a lesser degree) the Waterfall frame.

Note

Parameters for size, location, and frame settings of the tear-off windows are not saved
when settings are saved (File->Save Settings).

Screen capture of the tear-off windows are not stored by pressing Ctrl-S. Only the SIS
mainframe is captured by Ctrl-S.

Icons
The Icons menu is accessed from the View drop-down menu.

Choose between:
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• Small Icons: This will make all the frame toolbar buttons smaller
• Large Icons: This will make all the frame toolbar buttons larger

C-MAP detail level
Note

This menu option will only be available if C-MAP is installed.

The C-MAP detail level is accessed from the View menu.

To specify the detail level of the C-MAP background, choose between the following
display levels with increasing levels of details:
• Basic
• Standard
• Full

Related topics
• C-MAP – Licence administration on page 379
• Geographical – C-MAP manipulation mode on page 225
• C-MAP CM-93/3 on page 443

Colour palette
The Colour palette is accessed from the View menu.

Depending on light conditions where the SIS display is located the colours of may be
changed to best adapt to the conditions.

Choose between the following colour palettes:
• Day: Bright day
• Day Blackback: Day with black background
• Day Whiteback: Day with white background
• Dusk: Dusk – less brightness to adapt to night vision
• Night: Night – lesser brightness to adapt to night vision

Windows PaletteController

Each of above palettes use a colour scheme of 64 colours with different RGB value for
each palette. If used together with PaletteController, all Windows colours can be set as
well.

PaletteController is an additional SIS program found in the installation’s bin directory.
PaletteController can be used to set the Windows colours globally on your computer
according to the colour palettes defined by SIS.
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For PaletteController to take effect you must ensure that the Windows Display
Properties→Appearance is set toWindows Classic style for Windows XP and toWindows
Choice for other Windows platforms.

Status bar
The Status bar is accessed from the View menu.

By selecting Status bar from the view menu you will be given the choice to display
current value of four essential transducer parameters in a status bar at the bottom of the
SIS display. By ticking the check box for each parameter, current parameter value will
be continuously updated in the Status bar. Press the OK button to confirm the selection
and leave the menu.

The following parameters can be displayed:
• Mode: current ping mode
• Depth: current depth
• Across: swath width in metres on the bottom
• Soundspeed: Sound speed at transducer depth
• Last mess.: The last message (error, warning or information message) generated by

the system.
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Tip

Hovering with the cursor above the Last message field will display the last 3 messages
as a tool tip. The messages are numbered with the newest on top.

• Beam sp.: Beam spacing

Keyboard and mouse operations
In SIS there are different combinations of mouse and keyboard operations used to
change the view or give quick access to selected functions. The combination of mouse
and keyboard operation varies slightly depending on the frame you are working in. The
keyboard and mouse operations for panning, rotating and zooming for each frame these
functions applies to are presented in this section.

Topics
• Keyboard and mouse in the Geographical view on page 44
• Keyboard and mouse in the Planning module view on page 44
• Keyboard and mouse in the Sound velocity profile view on page 45
• Keyboard and mouse in the Waterfall view on page 45
• Keyboard and mouse in the Sensor layout view on page 45
• Keyboard and mouse in the Water column view on page 46
• Keyboard and mouse in the Calibration view on page 46

Rotate operations
To understand how to rotate the grid, it may be helpful to visualize a “virtual trackball”
in the centre of the view. To rotate the grid, click and drag the mouse as if you were
trying to rotate this “virtual trackball”. For example, if you click the mouse in the centre
of the view (i.e. the centre of the virtual trackball) and drag straight up or down, the
virtual trackball will rotate about it’s horizontal axis (i.e. the x-axis). This results in
the grid rotating purely about the x-axis.

If you click the mouse in the centre of the view and drag straight to the left or right,
the virtual trackball will rotate about it’s vertical axis (i.e. the y-axis). This results in
the grid rotating purely about the y-axis.

If you click the mouse at the edge of the view, and then drag the mouse, the virtual
trackball will rotate about an axis perpendicular to the plane of the view (i.e. the z-axis).
This results in the grid rotating purely about the z-axis.
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Keyboard and mouse in the Geographical view
Operation Keyboard and mouse operation

Zoom to region Left mouse button

Press left mouse button, drag the mouse to a new area and release the mouse
button.

Pan Right mouse button

Right click in the grid, hold down and move the view.

Zoom Scroll the mouse wheel

To zoom in or out on the geographical view, scroll the wheel forward to zoom
in, or backward to zoom out.

Rotate Shift key + Right mouse button

To rotate the grid, hold down the Shift key, right click and drag the mouse.

Display high res.
seabed image

Left mouse button + Shift key

Mark the area to display as seabed image by using left mouse button to mark
first corner, then press the Shift key, then drag the mouse to desired end corner.
Release buttons.

Note

3D must be enabled to rotate the geographical grid.

Keyboard and mouse in the Planning module view
Use the Ctrl key and the mouse to carry out any editing or manipulation of planned lines.
Operation Keyboard and mouse operation

Accept or Cancel Ctrl + Right mouse button

Use the Ctrl key while clicking the right mouse button to open the Confirm
changes dialogue. Use left mouse button to accept or cancel as required.

Select a line or a
polygon

Ctrl + Left mouse button

Selecting a line or a polygon is carried out by holding the Ctrl key down while
clicking on the object to be selected. Objects already selected will be deselected.

Deselecting multiple
objects

Ctrl + Right mouse button

Deselecting multiple objects can be carried out by holding the Ctrl key down
while clicking on the right mouse button. This will open the Selected objects
dialogue, where you can choose to deselect all selected lines, polygons or both.
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Keyboard and mouse in the Sound velocity profile view
Operation Keyboard and mouse operation

Zoom to a region Left mouse button

Press left mouse button, drag the mouse to a new area and release the mouse
button.
Press the Zoom Reset Button to return the display to the original state.

Zoom Ctrl key + Scroll the mouse wheel

To zoom in or out on the view, hold the ctrl key while scrolling the wheel forward
to zoom in, or backward to zoom out.
Press the Zoom Reset Button to return the display to the original state.

Pan Alt key + Scroll the mouse wheel

To pan up or down along the profile, hold the Alt key while scrolling the wheel
forward to pan down, or backward to pan up.
Note that you can only use the pan functionality if you have zoomed the view.

Keyboard and mouse in the Waterfall view
Operation Keyboard and mouse operation

Pan Right mouse button

To pan the waterfall grid, right click in the grid, hold down and move the view.

Zoom Scroll the mouse wheel

To zoom in or out on the waterfall view, scroll the wheel forward to zoom in, or
backward to zoom out.

Rotate Shift key + Right mouse button

To rotate the grid, hold down the Shift key, right click and drag the mouse.

Keyboard and mouse in the Sensor layout view
Operation Keyboard and mouse operation

Pan Right mouse button

To pan the waterfall grid, right click in the grid, hold down and move the view.

Zoom Scroll the mouse wheel

To zoom in or out on the waterfall view, scroll the wheel forward to zoom in, or
backward to zoom out.

Rotate Shift key + Right mouse button

To rotate the grid, hold down the Shift key, right click and drag the mouse.
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Keyboard and mouse in the Water column view
Operation Keyboard and mouse operation

Force depth Ctrl key + left mouse button

Short-cut to force the bottom detection to selected depth.

Set scope beam
number

Shift + left mouse button

To view the beam pointed on by your mouse pointer in the scope display.

Rotate Shift key + Right mouse button

To rotate the grid, hold down the Shift key, right click and drag the mouse.

Note

The Force depth and the Scope beam functions must have been enabled from the Show/hide
menu of the Water column view before activation is possible.

Keyboard and mouse in the Calibration view
In Calibration mode the Geographical window has the following additional keyboard
and mouse functionality:
To Operation

Select a line Ctrl + Left mouse button

To select a line, hold down the Ctrl key and left click on the line.

Open Calibration Action
Quick Menu

Ctrl + Right mouse button

To open the Calibration Action Quick Menu, hold down the Ctrl key, right click in
the view.

Select corridor Ctrl + Left mouse button

Set the end points of the corridor by holding the Ctrl key down while clicking
left mouse button on each end point.

Hotkeys
The following functional hotkeys are defined in SIS
Key Function

F2 Toggles logging on/off

F5 New line

F10 Toggle pinging on/off

F4 Toggle grid shading on/off

46 342682/D



Graphical user interface

Key Function

F8 Toggle depth under cursor on/off

Ctrl-S Screendump of the application window saved as bmp file

You may redefine the hotkeys used for toggling logging and pinging on/off and for
selecting new line. This is done from Tools→Custom...→Set parameters→Logging.

File storage locations used by SIS
During installation of SIS you will be prompted how to store your data. We strongly
recommend using separate disk partitions for grid and raw data. The grid and raw data
will be stored as follows:
• Raw data: <disk 1>:\sisdata\raw
• Grid data: <disk 2>:\sisdata\grids
The grid data disk will be used internally by SIS, and knowledge of the directory
structure on this disk is not required.
The raw data disk contains raw data logged by SIS, i.e. the *.all files. The directory
structure is by default \sisdata\raw\<survey_name>\, and the filenames of the *.all files
are defined during definition of your survey.
The raw data disk also contains the \common\ directory having a number of subfolders
and use:

Table 1 The <disk 1>:\sisdata\common\ subfolders and their contents and use

Folder name Contents/Use

3D_models Default location for 3D models, i.e. AutoCAD (dwg), Inventor (iv) or VRML (wrl)
files, to be imported into the geographical view.

ath Default location for storing Applanix True Heave (ATH) raw data.

background GeoTIFF files that are generated by pressing the Save background data button

are stored in this location.

backup_settings Every time the OK button in the Installation parameters frame is pressed a
backup file containing current PU parameters is generated. The backup file
can be imported using File→Import PU parameters. The file name convention is
Backup_<echo_sounder_name>_
<serial_number>_<YearMonthDay>_
<HourMinuteSecond>,
e.g. Backup_EM 2040_888_20100428_123035.txt.

bist Built-In Self Test results are saved to this location if the Save button on the BIST
page is pressed.

compass_dev This is the default location of any compass deviation files that you may want to
use. Compass deviation files applies only if you are using SIS without any EM
input, and are using a compass as your heading sensor. The compass deviation
file is selected from the External sensor page.

Events Location of events that are logged using the Global Event Marker.
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Table 1 The <disk 1>:\sisdata\common\ subfolders and their contents and use (cont'd.)

Folder name Contents/Use

javad Default location for storing Javad or Trimble GPS raw data.

KSGPL Default location for storing *.ksgpl files to loaded as background to the
geographical view.

maintenance Default storage location used by SIS Data Logger

message\auto The Message service automatically logs all system generated information,
warnings and error messages and stores the files in this location.

planning This is were the Planning module of SIS by defaults stores its files. The file
location may be altered by the user using standard Windows Save as functionality.

printer_files Default location for storage of the post script printer files that can be made from
the Geographical view by pressing the Printer button.

projections Default location for projection files to be imported into SIS
pu_param Default location for storage of PU parameter files used by File→Import PU

parameters and File→Export PU parameters.

screendumps When pressing Ctrl-S a screen shot will be created and saved as a .bmp file in
this location.

srh Default location for storing Seapath Real Heave (SRH) raw data.

svp_abscoeff This is where the default absorption coefficient files that SIS uses are located.
When you want to load or save an absorption coefficient file from the Runtime
parameters frame this is the default location for opening or saving the file.

svp_logger Default location to log raw SVP data to be used in the SVP Logger utility program.

sys_settings Contains the factory setting PU parameter files for all echo sounder system

terratec Default location for storing RTCM raw data.

user_settings Default location for storing the SIS display settings.

Common display buttons
Each SIS frame holds a toolbar with command buttons for parameter and display settings
applicable to that frame.

The display buttons holds the same functionality independent of what frame it applies to.
The common display buttons are described in this section.

Common display buttons
• Annotation colours button on page 49
• Dynamic colours button on page 50
• Print button on page 51
• Zoom and view buttons on page 51
• Scale buttons on page 53
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Annotation colours button

Display Colours: You can change the colours of the various
elements displayed by double-clicking in the check box(es). The
Colour Dialog window will appear. New colours can be selected
in a number of different ways (using the eye dropper tool,
entering the RGB colour code, using predefined colours etc.).

Select the new colour and click Accept to apply. Cancel if you do
not want to change the colour.
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Dynamic colours button

• Colour map: Select which objects to set
the dynamic colours to.

• Colour wheel: Set the colour representation
of the dynamic colours. Drag the arrow
to set the start and stop limits.

• Direction: Set the direction of the arrow
(CW or CCW).

• Overflow: Choose an overflow strategy for
the colours – only valid when fixed scaling
is selected.
– Clamp - lock to the limits
– Wrap - restart when reaching a limit
– Cut - do not show data outside the limits

• Intensity: Set the intensity of the colours
in the colour map. This can be used to dim
the colour map for low light conditions.

• Scaling: Select automatic or fixed scaling.
• Data Range: Manually set the range

(max/min) for the selected objects. The
total range is automatically found from the
data.

• Single Colour Ranges: Click in the Enable
check box to set a range of data values to a
single colour. For each set of depth ranges

a different colour can be chosen. Double-click in the right check box to open the
Colour Dialog window.

Note

The available settings varies slightly depending on what SIS frame the Dynamic colour
button applies to.
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Print button

Press the Print button to print the view. The Print Setup dialog will open.
The following options are available:
• Destination: Select if you want

to send the print to a postscript
printer or to a file. Files are saved
in postscript format (*.ps).

• Orientation: Select page orientation.
• Paper Size: Select paper size.
• Viewport: Select Current Area to

print current view.
Select Keep Scale to send a larger
area to the printer set by the Zoom
to region dialogue. When selecting
Keep Scale the centre of the view
will correspond to the centre of the
printout.

• Scaling: Select Optimize to Media to
print view with it's actual scale.
Select Best Nice Value to print the
view with rounded scale values.

• Annotation: Show the scale on the
printout or not.

Note

Only postscript printers or plotters can be used.

Zoom and view buttons

Zoom functionality
• in
• out
• to given region
• by mouse
• to ship
• to world
• to active survey
• reset zoom
• reset view
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• pause

Zoom in

When you press the Zoom in button, the magnification of the view will increase.

Zoom out

When you press the Zoom out button, the magnification of the view will decrease.

Zoom to given region

Any user-defined region can be zoomed up to fill the display view. To define the region,
perform the following:
1 Press the Zoom to given region button.

A Zoom to region dialogue box will appear.
2 Fill in the desired scale and the centre coordinates.

Zoom to active survey

When you press the Zoom to active survey button, the Geographical window will zoom
out to an area covering survey data for the active survey.

Zoom to world

When you press the Zoom to world button, the Geographical window will zoom out to an
area covering all loaded survey data. Note that if the data areas are small and widely
spread out the data may become invisible.

Zoom to ship

When you press the Zoom to ship button, the Geographical window will zoom to wherever
the ship is located in the world. This button will be disabled if no vessel is present.
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Zooming using the mouse
In addition to using the zoom buttons above you can also:
• Zoom in or out on the data by using the mouse wheel
• Zoom in on a specific region by pressing the left mouse button, drag the mouse to a

new location and then release the mouse button

Zoom Reset button

Reset the display after a zoom operation. This button is only active if the display has
been zoomed. Clicking on this button will reset the start and stop ranges and the start and
stop range modes.

Reset View Button

Reset pan, zoom and rotation to default values.

Pause button

Pause or continue the display of data. While paused, the display is visible, but not
updated.

Scale buttons

Scale functionality
• auto scale
• auto scale once
• fixed scale

Auto Scale button

Set the Start Range Mode and the Stop Range Mode of both the depth and across axes
to Auto.
When the Start Range is set to Auto, the start range of each axis is automatically set to
the minimum value in the data set each time data is received. When the Stop Range is set
to Auto, the stop range of each axis is automatically set to the maximum value in the
data set each time data is received.
This button provides a quick and convenient way to set both the start and stop ranges
to Auto.
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Pressing this button is equivalent to opening the Show/Hide dialogue and selecting Start
Range→→Auto and Stop Range→→Auto for both the depth and across axes.

Auto Scale Once button

Set the Start Range Mode and the Stop Range Mode (of both the depth and across
axes) based on the values of the current data set, then lock to this range setting for the
remaining of the data.

The fixed start and stop range values in the Show/Hide dialogue will be updated with
the new values. This is a quick and convenient way to change to Fixed range mode
and simultaneously update the fixed start and stop ranges with values appropriate for
the current water column data.

Note

Pressing this button will update the Fixed start range value and the Fixed stop range
value in the Show/Hide dialogue.

Fixed Scale button

Set the Start Range Mode and the Stop Range Mode of both the depth and across axes to
Fixed. The start and stop ranges will be set to the values that were last entered in the
respective Start/Stop Range text boxes in the Show/Hide dialogue.

This button provides a quick and convenient way to set the start and stop ranges of
both axes to Fixed.

Pressing this button is equivalent to opening the Show/Hide dialogue and selecting Start
Range→→Fixed and Stop Range→→Fixed.

Note that this is not equivalent to clicking on the Auto Scale Once button because the
Fixed Start/Stop Range values in the Show/Hide dialogue are not updated in this case.
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Windows and views

This chapter describes the various frames in SIS.
Seven frames can be displayed at the same time. The content of each and every frame is
defined by using the Frame selection button.
When the wanted frame configuration has been set up you may save the frame
configuration for later retrieval. The frame configuration is saved from the main menu,
File→Save settings.

Monitoring Windows
• Geographical view on page 57
• Beam intensity view on page 61
• Colour coded depth view on page 63
• Cross track view on page 64
• Seabed image view on page 66
• Numerical display on page 68
• Message service view on page 69
• Helmsman display view on page 70
• Time series view on page 72
• Waterfall view on page 73
• Water column view on page 75
• Sound velocity profile view on page 79
• Scope display on page 81
• Stave display on page 83
• PU sensor status view on page 86

Survey administration windows
• New survey window on page 89
• Survey administration window on page 91
• Planning module window on page 93

Parameter setup windows
• Installation parameters window on page 94
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• Runtime parameters window on page 95
• Runtime parameters mini view on page 96
• Sensor layout view on page 98

Calibration window
• Calibration view on page 100
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Geographical view
The Geographical window is accessed by selecting it from the Frame selection button or
by opening it as a separate window from the View→Tear Off menu.

Purpose

The main purpose of the Geographical window is to show geographical data like surveys,
shipstracks, coverage, planned lines and so on. The window consists of a geographical
region with a toolbar on top. It can also be referred to as main window.

This window is valid for all instruments.

Toolbar buttons

Figure 6 Toolbar example

The toolbar of the Geographical window holds the following buttons (from left to right):
Click this button To

Enter the geographical display options

Set annotation colours

Set dynamic colours
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Click this button To

Print the view

Show depth under cursor

Toggle grid shading on/off

Toggle between 2D or 3D

Enter inspection mode

Use the position and distance measure. Show position under cursor.

Enter KSGPL edit mode (when selected)

Enter planning edit mode (when selected)

Enter calibration edit mode (when selected)

Follow ship

Zoom to ship

Zoom to world

Zoom to active survey

Zoom to given region

Zoom in

Zoom out

Load background data in .bgksgpl format

Save background image in GeoTIFF format

Enter C-Map manipulation mode (only available when C-Map is installed)

Note

There can only be one edit button activated at a time.
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Modeless operation
• To open the Options menu as a modal dialogue, left click the Option button.
• To open the Options menu as a modeless dialogue, hold down the CTRL key and left

click the Option button. In this mode, you can continue to use the SIS user interface
while the dialogue is open.

• To open the Options menu as a modeless dialogue that always remains on top of other
windows, hold down the CTRL+SHIFT keys and left click the Option button. In this
mode, you can continue to use the SIS user interface while the dialogue is open and
the dialogue will always remain on top of the SIS user interface.

Note

The “modeless” operation of the Options menu is not fully implemented. If a parameter
is changed via the SIS user interface while the dialog is open, the dialog will not be
updated to reflect the change. For example, if you use the 'S' toolbar button toggle
grid shading while the dialog is open, the grid shading setting of the Options dialog
will retain its current setting. The next time you apply settings from the dialog the grid
shading will be toggled back to its original setting. Although the modeless operation
is not fully implemented, it has been included in this release because it is still a useful
feature, because most of the actions you can perform via the SIS user interface do not
affect the dialogue settings.

Quick menu
The Geographical window have a quick menu accessed by clicking
on the right mouse button inside the view. The following features
can be accessed from this menu:
• Menubar

– Annotation colours
– Dynamic colours

– Options
– Print

• Icons
– Small icons
– Large icons

• Frames
– Empty
– All available display frames

• Activate/Deactivate - toggle between Activate/Deactivate depending on the current
mode of the Geographical window

Related operational procedures
• How to display realtime depths on page 161
• How to display a smooth surface on page 165
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• How to look for artifacts on page 165
• How to display seabed imagery data in the Geographical view on page 162
• How to create and use a GeoTIFF background image in the Geographical view on

page 166
• How to display sound velocity at transducer depth in the Geographical view on

page 163

Parameter references
• Geographical – Display options on page 211
• Geographical – Show depth under cursor on page 222
• Geographical – Grid shading on page 222
• Geographical – 2D or 3D on page 223
• Geographical – Inspection mode on page 223
• Geographical – Compass button on page 223
• Geographical – KSGPL edit mode on page 223
• Geographical – Planning edit mode on page 224
• Geographical – Calibration edit mode on page 224
• Geographical – Follow ship on page 224
• Geographical – Load background data on page 224
• Geographical – C-MAP manipulation mode on page 225
• Geographical – Information field on page 225

Related topics
• Keyboard and mouse in the Geographical view on page 44
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Beam intensity view
The Beam intensity window is accessed by selecting it from the Frame selection button or
by opening it as a separate window from the View→Tear Off menu.

Purpose

The Beam intensity view gives a graphical presentation of the beam intensity and signal
quality factors.

This window applies to multibeam echo sounders.

The window contains scales along the left and right vertical axes, giving the signal
strength in dB values on left side and the quality measure for the data on right side.
The beam numbers are shown along the horizontal axis. This number depends on the
echo sounder model.

The window presents two types of bars, either red or blue, for each individual beam. The
bar colour shows what type of bottom detection used for each beam; blue for amplitude
detection and red for phase detection.

The value of each bar is the backscatter signal strength of the bottom presented in dB.
The values are corrected for system parameters, but not for any dependence upon angle
of incidence.

Normally the backscatter signal strength will be highest straight down, typically -15 dB,
and lowest in the outer beams, typically -35 dB. The signal strength depends on bottom
material type and roughness (±15 dB or more).

The green bar shows a data quality measure for each beam. Small values (on a scale
from 0 to 64 or 128) convey good data quality.
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Toolbar buttons

The toolbar of the Beam intensity window holds the following buttons (from left to right):

Click this button To

Enter the beam intensity view's show/hide options

Set annotation colours

Related operational procedures
• How to verify echo sounder main functions on page 162

Parameter references
• Beam intensity – Show/hide on page 227
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Colour coded depth view
The Colour coded depth window is accessed by selecting it from the Frame selection
button or by opening it as a separate window from the View→Tear Off menu.

Purpose

The Colour coded depth window shows the depth per beam shown by colour codes. A
history buffer of varying size is used. The size of the history buffer depends on the size
of the display. One vertical screen unit (pixel) is used per ping. Increasing the vertical
size of the display area increases the number of vertical screen units, thus increasing the
history buffer size.

The Colour coded depth window applies to multibeam echo sounders.

Toolbar button

The toolbar of the Colour coded depth window holds the following buttons (from left
to right):

Click this button To

Enter the colour coded depth show/hide options

Set dynamic colours

Parameter references
• Colour coded depth – Show/hide on page 227
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Cross track view
The Colour coded depth window is accessed by selecting it from the Frame selection
button or by opening it as a separate window from the View→Tear Off menu.

Purpose

The cross track window shows the measured depths in all beams from the last ping. This
window applies to the multibeam echo sounders.

The display contains a depth scale along the left-hand (vertical) axis and beam numbers
or metres along the horizontal axis.

Different colours are used to show if a beam has a valid bottom detection, and if so
what type of detection has been used. Red is used to show beams with phase detection,
blue is used to show beams with amplitude detection. Beams without any detection
are not shown.

Toolbar buttons

The toolbar of the Cross track window holds the following buttons (from left to right):

Click this button To

Enter the cross track display options

Set annotation colours
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Modeless operation
• To open the Options menu as a modal dialogue, left click the Option button.
• To open the Options menu as a modeless dialogue, hold down the CTRL key and left

click the Option button. In this mode, you can continue to use the SIS user interface
while the dialogue is open.

• To open the Options menu as a modeless dialogue that always remains on top of other
windows, hold down the CTRL+SHIFT keys and left click the Option button. In this
mode, you can continue to use the SIS user interface while the dialogue is open and
the dialogue will always remain on top of the SIS user interface.

Note

The “modeless” operation of the Options menu is not fully implemented. If a parameter
is changed via the SIS user interface while the dialog is open, the dialog will not be
updated to reflect the change. For example, if you use the 'S' toolbar button toggle
grid shading while the dialog is open, the grid shading setting of the Options dialog
will retain its current setting. The next time you apply settings from the dialog the grid
shading will be toggled back to its original setting. Although the modeless operation
is not fully implemented, it has been included in this release because it is still a useful
feature, because most of the actions you can perform via the SIS user interface do not
affect the dialogue settings.

Related operational procedures
• How to verify echo sounder main functions on page 162

Parameter references
• Cross track – Display options on page 227
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Seabed image view
The Seabed image window is accessed by selecting it from the Frame selection button or
by opening it as a separate window from the View→Tear Off menu.

Purpose

The Seabed image displays the seabed backscatter data. For each ping a straight line is
plotted, this covers the swath width. The darkness of the display at any point represents
the reflectivity of the bottom.

The horizontal distance between the outermost crosses in the view is set by the swath
width across parameters max and min. If these are set to be ±50 m, the total distance is
100 m. This can be used to make rough dimension estimates of artefacts on the seabed.

This window applies to the multibeam echo sounders.
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Toolbar button

The toolbar of the Seabed image window holds the following buttons (from left to right):

Click this button To

Enter the seabed image show/hide options

Print the view

Range Minimum: Minimum value of dynamic range used for computing colour
map for display. Use the arrows to increade/decrease or enter the value.
Range Maximum: Maximum value of dynamic range used for computing colour
map for display. Use the arrows to increade/decrease or enter the value. The
maximum value will not exceed 0 dB.
Automatically set the range minimum and maximum values. The current
maximum and minimum values of beam intensity from the most recent depth
datagram are used (these values are shown in the beam intensity display).
However, the minimum range window size (for range auto) is limited to 20 dB, so
the maximum and/or minimum values may be adjusted if necessary to satisfy
this criteria.
Move the range up (in dB) by increasing both the range minimum value and
range maximum value by 1 dB. The maximum value will not exceed 0 dB, so the
range will not be moved up past this point.
Move the range down (in dB) by decreasing both the range minimum value
and range maximum value by 1 dB.
Narrow the range by decreasing the range maximum by 1 dB and increasing
the range minimum by 1 dB.
Widen the range by increasing the range maximum by 1 dB and decreasing the
range minimum by 1 dB. The maximum value will not be increased past 0 dB.

Parameter references
• Seabed image – Show/hide on page 231
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Numerical display
The Numerical display window is accessed by selecting
it from the Frame selection button or by opening it as
a separate window from the View→Tear Off menu.

The Numerical display window allows you to monitor
various SIS parameters. The parameters cannot be
changed here. Exceeded limits are shown by red.

If you press the button next to the text, an alphabetically
ordered list with selectable parameters will appear.
Choose the parameter you want to monitor.

This window applies to all instruments.

Some parameters applies to specific instruments only.

Related operational procedures
• How to monitor the external sensors in SIS on

page 160
• How to monitor the survey progress on page 202
• How to verify echo sounder main functions on

page 162

Parameter references
• Numerical display on page 232
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Message service view
The Message service window is accessed by selecting it from the Frame selection button
or by opening it as a separate window from the View→Tear Off menu.

Purpose

The Message service instantaneously displays and logs all system generated information,
warnings and error messages. The automatic generated log files are store in
..sisdata/common/message/auto.

This window applies to all instruments.

Related operational procedures
• How to monitor the external sensors in SIS on page 160
• How to monitor the survey progress on page 202

342682/D 69



Seafloor Information System

Helmsman display view
The Helmsman Display window
is accessed by selecting it from
the Frame selection button or by
opening it as a separate window
from the View→Tear Off menu.

Purpose

The Helmsman Display provides
steering guidance of the ship
relative to planned survey lines.

This window applies to all
instruments.

A line may have several
waypoints, and the DTK,
XTE, CMG and DST deviation
indicators all show their values
to the next waypoint or to the
current line segment. The scale
changes automatically. Red and
green arrows indicate that the
helmsman have to steer port or
starboard to relocate. Before the
ship reaches the start of the line,
the indicator will form an arrow
pointing downwards.

When reaching the end of the
line (or before entering the line)
the Helmsman Display will
continue to display the ship’s

position relative to the continuation of the last line segment of the planned line.

Note

The Helmsman display must be active when SIS is controlling the Autopilot.

Toolbar buttons

The toolbar of the Helmsman display window holds the following buttons (from left
to right):
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Click this button To

Enter the helmsman display show/hide options

Set annotation colours

Related operational procedures
• How to start the Remote Helmsman Display on page 206
• How to plan a new job in SIS on page 201
• How to retrieve a planned job on page 202
• How to display planned lines on the Remote Helmsman Display on page 206

Parameter references
• Helmsman display – Show/hide on page 237
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Time series view
The Time series window is accessed by selecting it from the Frame selection button or by
opening it as a separate window from the View→Tear Off menu.

Purpose

The Time Series window is used for presenting external interfaces or depth information
as time series. Information from one or more sensors or beams can be selected.

Time series may be useful for detection of incorrect performance of the sensors or of
incorrect depth determination.

Toolbar buttons

The toolbar of the Time series window holds the following buttons (from left to right):

Click this button To

Enter the time series show/hide options

Set annotation colours

Clear plot

Related operational procedures
• How to monitor the external sensors in SIS on page 160

Parameter references
• Time series – Show/hide on page 238
• Time series – Clear plot on page 241
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Waterfall view
TheWaterfall window is accessed by selecting it from the Frame selection button or by
opening it as a separate window from the View→Tear Off menu.

Purpose
In the Waterfall window the depth profiles from a number of pings are displayed as a
function of acrosstrack horizontal distance with a small vertical offset between each
profile. This gives a crude 3D representation of the most recently measured bottom area.

Note that the colour coding applied to the profiles shows depth levels, not bottom
detection.

Toolbar buttons
The toolbar of theWaterfall window holds the following buttons (from left to right):
Click this button To

Enter the Waterfall show/hide options

Set annotation colours

Set dynamic colours

Reset the view

Related operational procedures
• How to verify echo sounder main functions on page 162

342682/D 73



Seafloor Information System

Parameter references
• Waterfall – Show/hide on page 241

Related topics
• Keyboard and mouse in the Waterfall view on page 45
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Water column view
TheWater column window is accessed by selecting it from the Frame selection button or
by opening it as a separate window from the View→Tear Off menu.

Purpose
The Water column display shows a graphical image of biomass and other acoustic
reflectors that might be present in the water column. The received amplitude of the
reflected signal through the entire water column for each beam is presented. The vertical
scale on the left of the display shows the depth in metres. The horizontal scale along the
bottom of the display shows the across track distance in metres. The seafloor is shown
as a yellow or red band in the data view.
The display may be found useful for debugging and for habitat monitoring.
A TVG fiunction (x log) is applied to the data.
The water column window applies to multibeam echo sounders with water column
capabilities.
There is a short-cut to forcing the bottom detection around the depth selected by the
mouse.
There is also a short cut to select scope display beam number.

Related topics
• Keyboard and mouse in the Water column view on page 46
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Figure 7 Water column data with associated seabed image – passing a wreck

Note

Sound velocity corrections and ray bending corrections are not applied.
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Water column logging

Water column data can selectively be logged to either the standard log file (.all) or to
a separate water column file (.wcd). Water column datagrams can not be logged to
both files simultaneously.

Water column logging to separate file must be enabled in the Output setup tab under
Installation parameters.

Logging is toggled on/off from the Main toolbar.

Please note that the logged data amount is very large, that is, typically 1 to 2 Gigabytes
per hour.

Separate water column data (.wcd) files may optionally be logged to a disk different from
the one used for the raw data (.all) files. Water column data file locations are set from the
Logging option accessed from Tools→Custom→Set Parameters for details.

Zooming

It is possible to zoom in to a region of the grid by clicking the left mouse button and
dragging a rectangle around a region of the grid. When the left mouse button is released,
the region of the grid to which you have zoomed will be displayed.

Note that the Zoom Reset button now will be enabled, i.e. not longer dimmed. It is
possible to zoom in even further, by clicking and dragging a rectangle inside the zoomed
region.
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To reset the zoom, click the Zoom Reset button. This will return the display to original
scale. You can also reset the zoom by selecting one of the auto range options from
the Show/Hide dialogue.

Toolbar buttons

The toolbar of theWater column window holds the following buttons (from left to right):

Click this button To

Enter the Water Column show/hide options

Set annotation colours

Set dynamic colours

Pause the water column display

Reset zoom

Scale the axes automatically

Scale the axes to currently received data

Scale the axes to fixed values

Related operational procedures
• How to verify echo sounder main functions on page 162
• How to log water column data on page 170

Parameter references
• PU communication – Output setup on page 279
• Water column – Show/hide on page 243
• Water column – Logging on page 247
• Logging on page 341

Related topics
• Keyboard and mouse in the Water column view on page 46
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Sound velocity profile view
The Sound velocity profile window
is accessed by selecting it from the
Frame selection button or by opening
it as a separate window from the
View→Tear Off menu.

Purpose
The Sound velocity profile window is
used for displaying the sound velocity
profile being used by the multibeam
echo sounder. It is not an editor.
The profile is a sequence of points.
These have coordinates with
increasing depth values.

Toolbar buttons
The toolbar of the Sound velocity
profile window holds the following
buttons (from left to right):

Click this button To

Enter the Sound Velocity Profile show/hide options

Set annotation colours

Reset zoom

Related operational procedures
• How to monitor the external sensors in SIS on page 160
• How to collect the sound velocity profile on page 141
• How to convert your sound velocity profile to SIS format on page 143
• How to modify and load a sound speed profile into SIS on page 151
• How to display sound velocity at transducer depth in the Geographical view on

page 163

Parameter references
• Sound velocity profile – Show/hide on page 247

Related topics
• Keyboard and mouse in the Sound velocity profile view on page 45
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• SVP Editor on page 395.
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Scope display
The Scope display window is accessed by selecting it from the Frame selection button or
by opening it as a separate window from the View→Tear Off menu.

Purpose

The Scope display is used for investigating the receiver echo data. It is mainly used
for test purposes. The data is not logged.

The Scope display window applies to all multibeam echo sounders.

The data is presented as an xy series, having time on the horizontal x-axis and receiver
echo level on the vertical y-axis. Beams close to normal incidence will have short
echo and a noisy split beam phase signal. The outer beams will normally have a long
echo and a well-defined phase curve. The range for the bottom detection is indicated
by a vertical dotted line. Amplitude detection, filtered amplitude detection and phase
detection are plotted.

Beam number to investigate is selected from Runtime parameters→Simulator. For
system with dual swath capability the Swath number for the Scope Display is also
selected from here.

The example above shows a phase detection for beam number 30.
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Toolbar buttons

The toolbar of the Scope display window holds the following buttons (from left to right):

Click this button To

Enter the Scope display show/hide options

Set annotation colours

Pause the scope display

Reset zoom

Scale the axes automatically

Scale the axes to currently received data

Reset zoom

Parameter references
• Scope display – Show/hide on page 247
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Stave display
The Stave display window is accessed by selecting it from the Frame selection button or
by opening it as a separate window from the View→Tear Off menu.

Purpose

The Stave display window shows a graphical presentation of the status of all the receiver
elements or staves in the multibeam. The number of staves varies from multibeam
to multibeam.

The Stave display can be helpful for debugging and verifying the performance of a
system, establishing if there is interference from other systems, if there are air bubbles
etc. The data is not logged.

This window applies to multibeam echo sounders with stave display capabilities.

The Stave display presents a grid in which each row of the grid corresponds to one data
sample, and each column in the grid corresponds to one receive stave. Each grid cell
shows the received signal level for the corresponding sample and stave.

The scale along the left vertical axis shows the sample number, the scale along the right
vertical axis shows the range in meters, and the scale along the horizontal axis at the
bottom shows the stave number.
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Toolbar buttons

The toolbar of the Stave display window holds the following buttons (from left to right):

Click this button To

Enter the Scope display show/hide options

Set annotation colours

Set dynamic colours

Pause the scope display

Reset zoom

Scale the axes automatically

Scale the axes to currently received data

Reset zoom

Zooming

You may zoom in to region of the grid
by clicking the left mouse button and
dragging a rectangle around a region
of the grid.

When the left mouse button is released,
the region of the grid to which you
have zoomed will be displayed. Note
also that the Zoom Reset button will
now be enabled (i.e. it is no longer
dimmed). It is possible to zoom in
even further by clicking and dragging
a rectangle inside the zoomed region.

To reset the zoom, click the Zoom
Reset button. This will return the
display to the scaling mode that

existed prior to the original zoom operation. You can also reset the zoom by selecting
one of the auto range options from the Show/Hide dialogue.
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Displaying cell information

It is possible to display the sample number, stave
number, TVG and level for any grid cell. To display
the cell information, hold down the Ctrl key and click
left mouse button on the desired grid cell. Because the
size of the grid cells sometimes is very small (down
to several cells per screen pixel), it may be necessary
to first zoom into a region of the grid before clicking
on a cell.

The cell information will remain on the screen and will be updated in real time as stave
data is received until the user left clicks somewhere inside the grid.

The user can repeatedly display cell information for several cells by holding down the
Ctrl key and repeatedly clicking left mouse button on different grid cells. In this case, it
may be helpful to pause the display first (otherwise the data will continue to be updated
in real time).

TVG curve

It is possible to display the TVG
(Time Varying Gain) curve on top of
the stave data. The TVG curve can be
shown or hidden from the Show/Hide
dialogue. The TVG curve scale is
not shown, however it is possible
to determine the TVG value at any
location on the curve by pressing the
Ctrl key and left mouse button on that
location on the curve.

Parameter references
• Stave display – Show/hide on

page 249
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PU sensor status view
The PU sensor status window is accessed by selecting it from the Frame selection button
or by opening it as a separate window from the View→Tear Off menu.

Note

The PU – Processing Unit may be a separate hardware unit or an integrated part of the
TRU – Transceiver Unit cabinet, depending on echo sounder system.

For SIS it makes no difference whether the communication is with a PU or a PU inside a
TRU. The term PU is used in this manual.

The window is intended for giving an overview of the current reception status of all
selected sensor inputs on a PU. It shows which sensors are selected as active sensors.
The information refers to the PU (Processing Unit) of the echo sounder selected as
Current echo sounder combo box in the Main toolbar.
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The status information is presented as a matrix with columns with the PU input ports
and a row for each of the available sensor types. The settings in this matrix reflects
the settings in the Installation parameters frame (i.e. Installation parameters→PU
Communication Setup→Input Setup). Colours are used to represent the status as follows:
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White: Combination not selected.
Green: Input from sensor selected and received
Red: Input from sensor selected, but not received.
Yellow: Input from sensor selected and received but having poor quality.

Any letters in the marked combinations are used to indicate which combination is set as
the active sensor. Different letters are used in the different supported languages. The
English equivalents are:

P: The marked combination is set as active position sensor.
M: The marked combination is set as active motion attitude sensor.
H: The marked combination is set as active heading sensor.

The display is updated with a frequency of 1 Hz and any changes done in the Installation
parameters frame will be reflected.

Errors (red indications) and poor quality (yellow indications) will be reported to the error
message system and may be viewed in theMessage Service frame. The problem will also
be indicated by setting the appropriate colour (red or yellow) in the PU status lamp in the
Main toolbar in SIS. Errors will have priority over bad quality in the lamp setting.

Note

Poor quality will only be reported for sensors selected as active.

PU sensor input status frame will only contain information for a PU if the PU has been
started (i.e. selected in the “Not Started” combo box in the “Main toolbar”).

PU Sensor logging

Logging of the received sensor data from a selected port can be started by pressing
Shift+Ctrl+Alt+RightMouseButton.

Related operational procedures
• How to monitor the external sensors in SIS on page 160

Parameter references
• PU communication – Input setup on page 275

Related topics
• Main toolbar on page 33
• Current echo sounder on page 36
• Message service view on page 69
• PU sensor input logging on page 440
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New survey window
The New survey window is accessed by selecting it from the Frame selection button or by
opening it as a separate window from the View→Tear Off menu.

Purpose
The New survey setup guides you through the configuration of all essential survey
parameters. These include projection data, background maps, storage location and data
gridding parameters. These are parameters that are vital for the data acquisition, and
incorrect settings may not be possible to correct for in post processing.
Note

To avoid having to set all the survey parameters every time a new survey is created, we
advise you to define your own Survey template from the Survey administration window,
and select this template as basis for your new survey.

The New survey parameters can be saved to current or all survey templates, and it is
thereby not required to set the survey parameters more than once for a survey.
The New survey window contains the following tab-menus:
• Basic parameters – used to create and identify the new survey. The GridEngine

Parameters are used to set the cell size when using the GridEngine gridding method
• Storage options – used to specify parameters for SIS raw data logging
• Advanced options – contains the following sub-tabs:

– Background data – used to specify background data such as projection, background
map, tide and geoid data

– Projections – used to specify what datum and projection to use for the survey
The parameters defined under New survey may also be accessed from the Survey
administration window, the difference being that the New survey parameters applies
to that survey definition only, whereas the Survey administration parameters applies
to templates.

Related operational procedures
• How to configure your survey on page 113
• How to enter parameters for a new survey on page 118
• How to enter survey parameters on page 114
• How to define a new projection and datum transformation on page 122

Parameter references
• Basic parameters on page 263
• Storage options on page 265
• Background data on page 267
• Projection parameters on page 269
• GridEngine parameters on page 269
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Related topics
• Survey administration window on page 91
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Survey administration window
The Survey administration window is accessed by selecting it from the Frame selection
button or by opening it as a separate window from the View→Tear Off menu.

Purpose
The Survey administration setup allows you configuration of all essential survey
parameters. These include projection data, background maps, storage location and data
gridding parameters. These are parameters that are vital for the data acquisition, and
incorrect settings may not be possible to correct for in post processing.
In addition, the Survey administration is an administrative tool for handling several
survey templates.
The Survey administration window contains the following tab-menus:
• User handling – used to identify the SIS user of the survey
• Background data – used to specify background data such as projection, background

map, tide and geoid data
• Survey template handling – contains the same sub-tabs as found in the New survey

window:
– Basic parameters – administrative data for the available survey templates
– Storage options – used to specify parameters for SIS raw data logging
– Advanced options – contains the following sub-tabs:

* Background data – used to specify background data such as projection,
background map, tide and geoid data

* Projections – used to specify what datum and projection to use for the survey
* GridEngine Parameters – used to set the cell size when using the GridEngine

gridding method
* CUBE parameters – used to set the grid specifications when CUBE is being used

Related operational procedures
• How to configure your survey on page 113
• How to enter parameters for a new survey on page 118
• How to enter survey parameters on page 114
• How to define a new projection and datum transformation on page 122

Parameter references
• Basic parameters on page 263
• Storage options on page 265
• Background data on page 267
• Projection parameters on page 269
• GridEngine parameters on page 269
• User handling on page 272
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• CUBE parameters on page 273

Related topics
• New survey window on page 89
• CUBE on page 464
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Planning module window
The Planning module window is accessed by selecting it from the Frame selection button
or by opening it as a separate window from the View→Tear Off menu.

Purpose

The Planning module in SIS is a tool that can be used to create and display survey lines.
These can be parallel lines, lines within a polygon or turns. The lines can be edited,
changed direction of, extended or cut. Guidance information relative to the active survey
line can be sent to the Helmsman display.

Note

All planning buttons are disabled until this the Planning module is activated by:
1 Select Planning from the Show/Hide option of the Geographical window
2 Press the Planning button P

Planning features

The Planning module has three elements:
• Jobs – used to create and save a new job, or to reactivate an existing job
• Remote – used to transfer data to a remote Helmsman Display
• Objects – used to create and manipulate lines and polygons within an existing job

Related operational procedures
• How to plan a new job in SIS on page 201
• How to retrieve a planned job on page 202
• How to display planned lines on the Remote Helmsman Display on page 206

Parameter references
• Planning – Jobs on page 251
• Planning – Remote on page 251
• Planning – Object on page 251

Related topics
• Keyboard and mouse in the Planning module view on page 44
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Installation parameters window
The Installation parameters window is accessed by selecting it from the Frame selection
button or by opening it as a separate window from the View→Tear Off menu.
Note

Pinging must be Off to configure the Installation Parameters

Purpose
The Installation parameters window is used to set parameters for all navigation systems,
motion sensors and sonar heads or transducers connected to the hydrographic system.
These parameters include:
• Sensor locations (x, y, z): Used to input the relative locations of the sensors
• Angular offsets: Input of installation angles of the sensors
• Waterline reference: Definition of the ship's draft relative to the sensors
• Position input system: Setup of position input
• Clock reference: Definition of clock source
• System parameters: Used for setting up Tx and Rx opening angles and backscatter

parameters
• PU input/output datagrams: Definition and setup of input and output datagrams
• BIST: Used for doing the Built-In Self Tests

Related operational procedures
• How to open the installation parameter interface on page 127
• How to modify the installation parameters on page 127

Parameter references
• PU communication – Input setup on page 275
• PU communication – Output setup on page 279
• PU communication – Clock setup on page 281
• Sensor setup – Settings on page 283
• Sensor setup – Location for EM 2040 on page 288
• Angular Offsets for EM 2040 on page 290
• ROV Specific for EM 2040 on page 291
• System parameters for EM 2040 on page 292
• BIST – Built-In Self Test on page 293
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Runtime parameters window
The Runtime parameters window is accessed by selecting it from the Frame selection
button or by opening it as a separate window from the View→Tear Off menu.

The contents of the window will differ, depending on the echo sounder system.
Equipment with a Processing Unit (i.e. all multibeam echo sounders) contains parameter
setting pages for the following features:
• Sounder main: Used to set ping mode, swath coverage, beam spacing, depth and

stabilization
• Sound speed: Used to enter the applicable sound speed data
• Filter and gains: Used to set what filter method and absorption coefficient to apply
• Data cleaning: Configuration of what rules to apply for data cleaning, ping processing,

grid processing and for seabed image processing
• GPS and delayed heave: Used for configuration of logging files related to positioning

and attitude data that optionally can be used in post processing.
• Simulator: Parameters for simulator mode.
• Survey information: Displays survey parameters for current survey.
In addition to the full Runtime parameters window described in this section a scaled
down window with only a subset of essential parameters are also available. This reduced
runtime parameters window will occupy very little space, still allowing you easy access
to basic runtime settings:
• See Runtime parameters mini view on page 96

Related operational procedures
• How to open the runtime parameter interface on page 134
• How to modify the runtime parameters on page 134

Parameter references
• Sounder main for EM 2040 on page 297
• Sound speed for EM 2040 on page 305
• Filter and gains for EM 2040 on page 310
• Data cleaning on page 317
• GPS and delayed heave on page 323
• Simulator for EM 2040 on page 329
• Survey Information on page 332
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Runtime parameters mini view
The Runtime param. Mini frame is accessed by selecting it from the Frame selection
button or by opening it as a separate window from the View→Tear Off menu.

The Runtime Parameters Mini frame provides easy access to most commonly used
parameters of the Runtime Parameters.

The parameters available in the Runtime Parameters Mini frame is a selection from the
Sounder Main tab in the full Runtime parameters window.

Runtime parameters Mini – EM 2040

When the parameters are changed, the background is marked using yellow colour. Press
enter on the keyboard, or make a selection in a combo box, to confirm and send the
parameters to the echo sounder (PU).

Note

When using the buttons in continuous mode no range checking will be made on the
changed parameter values. The parameters can therefore be set outside valid bounds.
However, when the button is released and you press enter to confirm, a single press on
the same button or editing of another parameter will cause an error message to appear if
the parameter is set outside valid boundaries.

Mini and full Runtime parameters frame synchronization
The Mini window can be displayed together with the full Runtime parameters window.
If a change is made and confirmed in one of the two windows the other window will be
updated automatically, keeping the windows synchronised.

Related operational procedures
• How to open the runtime parameter interface on page 134
• How to modify the runtime parameters on page 134
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Parameter references
• Sounder main for EM 2040 on page 297

342682/D 97



Seafloor Information System

Sensor layout view
The Sensor layout window is accessed by selecting it from the Frame selection button or
by opening it as a separate window from the View→Tear Off menu.

Purpose

The Sensor layout gives a graphical presentation of the sensor locations on the ship which
may be useful to verify installation parameters.

Toolbar buttons

The toolbar of the Sensor layout window holds the following buttons (from left to right):

Click this button To

Enter the Sensor Layout show/hide options

Set annotation colours

Reset the view

Zoom in

Zoom out
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Related operational procedures
• How to monitor the external sensors in SIS on page 160

Parameter references
• Sensor layout – Show/hide on page 258

Related topics
• Keyboard and mouse in the Sensor layout view on page 45
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Calibration view
Note

The SIS calibration frame is designed for determination of sensor angular offsets. It is
NOT intended for determining the angular orientation of the system transducers. These
must be determined through measurements as described in the installation manual. The
reason for this is that it is not possible to do a linear addition of sensor offsets and
transducer orientation angles.

The only exception to this is if the transducers are oriented such that they have zero
heading and pitch installation angles, i.e. that they lie horizontal when the pitch is zero
and are mounted parallel to the keel, in which case receive transducer roll installation
angle and sensor roll offset act as a linear sum. This may be exploited in temporary
installations where it may be very difficult to measure roll installation angles with
sufficient accuracy.

The calibration is neither intended for finding remaining errors in XYZ locations of
the sensors. Accurate locations of the sensors must be determined using land survey
methods as described in the systems installation manual.

The Calibration window is accessed by selecting it from the Frame selection button or by
opening it as a separate window from the View→Tear Off menu.

Purpose

The Calibration window is intended for analysis of data from a calibration survey, i.e.
a survey to determine remaining biases in the depth observations. Depths from two
different survey lines is compared in order to visualise the effect of the correction. Please
refer to related operational procedures for description of the principles of a calibration
survey.

The Calibration features of SIS can be run both during online and offline operations.

Note

No correction values will be applied until these are entered in the Installation Parameters
frame

The Calibration frame applies to multibeam echo sounders only.

Toolbar buttons

The toolbar of the Calibration frame holds the following buttons (from left to right):

Click this button To

Enter the Calibration show/hide options

Reset zoom
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Buttons
• Set: Apply changes to the corridor width.

To change the corridor width, enter a new value and press Set. If you select a new
corridor, the previously used offsets will be applied and corrected data will be
displayed in the diagram.

• Apply: Calculate and display the data points after setting new offsets.
• Store: Save the new offsets in the database.
• Auto Calib: If licensed this button brings up the dialogue to enter parameters to be

used by SeaCal.

Quick menu
The Calibration window have a quick menu accessed by clicking on the right mouse
button inside the view.
• Select shiptracks - First select two lines using Ctrl + Left mouse button.
• Create corridor - Then create a corridor using Ctrl + Left mouse button.
The system will now calculate and display the two lines from raw data. For a dual
system one head at a time must be calibrated.

Seacal auto calibration
If licensed the AutoCalib button brings up the dialogue to enter parameters to be used
by SeaCal.
AutoCalib may be used as an alternative to the visual determination of correction values
as offered by the Calibration frame. It is also a useful tool for verifying the correction
values found by the visual method.

Related operational procedures
• Roll offset in the acrosstrack direction on page 173
• Pitch offset and time delay on page 174
• Heading offset – Alternative 1 on page 176
• Heading offset – Alternative 2 on page 177
• Sound speed quality inspection on page 178
• Sound speed control on page 179
• Verification on page 180
• How to determine calibration values using SIS Calibration frame on page 181
• How to determine calibration values using SeaCal automatic calibration on page 184
• How to collect the sound velocity profile on page 141
• How to convert your sound velocity profile to SIS format on page 143
• How to modify and load a sound speed profile into SIS on page 151

Parameter references
• Calibration parameters on page 260
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• Seacal auto calibration on page 261

Related topics
• Keyboard and mouse in the Calibration view on page 46
• SeaCal on page 409
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The menu system

This chapter provides a brief description of the menu system provided by SIS. The menu
options are not explained in detail, but references are provided for the detailed dialog
box and functional description.

Main menu
The main menu is located on the top of the application window. It provides the following
choices:
• File menu on page 104
• View menu on page 105
• Tools menu on page 105
• Help menu on page 107
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File menu
The File menu gives you the following choices:
• Import/Export: Dialog for import and export of

raw data and gridded survey data
See Import/Export on page 352

• Export xyz file: Export of survey data to xyz ascii
file
See Export xyz file on page 361

• Remove survey from Database: Used to delete
surveys from the database
See Remove survey on page 362

• Remove sounder from Database: Used to delete
obsolete or unwanted echo sounders from the
database.
See Remove sounder on page 362

• Save settings: Used to save current frame settings
See Save settings on page 363

• Save settings as...: Save current frame settings with a new filename
See Save settings as... on page 363

• Delete settings: Used to delete selected frame setting file
See Delete settings on page 364

• Set startup settings: Used to select how you want the SIS frames to appear at start up
See Set startup settings on page 364

• Export PU parameters: Used to save the Installation and Runtime parameters for
current echo sounder to file in an ascii readable format
See Export PU parameters... on page 364

• Import PU parameters: Used to import previously saved parameters for a given echo
sounder
See Import PU parameters... on page 366

• Set PU factory settings: Used to restore the echo sounder's (PU's) original factory
settings.
See Set PU factory settings... on page 367

• Export user settings: Used to save current database settings for later retrieval
See Export user settings... on page 368

• Import user settings: Import previously exported database settings
See Import user settings... on page 369

• Create CUBE grid: Used to create a CUBE grid after completion of data logging
See Create CUBE grid on page 369

• Quit: Exit SIS
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See Quit on page 370

View menu
The View drop-down menu gives you the following choices:
• Tear-off windows on page 39
• Icons on page 40
• C-MAP detail level on page 41
• Colour palette on page 41
• Status bar on page 42

Tools menu
The Tools drop-down menu gives you the
following choices:
• External sensors: This is where you define

the interfaces to your external sensors that
are attached directly to the Hydrographic
Work Station (HWS)
See External sensors on page 371

• Instrument combination: This is a dialog for
creating combined interfaces from external
sensors that can be started as any system
sent from the PU

See Instrument combinations on page 377
• Remove instruments: Used to remove selected instrument combinations.

See Remove instruments on page 378
• C-MAP: Dialog for administrative for C-MAP – only available if C-MAP is installed

See C-MAP – Licence administration on page 379
• AutoCalib Wizard: Wizard that will guide you through a SeaCal calibration

See AutoCalib Wizard on page 380
• SeaCal results: Direct access to location where your Seacal result files are stored

See SeaCal results on page 381
• Extract IFF: Used to extract position datagrams

See Extract IFF on page 381
• Custom...: A new level of menu selections.

See Custom menu on page 106
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Custom menu

The Custom... sub-menu is accessed from the Tools menu. This menu is used to access
various Custom applications. It is also possible to manage or add applications to this
menu.
Choose between the following options:
• SVP editor: Used to load and edit sound speed profiles logged in .asvp or .actd format.

See SVP Editor on page 395
• Set parameters: Parameter settings that are used to control the behaviour of SIS.

See SIS parameters – Set parameters on page 333
• Datagram distribution: Used to route selected datagrams to given IP addresses on

the network.
See Request datagrams from an echo sounder on page 559

• Projection setup: Used to define the projections and datum transformation that you
later can apply.
See Projection and datum parameters on page 384

• Create grid from ASCII files: Dialog for creating terrain model from a Neptune ASCII
file.
See Create grid from ASCII files on page 451

• Licence information: Opens the log file to the license server, containing your SIS
license information.

• PU Simulator: Used for simulation and playback of previously logged raw data.
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See PU simulator and playback on page 449
• Objects: Opens a utility for adding points, lines, images, text, polygons, video and

html into the SIS map.
See SIS Objects on page 417

• SIS data logger: Opens a utility for logging data received on either the PU or the
SIS computer.
See Logging utilities on page 435

• BSCorr: Opens a utility program for editing the backscatter calibration. When
completed the backscatter calibration file is returned to the PU for use. Applicable for
EM 122 and EM 302.

• BSCorr EM710: Opens a utility program for editing the backscatter calibration for EM
710. When completed the backscatter calibration file is returned to the PU for use.
Applicable for EM 710.

• Configure...: Used to manage existing applications in the Custom sub-menu.
See Configure... on page 382

Help menu
The Help drop-down menu gives you the following
choices:
• Help: Opens online help

See Help on page 391
• Build info: Contains information about your SIS

software build.
See Build info on page 391

• OpenGL settings: Contains information related to SIS software drivers.
See OpenGL settings on page 392

• About SIS: General SIS software information.
See About SIS... on page 392
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Operational procedures

This chapter presents the most important operational procedures required to operate the
SIS software.
You will find descriptions and main operational procedures on how to start and exit SIS,
plan and run a survey, set installation and runtime parameters etc. in this chapter.

Note

This chapter applies to all the Kongsberg Maritime multibeam echo sounders. You may
therefore find that some procedures and parameter settings do not apply to your EM
2040 system.
For parameter description specific to your system we refer you to the Parameter
references on page 209.

The following operational procedures are described in this section:

Start, stop and operational procedures
• Normal operational sequence on page 111
• How to start SIS on page 112
• How to start pinging on page 160
• How to start the Remote Helmsman Display on page 206
• How to import a Neptune grid to SIS on page 159
• How to start the echo sounder on page 154
• Detecting the echo sounder on the network on page 158
• How to interface a singlebeam echo sounder in SIS on page 156
• How to start and stop logging – Alternative 1 on page 169
• How to start and stop logging – Alternative 2 on page 169
• How to save data on page 169
• How to log water column data on page 170
• How to log stave data on page 170
• How to export survey results after a survey on page 207
• How to exit the SIS software on page 207
• How to shut down the HWS on page 208
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• How to shut down the Processor Unit (PU) or the Transceiver Unit on page 208

Configuration procedures
• How to configure your survey on page 113
• How to enter parameters for a new survey on page 118
• How to enter survey parameters on page 114
• How to define a new projection and datum transformation on page 122
• How to setup the input from external sensors on page 137
• How to setup the output to external sensors on page 139
• How to enter the waterline for a single beam system on page 139
• How to open the installation parameter interface on page 127
• How to modify the installation parameters on page 127
• How to open the runtime parameter interface on page 134
• How to modify the runtime parameters on page 134
• How to collect the sound velocity profile on page 141
• How to convert your sound velocity profile to SIS format on page 143
• How to modify and load a sound speed profile into SIS on page 151
• How to automatically collect and apply a sound velocity profile in SIS on page 152

Quality control procedures
• How to monitor the external sensors in SIS on page 160
• How to monitor the survey progress on page 202
• How to verify data logging on page 170
• How to display realtime depths on page 161
• How to verify echo sounder main functions on page 162
• How to display a smooth surface on page 165
• How to look for artifacts on page 165
• How to display seabed imagery data in the Geographical view on page 162
• How to display sound velocity at transducer depth in the Geographical view on

page 163
• How to create and use a GeoTIFF background image in the Geographical view on

page 166

Calibration procedures
• Roll offset in the acrosstrack direction on page 173
• Pitch offset and time delay on page 174
• Heading offset – Alternative 1 on page 176
• Heading offset – Alternative 2 on page 177
• Sound speed quality inspection on page 178
• Sound speed control on page 179
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• Outer beam angle offset calibration on page 180
• Verification on page 180
• How to determine calibration values using SIS Calibration frame on page 181
• How to determine calibration values using SeaCal automatic calibration on page 184
• How to calibrate a dual head system on page 188

Planning procedures
• How to plan a new job in SIS on page 201
• How to retrieve a planned job on page 202
• How to display planned lines on the Remote Helmsman Display on page 206

SIS utilities

Operational procedures describing various functionality of the SIS utilities are found in
section SIS utilities on page 394. The following operational procedures are described:
• How to use SmartTalk on page 142
• How to use csv2asvp on page 143
• How to use SVP Logger on page 144
• How to use SVP Manager on page 145
• How to use SVP Editor to convert an SVP file to .asvp format on page 147
• How to use macros in the SVP Editor to convert an SVP file to .asvp format on

page 149
• How to run the PU simulator on page 203
• How to change the language of SIS on page 112
• Raypaths chart on page 401
• How to use SIS Objects on page 417
• How to convert S-57 chart files to SIS input data on page 458
• How to do Precise Point Positioning in SIS on page 478

Normal operational sequence
Note

To ensure correct setup and operation of SIS the Survey Template Handling is essential.
When all parameters are set up and stored in the template, all future surveys that are set
to using this template will be defined by these parameters.
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Note

If SIS has been left inactive for some time, the operating system may have swapped the
complete SIS process to disk. The operating system must then read SIS into the RAM
again. This may take a few seconds. Datagrams including installation and runtime
parameters must not be sent to the Processing Unit during this process.

Normal operational sequence
The normal sequence of operations required for running surveys using SIS are as follows:
1 Start SIS

See Start SIS on page 112
2 Enter survey and operator parameters, background data and set projection

See Enter survey and operator parameters, set projection on page 113
3 Check installation and runtime parameters

See Check installation and runtime parameters on page 125
4 Start the echo sounder

See Start the echo sounder on page 154
5 Run the Built-In Self Tests (recommended)

See BIST on page 133
6 Import a Neptune grid (optional)

See Import a Neptune grid to SIS on page 159
7 Start pinging

See Start pinging on page 160
8 Check sensor input

See Check sensor input on page 160
9 Check echo sounder main functions

See Check echo sounder main functions on page 161
10 Start and stop logging

See Start and stop logging on page 169
11 Perform a system calibration (optional)

See Perform a system calibration on page 171
12 Plan a survey (optional)

See Plan a survey on page 199
13 Run the survey

See Run the survey on page 202
14 Export data

See Export data on page 206
15 Operate Helmsman Display (optional)

See Remote Helmsman Display on page 206
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16 Exit SIS
See Exit SIS on page 207

Start SIS
How to start SIS
Note

The SIS license dongle must be connected to an USB port on the HWS. The license
dongle is required to run the advanced options of SIS.

1 Power up the echo sounder units.
2 Power up the external sensors.

Note

Your system may include a number of peripheral devices. Consult the applicable
manufacturer’s documentation for correct operation of these.

3 Configure the single beam echo sounder(s) - if applicable.
4 Power up the SIS HWS – Hydrographic Work Station.

The operating system on the SIS HWS loads automatically. When the boot process
is finished, you can open the SIS program.

5 Click on the SIS icon on the desktop or select SIS from the Windows start menu.
6 Verify that the SIS application window opens as described in The application

window on page 25.

How to change the language of SIS
Normally, you will set your language of SIS during software installation. It is also
possible to change the language. This is done from a command window outside SIS.
Note

The translations from English may be incomplete.

1 Open a console window, e.g. as follows
a Press the Windows Start button
b Select Run... in the right side of the Start menu
c Type cmd in the text field that appears
d Press OK

2 Go to the directory where the SIS\SQL directory.
To change drive and directory in a console window:
a Type the drive letter, e.g. C:, and press Enter to change the drive
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b Type cd\ to change directory to the root directory
c Type cd <sub-folder> \<next sub-folder> to change the directory

to an existing directory below, e.g. cd program files\Kongsberg
Maritime\SIS\sql to change to the SIS\SQL directory

3 Type setParameter SIMRAD_LANG 1 <number>, where <number> is.
1 = Norwegian
2 = English
3 = Spanish

4 Press the Enter button on the keyboard.

Enter survey and operator parameters, set
projection
We recommend that you define one or several survey templates for the survey area
before you start the survey.

How to configure your survey
1 Choose the frame Survey Administration and set the parameters for your survey

type. These settings can be stored as a survey template available for easy set up of
new surveys.

2 Select the frame New survey and select applicable survey template from here
3 Define the survey name
4 Check and verify reasonable grid cell size
The parameters can be saved to current or all survey templates, and it is thereby not
required to set these parameters more than once for a survey. This method will save you
a lot of work, and ensure correct survey parameter setup throughout the survey.
This section explains how to create and modify survey templates.

Operational procedures
• How to enter survey parameters on page 114
• How to enter parameters for a new survey on page 118
• How to define a new projection and datum transformation on page 122
The parameter settings are not explained in details in this section. Please refer to the
following sections for a complete description of the parameters:

Parameter references
• Survey parameters on page 263
• Basic parameters on page 263
• Storage options on page 265
• Background data on page 267
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• Projection parameters on page 269
• GridEngine parameters on page 269
• User handling on page 272
• CUBE parameters on page 273
• Data cleaning on page 317
• Projection and datum parameters on page 384

Related topics
• New survey window on page 89
• Survey administration window on page 91

Set survey parameters

How to enter survey parameters
Open the Survey administration frame, select the different tabs in turn and enter
parameters as described in the following.

User handling
This is where you add new users of SIS.
1 Enter identification a the new user
2 Press Update to apply

Background data
Background data in SIS are any projection file, KSGPL contour files, files containing
predicted tide or geoid data files that you want to apply.
If you have background data, you can enable (or disable) the files for your survey or
survey template by selecting the path to where the files are stored.
1 Select the path to the background data.
2 Press the Add button to add that file location to the list of background data

and/or
3 Select the background data path to be remove
4 Press Delete to remove the files from SIS.

The files are not deleted from the disk.

Survey template handling
The Survey template handling tab is used for creating survey templates or modifying
existing survey templates.
The survey templates are useful for easy and correct setup of the survey parameters of
SIS. Once a setup for a survey is done the complete setup can be stored in a template and
used for next survey at the same place, for next survey with similar setup or just as a
template for correct setup of a new template.
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1 Select the Basic parameters tab.
a Enter a new name in the New survey template text field if you want to create

a new template,
or
select the template you want to modify from the New survey template drop
down list.

b Select the Survey template you want your new template to be based upon from
the drop down list.
You can select any of previously stored templates, previous used template or
default template.

c Select name of user.
If you want a new user to be defined go to the User handling tab.

d It may be useful to add your own comments Comment to the generated template.
e Press Update to save the new template or the modifications you have done to

an existing template.

Note

If you do any further changes to the survey template you have defined, you must
remember to press the Update button again to save your changes.

2 Select the Storage options tab.
Observe the default storage location of raw data and gridded (survey) data. We
recommend that you stick to the default storage structure unless you have specific
requirements. Sub-directories will be added according to your selections of naming
convention as described in point 4 below.
a Select where you want gridded data to be stored.
b Select where you want your raw data to be stored.
c Select the naming convention of your raw data by selecting appropriate tick

boxes.
For each tick box you enable a new sub-directory for storage of raw data is
added.

d Enter name of the ship, and tick off for Use as postfix in filename if you want the
ship's name as the last part of the file names.

e Click Apply to all survey templates if you want your settings to apply to all
loaded templates.

Survey template handling – Advanced options
This tab is found both under the Survey administration frame and in the New survey
frame. Modifications that you do from the Survey administration frame applies to the
template you are working on, whilst if you do modifications from the New survey frame
they will only apply to current survey.
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Note

Independent of where you are accessing these pages from, you will find Apply buttons
that are short-cuts to applying your changes to either all survey templates or to the default
survey template.

The Advanced options tab contains four new tabs. The configuration of all are described
in the following procedure.
1 Select the Background data tab.

This is where you select the file location of background data that you want to use
for the survey template you currently are setting up. You can choose between
paths that were enabled in the Background data tab at the top level of the Survey
administration window.
The background data may be a projection file, a KSGPL contour file, a file
containing predicted tide or a geoid data file.
Click Apply this path to the Default survey only if you want your selection of
background data to apply to the Default template.

2 Select the Projections tab.
Select your projection from the drop-down list.
If your datum and projection is not in the list a new datum and projection can be
defined from Tools→Custom→Projection setup.
Click Apply this projection to the survey template only if you want your changed
projection to be the default projection in the Default template.

3 Select the GridEngine parameters tab.
a If you are applying real time data cleaning, select what depth to use in the

processing.
The real time data cleaning module will use the given depth plane to identify
outliers in the data and remove them.
Note

We recommend that you set the real time data processing depth to either tide
corrected depth, Zt, or to geoid and RTK corrected depth, Zv, in order to avoid
unwanted depth rejections caused by natural variations such as the tide.

b Select resolution of your grid, i.e. number of cells and cell size, suitable for
your depth and expected coverage.
Note

The grid resolution applies to displayed data only, the raw data is not affected.
The grid resolution can not be changed during the survey, and should therefore
be carefully set to apply to the whole survey area.

If the cell size is set too large the resolution in your geographical view will be
poorer than necessary. If you set the cell size too small you may experience
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that there are not sufficient data points in the cells to compute a valid depth
value, and no depth value is displayed. Too small cell size may also overload
the computer and give you delays in the real time display.
The following factors have influence on the selection of the cell number and
cell size:
• Depth
• Achieved swath width (shown in numerical display)
• Survey speed
• Coverage area per beam (footprint)
The following rule of thumb have proven to be reasonable:

Normal resolution
• Cell size = average swath width/100
• Number of cells in processing grids: 64x64

High resolution
• Cell size = average swath width/200
• Number of cells in processing grids: 128x128
Example: If depth is 100 meters and sector coverage is set to ±70°, the swath
width is 550 meters. Cell size computed from above rule of thumb for may then
be set to 5.5 meters for normal resolution and 2.8 meters for high resolution.
Note

The cell size settings applies to highest possible display resolution, i.e. LOD0.

c If you want to do real time data cleaning, you may access the real time
processing parameters by pressing the Processing... button.
You will be directed to the Real time data cleaning page normally accessed from
the Runtime parameters frame. The real time data cleaning uses rules, i.e. a
set of parameters that controls the algorithms used in the real time processing
of echo sounder data.
By default, the real time data cleaning is set off.

d Click Apply to all survey templates if you want your GridEngine settings to
apply to all loaded templates.

Cube parameters
This procedures applies only if you want to use the CUBE data cleaning method instead
of the default GridEngine.
CUBE is enabled from Tools→Custom→Set parameters→Logging.
1 Select the depth reference you want to use
2 Enter the geographical coordinates of the centre of your survey area.
3 Enter the width and height of your survey area.
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4 Enter your required grid cell size.
The smaller grid cell size the better resolution. However, too small grid cells will not
be accepted by the CUBE algorithms. You may have to enter a larger grid cell size.

Note

Remember to press the Update button from the Basic parameters tab to save your changes.

Related operational procedures
• How to enter parameters for a new survey on page 118
• How to define a new projection and datum transformation on page 122

Parameter references
• Survey parameters on page 263
• Basic parameters on page 263
• Storage options on page 265
• Background data on page 267
• Projection parameters on page 269
• GridEngine parameters on page 269
• User handling on page 272
• CUBE parameters on page 273
• Projection and datum parameters on page 384
• Data cleaning on page 317
• Logging on page 341

Related topics
• CUBE on page 464
• SIS architecture on page 487

Start a new survey

How to enter parameters for a new survey
We assume at this stage that you have created a survey template that defines your survey
parameters. The New survey frame is then used to define current survey, based upon
parameters given by the survey template.
Open the New survey frame, select the different tabs in turn and enter parameters as
suggested in the following.

Basic parameters
1 Select the Basic parameters tab.
2 Enter a unique survey name descriptive to your survey in the New Survey name

text field.
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3 Select the survey template you have defined for your survey in the Select
survey-template drop down list.
The setup for previous survey was automatically saved as a template named
Previous. If the conditions for your new survey are the same as for the previous one,
select the previous to easily select correct survey parameters.

4 Select a predefined User.
If your user name is not defined you may add a user from the User handling tab in
the Survey administration frame.

5 Select an existing survey if you want to continue data logging to an existing survey.
Press Continue on existing survey to confirm.

6 Add any comments that may give relevant information about the survey. The
comment will be logged in the header of each raw data file.

7 After you have set ALL parameters, including the storage options and advanced
options, press Save new survey to save and apply your settings.

Storage option

This tab is found both under the Survey administration frame and in the New survey
frame. Modifications that you do from the Survey administration frame applies to the
template you are working on, whilst if you do modifications from the New survey frame
they will only apply to current survey.

Observe the default storage location of raw data and gridded (survey) data. We
recommend that you stick to the default storage structure unless you have specific
requirements. Sub-directories will be added according to your selections of naming
convention as described in point 4 below.

If required,
a Select where you want gridded data to be stored.
b Select where you want your raw data to be stored.
c Select the naming convention of your raw data by selecting appropriate tick boxes.

For each tick box you enable a new sub-directory for storage of raw data is added.
d Enter name of the ship, and tick off for Use as postfix in filename if you want the

ship's name as the last part of the file names.
e Click Apply to all survey templates if you want your settings to apply to all loaded

templates.

Survey template handling – Advanced options

This tab is found both under the Survey administration frame and in the New survey
frame. Modifications that you do from the Survey administration frame applies to the
template you are working on, whilst if you do modifications from the New survey frame
they will only apply to current survey.
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Note

Independent of where you are accessing these pages from, you will find Apply buttons
that are short-cuts to applying your changes to either all survey templates or to the default
survey template.

The Advanced options tab contains four new tabs. The configuration of all are described
in the following procedure.
1 Select the Background data tab.

This is where you select the file location of background data that you want to use for
the survey you currently are setting up. You can choose between paths that were
enabled in the Background data tab at the top level of the Survey administration
window.
The background data may be a projection file, a KSGPL contour file, a file
containing predicted tide or a geoid data file.
Click Apply this path to the Default survey only if you want your selection of
background data to apply to the Default template.

2 Select the Projections tab.
Select your projection from the drop-down list.
If your datum and projection is not in the list a new datum and projection can be
defined from Tools→Custom→Projection setup.
Click Apply this projection to the survey template only if you want your changed
projection to be the default projection in the Default template.

3 Select the GridEngine parameters tab.
a If you are applying real time data cleaning, select what depth to use in the

processing.
The real time data cleaning module will use the given depth plane to identify
outliers in the data and remove them.
Note

We recommend that you set the real time data processing depth to either tide
corrected depth, Zt, or to geoid and RTK corrected depth, Zv, in order to avoid
unwanted depth rejections caused by natural variations such as the tide.

b Select resolution of your grid, i.e. number of cells and cell size, suitable for
your depth and expected coverage.
Note

The grid resolution applies to displayed data only, the raw data is not affected.
The grid resolution can not be changed during the survey, and should therefore
be carefully set to apply to the whole survey area.

If the cell size is set too large the resolution in your geographical view will be
poorer than necessary. If you set the cell size too small you may experience
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that there are not sufficient data points in the cells to compute a valid depth
value, and no depth value is displayed. Too small cell size may also overload
the computer and give you delays in the real time display.
The following factors have influence on the selection of the cell number and
cell size:
• Depth
• Achieved swath width (shown in numerical display)
• Survey speed
• Coverage area per beam (footprint)
The following rule of thumb have proven to be reasonable:

Normal resolution
• Cell size = average swath width/100
• Number of cells in processing grids: 64x64

High resolution
• Cell size = average swath width/200
• Number of cells in processing grids: 128x128
Example: If depth is 100 meters and sector coverage is set to ±70°, the swath
width is 550 meters. Cell size computed from above rule of thumb for may then
be set to 5.5 meters for normal resolution and 2.8 meters for high resolution.
Note

The cell size settings applies to highest possible display resolution, i.e. LOD0.

c If you want to do real time data cleaning, you may access the real time
processing parameters by pressing the Processing... button.
You will be directed to the Real time data cleaning page normally accessed from
the Runtime parameters frame. The real time data cleaning uses rules, i.e. a
set of parameters that controls the algorithms used in the real time processing
of echo sounder data.
By default, the real time data cleaning is set off.

d Click Apply to all survey templates if you want your GridEngine settings to
apply to all loaded templates.

Note

Remember to press the Save new survey button from the Basic parameters tab to save
your changes.

Related operational procedures
• How to define a new projection and datum transformation on page 122
• How to enter survey parameters on page 114
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Parameter references
• Survey parameters on page 263
• Basic parameters on page 263
• Storage options on page 265
• Background data on page 267
• Projection parameters on page 269
• GridEngine parameters on page 269
• User handling on page 272
• CUBE parameters on page 273
• Projection and datum parameters on page 384
• Data cleaning on page 317

Define a projection and datum transformation

How to define a new projection and datum transformation
1 Select Tools→Custom→Projection setup from the main menu.
2 Select the Define projections tab.
3 Locate the Projection definition section.
4 Press the New button.
5 Enter a name to identify the selected datum and projection, e.g. ED50_UTM30
6 Enter the type of projection for mapping the ellipsoidal coordinates onto the map

plane

Press OK to continue
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7 Tick off for Datum transformation active if you want the entered datum
transformation to be carried out to your input positions.
Datum transformation is by default turned off.

8 Press Choose ellipsoid to select the ellipsoid of the input position.
For GPS position input this will normally be the WGS84 ellipsoid.

9 Press Select transformation to use predefined datum transformation parameters
or

10 Enter the 7-parameter datum transformation parameters in the applicable parameter
fields

11 Press Choose Ellipsoid in the Ellipsoid field to enter the ellipsoid for the output
position.
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12
Select the ellipsoid and press OK to apply.
The available ellipsoids in SIS are identified by
(scroll the side bar to view the parameters):
• id
• short name
• major axis (a)
• reverse flattening (rf)
• full ellipsoid name
e.g. for ED50, the International 1909 ellipsoid
applies having the following parameters:
• id = 05
• short name = intl
• a = 6378388.0 m
• rf = 297.0

13

Press OK to apply the datum transformation
selected.
When UTM projection type has been selected the
Define UTM projection dialog will appear

14 Select UTM zone and whether you are on northern
or southern hemisphere.

15 Press OK to apply.
16 Press Edit... to change the datum transformation

or projection parameters selected
17 Press Delete... if you want to delete the settings

you have chosen

Parameter references
• Projection and datum parameters on page 384

Related topics
• Available projections in SIS on page 387
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Check installation and runtime parameters
Installation and runtime parameters are associated with the echo sounder and not with
the survey. This means that the installation and runtime parameters are set up separately
for each individual echo sounder. These parameter settings will remain the same for that
echo sounder, independent of the survey run.
The parameter settings for each echo sounder will be stored in a database. When an
echo sounder is detected for the first time, all parameters will be set to a default value,
determined by the type of echo sounder. It is important that the installation and runtime
parameters are checked and updated if necessary.

Note

We recommend that you keep a record of the parameters and settings used in a safe
and accessible place.

External sensors: For interfaces to external sensors that are attached directly to the
Hydrographic Work Station (HWS) the interface parameters must be defined in the
External sensors dialog.

Note

The Installation parameter window can be displayed at any time, but parameters can
only be modified when pinging and logging is deactivated.

The Runtime parameter window can be modified at any time, independent of pinging
and logging status.

Operational procedures
• How to open the installation parameter interface on page 127
• How to modify the installation parameters on page 127
• How to open the runtime parameter interface on page 134
• How to modify the runtime parameters on page 134
• How to setup the input from external sensors on page 137
• How to setup the output to external sensors on page 139
• How to enter the waterline for a single beam system on page 139

Parameter references
• Installation parameters on page 274
• Runtime parameters on page 297
• External sensors on page 371

Related topics
• Installation parameters window on page 94
• Runtime parameters window on page 95
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Installation parameters
The installation parameters are divided into three main groups described in the following:
• Communication setup parameters
• Sensor setup parameters
• BIST – self test
Note

The PU – Processing Unit may be a separate hardware unit or an integrated part of the
TRU – Transceiver Unit cabinet, depending on echo sounder system.

For SIS it makes no difference whether the communication is with a PU or a PU inside a
TRU. The term PU is used in this manual.

Communication setup parameters

The communication setup parameters define the input and output settings for the serial
- and network (Ethernet) ports on the echo sounder Processing Unit. In addition, this
parameter group defines the type of information (datagrams) that is received and/or sent
on the individual ports. To be able to set these parameters correctly it is necessary to
know the type of equipment connected to each individual PU port. Depending on the
port type, the connections are either direct using a serial link, or remote via the system
network. The equipment type and which port the different equipment types may be
connected to, is defined by a set of rules/restrictions. These rules are defined in the PU
communication→Input setup tab located in the Installation parameter frame.

Note

If the communication setup is not correct this may result in loss or corrupted functionality
- in worst case an inoperable system.

Sensor setup parameters

In order to determine correct depth values the system must know the physical positions,
tilt, biases and delays for all transducers and sensors. This information belongs in the
second main group of installation parameters - sensor setup parameters. Also, based on
the set of equipment that is connected to the echo sounder PU (Processing Unit), it may
be necessary to select what equipment to use as active units when several alternatives are
available. If no selection is made, the system will automatically use the sensor connected
to the lowest numbered port when two or more alternatives are available.

BIST - self tests

The options available allow you to test individual functions and hardware items.
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How to open the installation parameter interface
The installation parameters for the different echo sounders are located in the Installation
parameter window. All external sensors connected to the Hydrographic Work Station
(HWS) are located in the External sensors dialogue box found on the Tools drop-down
menu.
In order to open the installation parameter interface perform the following actions:
1 If you have more than one echo sounder connected, select the echo sounder you

want to change parameters for in the Current echo sounder combo box.
2 Select the Installation parameters by either:

• Use the Frame selection button to select Installation parameters in the desired
frame.

or
• Select Installation parameters from the View→Tear Off menu.

How to modify the installation parameters
Open the Installation parameters frame, select the different tabs in turn and enter
parameters according to the recommendations below.

PU communication setup
This is where you define input to and output from the Processing Unit (PU).

Note

The PU – Processing Unit may be a separate hardware unit or an integrated part of the
TRU – Transceiver Unit cabinet, depending on echo sounder system.
For SIS it makes no difference whether the communication is with a PU or a PU inside a
TRU. The term PU is used in this manual.

1 Select the Input Setup tab.
a Set the communication settings for each of the ports you are using for input to

the PU.
Select the port you want to modify first. Then baud rate, data bits, stop bits
and parity must be set equal to the settings in the external sensor the port
is connected to.
Note
• COM1 – position input
• COM2 – motion sensor input
• COM3 – position input
• COM4 – position input
• UDP2 – position and depth input
• UDP5 – attitude velocity input
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b Select the Input format of the data you want to read on the selected port, i.e.
select the format your external device is set up to output.

c Select Port UDP5 if you want to enable input of attitude velocity.
d Select if you want to use the secondary network for the attitude velocity data.
e Select what attitude sensor to read velocity data from.

You have to configure the PU's secondary network card. Find the net mask and
a vacant IP address in the network you are connecting to. Enter your selected
IP address and correct net mask. Set the port number to which the attitude
system is transmitting to. Refer to the attitude system user's documentation
if necessary.

2 Select the Output Setup tab to define the datagrams to be output from the Processing
Unit (PU)
a Set the UDP Host port to either SIS Logging or User defined depending on what

type of data you want to configure your output for.
• SIS Logging is used by the system to define what SIS raw data to log. The

settings for this link should normally not be changed. Mandatory datagrams
are disabled from deselecting

• User defined can be used when you need to define your own selection of
datagrams. By using the given port address these datagrams can be picked
up by any third party systems with access to the same network.

• PU Logging applies to systems where internal logging to PU disk is possible,
e.g. when the PU is installed in an AUV.
Must be enabled by ticking off the Enable PU logging to disk check box below.

• Watercolumn can be selected if you want to log Watercolumn data to a
separate file.
Must be enabled by ticking off the Log watercolumn to separate file check
box below.

Port addresses is given by SIS and can not be changed.
b Select the datagram subscriptions for each output

We recommend:
• SIS Logging: Use the default setup.
• User defined: Subscribe to datagrams required by the receiving system.
• PU Logging: Use the default setup.
• Watercolumn: Subscribe to at least the Installation and Position datagrams.

c Select if you want the PU to broadcast it's existence on the network on given
port.

3 Select the Clock Setup tab
a Select the time reference to synchronize the PU clock to.

The PU clock can be synchronized to either of the following time references:
• External ZDA Clock: An NMEA time datagram available from many GPS

receivers. Outputs current UTC time which the PU clock will be set to.
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Note

External ZDA can only be selected if ZDA input is selected. See PU
communication – Input setup on page 275.

When External ZDA clock is selected both the PU Communication Setup and
the Clock Setup tabulators are changed to red to indicate that you need to
check current clock setup.

The red tabulator setting is turned off when the OK or the CANCEL button
is pressed

In the case that the ZDA Clock input is turned off and the clock source
setting is External ZDA Clock the (fall back) clock source is automatically
set to Active pos. system.

• Active pos. system: The PU clock will be set to the time contained in the
position datagram, normally the NMEA GGA datagram. For modern GPS
system the time of Active pos. system is equal to current UTC time, i.e.
negligible processing delay.

Note

The GGA datagram contains no date entry.

• Operator station: Sets the PU clock to the internal clock of the SIS Operator
Station (HWS)

b Offset (sec) is used if you want to refer to a different time zone than your time
reference. This may be useful e.g. if you have tide data referred to Local time,
whereas you are synchronizing to UTC time.

c Select whether a 1PPS signal from a GPS receiver shall be used to synchronize
the PU for clock drift.
If a 1PPS signal is available, it is highly recommended that you utilize it.

If possible, we recommend using External ZDA Clock and 1PPS synchronization.

Related operational procedures
• How to monitor the external sensors in SIS on page 160
• How to modify the runtime parameters on page 134
• How to log water column data on page 170

Parameter references
• PU communication – Input setup on page 275
• PU communication – Output setup on page 279
• PU communication – Clock setup on page 281
• Water column – Logging on page 247
• Water column – Show/hide on page 243

342682/D 129



Seafloor Information System

Related topics
• Timing on page 498

Sensor setup
This is were you configure the input position and attitude sensors.
1 Select the Settings tab

a Select what positioning system to modify by selecting its input port.
Only ports enabled for position input by the PU communication setup tab can
be selected.

b Select Time to use, i.e. what time tag to use for the position.
This can be
• System time, defined by the time tag given by the PU when the datagram

arrives on the port
or

• Datagram time, i.e. the time of the observation read from the position
datagram

There are various scenarios:
• If the PU is synchronized to External ZDA clock and a 1PPS signal is used,

the position and depth will refer to the exact same time reference (UTC
time). The PU software will know the exact time difference between the
depth and the position observation, and correct for this.
Time to use is to be set to Datagram in this case. Position delay will not apply,
and should be set to 0.
Note

Datagram is to be selected ONLY if the PU clock (Clock Setup tab) is set to
External ZDA clock and 1PPS is connected and used.

This method is the recommended method for best possible time
synchronization.

• If the PU is synchronized to Active pos. system, Time to use should be set to
System and Position delay set to the processing time of your positioning
system.

Note

For modern positioning system the position delay is normally negligible,
but if the processing delay is significant you should consider choosing a
different source for synchronization of the PU.

• If the PU is synchronized to the Operator station, Time to use should be
set to System, and Position delay according to the processing time of your
positioning system.
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Note

Independent of what method you use, you must monitor the PU time versus
either the position time (PU-POS) or the ZDA (PU-ZDA) time in the Numerical
display. Any large figures indicates synchronization errors, and should be
corrected for.
Also note that the Time to use and Position delay settings can be changed during
post processing.

c Tick off for motion correction of your position input for.
d Enter a position delay.

You must refer to the position system's documentation to find the delay.
Delay will only apply if Time to use is set to System.

e Select name of the datum you are using.
Note

This is only text information to the logged files. Actual datum is given by your
position input. If required, datum transformation may be enabled from the
Tools→Custom→Projection setup menu.

f Select Log all heights if you want to enable height datagrams from the GGA and
GGK position input with height input having a quality factor as specified.

g Enter the quality indicator numbers (comma separated) that you want to
accepted as your height observations.
The quality indicators are given by the NMEA GGA and GGK specifications.

h Select the roll reference plane according to your motion sensor.
i Enter the motion sensor delay according to motion sensor documentation
j Select your active sensors by selecting the port to which the relevant sensor

is connected
2 Select the Location tab

Enter the location offsets relative to the vessel reference point for the different
sensors and transducers.
Caution
The positioning system may have internal offset parameters set. Make
sure that the antenna offsets are not applied both in the positioning
system and in SIS.

Note

If the vessel’s deplacement or trim changes during a survey, the waterline value
must be updated accordingly.

3 Select the Angular Offset tab
Enter the angular offsets for the different sensors and transducers.
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Caution

The attitude sensor may have internal offset parameters set. Make sure
that the angular offsets are not applied both in the attitude sensor and
in SIS.

4 Select the ROV specific tab if your system is mounted on an ROV/AUV.

Note

ROV depth found in the PU communication setup→Input setup tab must have been
selected to enable the ROV specific options.

Verify that the depth and pressure settings are set according to your conditions.

Related operational procedures
• How to monitor the external sensors in SIS on page 160
• How to define a new projection and datum transformation on page 122
• How to determine calibration values using SIS Calibration frame on page 181
• How to determine calibration values using SeaCal automatic calibration on page 184

Parameter references
• Sensor setup – Settings on page 283
• Sensor setup – Location for EM 2040 on page 288
• Angular Offsets for EM 2040 on page 290
• ROV Specific for EM 2040 on page 291
• PU communication – Input setup on page 275

System parameters
1 Select the System Parameters tab
2 Verify that the backscatter offset parameters and the Tx and Rx opening angles

are set as intended.

Note

The reference point of the array remains unchanged when the opening angle is
changed. This means that you do not have to change the TX/RX location offsets after
modification to the TX/RX opening angle.

Note

If the specified angles are set larger than the angles given by the physical array size,
the system will run with degraded performance.
Example: If RX and TX opening angles are both set to 2 degrees for a 1 x 1 degree
system, the system will run as a 2 x 2 degrees system, utilizing only parts of the
transducer arrays.
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Parameter references
• System parameters for EM 2040 on page 292

BIST
The BIST page gives you access to run the different Built-In Self Tests that you can
perform to check the operation of the echo sounder system.
1 Press the Run all BISTs button

or
Press each BIST test button one by one

2 Verify that all BIST test buttons turns green when test i performed.
If any of the tests fails the specific test button will turn red or yellow, and a
description of the test result will be displayed in the PU BIST result field.
Please refer to the echo sounder's maintenance manual for corrective actions.

Parameter references
• BIST – Built-In Self Test on page 293

Runtime parameters
Runtime parameters are divided into the following main groups:
• Sounder Main parameters
• Sound Speed
• Filter and Gains
• Data Cleaning
• GPS and delayed heave
• Simulator
• Survey information
The content of these groups will vary depending on echo sounder type.

Sounder main
The sounder main settings concern the operational parameters for the echo sounder
including coverage, depth and swath control.

Sound speed
Sound speed settings concerns selection and use of sound speed profiles and sound
speed at transducer settings.

Filter and gains
Filter and gains settings concern filtering to avoid erroneous measurements, e.g. false
bottom detection. It also includes settings for the bottom backscatter measurement
and seabed imaging.
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Data Cleaning and Seabed Image Processing
Data Cleaning defines rule sets for how the to carry out the gridding. There are two
parameter groups: Ping processing rules and Grid processing rules. It also includes
settings for the seabed imaging for the Geographical view.

GPS and delayed heave
The GPS and Delayed Heave tab contains options for logging of data files related to
position and attitude data that optionally can be used in post processing to improve
the final seabed data.

Simulator
The Simulator tab contains parameters for enabling simulation of echo sounder data.

Survey information
The Survey Information tab contains summarized information about current survey.

Advanced parameters
This menu is intended for Kongsberg Maritime internal use only. Pulse length and
bandwidth can be changed from here.

How to open the runtime parameter interface
To open the runtime parameter interface the following actions must be carried out:
1 Select the echo sounder you want to change parameters for in the Current echo

sounder combo box.
2 Select the Runtime parameters by either:

• Use the Frame button to select Runtime parameters in the desired frame.
or
• Select Runtime parameters from the View→Tear Off menu.

How to modify the runtime parameters
Open the Runtime parameters frame, select the different tabs in turn and enter parameters
according to the recommendations below.

Sounder main
1 Set the sector coverage parameters according to your conditions and requirements
2 Set the depth parameters according to your expected survey depth

Note

The Min and Max depth settings are used to guide the echo sounder in tracking the
bottom. Incorrect settings may result in a failure to detect the bottom and thus a
disabled system. If the echo sounder has problems detecting the bottom within
the min-max range use the Force Depth button with a measured depth or a depth
from a chart.
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3 Set the swath control parameters
4 Set Pitch and Yaw stabilization parameters
5 Select whether the echo sounder will receive trigger signals from an external device

(e.g. K-Sync)

Parameter references
• Sounder main for EM 2040 on page 297

Sound speed
In order to ensure accurate depth determination, you must know the sound speed profile
in the survey area. The profile may change with both time and position in the survey
area. It may therefore be necessary to determine the profile several times during a
survey. The profile is stored as a file.
1 Collect a sound speed profile from surface to bottom and save the profile to file.
2 Select the Sound Speed tab

This tab contains Sound Speed Profile and Sound speed at transducer depth.
3 Find and select the correct Sound Speed Profile file by using the Browse button.

The text field will turn yellow.
4 Activate the profile by pressing the button marked Use Sound Speed Profile.

The text field will return to original colour when loaded.
5 Select the Sound speed at transducer source as one of the following:

1 Manual – Sound speed value must be entered.
2 Profile – A value from the sound speed profile is used (existing value or

interpolated).
3 Probe – If you have a sound velocity probe attached at transducer depth the

values from the probe is used. The offset value must then be specified.

Related operational procedures
• How to collect the sound velocity profile on page 141
• How to convert your sound velocity profile to SIS format on page 143
• How to modify and load a sound speed profile into SIS on page 151
• How to display sound velocity at transducer depth in the Geographical view on

page 163

Parameter references
• Sound speed for EM 2040 on page 305

Filter and gains
1 Set the Filtering parameters.

We recommended to only change the filtering parameters from default settings if
false bottom detections is very likely.

2 Set the Absorption Coefficient parameters.
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A correct value for the absorption coefficient is important with respect to the validity
of the bottom backscatter measurements.
On broadband sonar systems, like the EM 710, absorption coefficient matrixes are
automatically calculated by SIS from sound speed profiles and salinity and CTD
profiles.
Default salinity is 35 ppt. Correct the value if necessary.

3 Set the Normal Incident Sector.
Degrees from nadir defines the angle at which the bottom backscatter can be
assumed to be independent of the strong increase at normal incidence. The value
is dependent on bottom type.

4 Set Mammal protection for system where this is implemented.
Reduced TX power level can be set, as well as a delay period in which the output
power level gradually will be increase from zero up to set maximum level.

Parameter references
• Filter and gains for EM 2040 on page 310

Data cleaning
This is where criteria for real time data cleaning are defined.
Caution
Please familiarize yourself with the SIS data cleaning functionality before
making any changes to it's parameters.

Note

Real time data cleaning does not delete any data, invalid data is simply flagged.

Parameter references
• Data cleaning on page 317

External sensors
The External sensors page is accessed from the Tools menu, and are used to define
interfaces to external sensors that are attached directly to the Hydrographic Work Station
(HWS).
Note

Interfaces to external sensors that are attached to the Processing Unit (PU) are defined
in the Installation parameters.

The External sensors dialog contain setup information for the following sensors:

Input
• Sound velocity probe
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• Real time tide
• SVP logger
• Barometer
• Geodimeter
• Heading
• Position

Output
• Auto pilot
• Dynamic positioning
• Depth below keel

How to setup the input from external sensors
1 Enter the sound velocity probe parameters

Sound velocity probe
To prepare and use an external sound velocity sensor the following steps must
be followed:
a Make sure that the external sensor is powered up and connected to a HWS

input port (i.e. COM port).
Alternatively, in the case where SIS is receiving external sound velocity
datagrams via UDP the datagrams must be available on the network.

b Select the type of sensor or input to use as source for the sound velocity
samples:
a Tick the Probe available box to signify that a sound velocity sensor or

external sound velocity datagrams is to be used.
The Probe type combo box is now enabled

b Select the specific type of sound velocity probe to be used.
A number of choices are available:
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c If a sensors is selected, set the port to where it is connected.
Note

There is no need to set communication settings for the selected input COM
ports. (Auto detect or fixed 9600 baud is assumed).
If ’Ext. datagrams’ is selected the port combo box is disabled as UDP is used.

c Configure the Sound speed parameters in the Runtime parameters.
2 Tick off if you have input from either of the following sensors

• Realtime tide
• SVP Logger
• Barometer
• Geodimeter

3 Set the port number, baud rate, data bits, stop bits and parity for each input enabled.
4 Enter the Heading and position parameters

This setting applies only if you are using SIS without any EM input, that is, if your
position and heading are input directly to the SIS HWS, and not to the PU. This may
be the case if you have single beam echo sounder input via NMEA datagrams and
no multibeam echo sounder, or if you want to use SIS without any echo sounder
input at all.
a Write a name in the Sensor name combo box.

The name given here will be the one that is displayed in the installation
parameters for GPS and single beam echo sounders.

b Choose either serial line or ethernet connection. Press Add for each sensor.
• If you choose a serial port, mark the check box under Serial and select the

port you want to use for heading and/or position by selecting it from the
combo boxes under Port. The communication parameter is set with the
respectively combo box.

• If you want to use an Ethernet connection, mark the check box under
Ethernet. The IP address and the port, where the data is to be send, is
displayed in the text field to the right.

• If serial line communication is chosen a small program starts automatically
when the equipment is started. This program receives data on RS-232 and
forwards the data on UDP. The program will close down automatically.

c Compass deviation file: Use the browse button (three dots) to find the desired
file.

d Position delay (sec): Enter any known position delay.
The accuracy of the position sensor is vital for the data accuracy, and it is
therefore important that the relative timing of vessel position data and system
depth data is correct. To define the duration of life of the positioning system
input data, you can enter a position delay.
A position delay is required if the position that is output on the port applies
to an observation that was done a significant number of seconds ago. The
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position delay may be significant for systems where the internal computation
and processing of the position takes time.

e Location offset (m): Use the text fields to enter the location of the GPS antenna
relative to the vessel's reference point.
Caution

The positioning system may have internal offset parameters set.
Make sure that the antenna offsets are not applied both in the
position system and in SIS.

How to setup the output to external sensors
1 Tick off if you want to output to either of the following systems

• Auto pilot
• Dynamic positioning
• Depth below keel

2 Set the port number, baud rate, data bits, stop bits and parity for each output enabled.

How to enter the waterline for a single beam system
This procedure only applies to single beam echo sounder interfaced to the SIS HWS
using NMEA datagrams. The waterline offset is used to compensate for the depth
difference between the vessel reference plane and the EA transducer depth.

Note

Waterline for the multibeam echo sounders are input through the Installation parameters.

1 Locate the Waterline (m) Downward (Z) entry in lower left corner of the External
sensor dialog box

2 Enter the vessel's waterline vertical location (in normal trim) in the vessel's
reference coordinate system.

Related operational procedures
• How to modify the runtime parameters on page 134

Parameter references
• External sensors on page 371
• Sound speed for EM 2040 on page 305

Enter a sound velocity profile
A sound speed profile must always be taken within the survey area and loaded in .asvp or
.actd format into SIS before the survey is started.

342682/D 139



Seafloor Information System

We recommend that you collect at least two profiles at each location. If the two profiles
deviates significantly, you should carry out further attempts until you are confident that
you have a representative sound velocity profile.
The method used for collecting a sound velocity profile depends on the type of sound
velocity probe you are using. You must refer to your sound velocity probe's user
documentation for instructions on how to collect the sound velocity data.
There are three stages in the process of entering a sound velocity profile into SIS:
1 Collecting the sound velocity profile data

See How to collect the sound velocity profile on page 141
2 Converting the sound velocity profile data to the SIS .asvp format

See How to convert your sound velocity profile to SIS format on page 143
3 Checking and preparing the sound velocity profile for SIS

See How to modify and load a sound speed profile into SIS on page 151
There is an automated method in SIS for collecting and applying a sound speed profile.
This method requires input of sound velocity profiles in one of the SSP format types.
See How to automatically collect and apply a sound velocity profile in SIS on page 152.
SIS reads the sound velocity profile in the .asvp and .actd formats only. The .asvp format
is an ascii format consisting of a header row and data rows for each depth and sound
speed as shown in the following example:
( SoundVelocity 1.00 12 200605290813 22.3452678
66.4483298 4500 200605290813 200605301210 SVP-16 PE 8 )
0.1 1483.6
5.0 1484.2
7.0 1485.3
12.0 1488.1
20.0 1485.7
25.0 1484.0
40.0 1483.8
12000.0 1509.6

The .actd format is a special format containing water density in addition to the sound
speed. It is used in ROV operations where the scaling factor is automatically calculated.
The .actd format is not described further in this section. See ACTD format on page 548
for description.
The SIS software package offers a number of utility programs that may assist you in
collecting, converting, checking and loading your sound velocity profile.
Program Description

SmartTalk Logging sound velocity profile data from an AML sound velocity probe. Logged
data in .csv format. Available on the SIS installation DVD

csv2asvp Converts the .csv file collected using SmartTalk into .asvp format. Available using
the SVP Editor utility in SIS

SVPLogger Logs sound velocity data from an AML or Morse sound velocity probe. Converts
the data into the .asvp format. Available using the SVP Editor utility in SIS

SVP Manager Reads any column based sound velocity file and will when configured convert
the file to an .asvp file. Available on the SIS installation DVD
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Program Description

SVP Editor Reads the .asvp file, displays the profile and holds a number of functions for
editing and preparing the profile for use in SIS. A SIS utility program.

SVP Editor Also reads any column based sound velocity file and converts it to the .asvp
format.

Operational procedures
• How to collect the sound velocity profile on page 141
• How to use SmartTalk on page 142
• How to use csv2asvp on page 143
• How to use SVP Logger on page 144
• How to use SVP Manager on page 145
• How to use SVP Editor to convert an SVP file to .asvp format on page 147
• How to use macros in the SVP Editor to convert an SVP file to .asvp format on

page 149
• How to modify and load a sound speed profile into SIS on page 151
• How to automatically collect and apply a sound velocity profile in SIS on page 152

Related operational procedures
• How to modify the runtime parameters on page 134
• How to display sound velocity at transducer depth in the Geographical view on

page 163

Related topics
• Sound speed profile formats on page 544
• ACTD format on page 548
• SVP Editor on page 395
• Raypaths chart on page 401
• SVP Logger on page 406
• SeaCast on page 405
• External sensors on page 371

How to collect the sound velocity profile
The method used for collecting a sound velocity profile depends on the type of
sound velocity probe you are using. You must refer to your sound velocity probe's
user documentation for instructions on how to collect the sound velocity data.
In general the method is as follows:
1 Prepare the probe for data logging.

There are two methods. Either to collect data through a data cable between the
probe and the PC while the probe is lowered, or to collect the data within the probe
and download the data to your computer when the probe is recovered.
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2 Lower the probe slowly from the surface to the bottom, or to a required depth.
3 If you are logging data directly to the computer, ensure that data is being recorded.
4 Recover the probe slowly.
5 Save your profile in the SIS computer.
Note

If you are using an AML sound velocity probe you may use the SmartTalk utility program
included on the SIS installation DVD to log the sound velocity profile in a comma
separated (.csv) format. The .csv format must then be converted to .asvp format.
SmartTalk is not a Kongsberg Maritime software.
Alternatively, for the AML and Morse SVP probes the SIS utility SVPLogger can be used
to log and directly convert the sound velocity data to .asvp format.

How to use SmartTalk
The AML sound velocity probe collects data internally during the sound velocity
dip. The logging must be configured before the you lower the probe, and the data is
downloaded to your computer after recovery of the unit.

1 Connect the probe to the serial port on your SIS computer.
2 Press Configure Instrument to set up the communication and data logging
3 Select your instrument
4 Press Configure
5 Enter a log file name and set the logging parameters according to your requirements
6 Press Program Instrument to load the settings into the probe
7 Disconnect the probe and collect the sound velocity data
8 Reconnect when the probe is recovered
9 Select Down Load Data from the main dialog
10 Select your instrument
11 Select the correct file and the destination path
12 Press Transfer file(s) to start downloading
13 Select View Data from the main dialog
14 Select Load File
15 Evaluate the data briefly
16 Press Export
17 Select Formatted Comma Separated Values
18 Enter a Destination file name with extension .csv
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19 Press Export File
20 Use the SIS utility csv2asvp to convert the file into .asvp format.

See How to use csv2asvp on page 143

How to convert your sound velocity profile to SIS format
SIS reads the sound velocity format in the standard .asvp (Ascii Sound Velocity
Profile) format. Your sound velocity data must be converted to the SIS .asvp format
before they can be applied.
Depending on what type of probe you have SIS offers various utility programs to convert
probe data into .asvp format.

How to use csv2asvp
csv2asvp converts observation files from an AML SVP sensors in .csv format to .asvp
format
1 Open the SVP Editor from the SIS menu Tools→Custom...→SVP Editor.
2 Select Tools→csv2asvp

3 Press Choose file.
A standard Windows file open dialog appears.

4 Browse for the .csv file you want to convert.
A message dialog appears telling you what file you have selected to convert.

5 Click the OK button.
A message dialog appears telling you the converting process is done.

6 Click OK.
7 Click Exit to leave csv2asvp
8 Verify that the file is converted.

The new file will have the same name as the original .csv file, but now with the
extension .asvp.

9 Modify and load the sound velocity profile into SIS.
See How to modify and load a sound speed profile into SIS on page 151
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How to use SVP Logger
SVP Logger logs raw data from Morse and AML SVP sensors and converts the data
to .asvp format
SVP Logger assumes that a Morse or AML SVP probe is interfaced to the SIS HWS
(Hydrographic Work Station) using the External Sensor Input setup.
For details, see
• External sensors on page 371
• How to setup the input from external sensors on page 137
1 Select Tools→External sensors
2 Locate the SVP Logger field
3 Check the SVP Logger avail checkbox
4 Select input port in the Port drop down list
5 Press OK to exit External sensors
6 Open the SVP Editor from the SIS menu Tools→Custom...→SVP Editor.
7 In the SVP Editor, select Tools→SVPLogger

8 Select the path of your SVP data by pressing File to log raw data to...
9 Select the path where you want the converted files to be saved to by pressing SVP

file to write...
10 Select whether your SVP format is AML or Morse by checking/unchecking

AML-format instead of Morse
11 Select whether your observations are in Bars or Meters by checking/unchecking

Input format is meters not Bar
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12 Enter your approximate latitude
13 Enter the surface pressure in bars
14 Press Start to start logging
15 Press Stop to stop logging.

Observe that the content of the .asvp file is displayed.
16 Press Send profile to SVP Editor to enable modifications to the data.
17 Modify and load the sound velocity profile into SIS.

See How to modify and load a sound speed profile into SIS on page 151

How to use SVP Manager

When configured SVP Manager will convert any column based ascii SVP file to the
.asvp format

SVP Manager is a utility program that is included on your SIS installation DVD. You
can use SVP Manager to define a standard conversion from your input SVP format
to the .asvp format.
1 Locate SVPMan on your SIS installation DVD.
2 Run the installation file called SVP Manager.msi.
3 Copy the SVP Manager program file to the desktop for accessibility
4 Start SVP Manager.
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Define the SVP format
First time you are using SVP Manager to convert your SVP data you need to define
your format. Some known formats are predefined.
a Locate the SVP Sources area
b Press Add
c Give a descriptive Name
d Set Source to be a File
e Set Data Type to User defined
f Press the Cfg button to configure the input

g Enter Number of header lines in your input file
h Select the Delimiter used in your input file.

Note

Tab and space may appear identical in a text file viewer.

i Select the column number in your input file where the Depth data is located

Note

Depth and pressure data can both be selected for this field.

j Select the column number in your input file where the Sound velocity is located
k Press OK to save the configuration
l Press OK to save your user defined SVP source
For each file you want to convert:

5 Highlight the SVP source you have created a converting routine for.
6 Select Read file.

A standard Windows File dialog opens.
7 Select the file you want to convert
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8 Enter an approximate location for the sound velocity profile in the Enter position
dialog that appears.

9 Press OK
10 Observe that the sound velocity profile is shown in the SVP Edit windows that

appears.
11 Verify that the file has been correctly converted.
12 Press OK
13 Select Export file from the SVP Manager main dialog.

A standard Windows Save as dialog opens.
14 Save the file the .asvp file to the SIS directory ../common/svp_abscoeff
15 Press Exit when you want to leave SVP Manager
16 Modify and load the sound velocity profile into SIS.

See How to modify and load a sound speed profile into SIS on page 151

How to use SVP Editor to convert an SVP file to .asvp format

This procedure describes how to convert a SVP file from any column based ascii format
to the .asvp format read by SIS.

Note

If your original file format requires a lot of operations to convert to the .asvp format, you
may define a macro that runs all operations in one automated process. In that way you
only have to define the operations once. See How to use macros in the SVP Editor to
convert an SVP file to .asvp format on page 149.

1 Open the SVP Editor from the SIS menu Tools→Custom...→SVP Editor.
2 Expand the view by dragging the boundaries of the window.
3 Open the SVP file from the File→Open in editor... menu
4 Change the Files of Type: drop down selection to All files
5 Browse for your SVP input file and press the Open button

The Raw file editor opens.

342682/D 147



Seafloor Information System

6 Remove all header rows by marking them and press the Delete key on your
keyboard.

7 Select the delimiter from the drop down list.
8 Press Split to apply the delimiter.

A new window will appear.

9 Mark the columns you do not need.
Position the mouse in the first data row to mark that column.

10 Press Delete selected columns to remove the columns you have marked
11 Press Add and/or multiply... to perform offset and scale operations to a column
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You can perform multiply-add/scale-offset operations in two ways:
• Multiply (scale), then add (offset) (ab+c)
• Add (offset), then multiply (scale) (a+b)c
Press Back/Close when finished. The figures in the selected column will be updated.

12 Move the columns by position the mouse pointer on the column header row and
drag the column to right position.

13 Press OK when selected columns are in right place.
You will now return to the Raw file editor

14 Select Save as...
15 Save the new file in the SIS directory ../common/svp_abscoeff

The file extension is automatically set to .asvp
16 Modify and load the sound velocity profile into SIS.

See How to modify and load a sound speed profile into SIS on page 151

How to use macros in the SVP Editor to convert an SVP file to .asvp format
This procedure describes how to define and use a macro to convert a SVP file from any
column based ascii format to the .asvp format read by SIS.
If your original file format requires a lot of operations to convert to the .asvp format, you
may define a macro that runs all operations in one automated process. In this way you
only have to define the operations once.
1 Open the SVP Editor from the SIS menu Tools→Custom...→SVP Editor.
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2 Expand the view by dragging the boundaries of the window.
3 Open the SVP file from the File→Open in editor... menu
4 Change the Files of Type: drop down selection to All files
5 Browse for your SVP input file and press the Open button

The Raw file editor opens.

6 Remove all header rows by marking them and press the Delete key on your
keyboard.

7 Press Define macro to define a new macro.
A new window will appear.

8 If required, use the Delete macro:<macroname> button to delete currently selected
macro.

9 Enter a new, unique Macro name.
10 Select the column split that separates the columns of your format.
11 Enter the column numbers that you want to keep, i.e. the depth and the sound

velocity readings
You may switch the order of the columns.
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Note

Left column is Column 0

12 Press OK to save the macro.
You will return in the Raw file editor window.

13 Select the macro you want to run from the drop down box.
14 Press the Run macro button to execute the selected macro.
15 If required, use the Add and/or multiply... to perform multiply-add instructions to

a column
16 Press OK when selected columns are in right place.

You will now return to the Raw file editor, and a new header has been added.
17 Select Save as...
18 Save the new file in the SIS directory ../common/svp_abscoeff

The file extension is automatically set to .asvp
19 Modify and load the sound velocity profile into SIS.

See How to modify and load a sound speed profile into SIS on page 151

How to modify and load a sound speed profile into SIS
This procedure assumes that a sound velocity profile file is available in .asvp format.
1 Open the SVP Editor from the SIS menu Tools→Custom...→SVP Editor.
2 Expand the view by dragging the boundaries of the window.
3 Open the .asvp file from the File→Open... menu
4 Adjust the graphical view by

1 Select From depth and To depth according to your depth range
Use the scroll bar on the right to scroll through your data.

2 Select From speed and To speed according to your recorded sound speed values
or

3 Enable Automatic speed scale to automatically adjust the scale to display all
sound speed observations

5 Check the observations for double entries or upward depths by choosing
Tools→Check profile

Observations that are suggested removed are highlighted.
6 Press Delete row to delete highlighted entries.
7 Remove gross errors/spikes from the profile by selecting the point you want to

remove
8 Press Delete row to delete highlighted point
9 Continue step 7 and 8 until the profile is acceptable
10 Extend the profile from the Tools→Extend menu.
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This will add sound velocity values from last observed depth down to 12000 meters
depth.

11 Thin the profile from the Tools→Thin Profile menu.
This will reduce number of observations to adopt to the PU's limitations for sound
velocity observations

12 Save the file from the File→Save as... menu
It is recommended to use a filename that identify date, time, place and that the
file is thinned

13 Select File→Send primary svp to echosounder to send the profile selected as you
primary profile to SIS.

14 Return to SIS.
15 Select Sound speed in the Runtime parameters frame
16 Use the browse button to open the correct .asvp file.

Normally the file will have been selected via the Send primary svp to echosounder
command from SVP Editor.
When selected the file name will be shown in the text field next to Use Sound Speed
Profile. The text field background colour will turn yellow, notifying that the input
must be accepted to be applied.

17 Press Use Sound Speed Profile to apply the selected sound speed profile

How to automatically collect and apply a sound velocity profile in SIS
This procedure applies when you have a sound velocity input into SIS via the Ethernet.
This applies e.g. to realtime collection of the sound velocity profile from moving
profilers.
1 A profile is obtained with a data set in accordance with one of the SSP format types

for immediate use, i.e S00, S01, S02, S03, S04, S05, S06 or the new S07.
2 The obtained profile must be extended and made error free.

This step is vital for the process to carry on.
3 The extended and error free profile is sent to SIS via the Ethernet network using

UDP and port 4001 on the SIS HWS.
4 The profile is received by SIS and checked for errors. If an error is detected at

this stage the automatic process is stopped and you will be notified for manual
intervention.

5 The error free profile is used to generate a standard depth/sound speed profile which
is distributed to all started echo sounders (PUs). In addition, a number of absorption
coefficient profiles are made, one for each major sounder frequency used. The
echo sounders are updated with the new absorption coefficient values by SIS when
appropriate. The absorption coefficient profiles are generated based on the CTD
information in the received profile (i.e. S01, S02, S03, S04, S05, S06 or S07) or
from the operator set salinity when no CTD information is available (i.e. S00).

6 The SIS operator display is updated with the new profile name (based on date and
time from the received profile) in the Runtime parameter frame. The profile will
also be displayed graphically in the Sound velocity profile frame if opened.
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Related topics
• Handling of SSP datagrams on page 539
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Start the echo sounder
The echo sounder is started by selecting the desired echo sounder from the Echo sounder -
not started combo box. The Logging, Pinging and Line counter buttons will all be disabled
until the echo sounder is ready. When the echo sounder is ready, you can start to ping.

How to start the echo sounder

Before you start pinging, the echo sounder must be turned on.
1 Press the Rescan button to scan for available echo sounders on the network.
2 Select your echo sounder from the Echo sounder - not started combo box.

Single beam echo sounders must be set up and started manually on its own Operator
Station.

Autostart

If the echo sounder is powered before SIS is started, you may set the echo sounder to
start automatically when it is detected by SIS on the network.

Autostart is enabled from Tools→Custom...→Set parameters under the Startup options for
the system settings.

For those who have more than one echo sounder on the same network, echo sounders
may start automatically when detected on the network, but only when the detected echo
sounders are the same as last time SIS was started. This means that Autostart is not
activated when new echo sounders are detected and/or previous used echo sounders
are missing. The Autostart mechanism may be enabled/disabled by a setting in the
SIS database. Default setting is disabled.

Automatic Built-In Self Test at echo sounder start-up

When an echo sounder is started it is an option to run all defined BISTs (Built In Self
Test) for the echo sounder automatically. This option is controlled (On-Off) from the
Tools→Custom...→Set parameters under the Startup options for the system settings.
Default setting is Off, i.e. BISTs are not run automatically. When changed it is not
necessary to restart SIS.

When this option is On and an echo sounder is started an Installation and Test tear off
window will be displayed showing the BIST tabulator content. If an Installation and Test
window is already opened this window will be used.
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A Run all BISTs test sequence is then automatically started for each available echo
sounder head. This sequence can be cancelled at any stage by pressing the Quit button
in the pop-up window that is displayed. When cancelling, the current test must run
to completion before the sequence halts.

The progress of the tests can be monitored by looking at the status colour in the test
buttons or in the PU BIST Result area. The results of the completed tests can be read
at any time during the test run.

When the test sequence has run to completion the test results may be saved by pressing
the Save button.

Note

The full selection of BISTs for an echo sounder may contain some special items that
should not be run during start-up. These include e.g. re-booting of BSP cards, upload of
new head software etc. Such tests will not be run in this context.

Some tests may require a considerable time to complete. There is no countdown or any
other indication of remaining time in the current implementation.
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How to interface a singlebeam echo sounder in SIS

EA singlebeam echo sounders, from version 2.4.0.0 and onwards, have the ability to be
used in a SIS compatible mode of operation. This will enable the EA echo sounder to be
integrated in the SIS topside environment for control, display and data logging purposes.

From the SIS point of view an EA in SIS operational mode will behave as a traditional
EM echo sounder except for some operational restrictions and a different data logging
format.

An EA in SIS operational mode will broadcast it’s presence on the network using port
1999. When detected by SIS it will be named EA600 and it can be started by SIS in the
same manner as used for the EM range of echo sounders.

Only a small number of the different SIS information display frames will be active for
the EA echo sounder. Most noteworthy, no installation and runtime parameter settings
are currently available for this echo sounder. The numerical display will have a restricted
function mainly showing position information, speed and depth. The major display for
the EA operation in SIS will be the Geographical view frame. It is used to present the
depth information in gridded format based on the logged data. The ship’s position will
be shown as a cross, as no heading is currently available in the EA position datagram.

The pinging and logging operation is controlled by the standard SIS buttons used for
this purpose. The data being sent from the EA echo sounder, and logged by SIS, is
processed data (i.e. not raw data). The following is a list of the different EA datagram
types being logged:
• GL (Geographical Location)
• CS (Comment String)
• D1, D2, D3, D4 (Detected bottom depth)
• Q1, Q2, Q3 (Echogram – post processor)
• PR (Parameter request)
• PE (Parameter Enter)
• ST(Status Telegram)
• MS (Motion Sensor)
• SV (Sound Velocity)

The data is stored in files with a ’.dg’ extension. The file name format is the same as for
standard SIS ’.all’ files. The ’.dg’ files will always contain a ’CS (Comment String)
datagram as first entry. It contains the date information (which is not found elsewhere).

Raw data logging can be performed by the EA itself to a local hard disk in parallel with
the logging operation in SIS. I.e. new EA raw data files are created in parallel with
the lines logged in SIS. This feature is turned on by default, but may be turned off by
selecting Tools→Custom...→Set parameters→Logging and setting EA raw data logging
(No=0, Yes=1) to 0.
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Note

EA is a single beam echo sounder normally only measuring the depth straight below the
ship. This implies that SIS is logging relatively small amounts of data and if running
a survey in straight lines the gridded result might be meagre. This is caused by the
method used for gridding based on making triangular planes between three measured
depths. A better gridding result will be obtained when the survey contains several lines,
more or less in parallel and close.

Note

The EA data must contain navigation data to be read by SIS.

1 In the EA software:
a Open the Interfaces→Network Interface dialog and locate the Datagram output

field.
b Check the Navigation check box to send navigation data to SIS.
c Press OK.
d Open the Install→Navigation dialog and locate the Protocol field.
e Select the NMEA protocol.
f Press OK.
g Open the File→Operationg dialog box
h Check SIS checkbox.
i Press OK.

The SIS display will apparently freeze.
2 Go to SIS

3 Press Rescan to scan for recognized systems on the network.

Note

Both EA 400 and EA 600 systems will be identified by SIS as EA 600.

4 Start the EA 600 system from the Not started drop-down menu of SIS.
Allow SIS to initialize the use of the EA system. SIS is ready for use when the
Logging and Pinging buttons becomes selectable.

5 Select Pinging from SIS to start EA pinging.
or

6 Select Logging from SIS to start EA pinging and raw data logging.
The EA system will continue in normal operation.

Your vessel will be shown in the geographical display of SIS.
All EA parameter settings and the display of the Echograms will be shown in the EA
software.
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Detecting the echo sounder on the network
This procedure describes how to detect echo sounders on the network, and applies only
to situations where you are using SIS with more than one echo sounder at the same time.
When the SIS program starts it will automatically scan the network for connected
echo sounders. This will normally take approximately 10 seconds. The detected echo
sounders will be compared with a list of echo sounders detected on the previous run of
the program. If new echo sounders are detected they will automatically be configured in
the SIS program according to a predefined setup for each echo sounder type. This will
take approximately 5-10 seconds for each new echo sounder. All detected echo sounders
will then be listed in the Current echo sounder combo box, available for selection of
an echo sounder in further configuration.
In addition, the same echo sounders may be listed in the Echo sounder - not started combo
box, depending on whether the autostart mechanism is triggered or not. The autostart
mechanism will automatically start all detected echo sounders, provided they are exactly
the same as on the previous run, that is, if no echo sounders are missing and no new echo
sounders are added since the last run. Otherwise the echo sounder will appear in the Echo
sounder - not started combo box and must be started manually.
Choose which system you want to change the parameters for, by selecting it from the
Current echo sounder combo box.
Since several types of echo sounders, with different purpose and capabilities, are handled
by the SIS software, the parameter settings for the different types will vary depending
on system.
The multibeam echo sounders broadcasts their existence on the network. EA single beam
echo sounders, from version 2.4.0.0 and onwards, will also be detected on the network
by SIS. Earlier versions of single beam echo sounders and other sensors transmitting
NMEA datagrams must be set up manually in SIS. Use the Add instruments combinations
found in the Tools menu. When defined, these sensors will be handled the same way as
echo sounders that broadcast their existence on the network.
The external sensors, connected directly to the HWS, such as a sound velocity probe,
heading and position sensors are registered in the External sensors found in the Tools
menu.
Note

It is important that the default parameter settings for each echo sounder is checked
and/or modified according to the operational and physical conditions applicable for
the current echo sounder.

Parameter references
• Logging on page 341
• Instrument combinations on page 377

Related topics
• Main toolbar on page 33
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• Echo sounder – Not started list on page 35
• Current echo sounder on page 36

Import a Neptune grid to SIS
If you have a terrain model generated by the Neptune software and want to load this as
your background grid in SIS you will need to add a definition of the projection to the
Neptune file(s).

How to import a Neptune grid to SIS
1 Select Tools→Custom...→Create grids from ascii files
2 Select the projection of your current SIS survey, i.e. the projection you want

the imported Neptune grid to appear in. The datum is given by the header of the
Neptune file.

3 Set Grid size in meters and Number of cells in processing grid according to depth and
coverage of your data.

4 Press Select grid output directory... to specify where to store the grid. Note that this
directory must exist and be accessible for writing.

5 Type a descriptive Grid name.
6 Select ascii input files opens a file selection dialog where you can browse for the

Neptune files to import.
7 Select Remove files in list if you want to remove a selected file from the list.
8 Press OK to start the process.
9 Select File→Import/Export... from the SIS main menu.
10 Press the Import button.
11 Browse for the directory where you selected to store the grid and select the directory

having the grid name that you entered.
12 Press OK to return to the Import/Export dialog box.
13 Highlight the survey to import and press OK.
14 In the Geographical view, press Zoom to world to display the grid.
Note

The GridEngine must be running for this program to work.

Note

If the process causes GridEngine to stop you may have to kill the Import from the process
manager and restart the GridEngine.

Parameter references
• Projection and datum parameters on page 384
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• Import/Export on page 352
• Create grid from ASCII files on page 451

Start pinging
How to start pinging
Pinging must be started manually after the echo sounder is ready. When pinging is On,
theWaterfall, Cross track and Beam intensity windows becomes active.
1 Select the echo sounder you want to ping with in the Current echo sounder combo

box.
2 Press the Pinging button on the toolbar. The button is red when Off and green

when On.
The selected echo sounder will now start transmitting.

Related topics
• Main toolbar on page 33
• Current echo sounder on page 36
• Beam intensity view on page 61
• Cross track view on page 64
• Waterfall view on page 73

Check sensor input
Proper operation of the external sensors are vital for the SIS operation. These are sensors
connected to the PU (Processing Unit) and not directly to the HWS (Hydrographic
Work Station).
Note

The PU – Processing Unit may be a separate hardware unit or an integrated part of the
TRU – Transceiver Unit cabinet, depending on echo sounder system.
For SIS it makes no difference whether the communication is with a PU or a PU inside a
TRU. The term PU is used in this manual.

External sensors are continuously monitored in SIS. The Time series window presents
data from the motion sensor. Sensor data is also shown in the Numerical display window.
Sensor errors are reported in the Message service window.

How to monitor the external sensors in SIS
1 Select the Time series frame.
2 Verify that roll, pitch and heave data is being received by SIS.
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3 Verify that the roll, pitch and heave data appears according to expected values.
4 Select the Numerical display frame.
5 Verify that values read from all your external sensors, including roll, pitch, heave

and sound velocity are close to what you expect.
6 Select the Message service frame.
7 Scroll through the logged messages and verify that there are no messages indicating

problems reading the external sensors.
8 Select the PU sensor status frame.
9 Verify that your sensors are marked with green, meaning that sensor is selected as

active and that data is being received.
10 Select the Sensor layout frame.
11 Verify that your sensors are located correctly

Related topics
• Time series view on page 72
• Numerical display on page 68
• Message service view on page 69
• PU sensor status view on page 86
• Sensor layout view on page 98

Check echo sounder main functions
Before you start logging, you are advised to make sure that the echo sounder system is
locked on the bottom and that the swath coverage is as expected.
The Geographical window presents a real time view of the system(s) performance during
online operation. The window shows the raw data from the system(s) after corrections
have been applied for vessel attitude and sound speed.

Note

The following information applies to multibeam echo sounders only. Single beam echo
sounders and GPS equipment do not have this option.

How to display realtime depths
While pinging or logging, realtime depths may be displayed in the Geographical window
using the following setup:
1 Press the Option button in the Geographical frame's toolbar.
2 Expand Survey in the left pan of the Geographical Options menu.
3 Select the Realtime Depth.
4 Press OK
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How to verify echo sounder main functions
Check the following windows:
1 Check the Waterfall window for a continuous bottom.
2 Check the Cross track window to see the depths for all the beams ping by ping.
3 Check the Beam intensity window for reasonable backscattering strengths for each

individual beam.
4 Check the sensor status in the Numerical display window and in the PU sensor status.
5 Check the Water Column display if available.

Related topics
• Geographical view on page 57
• Beam intensity view on page 61
• Cross track view on page 64
• Numerical display on page 68
• PU sensor status view on page 86
• Waterfall view on page 73
• Water column view on page 75

Geographical frame settings
How to display seabed imagery data in the Geographical view
Note

The grid must be generated with the seabed image options enabled. The seabed image
can be generated in real time or it can be generated during import of logged raw data.

1 Generate seabed image data in real time by
a Select the Survey administration frame.
b Open the Survey template handling tab.
c Select the Advanced tab.
d Select the GridEngine parameters tab.
e Press the Processing... button.
or generate seabed image data from logged raw data by
a Select File→Import/Export...
b Select Raw data files
c Enter Survey name, raw data path and other survey parameters as appropriate
d Locate the Grid Engine Parameters field at the bottom of the dialog
e Enter appropriate Number of cells and cell size.
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f Press the Processing... button.
2 Press the Advanced... button.
3 Tick off for Seabed Image Processing in Grid Engine.
4 Type a name for your new Seabed Image Processing rule the text field next to the

Save as button.
5 Press Save as
6 Press Apply to make changes active.
7 Press OK and next Accept to return to the Raw Data Files dialog box.
8 If you are creating the grid through importing raw data, press OK now and await the

import process to finish.
9 Select the Geographical frame.

10 Select the Options button.
11 Select Survey→SIS Based Surveys in the left tree structure.
12 Locate the show/hide field to the right of the dialog.
13 Check the Sonar Display Grid option.
14 Press OK
15 Select the area in the geographical view that you want to display with high

resolution seabed image by:
a Click left mouse button in start point for the area.
b Drag the mouse to the end point for the area.
c Press the shift key.
d Release the mouse button and the shift key.

16 Observe that selected area is shown with seabed image mosaic.

How to display sound velocity at transducer depth in the Geographical view
This functionality requires that your raw data (*.all files) contains data from a sound
velocity probe that is connected at the same or close to the depth of your transducer.
1 Open a console window, e.g. as follows

a Press the Windows Start button
b Select Run... in the right side of the Start menu
c Type cmd in the text field that appears
d Press OK

2 Go to the directory where the SIS executable files are located, i.e. the SIS\bin
directory.
To change drive and directory in a console window:
a Type the drive letter, e.g. C:, and press Enter to change the drive
b Type cd\ to change directory to the root directory

342682/D 163



Seafloor Information System

c Type cd <sub-folder> \<next sub-folder> to change the directory
to an existing directory below, e.g. cd program files\Kongsberg
Maritime\SIS\bin to change to the SIS\bin directory

3 Run makeSoundSpeedAtHeadFile.batwith the path to the raw data as argument.
E.g. if your raw data is stored at c:\sisdata\raw\testdata you must type the following
in the command window:
makeSoundSpeedAtHeadFile.bat c:\sisdata\raw\testdata

4 Observe that the program is running by reading the raw data files you have specified.
When completed the following message will be displayed in the command window:
File soundspeed.txt can now be imported into SIS
The new file will be stored at the same location as you run
makeSoundSpeedAtHeadFile from.

5 Return to SIS
6 Select Tools→Custom...→Create grid from ascii files

7 Select the Project that your data was logged in
8 Select a grid size and number of cells in processing grid.

Note

The grid cell size should be set a lot larger than you would for a standard survey.

9 Select the output directory and a name of your new gridded sound velocity data
10 Press Select ascii input files... and browse for the soundspeed.txt file
11 Enable the selection of the file by highlighting the file name in the File list
12 Press OK to start the importing.

A status window will be displayed as the data are converted into grid data
13 Select File→Import/Export...

14 Press the Import button to select a gridded data set
15 Browse for the folder named after the survey name set in the Create grid from

ascii files process
16 Highlight the selected survey and press OK to import
17 Press the Zoom to world button in the Geographical display toolbar
18 Verify that the sound speed is displayed.

Note

SIS will interpret the sound velocity as a depth value, so the legend will display
'Depth' even though the values are the sound velocity.
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Note

The sound velocity data may be easier to read if you display the data as
points, rather than filled polygons. Select the Display option button, then go to
Survey→Gridded data and set Drawstyle to Points.

How to display a smooth surface
To display a nice and smooth model of the seafloor, use the Option button and choose
Survey→SIS based survey→Depth operations: Min. This will select the minimum value
in each grid cell and create a surface from them. Noise will be hidden in this surface,
but it will be the shallowest surface drawn very smooth.
1 Press the Geographical option button
2 Expand Survey in the left tree structure
3 Select SIS based survey in the tree structure
4 Locate Depth operation in the mid field on the right side of the window
5 Set Depth operation to Minimum

How to look for artifacts
Inspection mode is used to scan for objects on the seafloor and to filter out noise that
may look like objects. The I button is used to toggle inspection mode on and off. When
in inspection mode, the LOD is set to 0, depth operation is set to median depth and
the depth scale factor is set to 2. Toggling the I button a second time will restore the
previous settings.
Alternatively, you may manually set the inspection parameters as follows:
1 Press the Geographical option button
2 Expand Survey in the left tree structure
3 Select SIS based survey in the tree structure
4 Locate Depth operation in the mid field on the right side of the window
5 Set Depth operation to Median
6 Select Gridded data in the tree structure
7 Locate Level of detail
8 Choose a smaller Level of detail (LOD)

You should not start using level of detail 0, as this may overload the system
resources. Instead try to use an increasingly smaller level of detail until a good
picture is found.

9 Select General in the tree structure
10 Locate Light source
11 Try to turn the light source on and off.

When off, the light source will follow the mouse cursor and make it easier to see
shadows from different angles.

12 Select Survey in the tree structure
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13 Locate Depth scale factor
14 Try to change the Depth scale factor to see shadows even better.

How to create and use a GeoTIFF background image in the Geographical view

Note

GeoTIFF is a standard which allows georeference information to be embedded within a
TIFF file.

You can create and display a GeoTIFF image from gridded survey data. You can also
import a GeoTIFF file into SIS and display it as background in the Geographical display.

How to create a GeoTIFF background image from the Geographical view

A gridded survey must be loaded in the Geographical view in SIS.
1 Select the area you want to create a graphical GeoTIFF file from.
2 To create a picture with best possible resolution, select the Geographical Options

button, locate the Level of Detail field, and select the Level Of Details (LOD) that
gives the best presentation of your selected area.

3 Press the Save background data button .
Three files are created in the background directory, i.e.
\sisdata\common\background:
• gvsor – the GeoTIFF file
• gvsor_tmp.tif – a standard tiff file (not geo-referenced)
• gvsor_tmp.tfw – a tiff world file (geo-referencing information for the tiff file)

4 Rename and copy the created file if you want to keep it.

How to use the GeoTIFF file in the Geographical view

A GeoTIFF file can be give useful background data information for an area, e.g. data
from an earlier survey in the area. To load a GeoTIFF file to be displayed as background
data in SIS:
1 Select File→Import/Export

2 Locate the Data Types field
3 Select Background Images
4 Press the Import button

The Background Image Information window appears
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5 Browse for the GeoTIFF file by pressing the browse button in the upper right corner.
When selected the image and georeference information fields in the Background
Image Information window will be completed.

6 Press OK to leave the Background Image Information window
7 Press OK once more to leave the Import/Export window

You will now have a background image in the Geographical view. The GeoTIFF
files will with it's georeferenced information be displayed in the correct projection
and scale.
The following figure shows an example of the use of a GeoTIFF background image.
A high resolution image of the survey is displayed on top of a loaded survey, which
in this example is displayed 50% transparent.
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Figure 8 Example of use of GeoTIFF background image

Related operational procedures
• How to enter survey parameters on page 114

Parameter references
• Geographical – Display options on page 211
• Geographical – Inspection mode on page 223
• Geographical – Save background image on page 224
• GridEngine parameters on page 269
• Data cleaning on page 317
• Import/Export on page 352
• Create grid from ASCII files on page 451

Related topics
• Geographical view on page 57
• Keyboard and mouse in the Geographical view on page 44
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Start and stop logging
Logging must be started manually after the echo sounder is ready. In the Current echo
sounder combo box, select the echo sounder you want to start.

Note that if pinging is Off when logging is turned On, pinging will automatically be
turned On. If logging is On and pinging is turned Off, logging will automatically be
turned Off.

How to start and stop logging – Alternative 1

During the survey, the vessel navigates along the pre-planned survey lines. Logging
must be started at the beginning of each line. Stop the logging at the end of each line and
start it again at the beginning of the next.

At the start of every survey line:
1 Press the red not logging button on the toolbar.
2 Verify that logging starts by that the button turns green.
3 Press the green logging button when the vessel has reached the end of the line.
4 Transit to the next line.
5 Press the red not logging button when starting the next line.
6 Press the green logging button when the final survey line has been completed.

How to start and stop logging – Alternative 2

You can also start the logging at beginning of the first line and let it run continuously,
changing line number only at start of each new survey line.

At the start of the first survey line:
1 Press the red not logging button on the toolbar.
2 Verify that logging starts and the button turns green.
3 Press Line Cnt (xxxx) at the beginning of each survey line.
4 Verify that a new line number has been assigned.
5 Press the green logging button when the final survey line has been completed.

Related topics
• Current echo sounder on page 36
• Line counter toolbar set on page 37

How to save data

When the echo sounder has started logging, data is automatically saved to disk.

The Line counter button on the toolbar shows the line count for the currently selected
echo sounder.
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To avoid very large log files the counter for all active echo sounders are incremented
automatically every 30 minutes (this is configurable). This, however, only happens when
the counter has not been incremented by other means within the last 30 minutes, i.e. by
pressing the line counter button or by stopping and restarting logging. Interval for line
counter is set from Tools→Set parameters→Logging.
A full disk warning will be given. When a full disk warning is received, you must copy
the surveyed data to an external storage device and delete the data from the logging
computer.

How to verify data logging
To verify that data is actually being logged, and that nothing has caused the logging
process to stop or not to start at all, there are different methods:
1 Verify that logging is started without any error messages or pop-up messages

appearing.
2 If you have not deliberately turned off the display of gridded data, the display of

gridded data is an indicator of that data is being logged. It is the logged data that
is the basis for the gridded data. The realtime tail or the realtime displays uses
data directly from the echo sounder and are thus no indication as to whether data
is being logged or no.
Note that missing gridded data also may be caused by memory problems, and gives
therefore no firm indication of that logging of raw data has stopped.

3 Open the Windows Explorer and locate the raw data directory. Verify that the raw
data file, .all file with current time, is being updated.

Parameter references
• Logging on page 341

How to log water column data
Water column data can be logged to either the standard log file (.all) or to a separate water
column file (.wcd). Water column data can not be logged to both files simultaneously.
Water column logging to separate file is enables as follows:
1 Open the Installation parameters frame.
2 Select the Output setup tab.
3 Enable Log watercolumn to separate file.
4 Open the Water Column frame.
5 Select the Show/Hide toolbar button
6 Toggle logging on/off by checking/unchecking the Logging option located as second

option in the dialog.

How to log stave data
Stave data can be logged to the currently opened .all file.
1 Open the Stave display frame.
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2 Select the Show/Hide toolbar button.
3 Enable Logging.
To enable this logging the following conditions must be fulfilled:
• The Stave display frame must be open and remain open.
• Standard logging must be started/active (i.e. the Logging button is the SIS main

toolbar must be green).

Parameter references
• PU communication – Output setup on page 279
• Water column – Logging on page 247
• Stave display – Show/hide on page 249

Perform a system calibration
This section contains the following procedures:

Operational procedures
• Roll offset in the acrosstrack direction on page 173
• Pitch offset and time delay on page 174
• Heading offset – Alternative 1 on page 176
• Heading offset – Alternative 2 on page 177
• Sound speed quality inspection on page 178
• Sound speed control on page 179
• Outer beam angle offset calibration on page 180
• Verification on page 180
• How to determine calibration values using SIS Calibration frame on page 181
• How to determine calibration values using SeaCal automatic calibration on page 184
• How to calibrate a dual head system on page 188
Note

This section applies to multibeam echo sounders only.

To ensure maximum reliability and accuracy of the depth determination, it is strongly
recommended that the system and it's externally connected sensors are calibrated before
the start of a new survey.
All sensors must be accurately surveyed with respect to the vessel's reference point
and with respect to the vessel's reference plane during installation of the system. The
attitude sensor will normally with intervals be calibrated while along a quay using land
survey methods.
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The intention of the SIS calibration is to find remaining biases in the installation angles
and to find any time synchronization biases between the systems. The biases can origin
from transducer alignment, from the alignment of the attitude sensor or be caused by
time synchronization differences between the sensors.

The correct calibration of the vessel's attitude sensors as well as determining the time
delay of the positioning system is vital to the quality of the depth data determined by the
multibeam echo sounder.

The calibration should be performed in the following order and the values from each
calibrations entered in the system before the next calibration:
• Rough roll calibration
• Pitch and time delay calibration
• Heading calibration
• Roll calibration

The calibrations should be repeated until the calibration results are within ±0.1 degree.

The built-in SIS calibration is used to process data from a calibration survey, usually
consisting of one or more sets of overlapping lines as described below. It is recommended
to use the SIS calibration, where depth data from two or more lines are compared. The
offset values are found either by visually determining the correction values that gives
best fit between the two depth curves, alternatively by using the SeaCal automatic
calibration feature if licensed.

Determining a suitable calibration area

Note

Sound speed and echo sounder errors are not considered in this discussion. Sound speed
must be thoroughly determined for the calibration area.

On a flat area only a roll offset will cause significant depth errors. Thus, if the survey is
to be run in a reasonably flat area, it may be sufficient to perform roll calibration only.
However, a full calibration is normally required. The calibration must then be carried out
to eliminate influence by other errors than the one you are calibrating for.

Note that the positioning accuracy is vital for good calibration results, except for the roll
error calibration on a flat bottom.

The ideal calibration area is partly flat and partly a fairly steep slope with little change
in depth acrosstrack, and with a distinct feature such as a peak or hollow in the flat
area. If the heading and positioning errors are negligible, the flat area is not required
if the slope has a reasonably constant depth acrosstrack. In order to resolve the pitch
offset and time delay accurately, the slope should have an appreciable relative change
in depth from top to bottom of approximately 30%. Note that the slope should not be
too steep, say not more than 20°, otherwise the echo sounder may have problems in
maintaining good data quality.
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Calibration lines

To determine any local variations across the swath, we recommend that you run
calibration survey lines that covers two times the swath width.

Related operational procedures
• Run the survey on page 202

Parameter references
• Calibration parameters on page 260

Related topics
• Calibration view on page 100
• SeaCal on page 409

Roll offset in the acrosstrack direction
1 Choose a horizontally flat area (at least acrosstrack)
2 Survey two lines in opposite directions.

Ensure that sufficient lead-in time to the line is used allowing the roll sensor to
stabilize.

3 Place a calibration corridor orthogonally to the survey lines.
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Figure 9 Roll offset calibration procedure

4 Compare depth data from the two lines in the selected corridor.
If there is a roll offset, there will be a depth difference between the two data sets,
increasing with acrosstrack distance from the centre where it is zero.

5 Repeat step 3 and 4, i.e. create several corridors along the calibration survey line to
determine any variations over the area.

Pitch offset and time delay
1 Choose an area with a continuous but not too steep slope alongtrack
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2 Survey two lines in opposite directions with constant vessel speed along each line
3 For time delay calibration, survey a third line on top of the two with constant, but

significantly lower speed.
The direction of the last line is not essential. Ensure that sufficient lead-in time to
the line is used for the pitch sensor to stabilize.

4 Place a calibration corridor parallel to the survey lines, on top of the vessel track

Figure 10 Pitch offset and time delay calibration procedure
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5 Compare depth data from the two lines in the selected corridor.
Any alongtrack depth difference between the runs may be due to four different
factors:
• Pitch offset
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• Time delay between actual position and position when position datagram is
supposed to be valid

• For multibeam echo sounders with transducers a position distance offset (either
due to an error in the positioning system or an error in entered locations)

• Tide difference
6 Determine any time delay in the position system

Note that a depth error on a constant gradient slope, due to pitch offset, increases
with increasing depths. Depth errors caused by position time delay increases with
vessel speed, whilst errors due to distance offset is independent of depth and speed.
Comparing data from the two lines in the same direction, but with different vessel
speed, will thus allow the time delay to be found.

7 Determine any pitch offset.
After the correction for time delay error has been applied to the data, the pitch offset
can be determined from the two lines run in opposite directions.

Note

If PPS and time from datagram are used, there should be zero time delay. Please refer to
Timing on page 498 for a detailed explanation.

Heading offset – Alternative 1

Note

The best check of the gyro is done using land survey methods while in harbour.

1 Run two parallel lines up or down a slope in the same direction, separated, but
with overlap in-between.

2 Select a calibration corridor.
The corridor used for comparison must be placed alongtrack in-between the lines.
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Figure 11 Heading offset calibration procedure (alternative 1)
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3 Compare depth data from the two lines in the selected corridor.
Any heading offset will give a depth difference between the two lines.

Heading offset – Alternative 2
1 Find an easy recognizable point or feature on the bottom such as a peak or a

depression.
2 Run two survey lines at opposite sides of this feature so that the point will be in the

outer part of the echo sounder swath.
Survey these two lines in same direction.

3 Select a calibration corridor
The corridor used to compare data from the two survey data sets must be placed so
that it intersects the feature, and is parallel to the survey lines.
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Figure 12 Heading offset calibration procedure (alternative 2)
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4 Compare depth data from the two lines in the selected corridor.
If there is a heading offset, you will have a different location alongtrack in the
two data sets
Note

Accurate positions and position time delays are required.

Sound speed quality inspection
1 Survey two lines or more, perpendicular to each other.

This means that the two lines in the pair cross each other on a flat area of the sea
floor with a difference in the sailing direction of about 90 degrees.

2 Create calibration corridors in the crossover area
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Figure 13 Outer beam angle calibration
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3 Compare the depth in different points in the crossover region.
Depth differences along the two centre lines with respect to the outer edges of the
swath from the other line (i.e. points 2, 4, 6, 8) will be due either to roll or sound
speed errors. Note that the depth error due to sound speed has the same sign, while
those due to roll changes sign across the centre line.

Sound speed control

The same procedure as used for the outer beam angle offset calibration may be used as a
check for sound speed corrections. Provided that the roll offset and outer beam angle
offsets are correct, any depth deviation between the two lines in the two calibration
corridors are due to sound speed errors, either in the used profile, and/or in the sound
speed at transducer depth.
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Outer beam angle offset calibration
Please see Outer beam angle calibration on page 179 for a graphical description of the
method.
Note

The outer bean angle offset calibration applies to EM 1002 only

Note

The outer beam angle offset is critically dependent upon correct roll calibration and
correct sound speed calibration.

1 Run two perpendicular survey lines on a relatively flat bottom.
The depth must be approximately 50 to 100 meters, and 150 degrees coverage
must be used.

2 Set a calibration corridor along each of the lines in the crossover area.
3 Compare the depth in different points in the crossover region.

Any angular error at the points 2, 4, 6 or 8 may be due to errors in:
• Outer beam angle offset
• Sound speed
• Roll offset

4 Determine the roll offset
If sound speed and roll offset are correct, determine angular errors by changing the
roll offset angle to make the outer beam depths equal at 2, 4, 6 and 8, and take the
average of these.
If the outer beams are too shallow compared to the centre beams, the outer beam
angle offset is positive, if they are too deep the outer beam angle offset is negative.

5 Add the outer beam angle offset to the outer beam angle offset already used in
the installation menu.

Verification
Important

After the calibration values have been determined, we strongly advise you to repeat the
procedure for verification. This is especially important if your calibration results is larger
than the expected accuracy of the sensors.

Automatic calibration
SIS offers an automatic calibration using the SeaCal program. Calibration survey lines
are as described in the procedures above. SeaCal will based on the selected lines
compute the offset values for each parameter that gives best fit, i.e. smallest residual
with highest possible reliability. SeaCal may be used as an alternative or as an addition to
the visual method.
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How to determine calibration values using SIS Calibration
frame
Calibration will only work with two or more selected lines in a survey. The lines must
have been surveyed according to recommended patterns. These patterns are:
• Roll calibration: parallel lines over a flat area, in opposite direction and with overlap

for the outer beams
• Pitch calibration: parallel lines over a slope, in opposite direction and with lines on

top of each other
• Heading calibration: parallel lines over a slope or a seabed feature, same direction

and with overlap for the outer beams
• Time: same as for pitch calibration, but with different constant vessel speed for the

two lines
The data used in the calibration computations is the data found inside the geographical
area currently displayed in the geographical view. You may select as many lines as you
want before you make your corridor. If the geographical area is set too large, or too
many lines are selected, the computation may become too resource demanding for the
computer. The solution is to reduce the displayed area (zoom in), or deselect some lines.
Note

Stored Shipstracks must be turned on from the Geographical Options menu.

1 Select Calibration from the frame selection drop down list of the main toolbar to
enable the calibration mode.

2 Press from the Geographical view's toolbar to enable selection of lines and
calibration corridor

3 Press the Follow ship button to stop the view from moving along with the ship
4 If more than one Survey is loaded, select from the Survey List box which survey to

use.
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5 Select the lines by holding down the Ctrl button and selecting the lines using left
mouse button.
or
select the lines by name by clicking on the Select Lines... button at the bottom of
the Calibration frame.
You can check that you have picked the correct line by looking at the file name of
the selected line that appears in lower left corner of the SIS application window.
Note

You may need to zoom in to be able to separate and select the correct lines

6 Enable selection of a calibration corridor to show the depth data for by holding
down the Ctrl button and click the right mouse button

7 Select a corridor by holding down the Ctrl button and clicking using left mouse
button at the two end points of the selected line
Data from two or more lines inside this corridor will be analysed.
• For roll calibration – select a corridor across the two survey lines
• For pitch calibration – select a corridor along the survey lines
• For heading calibration – select a corridor along the survey lines
• For timing calibration – select a corridor along the survey lines
When a corridor has been selected, the calibration module will read the raw depth
and display them in a diagram.

8 Make sure the depth data for the selected survey lines along the selected corridor
is displayed in the Calibration frame.

The system will use data within the corridor, which represents all points within
a specified distance from a calibration line. The data will be displayed using a
two-dimensional diagram with the horizontal axis representing the distance along
the corridor, and depth along the vertical axis. Data from two different survey lines
will be shown in the same diagram, each with its own colour.
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In the Calibration window you can change the offset value of the sensor you are
calibrating and immediately see its effect on the depths shown. The offset value
giving the best fit between the curves is the result of the calibration.
Note

The offsets applied in the selected files are shown as Current Offset. These are not
necessarily the current ones in the Installation parameters. Take care to check
that the lines used for calibration have been run with the same parameters as the
current ones in the Installation parameters

9 If you have dual head, select what head you want to calibrate.
10 Enter an estimated correction value for the sensor you are calibrating, i.e. either

roll, pitch, heave or time
The values can be increase/decreased by using the spin buttons.

11 Press Apply to calculate and display the effect on the depth curves
12 Iterate through step 9 and step 10 until you find the value that gives best visual fit

between the two depth curves
The offset value that gives the best fit between the depths on the two calibration
lines is finally to be entered in the corresponding sensor field in the system’s
Installation parameters.

13 Repeat step 7 to step 12 placing the corridor at different places along the calibration
lines.

14 Ensure that you have consistent calibration values along the line before you apply
any calibration values to the installation parameters.
If there is significant inconsistency along the line you must evaluate what may be
causing the inconsistency, and what you can do to correct for them. The reason for
inconsistency may be:
• Variation in sound speed over the area.
• Unreliable position and motion observations
• Remaining errors in the installation angles
Note

The Seacal calibration as described in the following can be used to verify any
suspected inconsistency along the calibration line. Seacal will automatically look
for consistency along the whole calibration line, and label the results as unreliable
if they are inconsistent.

15 Press Store to add the new values to the existing ones that are set from Installation
parameters→Sensor setup→Angular offset

and/or
16 Open the Installation parameters frame and select Sensor setup→Angular offset.
17 Verify the newly stored values, or manually enter your new calibration figures.
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Note

To verify that correct values have been automatically entered you must know the
original figures, which not necessarily were zeros.

For single head systems the values are to be applied to the Attitude sensor in use.
For dual head systems you have to enter the values manually.
For dual head system we recommend that you apply the average value for head 1
and 2 on the attitude sensor, and the difference from the average on each of the
sonar heads. I.e. if the results for head 1 and 2 are +0.3 and +0.5, respectively, we
recommend that you apply +0.4 on the attitude sensor and -0.1 and +0.1 on sonar
head 1 and 2.

18 Press OK to download the new values to the echo sounder.
19 Verify the calibration results by rerunning the calibration procedure step 1 to step 13.

If the calibration was successful, the new correction values will be close to zero.

Parameter references
• Angular Offsets for EM 2040 on page 290

Related topics
• Calibration view on page 100
• Keyboard and mouse in the Calibration view on page 46

How to determine calibration values using SeaCal automatic
calibration
Automatic calibration requires two or more selected lines that have been surveyed
according to patterns described earlier in this chapter. The lines may be the same as
you have used for visual determination of calibration values as described in How to
determine calibration values using SIS Calibration frame on page 181. If you already
have selected your calibration lines you do not have to repeat it.
SeaCal will use all available data within what is currently displayed inside the
geographical view. By panning and zooming you may select the optimal area for the
calibration computations. If the geographical area is set too large, or too many lines are
selected, the computation may become too resource demanding for the computer. The
solution is to reduce the displayed area (zoom in), or deselect some lines.
1 Select the lines by holding down the Ctrl button and selecting the lines using left

mouse button.
You can check that you have picked the correct line by looking at the file name of
the selected line that appears in lower left corner of the SIS application window.
Note

You may need to zoom in to be able to separate and select the correct lines

2 Zoom back to a view showing the complete length of the lines.
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If not, only data from the view will be used in the computation.
3 Select what head you are calibrating.

Note

If you have a dual head system you are allowed to calibrate both heads in one
computation. Select Both heads to calibrate both heads.

4 Press the AutoCalib button

5 Tick off for the element you are calibration, i.e. either roll, pitch or heading. Further,
we recommended to tick off for the following options:
• Relative Tide: All
• Beam Sector: All
• Maximum sea depth: All
• Resolution: Auto
• Max iterations: Auto
Leave the remaining parameters unchecked.

6 Set Type of computation to Calibration with Reliability test
7 Press Accept to start the computations

Depending on the data consistency there will be a number of iterations carried out.
You may follow the iteration process in a command window appearing.
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When completed windows showing the reliability of the computed values are shown
for each head. The graph shows how well Seacal is able to compute the calibration
value. The reliability indicator, R, should be as close to 1.0 as possible.

8 Close the reliability windows
The window Open SeaCal result file appears.

9 Open the *.res file. The filename of the result file has the format
Seacal_yyyymmdd_hhmmss.res, where yyyymmdd is date of computation and
hhmmss is local time of computation.
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Note

For dual head systems the result file will contain the results for both heads.

The SeaCal Results window will appear. In example below roll has been calibrated
giving the following results:
• Roll calibration value = 0.879/-0.129, i.e. the correction value that may be

applied to head 1 and head 2, respectively
• Correlation = 0.00

The correlation coefficient gives information about how well the parameters can
be separated. Values below 0.3 is labelled OK.

• Reliability = 0.00/0.98, i.e. close to 1, which is best achievable figure for
reliability

The result values for roll are labelled with green label, which means results are
consistent and considered to be reliable.

10 Press OK to finish.

Note

No corrections are applied. Correction values must be entered into Angular Offsets
set in the Installation Parameters frame

Note

To review the SeaCal results, select Tools→Seacal Results from the SIS main menu
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Related operational procedures
• How to determine calibration values using SIS Calibration frame on page 181

Parameter references
• Seacal auto calibration on page 261
• SeaCal results on page 381

Related topics
• SeaCal on page 409

How to calibrate a dual head system

If you have a multibeam echo sounder with two heads installed there are some additional
concerns related to calibration you need to consider:
• You have to determine offset values separately for both heads
• The heads will normally be installed pointing sideways instead of down calling for a

different calibration survey pattern
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Note

A valid sound velocity profile must be used to obtain a correct result.

The calibration should be performed in the following order and the values from each
calibrations entered in the system before the next calibration:
• Rough roll calibration
• Pitch and time delay calibration
• Heading calibration
• Roll calibration

The calibrations should be repeated until the calibration results are within ±0.1 degree.

Use the SIS Calibration frame and/or the Seacal automatic calibration to evaluate the
data and determine the offset value. See
• How to determine calibration values using SIS Calibration frame on page 181
• How to determine calibration values using SeaCal automatic calibration on page 184

Roll offset calibration – dual head
1 Choose a horizontally flat area (at least acrosstrack)
2 Survey three lines in opposite directions and with distance between the lines to

ensure full overlap for each head, i.e approximately half the swath width. Survey
these lines at the same speed.
Ensure that sufficient lead-in time to the line is used allowing the roll sensor to
stabilize.

3 Select two of the lines.
Select the lines that gives full overlap for one of the heads.

4 Place a calibration corridor (A) orthogonally to the survey lines.
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Figure 14 Roll offset calibration procedure
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5 Compare depth data from the two lines in the selected corridor.
If there is a roll offset, there will be a depth difference between the two data sets,
increasing with acrosstrack distance from the centre where it is zero.

6 Select two of the lines that gives full overlap for the other head.
7 Place a calibration corridor (B) orthogonally to the survey lines.
8 Compare depth data from the two lines in the selected corridor.

If there is a roll offset, there will be a depth difference between the two data sets,
increasing with acrosstrack distance from the centre where it is zero.

Pitch offset calibration – dual head – Alternative 1
Preparations: Reduce the opening angle to ±50 degrees on the outer sectors. Open the
inner angle to ±20 degrees on the inner sectors.
1 Choose an area with a continuous, but not too steep, slope alongtrack.

190 342682/D



Operational procedures

2 Survey two lines in opposite directions with constant vessel speed along each line.
Survey these lines at the same speed.

3 For time delay calibration, survey a third line on top of the two with constant, but
significantly lower speed.
The direction of the last line is not essential. Ensure that sufficient lead-in time to
the line is used for the pitch sensor to stabilize.

4 Place a calibration corridor parallel to the survey lines, on top of the vessel track.

Figure 15 Pitch offset and time delay calibration procedure, alternative 1
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5 Compare depth data from the two lines in the selected corridor.
Any alongtrack depth difference between the runs may be due to four different
factors:
• Pitch offset
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• Time delay between actual position and position when position datagram is
supposed to be valid

• For multibeam echo sounders with transducers a position distance offset (either
due to an error in the positioning system or an error in entered locations)

• Tide difference
6 Determine any time delay in the position system

Note that a depth error on a constant gradient slope, due to pitch offset, increases
with increasing depths. Depth errors caused by position time delay increases with
vessel speed, whilst errors due to distance offset is independent of depth and speed.
Comparing data from the two lines in the same direction, but with different vessel
speed, will thus allow the time delay to be found.

7 Determine any pitch offset.
After the correction for time delay error has been applied to the data, the pitch offset
can be determined from the two lines run in opposite directions.

Pitch offset calibration – dual head – Alternative 2

Preparations: Reduce the opening angle to ±50 degrees on the outer sectors. Open the
inner angle to ±20 degrees on the inner sectors.
1 Find an easy recognizable point or feature on the bottom such as a peak or a

depression.
2 Survey two lines in opposite directions with constant vessel speed across the feature.

Survey these lines at the same speed.
3 For time delay calibration, survey a third line on top of the two with constant, but

significantly lower speed.
The direction of the last line is not essential. Ensure that sufficient lead-in time to
the line is used for the pitch sensor to stabilize.

4 Place a calibration corridor parallel to the survey lines, on top of the vessel track.
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Figure 16 Pitch offset and time delay calibration procedure, alternative 2
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5 Compare depth data from the two lines in the selected corridor.
Any alongtrack depth difference between the runs may be due to four different
factors:
• Pitch offset
• Time delay between actual position and position when position datagram is

supposed to be valid
• For multibeam echo sounders with transducers a position distance offset (either

due to an error in the positioning system or an error in entered locations)
• Tide difference

6 Determine any time delay in the position system.
Comparing data from the two lines in the same direction, but with different vessel
speed, will thus allow the time delay to be found.
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7 Determine any pitch offset.
After the correction for time delay error has been applied to the data, the pitch offset
can be determined from the two lines run in opposite directions.

Heading offset calibration – dual head – Alternative 1

Note

The best check of the gyro is done using land survey methods while in harbour.

1 Run two parallel survey lines up or down a slope in the same direction, separated,
but with overlap in-between. Survey these lines at the same speed.

2 Place a calibration corridor on top of one of the survey lines:

Figure 17 Heading offset calibration procedure – dual head alternative 1
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3 Compare depth data from the two lines in the selected corridor.
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Any heading offset will give a depth difference between the two lines.
4 Repeat step 2 and 3, i.e. create a calibration corridor on top of the other survey

line to compare data for the other head.

Heading offset calibration – dual head – Alternative 2
1 Find an easy recognizable point or feature on the bottom such as a peak or a

depression.
2 Run three survey lines, one on each side of the feature, and one on top of it. Survey

these three lines in same direction and at the same speed.
The lines should be separated, but with overlap in-between.

3 Place a calibration corridor on the survey line on top of the object.

Figure 18 Heading offset calibration procedure – dual head alternative 2
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4 Compare depth data from the line in centre with the lines on each side of the object.
Any heading offset will give a depth difference between the two lines.
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Example 1 Roll calibration – changing the installation parameters

Original installation parameters:

Roll calibration result:
• Head 1: 0.2 degrees
• Head 2: 0.4 degrees

Corrections:
A Mean value for attitude sensor: (0.2 + 0.4) / 2 = 0.3
B Correction for head 1: 02 – 0.3 = –0.1

Value to enter in installation parameters: 40 + (–0.1) = 39.9
C Correction for head 2: 0.4 – 0.3 = 0.1

Value to enter in installation parameters: –40 + 0.1 = –39.9
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Example 2 Pitch calibration – changing the installation parameters

Original installation parameters:

Pitch calibration result:
• Head 1: 0.2 degrees
• Head 2: –0.4 degrees

Corrections:
A Mean value for attitude sensor: (0.2 + (–0.4)) / 2 = –0.1
B Correction for head 1: 0.2 – (–0.1) = 0.3

Value to enter in installation parameters: 2 + (0.3) = 2.3
C Correction for head 2: –0.4 –(–0.1) = –0.3

Value to enter in installation parameters: 2.2 + (–0.3) = 1.9
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Example 3 Heading calibration – changing the installation parameters
Original installation parameters:

Heading calibration result:
• Head 1: 0.342 degrees
• Head 2: –2.240 degrees
Corrections:
A Mean value for attitude sensor: (0.342+ (–2.240))/2= –0.949 degrees
B Correction value for head 1: 0.342–(–0.949) =1.291 degreees

Value to enter in installation parameters: 359.5 +1.291 =360.791
360.791 –360 =0.791 degrees

C Correction value for head 2: –2.240 – (–0.949 )= –1.291 degrees
Value to enter in installation parameters: 1.75 –1.291= 0.459 degrees
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Related operational procedures
• How to determine calibration values using SIS Calibration frame on page 181
• How to determine calibration values using SeaCal automatic calibration on page 184

Parameter references
• Calibration parameters on page 260
• Seacal auto calibration on page 261
• SeaCal results on page 381

Related topics
• SeaCal on page 409

Plan a survey
Introduction
A survey plan will normally define the following factors:
• The survey area
• Bottom conditions
• The survey lines
• The direction and order of the survey lines
• The survey lines required for system calibration
• The location and timing for sound speed profiles
When planning the survey lines islands, coastlines, shoals and other obstacles within the
survey area that may have influence on safety or efficiency of the survey must be taken
into account. The achievable coverage of the multibeam echo sounder and the overlap
required between neighbouring lines is usually used to determine the line spacing.
A fully comprehensive survey plan is most useful in areas of deep waters or where
the depth and hence coverage is fairly constant. In shallow waters where the depth
changes rapidly and may not even be known, a comprehensive plan may not be as useful,
especially if the survey is to be run with a small and agile vessel. A defined survey
area boundary plus a few pre-planned lines for calibration may then be enough. Actual
coverage is obtained on the spot instead of being used to determine the survey lines.
The SIS Planning module allows a survey to be split into sub-surveys or jobs. The
survey area boundary may be defined as a polygon with any number of corners, as may
areas which are not to be entered. Automatic line clipping at the polygon boundaries
and automatic generation of parallel lines is supported.
During the survey, planned lines may be activated to generate steering information
for the bridge and helmsman's display. The purpose of the Planning module is thus to
provide help before and during the survey.

342682/D 199



Seafloor Information System

Factors to consider
• A survey is normally planned taking the following into account:

– Echo sounder coverage
– Seafloor topography
– Sound speed variations
– Weather conditions

• The requirements for calibration of the positions (time delay), heading, roll and pitch
sensors must be considered, and how and where to gather sound speed profiles.

• Coverage capability determines line spacing, and as it varies with bottom reflectivity,
this must be estimated. Usually 10% overlap between lines is sufficient, but if large
variations in bottom reflectivity is expected, or reflectivity is unknown, it may be
necessary to increase the overlap. The overlap must also be increased if the vessel’s
roll is excessive.

• If there are steep slopes on the bottom, it is strongly advised to run along these slopes,
not up or down them. This is beneficial for keeping coverage reasonably constant
along the survey lines, thus making survey planning easier. However, the main reason
for this advice is that the echo sounder performance will usually be poorer when
running up or down a slope rather than along. This is because less acoustic energy is
reflected towards the transducer from steep slopes, causing poorer detections and the
possibility of false detections in sidelobes. Sidelobe detections is however very rare
in the Kongsberg multibeam echo sounders due to the advanced signal processing
implemented. Note that if circumstances require that survey lines are run up or down
a slope, reduction of vessel speed may be required to allow the echo sounder to track
the bottom continuously.

• Coverage capability is also affected by weather conditions and possibly also by vessel
speed. Heavy seas and possibly vessel speed lead to increased noise level, and may
also cause aeration on the Sonar Head or the transducer array.

• Aeration is a function of sea state, but also of the heading with respect to the wave
direction and the vessel speed. It is strongly advised that one builds a record of
coverage and aeration problems versus sea state, heading with respect to wave
direction, and vessel speed. This record may be helpful in ensuring that surveys
can be performed efficiently with a minimum of line rejections and corresponding
reruns and infills.

• Any drift rates of roll, pitch and heading should also be recorded to enable efficient
planning of calibration intervals. If calibration is required before a survey, a suitable
calibration area must be identified before reaching the survey area.

• A sound speed profile must always be taken within the survey area and loaded into
SIS before the survey is started. In some areas the profile will vary, mostly due to
fresh water inflows from rivers or currents from areas with different salinity. Surface
sound speed variation may be strongly affected by solar warming. If variations can be
expected, where and when sound velocity profiles are to be taken must be planned,
and the survey line schedule adjusted to take this into account.

• If the measured sound speed value at the Sonar Head or the transducer array depth is
continuously measured, it is recommended to compared this to what is observed by
the profiling instrument to evaluate the need for observing a new profile.
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• Note that in some cases the coverage capability of the echo sounder cannot be fully
utilized, because remaining errors in roll and sound speed profile measurements,
which are critical for maintaining the accuracy of the outer beams, become too large.
The ray bending effect (Snell’s law) may also reduce the online coverage since the
energy can bend inwards.

How to plan a new job in SIS
1 Select the Planning module frame.

The Geographical view must also be accessible.
2 Expand Jobs.
3 Press New job

4 Enter a descriptive name of the job
5 Select your preferred coordinate format
6 Expand Objects

7 Select New line, New polygon, New line from or New object depending on your plan.
8 Select the end points of your object by pointing the mouse in the geographical view,

hold the Ctrl button while clicking on the left mouse button.
9 Hold the Ctrl button while clicking on right mouse button to bring up the confirm

changes menu.
10 Press Accept to finish the object
11 Press the New line, New polygon, New line from or New object again to finish the

process.
12 Select one of the planned lines or objects by ctrl + left mouse button.
13 Observe that the buttons that can be used to modify your plan becomes active.
14 Edit, move, extend, reverse, make parallel lines, etc. according to your plan.
15 Press Save Job or Save Job as....
16 Transfer plan to the Remote Helmsman display when your plan is ready by

expanding Remote and pressing Transfer plan

Parameter references
• Planning – Jobs on page 251
• Planning – Remote on page 251
• Planning – Object on page 251

Related topics
• Planning module window on page 93
• Keyboard and mouse in the Planning module view on page 44
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Run the survey
Operational procedures
• How to retrieve a planned job on page 202
• How to monitor the survey progress on page 202
• How to run the PU simulator on page 203

How to retrieve a planned job
1 Open the Planning module frame.
2 Expand Jobs

3 Press the Open job button.
A standard file open window appears.

4 Select the file where your planned survey lines are stored.
5 Verify that the correct job i loaded.
6 Expand Remote.
7 Press Transfer plan so send the planned lines and objects to the remote helmsman

display.

Related operational procedures
• Plan a survey on page 199

Start and stop logging

Observe the procedures in Start and stop logging on page 169.

How to monitor the survey progress

There are different ways to monitor the progress depending on the system you are
running. The logging and system status is observed and presented in Status information.
The following is a summary of the Status information:

202 342682/D



Operational procedures

1 Observe the Geographical window.
The Geographical view gives an overall control of the performance of SIS and the
multibeam echo sounder

2 Observe logging, pinging and line number status.
On the right hand side of the toolbar there are three buttons which show the status of
logging, pinging and line number.

3 Observe the Numerical display
In the numerical display view you may select the sensor data values you want to
monitor.

4 Observe the status lamps.
Three status lamps on the main toolbar give status of hardware units (applies to
multibeam echo sounders only).

5 Observe the sound velocity.

How to run the PU simulator

The PU Simulator is a replay program using logged raw data from EM multibeam echo
sounders.
1 Start the PU simulator from the Tools→Custom...→PU Simulator menu.

PU.exe will start in the background.
If PU simulator has been run before on your SIS installation you will be prompted
whether to continue from last set of raw data or to start a new replay.
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2 Press OK to continue last dataset.
The PU control will open and start output of selected raw data.
or

3 Press Cancel to select a different dataset.
The PU control will open.

4 Select the raw data files to replay be pressing Start.
A file selection dialog box will open.

5 Browse to the directory of your raw data files.
6 Press Open to activate the replay.
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7 Observe that raw data from selected type of echo sounder with head serial number
888 is broadcast in the PU.exe command window.

8 Return to the SIS to start and run the simulated echo sounder the same way as you
start any other echo sounder.
Note that the serial number of a simulated echo sounder is 888 to distinguish it
from an actual echo sounder.

9 Press Rescan to make SIS recognize the simulated echo sounder with serial number
888.

10 Select the simulated echo sounder with serial number 888 from the Not started
drop-down box.
SIS will soon start running as for an online survey. You can operate SIS as with
any other echo sounder.

11 If you have a slow computer, you can press Pause to allow SIS to catch up.
12 You can control the speed of the simulator by reducing the playback rate
13 Press Stop in the PU control window to stop the simulator

Related operational procedures
• How to start the echo sounder on page 154

Related topics
• Time series view on page 72
• Numerical display on page 68
• Message service view on page 69
• PU sensor status view on page 86
• Sensor layout view on page 98
• Main toolbar on page 33
• Sound velocity profile view on page 79
• PU simulator and playback on page 449
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Export data
Data can be exported into various output data formats. The formats are described in the
parameter section of this manual.

To export data use the Import/Export dialogue box found in the File menu.

Parameter references
• Import/Export on page 352

Remote Helmsman Display
How to start the Remote Helmsman Display

The Helmsman Display must be connected to the echo sounder’s operator station
(normally the HWS). From the HWS Operator Station you can control what surveys to
be displayed on the remote Helmsman Display as follows:
1 Import the survey to be shown
2 Select Transfer grids from the Planning module.
3 Verify that the same grids (terrain models) are displayed on the Remote Helmsman

Display.

How to display planned lines on the Remote Helmsman Display

You can display all the currently planned lines on the Remote Helmsman Display:
1 Select Transfer plan from the Planning module

Current active line will always be sent from the HWS Operator Station to the
remote Helmsman Display. The Helmsman is presented with guidance information,
such as distance from planned line to current position and other information about
current line.

The Helmsman may freely set his own colours, shading, scale and area to display. He
can choose to see a completely different area than what is currently surveyed. This
makes it possible for the Helmsman to do his own quality assessment of the surveyed
data and to take action if required.

If the logging stops for whatever reason, the Helmsman Display will no longer update.
This allows the Helmsman to follow the progression of the survey.

Related topics
• Helmsman display view on page 70
• Planning module window on page 93

Installation of the Remote Helmsman Display is described in the SIS Installation
Procedure, document number 164891.
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Exporting survey results
How to export survey results after a survey

There are several different possibilities and formats available for exporting the results
form a survey:
1 Raw data as recorded using the binary instrument data format described in the

Operator manual – EM series Datagram Formats, published on the webpage
www.kongsberg.com under multibeam echo sounders. Examples of compatible
software systems are Neptune B and CARIS HIPS.

2 Flags – The flag is compatible with Neptune B. Data cleaning (flagging out
soundings) performed by SIS, can be inspected and/or modified in Neptune B.

3 All soundings in xyz-format. The following variations can be selected:
• Depth in centimetres
• Tide corrected depth (cm). (Correction are derived from predicted or real time

tide.)
• Geoide and RTK corrected depth (cm).
• Seafloor to geoide distance (cm).
• Seafloor to ellipsoid distance (cm)

4 Grid node value from Grid Engine, binary or ASCII format.
5 Contour lines in DAF format. The DAF format is compatible with the DKART

software for electronic charting.
6 Terrain model generated by CUBE.
7 Raw data converted to .XTF format. This is an option which includes a converter

program.

Parameter references
• Import/Export on page 352
• Export xyz file on page 361

Exit SIS
How to exit the SIS software

SIS can be exited by one of the two following methods:
1 Stop logging and pinging.
2 Select File→Quit,

or
3 Press the Close button in upper right corner of the SIS window.
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How to shut down the HWS

The SIS HWS (Hydrographic Work Station) is first powered down:
1 Switch the power Off
2 Switch off all peripherals

How to shut down the Processor Unit (PU) or the Transceiver Unit
1 Open the door on the Processing/Transceiver Unit
2 Switch the power Off
3 Alternatively, use the Remote Power switch
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Parameter references

This chapter provides reference information about the dialog boxes, parameters and
functions used throughout the Seafloor Information System (SIS). The information is
provided in the following order:
• Frame toolbars parameters on page 209
• Calibration parameters on page 260
• Survey parameters on page 263
• Installation parameters on page 274
• Runtime parameters on page 297
• SIS parameters – Set parameters on page 333
• File menu parameters on page 352
• Tools menu parameters on page 371
• Projection and datum parameters on page 384

Frame toolbars parameters
This section contains description of the dialog boxes and parameter settings provided by
the Frame toolbars in SIS.

Topics
• Geographical – Display options on page 211
• Geographical – Show depth under cursor on page 222
• Geographical – Grid shading on page 222
• Geographical – 2D or 3D on page 223
• Geographical – Inspection mode on page 223
• Geographical – Compass button on page 223
• Geographical – KSGPL edit mode on page 223
• Geographical – Planning edit mode on page 224
• Geographical – Calibration edit mode on page 224
• Geographical – Follow ship on page 224
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• Geographical – Load background data on page 224
• Geographical – Save background image on page 224
• Geographical – C-MAP manipulation mode on page 225
• Geographical – Information field on page 225
• Beam intensity – Show/hide on page 227
• Colour coded depth – Show/hide on page 227
• Cross track – Display options on page 227
• Seabed image – Show/hide on page 231
• Numerical display on page 232
• Helmsman display – Show/hide on page 237
• Time series – Show/hide on page 238
• Time series – Clear plot on page 241
• Waterfall – Show/hide on page 241
• Water column – Show/hide on page 243
• Water column – Logging on page 247
• Sound velocity profile – Show/hide on page 247
• Scope display – Show/hide on page 247
• Stave display – Show/hide on page 249
• Planning – Jobs on page 251
• Planning – Remote on page 251
• Planning – Object on page 251
• Sensor layout – Show/hide on page 258
Display buttons related to colour selection, zooming and scaling are not included in
the following.

Related topics
• The application window on page 25
• SIS frames on page 27
• Toolbars on page 33
• View menu on page 38
• Keyboard and mouse operations on page 43
• Common display buttons on page 48

Related operational procedures
• How to monitor the external sensors in SIS on page 160
• How to monitor the survey progress on page 202
• How to display realtime depths on page 161
• How to verify echo sounder main functions on page 162
• How to display a smooth surface on page 165
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• How to look for artifacts on page 165
• How to display seabed imagery data in the Geographical view on page 162
• How to display sound velocity at transducer depth in the Geographical view on

page 163
• How to create and use a GeoTIFF background image in the Geographical view on

page 166

Geographical – Display options

Options

The Options menu contains a tree structure on the left
side that can be used to select which menu pane (i.e. set of
options) to show on the right.

The tree list on the left side contains the following parameter
settings:
• General

See General display options on page 212.
• Survey

See Survey display options on page 214.
• SIS Based Surveys

See SIS based survey display options on page 216.
• Sonar Display Grid

See Sonar display grid options on page 218
• Neptune Based Surveys

See Neptune based surveys display options on page 219.
• Gridded Data

See Gridded data display options on page 220.
• Point Data

See Point data display options on page 221.
• KSGPL

See KSGPL display options on page 222.

Different dialog boxes appears as you click on any of the options. These are described in
the following.
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General display options

General: Select general display options for the Geographical window.

• Show/Hide:

– Graticule: Toggle show/hide graticule
– Survey ship: Show the survey ship or not.
– C-MAP background: Use C-MAP as background map. When the C-Map edit is

enabled, clicking the right mouse button in the geographical view will display
additional C-Map objects information. This option will only be available for
C-Map users.
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– Planning: This will enable the planning module in the Geographical window. A
planning button P will be added to the Geographical window toolbar.

– KSGPL: Turn KSGPL (Kongsberg SIS Graphic Programming Language) on or off.
* Unchecked: No input/output is allowed. This will also hide all the loaded

KSGPL objects.
* Checked: Use predefined settings.

• Graticule Label Format: Show or hide the position text fields (latitude and longitude)
– DD.DD: Display position as decimal degrees.
– DD MM.MM: Display position as degrees and decimal minutes.
– DD MM SS.SS: Display position as degrees, minutes, and decimal seconds.
– Projection: Display position as projection coordinates.

• Light Source: Toggle light source on or off to achieve shadowed effects
• Light Position: Position light source according to your preferences:

– Upper left corner
– Upper right corner
– Lower left corner
– Lower right corner
– Follow cursor

• COG Vector: When the COG Vector check box is checked, a course over ground
(COG) vector is displayed on the ship symbol in the geographical view.
– The Length text box can be used to set the length of the COG vector in minutes

(of time). For example, if you set the 'Length' text box to 5, the end of the COG
vector should be at the location where the ship will be in 5 minutes (if the ship
continues on it's current course).

– The Line Width text box is the width of the COG vector (on the display) in pixels.
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Survey display options

Set your preferences for display of current survey.

• Show/Hide:

– Realtime depths: Show realtime depths or not. All depths can be shown as a tail
behind the ship.
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– Realtime shipstrack: Show shipstrack current line or not.
– Realtime coverage: Show coverage from current line or not.
– Common Shipstrack: Show shipstrack lines from previous surveys or not.

The common shipstrack data must be stored in a folder named tracks. The
tracks folder must be a subfolder of the “Background data directory” defined for
the active survey.

– Common Coverage: Show coverage from previous surveys or not.
The common coverage data must be stored in a folder named tracks. The tracks
folder must be a subfolder of the “Background data directory” defined for the
active survey.

– Surveys: Set what type of surveys you want to be displayed from
* SIS Based Surveys
* Neptune Based Surveys
* Gridded Data
* Point Data

• Realtime Depth:

– Colour by Depth: Display dynamic colours by depth
– Single Colour: Display one only one colour for all depths

• Depth Scale Factor: Factor by which depth is multiplied by. This has the effect of
stretching the grid along the depth axis (i.e. a depth scaling factor of 2 stretches the
waterfall grid to twice its normal height). This can make it easier for example to
discover artefacts.
– x 1: No scaling
– x 2: Scale the depth by 2
– x 5: Scale the depth by 5
– x 10: Scale the depth by 10

• Survey Reload: Interval in seconds between reloading the survey.
May be set to Auto Reload by ticking off the check box.
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SIS based survey display options
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• Show/Hide:

– Stored Shipstrack: Toggle to show the stored shipstrack or not. Currently logged
line/realtime shipstrack will be stored to disk as a stored shipstrack whenever a
new line is being created.

– Stored Coverage: Show the stored coverage or not. The currently logged
line/realtime coverage will be stored to disk whenever a new line is being created.

– Processed Positions: Shows position quality. The positions can be colour-coded
by the quality indicator in the GGA datagram. Note that logging must be off for
position quality to be displayed. IFF is extracted from activated survey. See also
Extract IFF on page 381.

– Sonar Display Grid: Enable or disable the seabed image display in the Geographical
window.

Note

Must be selected to enable seabed image features described in Sonar display grid
options on page 218.

– Display Grid Mesh: Toggle to show the display grid mesh or not.
– Safety Contour: Toggle to show the safety contour or not.

This feature defines a range of depths below which it is considered too shallow for
the survey vessel when accounting for the current tide. This range of depths can be
shown in any single colour. Before being able to use the safety contour feature it
must be enabled and the required range of depths must be set. This is performed in
the Tools →Custom... →Set Parameters →Display menu.

• Depth Type: Select depth variable to be displayed.
– Z: Depth, sea surface to sea bottom distance.
– Zt: Tide file corrected depth, vertical datum to seafloor distance.
– Zv: Geoide and RTK corrected depth, vertical datum to seafloor distance.
– Zg: Seafloor to geoide distance.
– Zr: Seafloor to ellipsoid distance.

• Depth Operation: Parameter to set what depth to be displayed:
– Minimum depth of each cell will be displayed
– Median depth of each cell will be displayed
– Maximum depth of each cell will be displayed
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• Grid Colour Value: Grid values are presented according to given values with given
colour scheme.
– Depth: Display depth values of the grid
– Backscatter: Display backscatter values of the grid
– Points per cell: Display number of cells of the grid
– Depth diff. per cell: Display depth differences in the grid
– Grayscale: Map a grayscale range (i.e. black to white) to a range of data. The

grayscale range and the data range to which the grayscale is mapped are set via
the Dynamic Colours dialogue.

• Position Colour Coding: For position monitoring the colour coding of position may be
given by
– Single colour, or by
– GPS quality indicator

Sonar display grid options
The seabed image data generated by the grid engine can be viewed in the Geographical
display.

Note

To show the seabed image data in the Geographical view the following must be enabled:
• The Sonar display grid check box located in the Show/Hide menu of the SIS Based Survey
branch of the Geographical Options must be selected.

• Seabed Image Processing in GridEngine located in Runtime parameters→Data
Cleaning→Advanced

• Grid size: Selects maximum number of processing grids to display in the Sonar
Display Grid option.
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Note

The actual size of each processing grid is part of the Grid Engine parameters, and is
set from the New Survey tab, through import of raw data or via the Survey Template
Handling.

• The Clear Image button will clear the geographical display of the seabed image.
• Dynamic range: Sets the minimum and maximum intensity values (dB) for the range

to be displayed

Please also refer to the operational procedure How to display seabed imagery data in the
Geographical view on page 162.

Neptune based surveys display options

This choice is available only if you have imported Neptune based surveys.

Colour Coding: Check box for selecting whether static or dynamic colour scheme are
going to be used for the presentation in the Geographical display.
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Gridded data display options

Parameters for presentation of the gridded data in the Geographical display.

• Drawstyle:

– Points: Presents gridded data as points
– Triangles: Presents the triangles used to form the surface formed by the gridded

points
– Filled: Presents the filled triangles
– Text (dynamic colour): Presents gridded values as colour coded text
– Text overlay (dynamic colours): Presents the gridded values as colour coded text on

top of the filled colour coded surface
– Text (static colour): Presents gridded values as text
– Text overlay (static colour): Presents gridded values as text on top of the filled

surface
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• Level of Detail: Specifies to what level of details the gridded data are to be presented
by in the Geographical display
– LOD Auto: SIS will automatically choose the best LOD using available system

resources
– LOD 0: Presents all processed data
– LOD 1: Reduced presentation to 1/4 of LOD 0
– LOD 2: Reduced presentation to 1/4 of LOD 1
– LOD 3: Reduced presentation to 1/4 of LOD 2
– LOD 4: Reduced presentation to 1/4 of LOD 3
– LOD 5: Reduced presentation to 1/4 of LOD 4
Refer to Geographical – Level of Detail on page 225 for further details

• Transparency: Set grid transparency. Choose values from 0 (not transparent) to 100
(maximum transparent)

Point data display options

• Point Type: Defines what type of points to be displayed of:
– All points
– Valid points only
– Invalid points only

• Point size in number of pixels
• Max points: Maximum number of points allowed. If there are more points in the

area than this no points will be displayed.
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KSGPL display options

KSGPL Object types:

• [0] – Generic objects (objects without an object type)
• [1] – Coast
• [2] – Dryfall
• [3] – Riverbank
• [4] – Text

Geographical – Show depth under cursor

The depth of the grid under the cursor can be displayed in a pop-up text box by toggling
the Show depth under cursor button D, or by toggling the F8 hotkey.

Depth under cursor information can displayed together with position under cursor.
Enable the Compass button to show position under cursor.

Note

The depth will only be displayed as you stop the movement of the cursor.

Geographical – Grid shading

Grid shading can be toggled on/off via the Toggle Grid Shading button S. The F4 hotkey
can also be used to toggle the grid shading on/off.
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Geographical – 2D or 3D

Press the 3D button to enter the 3D mode. 3D mode will allow you to pan, zoom and
rotate the currently loaded grid(s) in 3 dimensions. Panning and zooming will work both
in 2D and 3D. Shift + Right mouse button will rotate the data. Note that no new data will
be reloaded in 3D mode. Press the 3D button to return to 2D mode.

Geographical – Inspection mode

Inspection mode is used to scan for objects on the seafloor and to filter out noise that
may look like objects. The I button is used to toggle inspection mode on and off. When
in inspection mode, the LOD is set to 0, depth operation is set to median depth and
the depth scale factor is set to 2. Toggling the I button a second time will restore the
previous settings.

Geographical – Compass button

The compass button is used to read position, distance and heading information from
the Geographical window.

When enabled the latitude and longitude under the cursor will be displayed. Note
that this button can be enabled at the same time as Depth under cursor to display both
position and depth.

Use Ctrl + Right mouse button inside the Geographical window to open the Compass
action short-cut menu. The following options are available:
• Measure position: This is used to display the position of a given point in the view.

Move the cursor inside the view. Position information (lat/lon) is given at the cursor’s
tip.

• Measure distance and heading: This is used to measure position, distance and heading
between two points in the view. Use Ctrl + Left mouse button to mark position 1.
Draw a line to position 2 and use Ctrl + Left mouse button to mark this position. The
requested information is given at the cursor’s tip.

Geographical – KSGPL edit mode

Press the KSGPL button K to allow KSGPL manipulation. This button is made available
only if the KSGPL option is selected in the Options→Show/Hide dialogue box.
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Geographical – Planning edit mode

Press this button to allow Planning manipulation. This button is made available only if
the Planning option is selected in the Show/hide dialogue box.

Geographical – Calibration edit mode

Press the Calibration button C to allow calibration manipulation. This button is made
available only if the Calibration window is opened in one of the other frames.

Geographical – Follow ship

This button is used to force current view to follow the ship wherever it moves. It is
possible to pan the ship to a user defined location on the screen.

Geographical – Load background data

Press the Load background data button to add background data to the Geographical
window. Data can be loaded from the current active survey or you can browse for stored
background files (*.bgksgpl).

Geographical – Save background image
You can create a GeoTIFF image from gridded survey data. You can later import the
GeoTIFF file into SIS and display it as background in the Geographical display.

Note

GeoTIFF is a standard which allows georeferenceing information to be embedded
within a TIFF file.

Pressing the Save background image button will save currently displayed survey data to
three different files in the background directory \sisdata\common\background:
• gvosr.tif – a geotiff file
• gvosr_tmp.tif – a normal tiff file (not geo-referenced)
• gvosr_temp.tfw – a tiff world file (geo-reference information for the tiff file)
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Related operational procedures
• How to create and use a GeoTIFF background image in the Geographical view on

page 166

Geographical – C-MAP manipulation mode
Note

This button is only shown if C-Map is installed.

Press the C-Map button to allow C-Map manipulation. This button is made available
only if the C-Map background is enabled in the Options→Show/Hide menu. Please note
that C-Map functionality requires a separate C-Map license.

Related topics
• C-MAP detail level on page 41
• C-MAP – Licence administration on page 379
• C-MAP CM-93/3 on page 443

Geographical – Information field

The Information field shows current scale of the Geographical window and its position in
degrees lat/lon with two decimals. The monitor size is read from the database.

Geographical – Level of Detail
Data may be displayed in the Geographical window with various levels of details, based
on the current map scale selected by the operator.

The gridding system use two types of grids:
• Processing grid
• Display grid

The processing grid is used for processing depth data, and the display grid is used for
displaying data. Data is transferred from the processing grid to the display grid, and from
the display grid with a lower level of detail to the display grid with a higher level of detail.

The number of levels of details depends of the number of cells in the processing grid. A
processing grid with 64x64 cells will have 6 levels of detail, in other words log2(64).

The organization of process grids and display grids may look as shown in the figure
below.
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Figure 19 Organization of process grids and display grids (example)

When looking at a small area it can be convenient to select LOD 0, as all processed data
then will be displayed. In a larger scale a higher LOD should be used.

Choose between the following levels:
• LOD 0
• LOD 1
• LOD 2
• LOD 3
• LOD 4
• LOD 5
• LOD auto
Note

Due to the limitations in memory and processing capabilities inherent in today's PC
platform, it is necessary to impose some restrictions in SIS with regard to display and
handling of survey data.

When a high resolution presentation is selected (e.g. LOD 0) more data must be fetched
from the GridEngine to be able to display the necessary details.

The restrictions in SIS are imposed when a level of detail other than “LOD auto” is
selected. To avoid an overload situation in this case, SIS will restrict the size of the
displayed survey area. This will reduce the amount of the fetched data.

When “LOD auto” is set, SIS will automatically choose a LOD level that will not
overload the system an no area size restrictions are imposed.

The settings to control the restriction handling is found in the menu Tools→Custom→Set
Parameters→Advanced display options. These settings are intended for internal KM use
and other advanced users and should normally not be changed.

226 342682/D



Parameter references

Beam intensity – Show/hide

Show/Hide button

Active: Activate or deactivate the display. Deactivating
the display will minimize the CPU usage of the display.

Axes: Show or hide the axes.

Grid Lines: Show or hide the grid lines.

Legend: Show or hide the legend.

Colour coded depth – Show/hide

Show/Hide button

Active: Activate or deactivate the display. Deactivating
the display will minimize the CPU usage of the display.

Shade Model: Options for setting the shade model used
for displaying the data.
• Flat: Each cell has a distinct colour.
• Smooth: Colours are smoothly interpolated between

cells.

Cross track – Display options

Display options

The Options menu contains a tree list on the left side that
can be used to select which menu pane (i.e. set of options) will be shown on the right.
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The tree list on the left side contains the following parameter settings:
• Show/Hide
• General
• Scaling

A number of check boxes becomes available for each of above listed cross track display
options.
• Show/Hide:

– Axes: Show or hide the axes
– Grid lines: Show or hide the grid lines
– Legend: Show or hide the legend
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– Depth Text Re Waterline/Transducer: When enabled, the depth (selectable
reference, either from the waterline or from the transducer) of the most vertical
beam will be displayed. The size of depth figure is scaled to fit the frame.
Enlarging this window makes it easy to read the depth at distance.

The Crosstrack depth re parameter is selected from Set parameters→Display. If set
to 1, the reference is 'waterline'. If set to 2, the reference is 'transducer'. Note that
SIS must be restarted for change of this parameter to take effect.
See Display on page 339.

• General:

– Refresh Rate: Specifies the rate with which the display is updated (i.e. number of
times per second)
* 1: Update the display once every second
* 3: Update the display three times per second
* 10: Update the display ten times per second

– Across Track Units: Select the units for the horizontal axis.
* Beams: Units for the across track scale are beams.
* Meters: Units for across track scale are meters.

– Colour Coding: Select colour coding of the depth curve to be displayed as:
* Beam detection: Colours of the depth curve will be red for phase detection and

blue for amplitude detection
* Depth value: Colours of the depth curve will be displayed according to dynamic

colours for depth set by the Dynamic colour button of the Geographical window.
See Dynamic colours button on page 50 for description.

– Depth value: Select depth variable to be displayed.
* Z: Depth, sea surface to sea bottom distance.
* Zt: Tide file corrected depth, vertical datum to seafloor distance.

– Across Track Style: Select the line style for the across track plot.
* Line: The across track plot is displayed as a continuous line.
* Points: The across track plot is displayed as a series of points.

– Point size: The size of each point in pixels when the style is Points. The value
specifies line width in pixels when the style is Line
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– Deactivate display: When selected the display become inactive, thus minimize
the CPU usage of the display.

• Scaling:

– Depth:

* Scaling Mode: Options for controlling the scaling mode for the depth axis.
* Auto: Automatically adjust the start and stop ranges to show the entire range

of data each time data is received
* Fixed: Use the start and stop ranges entered in the min and max text boxes:

* Min (m): Fixed start (min) range in meters.
* Max (m): Fixed stop (max) range in meters.

* Scaling factor: You can choose to scale the cross track vertically by a
multiplication factor or by a percentage of the view. This has the effect of
stretching or compressing the cross track plot along the depth axis (e.g. a depth
scaling factor of 0.25 compresses the cross track plot to a quarter of its normal
height). This may be used for e.g. discovering artefacts.

* Compress Depth to Fit View: When this option is selected, the data will not
be stretched outside the current view. In cases where the depth scaling factor
would cause the data to be stretched outside the view, this option has the effect
of overriding the current depth scaling factor and using the next largest factor
that will allow the plot to remain inside the current view. If the current depth
scaling factor would not otherwise stretch the data outside the current view,
then this setting has no effect.

– Across:

* Scaling Mode: Options for controlling the scaling mode for the across axis.
* Auto: Automatically adjust the start and stop ranges to show the entire range

of data each time data is received.
* Fixed: Use the start and stop ranges entered in the min and max text boxes

* Min (m): Fixed start (min) range in meters.
* Max (m): Fixed stop (max) range in meters.

* Keep Across Axis Symmetric: Keeps the across axis symmetric. If this option
is selected, the across axis will be symmetric with respect to zero, even if the
coverage is not the same to both sides.
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Seabed image – Show/hide

Active: Activate or deactivate the display.
Deactivating the display will minimize the CPU
usage of the display.
Paused: Pause or continue the display. While
paused, the display is shown, but it is not updated
with new data.
Time Markers: Show or hide the time markers.
Swath Width: Options for setting the displayed
swath width:
• Across Min (m): Across track start (min) range

in meters
• Across Max (m): Across track stop (max) range

in meters
• Auto scaling is enabled by setting the Swath

Width to Across Max (m): 1.0 m and Across
Min (m): -1.0 m.

Dynamic Range: Options for setting the amplitude
range used for colour mapping.
• Amplit. Min (dB): Minimum expected amplitude
• Amplit. Max (dB): Maximum expected

amplitude
Colour Code: Options for setting the type of colour
coding used by the display.
• High Intensity is Dark: Darker colour (i.e. more

black) indicates higher intensity
• High Intensity is Light: Lighter colour (i.e. more

white) indicates higher intensity
Shade Model: Options for setting the shade model used for displaying the data. Smooth
shading may provide slightly better results when the cell size is set larger than 1 pixel.

• Flat: Each cell has a distinct colour.
• Smooth: Colours are smoothly interpolated between cells.
Cell Size: Sets the cell size in pixels. Choosing a larger cell size reduces the CPU usage
of this display significantly.
• 1 Pixel: Cell size is 1 pixel
• 2 Pixels: Cell size is 2 pixels
• 3 Pixels: Cell size is 3 pixels
• 4 Pixels: Cell size is 4 pixels
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Numerical display
The numerical display holds the instantaneous values for the following parameters –
in alphabetic order:
Parameter Description Note

ATH Log Shows the status of ATH POSMV data logging, i.e. ON or OFF 8

Across Across distance between the outermost beams (same as swath
width)

AttVel downward Attitude Velocity read from the PU Status output datagram. Applies
to EM 122, EM302, EM 710, EM 2040 and EM 2040C. For other
instruments '—' is displayed.

AttVel forward Attitude Velocity read from the PU Status output datagram. Applies
to EM 122, EM302, EM 710, EM 2040 and EM 2040C. For other
instruments '—' is displayed.

AttVel starboard Attitude Velocity read from the PU Status output datagram. Applies
to EM 122, EM302, EM 710, EM 2040 and EM 2040C. For other
instruments '—' is displayed.

Beam sp. Type of footprint/distribution of the beams on the seafloor, for
example equidistant or equiangular

Beams Beams received versus maximum available beams

Cover. (deg.) Coverage in degrees to port and starboard

Cover. (m) Across distance in meters of beams on port and starboard side

DGPS age Age of differential GPS data in seconds from the NMEA GGA
datagram

Depth Current centre depth from the waterline to the seafloor.
A yellow warning indication is issued when max or min depths are
close set limits
In case of a warning, the Message Service will also be notified.

1

Depth Sens. The depth from the depth (pressure) or height datagram or from
the Ships Own data (proprietary format) input datagram or from
the SIMRAD90 datagram.

Det. mode Currently set detector mode. Applies to systems where different
detector modes are implemented, i.e. EM 2040, EM 2040C and
EM 3002

Dual swath Shows status of dual swath settings, Off, Fixed or Dynamic.
Applies to EM 122, EM302 and EM 710. Dual swath status is set
in the Runtime parameters frame.

East Easting in meters in projection coordinates

East DD.DD Easting in decimal degrees

East DDMM.MM Easting in decimal minutes

Ext. Date The date from the clock datagram. The datagram is created by the
PU (Processing Unit), but the date information is read from an
external input, either ZDA or other GPS input.

Ext. Time The time read from the ZDA clock datagram

Frequency Transmit frequency in kHz. Applies to EM 2040C. 11

GGA height Height derived from NMEA GGA datagram

GGA time UTC time from NMEA GGA datagram
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Parameter Description Note

GSA HDOP HDOP (Horizontal Dilution Of Precision) from the NMEA GSA
datagram

GST HSTD HSTD (Horizontal Standard Deviation) derived from the NMEA
GST datagram

Geo. und. Geoid undulation used (the distance from the ellipsoid to the geoid)

Geo. vref. Distance from geoid to vertical reference from geoid model

HDOP GPS position HDOP indicator derived from the position input GGA
datagram

Head used Shows the status of the heads, i.e. ON or OFF, in a dual or three
head configuration. Applies to EM 2040, EM 2040C and EM 3002.

Heading Heading from the PU status datagram. The heading value is read
from the external heading sensor

Heave The current heave in meters 3

Height The height from the depth pressure or height datagram.

K-Sync K-Sync synchronization status for up to seven different echo
sounder controlled by K-Sync. By holding the cursor on top of
one of the coloured status elements the associated echo sounder
name will be shown.

10

ME70/BO Gray colour; connected to Simrad ME70/BO. Red colour;
disconnected

Mode The current mode used by the echo sounder. Refer to the EM
datagram manual

No. sat. The number of satellites from the position datagram

North Northing in meters in projection coordinates

North DD.DD Northing in decimal degrees

North DDMM.MM Northing in decimal minutes

PPS The 1PPS status from the clock datagram 2

PU-POS Time difference between PU clock and time in position datagram
received in PU.

PU-ZDA Time difference between PU clock and ZDA clock received in PU.

PU date Time from the PU read from info/status datagram

PU time Time from the PU read from info/status datagram

PU load PU (Processing Unit) load from the PU status output datagram

Ping Hz The ping rate (pings per second)

Pingno The current ping number

Pitch The current pitch angle in degrees 3

Pos. qual The position quality calculated from information in the position
telegrams. This is an indicator of the relative accuracy of the
current position. Refer to the EM datagram manual.

Qfactor GPS position quality indicator derived from the position input
GGA/GGK datagram

ROV Offset Offset (barometer) value sent to echo sounder. Manually entered
in Runtime Parameters > Sound Speed frame or received from
external barometer sensor. Currently only used for EM 3002
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Parameter Description Note

ROV Scale Scale value sent to echo sounder. Manually entered in Runtime
Parameters > Sound Speed frame or automatically calculated.
Value is appended with “M” if manually entered. Currently only
used for EM 3002

ROV depth Depth from water surface to the sonar head/transducer. The depth
value contains offset and scaling compensation.

RTCM Log. Shows the status of RTCM data logging, i.e. ON or OFF 8

Raw log Shows status for raw data logging in echo sounder. Status is
displayed as ON or OFF. A file name indication in the form of a line
number being logged in the echo sounder, is appended when ON.
Currently only used for EM 3002

Ref. st Name and Id of differential reference station derived from NMEA
GGA datagram and file containing reference station names

Remain. ramp Remaining time (in seconds) until full effect of the echo sounder is
transmitted. Applies to the mammal protection feature of the EM
122, Em 302 and the EM 710.

Roll The current roll angle in degrees 3

SRH Log. Shows the status of SRH data logging, i.e. ON or OFF 8

SV profile The sound velocity used by the echo sounder

SV used The filtered sound velocity from the real time sensor. The filter
length is set in the Runtime menu

SV sensor Raw unfiltered real time sensor data

Speed kn Speed over ground in knots

Speed m/s Speed over ground in meters/second

Swath Dist. Requiered swath distance / Achieved swath distance in meters.

TVG FG TVG Fixed Gain from the PU status output datagram. 4

TVG NIB TVG Normal Incidence Backscatter from PU status output
datagram.

5

TVG OB TVG Oblique Backscatter from the PU status output datagram. 6

TVG RN TVG Range To Normal Incidence from the PU status output
datagram.

7

Tx. pow Transmit power level from the Runtime parameter datagram

TX pulse (ms) Pulse length in milliseconds 9

TX pulse form Currently used pulse type, either CW, FM or a mix of the two.
Applies to EM 122, EM 302, EM 710 EM 2040 and EM 2040C. For
EM 2040C a time length indication is also included, either short,
medium or long.

Temp probe C Real time temperature sensor data (in degrees Celsius)

Tide Tide used (predicted or real time)

Yaw. stab Heading offset angle used by the Transmitter to compensate for
ship’s yaw. This parameter is also used to show the tilt angle in
3D scanning mode.
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Notes
1 When the minimum depth value in a swath (i.e. minimum measured depth) is

within a set percentage of the minimum legal depth value set in the Runtime
parameters→Sounder Main window, a yellow warning indication will be given in
the Depth item in the Numerical Display window.
In the same manner, a yellow warning will be given when the maximum depth
value in a swath (i.e. maximum measured depth) is within a set percentage of the
maximum depth value set in the Runtime parameters→Sounder Main window.
Also, in both cases a message is sent to the Message Service system and logged.
The percentage used is the same for both the minimum and maximum depth settings.
The value is set to 10% as standard, but if necessary it can be changed by updating
the NUMDISP_PERCENTAGE_MINMAX_DEPTH integer token to the required
percentage using e.g. setParameter.bat and then restarting SIS.
Legal range for the percentage is 0–100. By setting the percentage to 0 no checks
will be performed and no warnings given.

2 The 1PPS status is one of the following:
• ON: 1PPS is connected
• OK: Normal operation
• OFF (and red colour): Failure
• UNUSED: No 1PPS is connected

3 Monitoring of PU motion sensor input frequency.
The PU must receive motion sensor input with a sufficiently high update rate to be
able to produce depth information etc. of an acceptable quality. If the movement of
the ship is not properly compensated for when a ping is processed the generated
data will be of poor quality or rendered useless.

SIS will therefore monitor the received motion sensor input
rate and generate warning information if it is below a preset
frequency. The warning will be in the form of a yellow
background in the motion related display items (Roll, Pitch and
Heave) in the Numerical display frame:

The PU Status Lamp in the Toolbar will also be yellow. In addition a warning
will be generated in the message system to the same effect. No pop-up is displayed
for this problem.
This frequency monitoring is only performed for the active motion sensor.
The predefined minimum motion sensor input frequency can be changed by using
Tools→Custom...→Set Parameters →Sensor options
The minimum motion sensor input frequency is set to 90Hz by default.

4 TVG FG (Fixed Gain): The older multibeams has two independent gain controls;
a fixed gain consistent during each ping, and a time varying gain (TVG), both are
controlled by the system software. The newer multibeams, starting with EM 710,
has an automatic gain control in the receiver that does not use the fixed gain (FG)
parameter. On these systems the TVG applied after the receiever signals have been
digitized.
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5 The TVG NIB (Normal Incidence Backscatter) parameter shows the backscatter
level at the normal incidence. The received echo level from the first hit (the normal
incidence) depends strongly on the bottom type and the frequency.

6 The TVG OB (Oblique Backscatter) parameter shows the oblique backscatter
strength. This is an average of the backscatter level measured for the beams placed
outside the normal incidence region and inside 60 degrees from the vertical. Time
varying gain (TVG) applied to the system shall compensate for the transmission
loss, the illuminated area, the bottom incident angle etc.
The model assumes the bottom to be flat, and that the signals is attenuated by
spherical spreading (Lamberts law) and absorption loss in the water column.

7 The TVG RN Range To Normal Incidence is the estimated shortest range from the
transducer to the bottom. The RN is not corrected for the sound speed profile or for
the transducer draft, so it may differ some from the actual depth.

8 The Log status is updated when a new file is created or as a result of changed log
parameter settings. When turning logging on for the first time the "ON" indication
will not be displayed until the first data is received from the sensor. A warning
(pop-up) is issued if no input is received within a defined interval, currently set
to 20 sec.

9 The displayed value is the effective pulse length, which is defined as the inverse
of the bandwidth of the transmit pulse.
For CW pulses, this is usually slightly less than the total pulse length (due to
shaping of the pulse). For FM pulses, this is equal to the pulse length after pulse
compression (match filtering) at the receiver. The effective pulse length usually
increases with depth.
For details about actual pulse length in the various modes, see:
• Sounder main for EM 2040 on page 297

10 The colour shows the K-Sync status according to the following scheme:
• Background: Disabled
• Green: Ready
• Dark green: Trigger and busy after trigger
• Yellow: Busy (explicit Busy status, not as a result of trigger)
• Red: Error
Refer to K-Sync interface on page 575 for further details about the K-Sync interface.

11 Dual Head requires different frequencies for the two heads, and there must be a
certain frequency separation between the two heads. The operator may choose
frequency in 10 kHz steps. The processing unit will select a slightly lower frequency
for one head and a slightly higher frequency for the other head. The required
separation is a function of used pulse length - the shorter the pulse is, the larger
the frequency separation needs to be. The average of the two frequencies will be
available in the Numerical Display. For multiple swaths, if the highest or lowest
frequencies are selected by the operator, the average frequency (Numerical Display)
may show a different number.

236 342682/D



Parameter references

Helmsman display – Show/hide

Active: Activate or deactivate the display. Deactivating
the display will minimize the CPU usage of the display.

Position: Show or hide the position text fields (latitude
and longitude).
• DD.DD: Display position as decimal degrees
• DD MM.MM: Display position as degrees and

decimal minutes
• DD MM SS.SS: Display position as degrees, minutes

and decimal seconds
• Projection: Display position as projection coordinates

DPT: Show or hide the water depth text field.

SOG: Show or hide the speed over ground text field.
• m/s: Display speed over ground in units of meters per

second
• Knots: Display speed over ground in units of knots

COG: Show or hide the course over ground text field.
This is the course between position updates.

DTK: Show or hide the desired track text field. This is
the heading of the current line segment.

BRG: Show or hide the course to waypoint text field.
This is the heading from the current position to the next
waypoint.

XTE: Show or hide the cross track error text field. This is
the shortest distance to the current line segment.

RNG: Show or hide the range to waypoint text field. This is the distance from the current
position to the next waypoint.

ETW: Show or hide the estimated time to the next waypoint text field. This is the
estimated time of arrival at the next waypoint.

ETA: Show or hide the estimated time of arrival text field. This is the estimated time of
arrival at the last point in current planned line.

XTE Plot: Show or hide the cross track error plot.

APB Output: Enable or disable output of the NMEA APB message to the autopilot.

For the setup of the serial line see External sensors on page 371
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Caution

NMEA APB datagrams contain information about the vessel’s position with
relative to the active survey line. The correctness of this information is
critically dependent of the positioning system input, correct setup of the
system and user definition of the survey. Using the APB datagrams as
autopilot input is possible as a help in steering the vessel during the survey,
but it cannot in any way relieve the vessel crew from the responsibility in
safe handling of the vessel. The APB output is only available when the
Helmsman Display window is open.

Time series – Show/hide
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Active: Activate or deactivate the display. Deactivating the display will minimize the
CPU usage of the display.

Axes: Show or hide the axes
• Show or hide axis Y1
• Show or hide axis Y2

Grid lines: Show or hide the grid lines.
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Y1 Data Type: Select the data type to plot on the Y1 axis from the following variables:
• Depth (4 beams): Depth of four user selected beams
• Depth (below keel): Depth below the water surface for the most vertical beam. The

centre beam is most likely not the most vertical beam due to the roll of the vessel.
• Depth (centre beam): Depth of the centre beam
• Depth (EM and EA): Depth of the EA (single beam echo sounder) compared to the

depth of the shallowest EM (multibeam echo sounder) beam (in the ping) that lies
within the footprint of the EA sounder.

• Heave (active): Heave from the active motion sensor. This is selected for graphical
presentation.

• Heave (inactive): Heave from the inactive motion sensor. This is logged to the hard
disk.

• Across (4 beams): Across track distance of four user selected beams
• Backscatter (4 beams): Backscatter strength of four user selected beams
• Backscatter (centre beam): Backscatter strength of the centre beam
• Height: Height from the height sensor
• Pitch/Roll (active): Pitch and roll from the active motion sensor. This is selected for

graphical presentation
• Pitch/Roll (inactive): Pitch and roll from the inactive motion sensor. This is logged to

the hard disk
Y2 Data Type: Select the data type to plot on the Y2 axis.
• Depth (4 beams): Depth of four user selected beams
• Depth (below keel): Depth below the water surface for the most vertical beam. The

centre beam is most likely not the most vertical beam due to the roll of the vessel.
• Depth (centre beam): Depth of the centre beam
• Depth (EM and EA): Depth of the EA (single beam echo sounder) compared to the

depth of the shallowest EM (multibeam echo sounder) beam (in the ping) that lies
within the footprint of the EA sounder.

• Heave (active): Heave from the active motion sensor. This is selected for graphical
presentation.

• Heave (inactive): Heave from the inactive motion sensor. This is logged to the hard
disk.

• Across (4 beams): Across track distance of four user selected beams
• Across (4 beams): Across track distance of four user selected beams
• Backscatter (4 beams): Backscatter strength of four user selected beams
• Backscatter (centre beam): Backscatter strength of the centre beam
• Height: Height from the height sensor
• Pitch/Roll (active): Pitch and roll from the active motion sensor. This is selected for

graphical presentation
• Pitch/Roll (inactive): Pitch and roll from the inactive motion sensor. This is logged to

the hard disk
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X axis Range Mode: Mode used to set the X axis (time axis) range.
• Auto: Use the range of the longest displayed data series (show all data)
• Sync: Use the longest range common to all the displayed data series
• Fixed: Set the range to a fixed number of seconds

– Window: Range (time window) in seconds

Y1 axis Range Mode: Mode used to set the Y1 axis range.
• Auto: Use the range of the longest displayed data series (show all data)
• Fixed: Specify a fixed range

– Fixed Max: maximum (upper) range
– Fixed Min: minimum (lower) range

Y2 axis Range Mode: Mode used to set the Y2 axis range.
• Fixed Max: maximum (upper) range
• Fixed Min: minimum (lower) range

User Beams: The beams for the data types which require the user to select four beams.
This feature is used to compare beams, normally on a flat seabed.
• Beam: First user selected beam
• Beam: Second user selected beam
• Beam: Third user selected beam
• Beam: Fourth user selected beam

Line Draw Style: Select the line style for the across track plot
• Line: The across track plot is displayed as a continuous line.
• Points: The across track plot is displayed as a series of points.

Line width: The line width in pixels when the style is Line. The value specifies point size
in pixels when the style is Points

Attitude Step: Decimal factor for the attitude data

Time series – Clear plot

Press the Clear plot button to clear the time series display at any time.

Waterfall – Show/hide
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Active: Activate or decativate the display.
Deactivating the display will minimize the CPU
usage of the display.
Paused: Pause or continue the display of waterfall
data. While paused, the display is visible, but it
is not updated with new data.
Lighting: Enable or disable lightning (and 3D
shading). Useful in situations where the shape
of the grid is such that shading makes the grid (or
portions of the grid) difficult to see.
Colour Scale Legend: Show or hide the colour scale
legend (shown along the bottom of the grid).
Show All Pings: When selected, all pings are
displayed. When not selected, only the most recent
ping is displayed. Deselecting this options can
reduce the CPU load of this display significantly
(depending on the ping rate).
Use Gray Scale Coloring: Display the Waterfall in
grayscale. This mode requires less CPU than the
full colour mode.
Across Track Units: Select the units for the
horizontal axis.
• Beams: Unit for the across track scale is beams
• Meters: Unit for across track scale is meters
Depth Scale Factor: Factor to multiply the depth
with. This has the effect of stretching the waterfall
grid along the depth axis (e.g. a depth scaling
factor of 2 stretches the waterfall grid to twice
its normal height). This can e.g. make it easier to
discover artefacts.
• x 1: No scaling
• x 2: Scale the depth by 2
• x 5: Scale the depth by 5
• x 10: Scale the depth by 10
View Point: Set the point from where the grid is
viewed.
• Front Upper Left: Set the view point to the front

upper left of the grid
• Front Upper Centre: Set the view point to front

upper centre of the grid
• Front Upper Right: Set the view point to front

upper right of the grid
• Front Middle Centre: Set the view point to front middle centre of the grid
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Light Position: Set the position of the light source.
• Front Upper Left: Position the light source at front upper left of the grid
• Front Upper Centre: Position the light source at front upper centre of the grid
• Front Upper Right: Position the light source at front upper right of the grid
• Back Upper Centre: Position the light source at back upper centre of the grid

Waterfall Style: Set the style in which the waterfall grid is displayed.
• Filled: The grid is displayed as a surface
• Lines: The grid is displayed as a triangle mesh
• Points: The grid is displayed as a point set

Water column – Show/hide

Show/Hide button

Note

Please note that the Water column show/hide menu has a scroll bar that must be used
to see all options.
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Active: Activate or deactivate the display. Deactivating the display will minimize the
CPU usage of the display.

Axes: Show or hide the axes.

Y and X axis grid lines: Show or hide X and Y grid lines, and how many grid lines to show.
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Colour Scale Legend: Show or hide the colour scale legend (shown along the bottom of
the grid).

Detected Depth Curve: Show or hide a curve showing the detected depth for all beams.
The curve is shown on top of the water column data.

Stretch Data to Fill View: When this option is not selected, the same scale is used for both
the x- and y-axis. The data is displayed with correct proportions, but this may result in
a lot of unused space in the view. When selecting this option, the x- and y-axis are
scaled to fill the window.

Head 1: Show or hide the data from sonar head 1.
• Max Angle Port: The maximum beam angle to the port side for sonar head 1
• Max Angle Stbd: The maximum beam angle to the starboard side for sonar head 1

Head 2: Show or hide the data from sonar head 2 (applicable for dual sonar head
sounders only).
• Max Angle Port: The maximum beam angle to the port side for sonar head 2
• Max Angle Stbd: The maximum beam angle to the starboard side for sonar head 2

Overlap Mapping Mode: Options for controlling how the data in the overlapped region is
displayed (applicable to dual sonar head echo sounders only).
• Cut: The data from each head is cut vertically at 0 meters across
• Blend: The overlap area is blended using alpha blending.
• Head 1 on Top: The data from head 1 is displayed on top of the data from head 2.
• Head 2 on Top: The data from head 2 is displayed on top of the data from head 1.
Note

Blend Overlap Mapping Mode is not enabled if the background colour is any other
colour than black. Although it is not possible to change the background colour using
Water Column Display menus, the SIS application does provide means to change the
background colour via the Colour Dialog menu.

Depth Start Range Mode: Options for controlling the start range mode of the depth axis
scale.
• Auto: Automatically set the start range of the depth axis to match the minimum value

of the data each time data is received.
• Auto Once: Automatically set the start range of the depth axis to match the minimum

value of current data, then lock to this value in fixed range mode.
• Fixed: Use the start range for the depth axis entered in the Range (m) text box

– Range (m): Fixed start range (in metres)
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Depth Stop Range Mode: Options for controlling the stop range mode of the depth axis
scale.
• Auto: Automatically set the stop range of the depth axis to match the maximum of

the data.
• Auto Once: Automatically set the stop range of the depth axis to match the maximum

range of current data, then lock to this value.
• Fixed: Use the stop range entered in the (Stop) Range text box.

– Range (m): Fixed depth axis stop range (in metres).

Across Start Range Mode: Options for controlling the start range mode of the across
axis scale:
• Auto: Automatically set the start range of the across axis to match the minimum value

of the data each time data is received.
• Auto Once: Automatically set the start range of the across axis to match the minimum

value of current data, then lock to this value in fixed range mode.
• Fixed: Use the range entered in the (Start) Range text box.

– Range (m): Fixed across axis start range (in metres)

Across Stop Range Mode: Options for controlling the stop range mode of the across
axis scale.
• Auto: Automatically set the stop range of the across axis to match the maximum value

of the data each time data is received.
• Auto Once: Automatically set the stop range of the across axis to match the maximum

range of current data, then lock to this value in fixed range mode.
• Fixed: Use the range entered in the (Stop) Range text box.

– Range (m): Fixed across axis stop range (in metres).

Colour Map Mode: Select the type of colour mapping to be used by the display.
• Colour: Map a range of colours to a range of data. The range of colours and the data

range to which the colours are mapped are set via the Dynamic Colours dialogue.
• Grayscale: Map a grayscale range (i.e. black to white) to a range of data. The

grayscale range and the data range to which the grayscale is mapped are set via the
Dynamic Colours dialogue.

Enable Force Depth: When enabled you may use the Ctrl+left mouse button to force the
bottom detection to a depth selected from the water column display. This has the same
effect as setting the Force depth parameter in the Depth settings field found under Runtime
parameters→Sounder main→Depth settings.

Enable Scope Beam: When enabled you may select which beam to display in the Scope
display. The beam number is selected by pressing the Shift button while clicking using
left mouse button on the selected beam.
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Water column – Logging

Water column data can selectively be logged to either the standard log file (.all) or to
a separate water column file (.wcd). Water column datagrams can not be logged to
both files simultaneously.

Water column logging to separate file must be enabled in the Output setup tab under
Installation parameters.

Logging is toggled on/off from the Main toolbar.

Please note that the logged data amount is very large, that is, typically 1 to 2 Gigabytes
per hour.

Separate water column data (.wcd) files may optionally be logged to a disk different from
the one used for the raw data (.all) files. Water column data file locations are set from the
Logging option accessed from Tools→Custom→Set Parameters for details.

Sound velocity profile – Show/hide

Active: Activate or deactivate the display. Deactivating
the display will minimize the CPU usage of the display.

Axes: Show or hide the axes.

Grid Lines: Show or hide the grid lines.

Data Points: Show the sound velocity profile sample
values on the sound velocity profile plot.

Scope display – Show/hide

342682/D 247



Seafloor Information System

Active: Activate or deactivate the display.
Deactivating the display will minimize the CPU
usage of the display.

Axes: Show or hide the axes.

Grid Lines: Show or hide the grid lines.

Legend: Show or hide the legend.

Annotation: Show or hide the on screen text
annotation.

Data As Point: Show the data series as a series of
points, rather than a solid line.

Amplitude: Show or hide the amplitude plot.

Filtered Amplitude: Show or hide the plot of the
filtered amplitude.

Phase: Show or hide the plot of the electrical phase
difference between the two so-called half beams.
This is also called the interferometric, or split beam,
phase signal.

Axis Setup: Option for defining number of grid lines
along the x and y axes.
• Y Division: Number of divisions along the y-axis
• X Division: Number of divisions along the x-axis

Start Range: Options for controlling the start range
mode of the x-axis scale.
• Auto: Automatically set the start range of the

x-axis to match the minimum value of the data
each time data is received.

• Fixed: Use the start range for the x-axis entered in the Range (s) text box
– Range (s): Fixed start range (in seconds)

Stop Range: Options for controlling the stop range mode of the x-axis scale.
• Auto: Automatically set the stop range of the x-axis to match the maximum of the

data.
• Fixed: Use the stop range entered in the (Stop) Range text box.

– Range (s): Fixed stop range (in seconds).
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Stave display – Show/hide

Active: Activate or decativate the
display. Deactivating the display
will minimize the CPU usage of the
display.

Logging: Enable/disable logging of
stave data to the .all file.
• The Stave display must be open

and remain open to log stave
data.

• Standard logging must be
started/active (i.e. the Logging
button in the SIS main toolbar
must be green).

Axes: Show or hide the axes.
• Axis Y1: Show or hide the

Sample axis (the vertical axis to
the left of the grid).

• Axis Y2: Show or hide the
Range axis (the vertical axis to
the right of the grid).

TVG Curve: Show or hide the TVG
(time varying gain) curve. When
shown, the TVG curve is displayed
on top of the Stave data grid.

Colour Scale Legend: Show or hide
the colour scale legend (shown
along the bottom of the grid).

Paused: Pause or continue the
display of stave data. While paused,
the display is visible, but it is not
updated with new data. This may
be useful for example if you want
to look at the cell information of
more than one cell in the grid for

a single ping.
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Start Range Mode: Options for controlling the start range mode for the vertical scale(s).
• Auto: Automatically set the start range to match the minimum range of the data

each time data is received.
• Auto 90: Automatically set the start range to be 90 percent of the range to normal

incidence each time data is received.
• Auto Once: Automatically set the start range (once) to match the minimum range

of the data, then keep this fixed range.
• Fixed: Use the range entered in the Range (samples) text box.

– Range (samples): Fixed start range (in samples).

Stop Range Mode: Options for controlling the stop range mode for the vertical scale(s).
• Auto: Automatically set the stop range to match the maximum range of the data

each time data is received.
• Auto Once: Automatically set the stop range (once) to match the maximum range

of the data, then keep this fixed range.
• Fixed: Use the range entered in the Range (samples) text box.

– Range (samples): Fixed stop range (in samples).
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Planning – Jobs
These buttons are used to create and save a new
job, or to reactivate an existing job.
A job is a collection of planned lines and possibly
one or more polygons. Each job is given a
unique name. A job must first be selected as the
current job before any other operations can be
performed. The selected job can either be new,
or you can continue to work on an existing job.
The following options are available:
• New Job: Create a new job
• Open Job: Open an existing job
• Save Job: Save the current job
• Save Job as...: Save the current job using a

different name
• Clear Job: Clear the current job from the

graphical display

Planning – Remote
These buttons are used to transfer data to
a remote Helmsman Display, see Remote
Helmsman Display on page 206.
Whenever data is transferred to the remote
display it will replace whatever is already
there. All defined lines, polygons and grids will
automatically be transferred if Transfer Plan or

Transfer Grids is selected.
The following options are available:
• Transfer Plan: Transfers lines and polygons to the remote display
• Remove Plan: Removes lines and polygons from the remote display
• Transfer Grid: Transfers the terrain data to the remote display
• Remove Grid: Removes the terrain data from the remote display

Planning – Object

Object
These buttons are used to create and manipulate lines and polygons within an existing job.
Buttons are enabled/disabled depending on allowed actions. As an example, a line must
be activated in order to be able to deactivate it.
The following options are available:
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• New Line: Create a new line by holding the Ctrl key down while clicking the left
mouse button for each new point. At the end of the line, click the right mouse button
to accept or cancel the operation.
This option is active until the New Line button is pressed again or New Polygon is
selected.

• New Polygon: Create a polygon by holding the Ctrl key down while clicking the left
mouse button for each new point in the polygon. Note that a polygon must have
at least three nodes. When last point is defined, click the right mouse button, still
holding down the Ctrl key, to accept or cancel the operation.
This option is active until the user changes to another option or presses the button
once more.

• New Line From: Create a new line by entering the start position, it's azimuth and
distance. The start coordinates can be given in geographical or projection coordinates.

• New Object: Create lines or polygons by entering the coordinates. The following
features are available:
– Object type: Select Line or Polygon
– Coordinate type: Select Geographical or Projection coordinates
– Name: Give the object an identifying name
– Add: Add coordinates for a new point
– Delete: Delete point from the list
– Up/Down: Change the order of the points
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• Extend Line: This option is only allowed if one line only is selected.
Press the Extend Line button to show the two end points of the line. Select which
end you want to extend by holding the Ctrl key down while clicking on it with the
left mouse button.
Click the right mouse button to accept or cancel the operation. When accepting,
the object is deselected.

• Activate Line: First select the line, then press the Activate Line button to make the line
active. The activated line will have a new colour and be deselected. This line will be
sent to the Helmsman display (if present).

• Deactivate Line: First select the line, then press the Deactivate Line button to make the
line inactive. This line will be removed from the Helmsman display (if present).

• Reverse Line: Every line has a defined direction, shown by a dot at the start of the
line. Pressing the Reverse Line button will reverse the direction of all selected lines.
Accepting this action will deselect the lines. Click the right mouse button to accept or
cancel the operation. When accepting, the object is deselected.
This option is only allowed if one or more lines are selected. Any selected polygons
are ignored.

• Rename: Press the Rename button to open a dialogue where you can change the
object’s name. The object will remain selected.
This option is only allowed if one object only is selected.

• Make Parallels: A user defined number of lines parallel to a selected line can be
created using this option. Select a line and then press the button to open the Parallel
Lines dialogue. This dialogue allow you to define how many lines to create in both
directions (port and starboard). The distance and spacing between the lines (in metres)
must be specified. Click the right mouse button to accept or cancel the operation.
When accepting, the line is deselected.
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This option is only allowed if one line only is selected. Any selected polygons are
ignored.

• Make Turn: This option is used to create a turn between two lines. Pressing theMake
Turn button will create a turn by adding a new line between the end point of the first
line and the start point of the second line.
This option is only allowed if two (and only two) lines are selected.

• Keep Lines Inside: This option is used to clip the parts of a line lying outside the
borders of a polygon.

When accepting, the objects are deselected. Multiple lines can be selected.
• Keep Lines Outside: This option is used to clip the parts of a line lying inside the

borders of a polygon. When accepting, the objects are deselected. Multiple lines
can be selected.

• Fill Polygon: This option is used to fill a polygon.
Select a polygon and a line and select Fill Polygon. This dialogue allow you to define
the distance and spacing between parallel lines to be created (both port and starboard
directions). The lines will be clipped at the polygon’s border. When accepting, the
objects are deselected.
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• Move Point: Any point can be moved. Select a line or a polygon and press the Move
Point button to show all points of the selected object. Select which point you want
to move by holding the Ctrl key down while pressing the left mouse button and
moving the mouse. The selected point will move with the mouse cursor until left
mouse button is released. Pressing the left mouse button again elsewhere in the
view, will continue moving the point with the mouse cursor until the mouse button
is released again. This action needs to be confirmed prior to moving other points.
When accepting, the line is deselected.
This option is only allowed if one object only is selected.
Note

It may be difficult to hit a point on an object if the point is directly on top of another
object. Zooming in on the point may help.

• Insert Point: A point can be inserted to an existing line or polygon. Select a line or a
polygon and press the Insert Point button to show all points of the selected object.
Insert a point by holding the Ctrl key down and clicking on one of the line segments
using the left mouse button. After inserting the desired number of points, click the
right mouse button to accept or cancel the operation. When accepting, the object
is deselected.
This option is only allowed if one object only is selected.

Inserting a point may be found difficult. You may alternatively edit the SIS database
as follows:
1 Get the current threshold value by calling:

getParameter.bat
GEOVIEW_PLANNING_INSERT_VERTEX_THRESHOLD 1

2 Increase this value by 20 and update the database by calling:
“setParameter.bat
GEOVIEW_PLANNING_INSERT_VERTEX_THRESHOLD 1 N”
where "N" is the new value.

3 Open the Show/Hide button in the Geographical display, deselect the Planning
check box, press Apply, then check Planning and press OK.
If this did not help, try to increase the value a bit more.
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• Delete Point: Any point can be deleted. Select a line or a polygon and press the Delete
Point button to show all points of the selected object. Delete a point by holding the
Ctrl key down and clicking on it using left mouse button. After deleting the desired
number of points, click the right mouse button to accept or cancel the operation.
When accepting, the object is deselected.
Note that when deleting points, you must leave at least two points on a line and three
points on a polygon.
This option is only allowed if one object only is selected.
Note

If you find it difficult to delete a point in an object, the point may be directly on top
of another object. Zooming in on the point may help.

• Edit Selected: This option is used for editing objects. Select an object and press the
button to open the Planning Edit Module dialogue.
This dialogue allow you to change, delete or add points as well as renaming the
object. After updating, the object is deselected.

This option is only allowed if an object only is selected.
• Move Selected: Any object can be moved. Select one or more objects and press the

Move Selected button. Move the objects by holding the Ctrl key down, pressing the
left mouse button and then moving the mouse. The objects will move with the mouse
cursor until releasing the left mouse button.
After moving the objects to the wanted location, click the right mouse button to accept
or cancel the operation. When accepting, the objects are deselected.
This option is only allowed if at least one object is selected.

• Delete Selected: Press this button to remove all selected objects from memory. No
confirmation is required.
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This option is only allowed if at least one object is selected.
• Export Selected: Press this button to append all selected objects to an already existing

job (to file).
This option is only allowed if at least one object is selected.
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Sensor layout – Show/hide

Note

Please note that the Sensor layout show/hide menu has a scroll bar that must be used
to see all options.

Antialising: Apply antialising to make the
drawing appear smoother on the screen
Ship: Show or hide the ship
• Line width: in pixels
Ships water line: Show or hide the ship's water
line
• Line width: in pixels
Water plane: Show or hide the water plane
• Water plane width: in meters
• Transparency: scaled from 1 to 100,

where 100 is fully transparent and 1 is not
transparent

XY meter mesh: Show or hide mesh in XY plane
• Width (m): Mesh width in metres
XZ meter mesh: Show or hide mesh in XZ plane
• Width (m): Mesh width in metres
YZ meter mesh:Show or hide mesh in YZ plane
• Width (m): Mesh width in metres
Origo sphere: Show or hide the ship's reference
point as a small sphere
• Radius (cm): Radius of sphere, max 25 cm
• Transparency: scaled from 1 to 100,

where 100 is fully transparent and 1 is not
transparent

Active sensors only: Show or hide all system
defines sensors
Position system: Show or hide the location of
the position system
• Line width: in pixels

• Joint radius (cm): Position system is shown as a sphere with given radius. Max radius
is 20 cm

Motion sensor: Show or hide location of motion sensors
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• Line width: in pixels
• Joint radius (cm): Motion system is shown as a sphere with given radius. Max radius

is 20 cm

Transducer/head: Show or hide location of
transducer or head
• Line width: in pixels
• Joint radius (cm): Transducer or head is

shown as a sphere with given radius. Max
radius is 20 cm

Depth sensor: Show or hide location of depth
sensor
• Line width: in pixels
• Joint radius (cm): Transducer or head is

shown as a sphere with given radius. Max
radius is 20 cm

Echo sounder beam 1: Show or hide visualisation
of beam 1
• Depth: To what depth the beam is visualised

(in metres)
• Transparency: scaled from 1 to 100,

where 100 is fully transparent and 1 is not
transparent

Echo sounder beam 2: Show or hide visualisation
of beam 2, if applicable
• Depth: To what depth the beam is visualised

(in metres)
• Transparency: scaled from 1 to 100, where 100 is fully transparent and 1 is not

transparent

Pipe: Show or hide a visualisation of a seabed pipe
• Diameter (cm): of pipe (true size)
• Length (cm): of pipe
• Depth (cm): of pipe
• Transparency: scaled from 1 to 100, where 100 is fully transparent and 1 is not

transparent
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Calibration parameters
Related operational procedures
• How to determine calibration values using SIS Calibration frame on page 181
• How to determine calibration values using SeaCal automatic calibration on page 184

The following calibration parameters
may be set:
• Head 1 / Head 2 / Both heads: Select

the sonar head(s) to be calibrated.
Head 2 applies to dual head systems
only.

• Depth Value to use: Choose between
depth, tide corrected depth and depth
referred to vertical reference point.

• Corridor width (m): Use the slidebar
or the textfield to give a new value.
Press Set to activate.

• Current offset: The Current offsets
fields are used to show the offset
values used when the data was
logged. This field can not be
changed.

• Correction: Set the correction value
you believe give best fit between the
curves. Press Apply to activate.
Note

Only one element must be corrected
for each set of lines

– Roll MRU (deg): Use the slidebar or the textfield to give a new value. Press Apply
to activate.

– Pitch MRU (deg): Use the slidebar or the textfield to give a new value. Press
Apply to activate.

– Heading MRU (deg): Use the slidebar or the textfield to give a new value. Press
Apply to activate.

– Time (ms): Use the slidebar or the textfield to give a new value. Press Apply to
activate.

• Auto Calib: Press this button to launch Seacal auto calibration.
• Store: Press this button to add the entered calibration values to the existing ones set

from Installation parameters→Sensor setup→Angular offset.
• Select lines... opens a dialogue box showing all lines in the calibration survey. You

may select the lines to compute the calibration values from in the list that appear.
Press OK to confirm.
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Note

The Select lines... dialogue box can only be opened when SIS is in calibration mode.

Show/Hide button

Show grid: Show or hide the grid.
Show legend: Show or hide the legends
Depth Scaling mode: Options for controlling the scaling
mode for the depth axis.
• Auto - Automatically adjust the start and stop ranges

to show the entire range of data each time data is
received.

• Fixed - Use the start and stop ranges entered in the
min and max text boxes.
– Min (m): Fixed start (min) range in meters.
– Max (m): Fixed stop (max) range in meters.

Line style: Select whether to show the calibration lines
as lines, points or a combination of both.
Line width: Set line width in pixels.
Point size: Set point size in pixels.

Seacal auto calibration
The following Auto Calib parameters can be entered:

• Roll
• Pitch
• Heading
• X0 (translation alongships)
• Y0 (translation athwartships)
• Roll scale
• Y scale
• Relative tide
• Beam sector
• Maximum sea depth
For each parameter to be used, the corresponding On/Off button must be checked.
• Resolution: The resolution of the grid model applied in the calculation affects the

computing time. The Auto option asks SeaCal to compute the resolution, but you
can also define the resolution manually.
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• Max Iterations: Usually, SeaCal needs two or more iterations to compute the
calibration. You can define the maximum number of iterations manually, or you select
Auto, i.e. SeaCal iterates until the solution is stable.

• Type of computation: It is also possible to select calibration with or without a
reliability test. It is recommended to run this test, as it gives a comprehensive control
of the calibration.
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Survey parameters
This section contains a description of the dialog boxes and parameter settings provided
by the New survey and the Survey administration frames in SIS.

Topics
• Basic parameters on page 263
• Storage options on page 265
• Background data on page 267
• Projection parameters on page 269
• GridEngine parameters on page 269
• User handling on page 272
• CUBE parameters on page 273
The survey parameters that can be set and administrated from these dialogs partly
overlap each other, but differs slightly depending on whether a new survey is being set
up or the survey parameters are being modified.

Related operational procedures
• How to enter parameters for a new survey on page 118
• How to enter survey parameters on page 114
• How to define a new projection and datum transformation on page 122

Basic parameters
Basic parameters are accessed through New survey→Basic Parameters .
The survey name is mandatory when creating a new survey. Further, it is required that
the parameters for the default surveys are maintained by the user.
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Parameters
• New Survey name: Give a unique name to your survey (mandatory)
• Select survey-template: Loads Storage and Advanced Options parameters defined in a

template
• User: Select the identification of the user. To add new user(s), refer to User handling

on page 272.
• Existing Surveys: Select an existing survey. Press Continue on existing survey button

before the survey can be changed
• Comment: Give additional information about the survey
• Save new survey: Create the new survey. All parameters stored under the Storage

options tab and the Advanced options tab are stored in the database for this new survey
The Basic parameters are also located under the Survey templates handling tab in the
Survey administration frame. The look and parameters differs slightly from when
accessed from New survey.
The Survey template handling manages the default surveys used as template.

Parameters - Add/Change survey template
• New Survey name: Select the survey you want to add/change from
• Select survey-template: Select a survey template you want the new template to be

based upon for the parameters for Storage options and Advanced options.

264 342682/D



Parameter references

• User: Select a user. To add new user(s), you must use the User handling tool, see User
handling on page 272.

• Comment: Write your own comment for the survey template
• Update: Update the existing default survey or add a new default survey to the

database. This includes the parameters stored under the Storage options tab and the
Advanced options tab.

Parameters - Delete survey template
• Survey name: Select the survey you want to delete
• Delete: Delete the selected survey

Parameters - Survey type as default
• Default/Previous: Define which default survey is to appear in the Select survey-type

combo box

Related operational procedures
• How to enter parameters for a new survey on page 118
• How to enter survey parameters on page 114

Storage options
Storage options are accessed through the New survey frame or through the Survey
administration frame on the Survey template handling tab.

Observe the default storage locations of raw and gridded (survey) data. We recommend
that you stick to the default storage structure, unless you have specific requirements.
Sub-directories will be added according to your selections in the raw data structure
dialog field.
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Parameters
• Survey data storage location: Specify the location to store Survey Data files. Enter the

folder identification directly, or use the browse button to navigate
• Raw data root location: Specify the location to store Raw Data files. Enter the folder

identification directly, or use the browse button to navigate. Press the Apply to all
default surveys button to apply

• Current raw data storage structure: Description of current structure
• Use current structure: Keep current structure
• Clear new survey: Create a new structure
• Build raw data storage structure from tickboxes: Build a new storage structure by

enabling the check boxes you want to use. The new structure will appear in the text
field behind New raw data storage structure

• Shipname: To identify the data files by your ship's name if the Use as postfix in filename
check box is ticked off

• Apply to all survey templates: Update these parameters for all survey templates in the
database. If you want to store these parameters to a particular survey, you must select
a different survey template from the Basic Parameters

Related operational procedures
• How to enter parameters for a new survey on page 118
• How to enter survey parameters on page 114
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Background data
Background data is found under three different tabs under the New survey and under
the Survey administration display view:
1 Survey Administration→Background data

The Background data tab located directly under the Survey Administration frame is
used for enabling and disabling file locations where your background data is stored.

2 Survey Administration→Survey templates handling→Advanced options→Background
data
This is where you select the background data you want to use for the survey
template you currently are setting up.

3 New survey→Advanced options→Background data
This is where you select the background data you want to use for the survey you
currently are setting up.

The Background data dialog boxes selected from (2) and (3) above appears identical, but
applies to the survey template or current survey depending of where you are accessing
the dialog from. The parameters from this dialog box are described in the following.

Parameters
• Path to Background data: Choose the path you want to use for the background data.

You can use the browse button to find a path
• Comment: Write your own comment for the background data
• Apply this path to Default survey: Apply the path.

If you want to store these parameters to a particular survey, you must use the New
Survey→Basic parameters or Survey Administration→Basic parameters.

In the background data directory the following files can be stored:
• Projection setup: proj.txt used to define the geographic projection for the survey.
• KSGPL background data: *.ksgpl. KSGPL formatted files with background data to

be shown in the Geographical display.
• Predicted tide: predictedtide.tide, predicted tide file.
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• Geoid model: geoidmodel.geoid, geoid model.
Background data can also be accessed from Survey administration frame and is used for
enabling and disabling file locations where your background data is stored.

Parameters – Add data
• Pathname: Set the path to the background data
• Comment: Write your own comment for the background data
• Add: Add the selected path
In the background data directory these files can be stored:
• Predicted tide: predictedtide.tide, predicted tide file.
• Geoid model: geoidmodel.geoid, geoid model.
• Background image: Tiff and geotiff files.
If you want to store these parameters to a particular survey, please refer to Basic
parameters on page 263.

Parameters - Delete data
• Pathname: Select the path you want to delete from the combo box
• Comment: See information given about the selected path
• Delete: Delete selected path
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Related operational procedures
• How to enter parameters for a new survey on page 118
• How to enter survey parameters on page 114

Projection parameters
Projections is located under the Advanced options tab on the New survey display view and
under the Advanced options tab under the Survey templates handling tab on the Survey
administration display view.

When defining a survey or a survey template, you have to define what projection to use
in that survey or survey template. New projections can be created and tested using the
Projection setup application available from the Tools→Custom menu.

Parameters
• Projection: Select a projection from the drop-down combo box
• Apply this projection to the Default survey: These projections will be saved in the

database for all default surveys
If you want to store these parameters to a particular survey, you must use the New
Survey→Basic parameters or Survey Administration→Basic parameters.

If a survey is loaded into SIS, the user is prompted to change projection. If yes, all earlier
surveys loaded into SIS will be removed, before activation of the new survey.

It is possible to change projection after a projection has been set.

Related operational procedures
• How to define a new projection and datum transformation on page 122

GridEngine parameters
The GridEngine parameters is located under the Basic Parameters tab on the New survey
display view and under the Advanced options tab under the Survey templates handling tab
on the Survey administration display view.

When defining a survey or a survey template, you have to define what parameters to
use for the GridEngine.
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Parameters

The terrain modelling module in SIS uses an internal Processing Grid. Nine Processing
Grids may be loaded into RAM simultaneously. The Processing Grid is a square, and the
size of one side should be approximately the expected swath width.

The following factors have influence on the selection of the cell number and cell size:
• Depth
• Achieved swath width (shown in numerical display)
• Survey speed
• Coverage area per beam (footprint)
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If the cell size is set too large the resolution in your geographical view will be poorer
than necessary. If you set the cell size too small you may experience that there are not
sufficient data points in the cells to compute a valid depth value, and no depth value is
displayed. Too small cell size may also overload the computer and give you delays
in the real time display.
Note

The grid resolution applies to displayed data only, the raw data is not affected.
The grid resolution can not be changed during the survey, and should therefore be
carefully set to apply to the whole survey area.

The following rule of thumb have proven to be reasonable:

Normal resolution
• Cell size = average swath width/100
• Number of cells in processing grids: 64x64

High resolution
• Cell size = average swath width/200
• Number of cells in processing grids: 128x128
Example: If depth is 100 meters and sector coverage is set to ±70°, the swath width is
550 meters. Cell size computed from above rule of thumb for may then be set to 5.5
meters for normal resolution and 2.8 meters for high resolution.
Note

The cell size settings applies to highest possible display resolution, i.e. LOD0.

• Depth variable: If you are applying real time data cleaning, select what depth to use
in the processing.
The real time data cleaning module will use the given depth plane to identify outliers
in the data and remove them.
Note

We recommend that you set the real time data processing depth to either tide corrected
depth, Zt, or to geoid and RTK corrected depth, Zv, in order to avoid unwanted depth
rejections caused by natural variations such as the tide.

The depth variable can be set to:
– Z: Depth, sea surface to sea bottom distance.
– Zt: Tide file corrected depth, vertical datum to seafloor distance.
– Zv: Geoide and RTK corrected depth, vertical datum to seafloor distance.
– Zg: Seafloor to geoide distance.
– Zr: Seafloor to ellipsoid distance.

• Number of cells: Set number of cells in the processing grid:
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– 16 x 16
– 32 x 32
– 64 x 64
– 128 x 128
– 256 x 256
– 512 x 512

• Cell size (cm): Set the cell size (in m). The selectable range is from 0.1 to 150 m
• Processing parameters: Set the Ping processing and Grid processing rules. These rules

are explained under the Data Cleaning tab. See Data cleaning on page 317
• Apply to all survey templates: This will update the grid engine parameters for all

survey templates currently in the database.
If you want to store these parameters to a particular survey, you must use the New
Survey→Basic parameters or Survey Administration→Basic parameters.

Related operational procedures
• How to enter parameters for a new survey on page 118
• How to enter survey parameters on page 114

User handling
User handling is located under the Survey administration display view.

Parameters – Add user/Change user information
• User: Type the name of the new user

The user parameter is logged in the raw survey format files (.all-files). This makes it
possible to recall who was responsible for the survey.

• User Info: Type any additional information about the user
• Update: Apply your changes
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Related operational procedures
• How to enter survey parameters on page 114

CUBE parameters
The CUBE (Combined Uncertainty and Bathymetry Estimator) algorithm is developed at
The Centre for Coastal and Ocean Mapping (C-COM)/Joint Hydrographic Centre (JHC)
at University of New Hampshire. The algorithm is available as a library and is used
inside one separate module in SIS. The CUBE algorithm can be used as an alternative
data gridding and data cleaning method in SIS. The gridding and data cleaning is a
default process done by the GridEngine.

A CUBE grid can be generated for all the raw data files in a survey when logging is
completed. This requires that all necessary parameters are defined in the survey template.

Related topics
• CUBE on page 464

Related operational procedures
• How to enter survey parameters on page 114
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Installation parameters
This section contains a description of the dialog boxes and parameter settings provided
by the Installation parameters frame in SIS.

Note

Any changes to the installation parameters have to be confirmed. When a parameter
value has been changed the OK button turns yellow. You have to confirm your change by
pressing the yellow OK button. The button will return to it's original colour.

Note

Whenever the OK button is pressed from the Installation parameters
frame a backup file containing current PU parameters is generated.
The backup file can be Imported through File→Import PU parameters....
The backup files are stored in \sisdata\common\backup-settings
with the naming convention Backup_<echo_sounder_name>_<serial
number>_ <YearMonthDay>_<HourMinuteSecond>.txt e.g.Backup_EM
2040_402_20090430_105852.txt.

Note

The PU – Processing Unit may be a separate hardware unit or an integrated part of the
TRU – Transceiver Unit cabinet, depending on echo sounder system.

For SIS it makes no difference whether the communication is with a PU or a PU inside a
TRU. The term PU is used in this manual.

Topics
• PU communication – Input setup on page 275
• PU communication – Output setup on page 279
• PU communication – Clock setup on page 281
• Sensor setup – Settings on page 283
• Sensor setup – Location for EM 2040 on page 288
• Angular Offsets for EM 2040 on page 290
• ROV Specific for EM 2040 on page 291
• System parameters for EM 2040 on page 292
• BIST – Built-In Self Test on page 293

Related operational procedures
• How to open the installation parameter interface on page 127
• How to modify the installation parameters on page 127
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PU communication – Input setup
Input Setup is located under the PU Communication Setup tab on the Installation
parameters display view and is used to define the communication parameters for input
data to the PU.

Note

When Input Setup configuration is changed, you should check that the parameters in
the Sensor setup tab still applies.

Input setup parameters – Port settings

Port
Input port: This drop-down combo-box is used to select which of the PU (Processing
Unit) ports the dialogue box is applicable to. Choose between the serial ports COM1
to COM4 or the network ports UDP2, UDP5 or UDP6.
• COM1: Normally used for position, clock and depth input.
• COM2: Designated to input from a motion sensor.
• COM3: Optional (position, motion and heading input).
• COM4: Optional (position and heading input).
• UDP2: Attitude/Position and EA 500 depth input.
• UDP5: Attitude velocity input 1 (applies to EM 122, EM 302, EM 710, EM 2040

and EM 2040C)
• UDP6: Attitude velocity input 2 (applies to EM 122, EM 302, EM 710, EM 2040

and EM 2040C)

COM port settings:
• Baud rate: Define the baud rate for the currently selected serial port.
• Data bits: Select the number of data bits for the currently selected serial port.
• Stop bits: Select the number of stop bits for the currently selected serial port.
• Parity: Select the parity for the currently selected serial port.
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UDP port settings

The UDP port settings are given by the PU status and information datagram broadcasted
by the PU.

The port settings are as follows:
Port Port number

UDP2: 2022

UDP3: 2032 (not used)

UDP4: 2042 (not used)

UDP5: Defined by attitude velocity sensor 1

UDP6: Defined by attitude velocity sensor 2

Network addresses

Caution

You must ensure that the network addresses and ports are not used by
other systems.

The Ethernet 1 network addresses for the different Kongsberg Maritime echo sounders
are as follows:
System Network address

EM 120: 157.237.14.60

EM 122: 157.237.14.60

EM 300: 157.237.14.60

EM 302: 157.237.14.60

EM 710: 157.237.2.71

EM 1002: 157.237.15.60

EM 2000: 157.237.2.58

EM 3000: 157.237.2.58

EM 3002: 157.237.2.61

EM 2040 / EM 2040C: 157.237.20.40

ME70/BO: Defined by the Simrad ME70/BO system

UDP5/UDP6 Setup – Attitude velocity settings

When you set the Input port to UDP5 or UDP6 an additional dialog appears.
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The system may be configured with one or two standard motion (attitude) sensors via
COM ports. Both these sensors can also provide attitude velocity via UDP ports:
• UDP5 is associated with Attitude 1 using the setup information (i.e. location

information) for Attitude on COM2.
• UDP6 is associated with Attitude 2 using the setup information (i.e. location

information) for Attitude on COM3.

See Sensor setup – Location for EM 2040 on page 288

Settings for both UDP5 and UDP6 ports are displayed simultaneously, but only the
settings for the selected port (UDP5 or UDP6) can be changed, the other is disabled
(greyed out). Also note that the Ethernet 2 settings, i.e. IP address and Net mask, may
only be changed if the Use Ethernet 2 tick button has been set.
• If input from an Attitude Velocity sensor is required Attitude/Velocity in the Input

format list must be ticked off. If not enabled, no UDP5 or UDP6 parameters will
be received by the PU.

• Use Ethernet 2 defines if the PU Ethernet 2 port is to be used or not. If not selected
the sensor input is assumed to go via Ethernet 1 (same as used for the HWS). It is
recommended to use Ethernet 2 for the attitude velocity. The UDP port number will
be used in any case. The Ethernet 2 settings are the same for both UDP5 and UDP6.

• IP addr. sets the IP address to be used by the PU Ethernet 2 port. Net mask sets the
net mask to be used. The IP address and network mask must be in the same subnet
as the sensor.

• UDP port settings set the UDP port number used by the attitude velocity sensor when
transmitting data according to the following available settings:
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Sensor Port number

Kongsberg Seatex Seapath 200: 3001

Applanix POSMV: 5602

CodaOctopus F180: 3000

Note

The Ethernet 2 settings are the same for both UDP5 and UDP6. Some Attitude/Velocity
sensors have a hard coded port address. This restricts the use to only one such sensor in
a two sensor configuration.

Note

When an Attitude/Velocity setup change has been completed in the Port Settings group it is
necessary to check the Active Sensors selection group in the Installation and Test →Sensor
Setup →Settings frame to make sure that the correct sensor is set as active.

As a reminder the Sensor →Sensor Setup tabulators are coloured red to advice the
operator to check, and possibly modify, the selections.

Input formats
This area allows you to define what type of external sensor is connected to the serial or
network port you selected in the Input port combo box.
Inputs in the following formats are available:
• GGK Positions (NMEA)
• GGA Positions (NMEA)
• GGA_RTK Positions (NMEA)
• Simrad90 Positions
• Attitude
• ZDA Clock (NMEA)
• HDT Heading (NMEA)
• SKR82 Heading
• MK39 Heading
• Ethernet AttVel
• DBS Depth (NMEA)
• DBT Depth (NMEA)
• EA500 Depth
• ROV Depth
• Height (special purpose only)
Refer to the Datagram Formats in the appropriate user documentation for a description of
these formats.
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Restrictions to sensor input

A number of restrictions apply to the selection of the PU (Processing Unit) input formats.
These restrictions are integrated into the user interface and will be reflected in the
enabling/disabling of check boxes for the different ports. The restrictions are as follows:
• Only one positioning system is allowed on each port, with a maximum of three

positioning systems
• Positioning system 1 is by definition on COM1
• Positioning system 2 is by definition on COM3
• Positioning system 3 is by definition on COM4 or UDP2
• Only one motion sensor is allowed on each port, with a maximum of two motion

sensors
• Motion sensor 1 is by definition on COM2
• Motion sensor 2 is by definition on COM3
• A motion sensor cannot share a serial line (COM) with other sensors
• The Sperry MK39 MOD2 motion sensor (roll, pitch, heading) can only be used on

serial line COM3
• A stand alone heading sensor using SKR80/82 format can only be used on a COM

(serial line) port. This port cannot be shared by others sensors when in use
• A stand alone heading sensor using SKR80/82 format can only be used on a COM

(serial line) port. This port cannot be shared by others sensors when in use
• Only one clock input (normally ZDA) is allowed plus a single 1PPS clock sync.

signal. See PU communication – Clock setup on page 281
• Only one depth sensor is allowed (pressure sensor for ROV)
• The EA500 format can only be used on UDP2

PU communication – Output setup
Output Setup is located under the PU Communication Setup tab on the Installation
parameters display view.

Output setup is used to defined what datagrams to be output from the PU (Processing
Unit) to the following:
• SIS raw data logging
• Raw data logging to PU disk
• User defined selection to third party systems (e.g. QINSy or HYPACK)

Enabling of water column data logging to separate file is enabled from here.
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Output setup parameters

UDP host port: Available options depend on system connected.
• SIS Logging is used by the system to define what SIS raw data to log. The settings

for this link should normally not be changed. Mandatory datagrams are disabled
from deselecting

• User defined can be set up to contain any datagrams selcted from the list. By using
the given port address these datagrams can be picked up by any third party systems
with access to the same network.

Port address: Can NOT be changed.

Note

Port number 2999 is reserved for internal use.

Log watercolumn to separate file enables logging of water column data to a *.wcl file.
Water column data file locations is set from the Tools→Custom→Set Parameters menu.

See How to log water column data on page 170 for details.

Enable PU logging to disk applies to systems where internal logging to PU disk is possible.

PU broadcast enable: Tell the PU (Processing Unit) to broadcast its presence on the
network, using port 1999. The PU will send out a broadcast datagram every second to
port 1999. This function can not be turned off.
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Datagram subscription on the UDP port: The table below shows datagram subscriptions
available for various multibeam echo sounders.

Echo sounder

Datagram
EM
120

EM
122

EM
300

EM
302

EM
710

EM
1002

EM
2000

EM
3000

EM
2040

EM
2040C

EM
3002

ME70
/BO

Depth x x x x x x x x x x x x

Raw range and beam
angle x x x x x x x x x x x x

Seabed image x x x x x x x x x x x x

Central beams x x

Position x x x x x x x x x x x x

Attitude x x x x x x x x x x x x

Heading x x x x x x x x x x x x

Height x x x x x x x x x x x x

Clock x x x x x x x x x x x x

Single beam echo
sounder depth x x x x x x x x x x x x

Sound Speed Profile x x x x x x x x x x x x

Runtime parameters x x x x x x x x x x x x

Installation parameters x x x x x x x x x x x x

BIST Reply x x x x x x x x x x x x

Status parameters x x x x x x x x x x x x

PU broadcast x x x x x x x x x x x x

Detection quality x x x x x x

Stave display x x x x x x

Water column x x x x x x x

Hull unit x

Internal, Scope Data x x x x x x x x x x x x

Related procedures
• How to log water column data on page 170
• How to log stave data on page 170

PU communication – Clock setup
Clock Setup is located under the PU Communication Setup tab on the Installation
parameters display view.

Clock Setup is used to set the PU clock based on selected input source.

Please refer to Timing on page 498 for detailed description about timing in SIS.
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The echo sounder system has an internal clock with 1 millisecond resolution. This clock
is used to time stamp all logged data. The clock will drift, typically some seconds per
day, unless it is synchronized to a 1PPS (one pulse per second) input signal. The 1PPS
signal will determine the clock’s drift rate, and in practice reduce it to zero using a
GPS receiver as source.
The clock may be set in three situations:
1 When the PU is initialized during start-up of PU from SIS.
2 When the Clock Source is changed.
3 When a new survey is started.
A fully correct clock is only necessary if the output data are later to be combined with
other time critical data logged or created by other systems, for example an accuracy of
up to one minute would be necessary to apply tidal changes.
If the timestamp supplied in the position input datagrams is to be used, it is imperative
that the system clock is correctly set and that 1PPS synchronization is used.

Clock setup parameters
Source: This selector is used to define the source for the synchronization of date and
time. The following options are available:
• External ZDA clock (UTC time received in ZDA format)
• Active Positioning System (time stamp of position datagram)
• Operator Station
• No sync
Note

External ZDA can only be selected if ZDA input is selected. See PU communication –
Input setup on page 275.
When External ZDA clock is selected both the PU Communication Setup and the Clock
Setup tabulators are changed to red to indicate that you need to check current clock setup.
The red tabulator setting is turned off when the OK or the CANCEL button is pressed
In the case that the ZDA Clock input is turned off and the clock source setting is External
ZDA Clock the (fall back) clock source is automatically set to Active pos. system.

Offset [sec]: Offset (sec) is used if you want to refer to a different time zone than your
time reference. This may be useful e.g. if you have tide data referred to Local time,
whereas you are synchronizing to UTC time.
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It is possible to use the Offset to adjust the echo sounder clock to a local time zone.
If a local time zone is set, there are restrictions: Time to use located under the Sensor
setup→Settings tab for active positioning must be set to System. If not, no data will be
displayed in the geographical view. The data it self will be correct regardless of the
selected Time to use. The problem is that SIS will not take the time offset into account
when reading position time tags.

1PPS Clock Sync: This selector is used to turn on the 1 pulse per second external clock
synchronization and select if the synchronisation should occur on a rising or falling edge
transition. The following options are available:
• Off the 1 pulse per second external clock synchronization is turned off (this is the

default value)
• Falling edge synchronisation on a falling edge transition
• Rising edge synchronisation on a rising edge transition

1PPS input signal is normally “resting” at a high level. Each second, a low going 100
mS-1000 mS pulse adjusts the second counter in the PU (Processing Unit). Since 1PPS
is a TTL-signal, a high level at the input connector must be higher than 2.7 Vdc (the
margin is then 0.3 Vdc) and a low level (during the pulse) must not exceed 0.6 Vdc (the
margin is then 0.2 Vdc).

Sensor setup – Settings
Settings (of sensors) is located under the Sensor Setup tab on the Installation parameters
display view and contains the following dialog fields:
• Position system settings
• Motion system settings
• Active sensors
Note

When the Input Setup configuration is changed the Settings must be verified!
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Positioning systems parameter settings

You can connect three positioning systems to the multibeam echo sounder, but only one
can be active at a time. One positioning system can be connected using a network port
instead of a serial line.
Data from all positioning systems are logged, and may all be used in post-processing.
However, only the positioning system selected as active will be used in the realtime
displays. (See Active sensors parameter settings on page 287).
For each of these positioning systems, some basic parameters must be defined.
Positioning System Ports: Use this drop-down combo box to choose which positioning
system you wish to set the parameters for. The positioning system is not identified by its
name, but by the port it is connected to.
The following ports are available:
• COM1 (positioning system 1)
• COM3 (positioning system 2)
• COM4 (positioning system 3)
• UDP2 (positioning system 3)
Time to use: Usually the input datagram's timestamp is used. However, it is then assumed
that the multibeam echo sounders clock is set from External ZDA clock, that both the PU
system clock and the positioning system clock are synchronized with the 1PPS signal
and that there is no time difference between the two clocks.
Any time difference can be set from the Installation parameters→PU communication
setup→Clock setup tab. This is also where you set the PU clock to be synchronized
with External ZDA clock.
Select Datagram or System:
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• Datagram: The time of the observation read from the position datagram.
• System: The multibeam echo sounder will use its own internal time stamp when

applying positions to the real time display.
Note

Both time stamps are stored, hence the time reference can be changed or corrected
in post processing.

Enable position motion correction: When the vessel moves due to roll, pitch and heave,
the antenna on the positioning system moves as well. This parameter allows the system
to compensate for this movement by adjusting the values from the positioning system
based on current information from the motion sensor(s).

Correct timing of the positions is very important if motion correction is to improve
position accuracy.

Position delay (sec): This parameter is used to define the age of the position in the
position datagrams.

The relative timing of vessel position data and system depth data is critical to the total
achievable accuracy. The best solution is if it can be assured that the position datagrams
are always received by the system with a fixed and sufficiently constant age with respect
to the time of validity of the enclosed positions. This age is the position delay to be
entered. Such a solution will make the use of any clock synchronization of the system
with the positioning system unnecessary.

Datum: This parameter enables you to set the internal datum identical to what the
positioning system sends to the echo sounder. This will also be logged onto the harddisk.
The projection reference in the survey module must also be set accordingly.

Log all heights: When enabled the PU will send height datagrams for the selected
positioning system, i.e. the COM port selected.

Pos. qual. indicators for height acceptance: Enter the quality indicator numbers (comma
separated) that you want to interpret as accepted height observations. The quality factor
applies to GGA and GGK position data only.
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Attitude sensor parameter settings

You can connect two motion systems to the multibeam echo sounder, but only one can
be active at a time. Data from both systems will be logged. The motion system you
have selected as active will be used in the real time displays. For each of these motion
systems some basic parameters need to be set.
Attitude Sensor Ports: Choose which motion sensor you wish to set the parameters for.
The motion system is not identified by name, but by the port it is connected to.
The following ports are available:
• COM2 (motion sensor 1)
• COM3 (motion sensor 2)
• UDP5 (attitude 1) Applies to EM 122, EM 302, EM 710, EM 2040 and EM2040C
• UDP6 (attitude 2) Applies to EM 122, EM 302, EM 710, EM 2040 and EM2040C
Roll reference plane: The roll reference plane is used to define the reference plane against
which the roll angle is measured.
Select Horizontal or Pitch/Roll Plane:
• Horizontal: Select this alternative if roll is measured against the horizontal plane, i.e.

against the plane normal to the gravity vector. This is the convention used by the
Hippy 120, often emulated by other sensors.

• Rotation: Select this alternative if roll is measured against a plane defined as
horizontal in the acrosstrack direction, but following the vessel pitch in the alongtrack
direction, i.e. as a rotation around the forward pointing axis of the vessel coordinate
system. This is the convention usually used by inertial systems such as the POS/MV
(the Tate-Bryant convention).

286 342682/D



Parameter references

Attitude delay (msec): This parameter is used to define the expected time delay of the
motion data.

If the data from the attitude sensor are delayed with respect to when they were valid,
this may be corrected by the system provided the delay is known. This delay may be
due to filtering and/or processing time in the sensor, and should be provided by its
manufacturer. Some sensors are able to compensate for such delays by a prediction, but
it is not advisable to use such a feature.

Active sensors parameter settings

Only one positioning system, one motion sensor, one heading sensor and one velocity
sensor can be active at a time.

The selection of which system/sensor to be active is performed by selecting which
input port the relevant equipment is connected to. The available choices for each
system/sensor is dependant on the settings made in the Input Setup configuration of
the PU (Processing Unit).

Refer to PU communication – Input setup on page 275 for more information.

There is a drop-down combo box for each of the system/sensor types.

Note

When the Input Setup configuration is changed the Active Sensor setting must be checked.

Position: Select port number of active positioning system.

Motion: Select port number of active motion sensor.

Heading: Select port number of active heading sensor.

Velocity: Select port number of active velocity sensor.
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Sensor setup – Location for EM 2040
Locations (of sensors) is located under the Sensor Setup tab on the Installation parameters
display view.

In order to make correct computations, SIS must know the physical location of all
sensors, including it's transducers.

The locations must be referred to the vessel’s reference point. The location of each
system must therefore be given as a forward (x), downward (z) and starboard (y) position
relative to the reference point. The coordinate system assumes that the x-axis follows the
vessel’s keel, and that the x-y plane is horizontal while the vessel is in normal trim.

Location parameters

Positioning systems (Pos): These settings are used to define the physical location of the
selected positioning system’s position point, i.e. the point on the ship where the position
is valid.

Note

The position data you define here may however not necessarily be the physical location
of the antenna. This is because settings in the positioning system’s own software may
redefine the location of the antenna. The xy values of the soundings are referred to the
location of the active positioning system, and it is this virtual position that you must enter.
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The downward locations are required if the bottom is being determined with respect
to a vertical datum.

The downward position will also be used if the positions are to be corrected for vessel
attitude. This requires that the actual physical antenna position is entered and that the
given position is at the antenna.

TX/RX Transducer: Use these settings to define the physical location of the centre of the
face of the respective transducer arrays.

Attitude (motion): The Attitude Sensor parameters allow you to define where the sensor
is physically located, or where its data are valid, e.g. in case the attitude sensor is
programmed to calculate heave at a different location than where it is actually mounted.

Waterline: Enter the vessel’s waterline (in normal trim) related to the vessel’s reference
point. The value should be an average of two measurements; one on each side of the
vessel. The measurement must be made at the same alongship location as the physical
location of the motion sensor.

Note

If the vessel’s deplacement or trim changes during a survey, this value must be updated
accordingly.

Depth sensor: Position of depth sensor.
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Angular Offsets for EM 2040
Angular Offsets (of sensors) is located under the Sensor Setup tab on the Installation
parameters display view.

Note

For a dual RX system the RX parameters are to be entered for RX Transducer port and
RX Transducer starboard.

In order to make correct measurements, the system must know the physical installation
angles for the transducers and sensors relative the vessel coordinate system.

Offset angles are partly determined during installation and partly during calibration.

Angular offset parameters

Transducer orientation Use these settings to select the orientation of the TX and RX
arrays. If the TX array is mounted with cables pointing to starboard side, select Starb. If
the TX array is mounted with cables pointing to port side, select Port. If the RX array(s)
is mounted with the cables pointing towards the stern, select Aft. If the RX array(s) is
mounted with the cables pointing towards the bow, select Fwd.

TX Transducer/RX Transducer Use these settings to enter the installation angles. These
settings are normally entered once and for all, but if the vessel undergoes repair or
maintenance etc. and the array is moved, the installation measurements must be repeated
and new angles defined.

Motion sensors (Attitude): Use these settings to set a correction offset for the
corresponding values received from the motion sensors. The settings are added to the
values received from the sensors.

Stand-alone Heading: Use this setting to set a correction offset from the values received
from the heading sensor. It is only allowed to enter positive values. Example: If the
offset is -0.15, you must enter 359.85.
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ROV Specific for EM 2040
ROV Specific is located under the Sensor Setup tab on the Installation parameters display
view.

This dialog box applies to depth determination from either depth or pressure sensors.
If a pressure sensor is used, scaling and offset of the pressure sensor must be entered.
Scaling and Offset parameters are located in Runtime parameters→Sound Speed frame,
see Sound speed for EM 2040 on page 305.

Depth/Pressure sensor parameters

The parameters are available only if ROV depth is selected in the PU communication –
Input setup on page 275. Otherwise they are disabled. Also note that when deselecting
the ROV depth selection in the Input Setup frame these parameters will be reset to
default and disabled.
• Delay: This parameter is used to define the expected time delay (in ms) of the sensor

data.
• Disable Heave Sensor: This must always be unchecked unless the effect of heave is

taken into account by another sensor. An example is the depth of an ROVmeasured by
a pressure sensor whose output also includes any heave effect unless the depth is large.
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System parameters for EM 2040
System parameters is located on the Installation parameters display view.

Note

For a dual RX system the RX transducer BS offset are to be entered for RX Transducer
port and RX Transducer starboard.

Parameters
• BS (Backscatter) Offset (dB) - RX Transducer: The acoustic backscatter strength of the

bottom is calibrated in our factory, and have a typical accuracy of ±1 dB.
However, this value may be offset from zero to serve as a correction factor, for
example if there is a change with the age of the system, or if data from two different
systems are merged and there is a systematic offset between the two systems.
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BIST – Built-In Self Test
The BIST (Built-In Self Test) options provide a number of automatic tests that may be
started to check the operation of the echo sounder system.

Note

The tests may be automatically run at echo sounder startup provided that this option is
set to On from the Tools→Custom→Set parameters→Startup options for the system page.

BIST is located on the Installation parameters display view.

Various test are available, and the test presented will depend on what system you have.

Parameters
• Clear all: Press to clear results of previous BIST tests.
• Run all BISTs: Press to run all available BIST tests.

Note

When the button is pressed, all BIST tests will be run, without any further questions.

• BIST test buttons: Single BIST tests can be run by pressing the corresponding test
buttons.
The button turns green if the test results are OK, it turns yellow if the test is not
successfully carried out. The button will turn red if the test fails.
Note

When a button is pressed, the selected BIST test will be run, without any further
questions.

• Save: The results of the BIST tests may be saved to file. Press Save to set file name
and storage location.

• PU BIST Result area: The results are presented in this area with the following
information for each test:
– Date: Date when the test was run.
– Time: Time when the test was run.
– Ser. No: Serial number of the transceiver unit.
– BIST: The number of the BIST test that has been run.
– Result: The overall result of the test.
– Description: A description of the test returned from the PU (Processing Unit).
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EM 2040 BIST

294 342682/D



Parameter references

The following tests are available:

EM 2040 BIST

0 CPU Test

1 BSP Test

2 IO 2040 Test

3 RX unit test

4 TX unit test

5 IO 2040-BSP link

6 RX unit-BSP link

7 RX Channels

8 TX channels via RX

9 RX Noise Level

10 RX Noise Spectrum

15 Software Date/Version

16 System info

For description of the tests please refer to the Instruction Manual
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System report
The System Report function will produce a status summary of all serial numbers and
versions of the echo sounder. In addition a selection of tests (e.g. BISTs — Built In Self
Tests and other tests) may be executed internally in the echo sounder and the results
returned.

The result file name will be generated automatically by SIS and contains the echo
sounder id and the date and time as part of the name. The file extension is .txt. This file
name can not be changed by the operator.

The default location of the result is ...\sisdata\common\bist. The location of the
result file might be changed by the operator.

Parameters
• Path: Location of the result file. To change the directory, use the browse button […]

to find or make the relevant directory for storing the report.
• Name:Name of the result file will be shown. The file name can not be changed.
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Runtime parameters
This section contains a description of the dialog boxes and parameter settings provided
by the Runtime parameters frame in SIS

Note

The PU – Processing Unit may be a separate hardware unit or an integrated part of the
TRU – Transceiver Unit cabinet, depending on echo sounder system.

For SIS it makes no difference whether the communication is with a PU or a PU inside a
TRU. The term PU is used in this manual.

Topics
• Sounder main for EM 2040 on page 297
• Sound speed for EM 2040 on page 305
• Filter and gains for EM 2040 on page 310
• Data cleaning on page 317
• GPS and delayed heave on page 323
• Simulator for EM 2040 on page 329
• Survey Information on page 332

Related operational procedures
• How to open the runtime parameter interface on page 134
• How to modify the runtime parameters on page 134
• How to collect the sound velocity profile on page 141
• How to convert your sound velocity profile to SIS format on page 143
• How to modify and load a sound speed profile into SIS on page 151

Sounder main for EM 2040
Sounder Main is located on the Runtime parameters display view. The Sounder Main
parameters allow you to:
• Define the pingmode, the desired swath coverage and the beam spacing
• Define maximum port and starboard coverage
• Define the maximum and minimum depth for the echo sounder
• Force a desired depth
• Select stabilization (pitch, yaw) and transmit control
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Parameters – Sector coverage

Port < - > Starboard: This button allows the settings for the port and starboard sector
coverage parameters to be swapped. This is convenient when logging along a shoreline
and the vessel is turning around.

Max angle (deg), port/starboard: These parameters allow you to define the maximum
swath width by setting the maximum port and starboard angles. The values are entered
in degrees.

Max coverage (m), port/starboard: These parameters allow you to define the maximum
swath width to each side by selecting values in meters. The port and starboard angles (as
defined above) will then be adjusted accordingly by the system. To make use of these
settings, you must set Angular Coverage mode to Auto.

Angular Coverage mode: Choose between Manual and Auto.
• Manual: If Angular Coverage is set to manual, the values defined as Max port and

starboard angle above (in degrees) are used directly. The Max coverage port and
starboard settings (in meters) are not used in this case. Be aware that the outermost
beams may be lost if the angular coverage set is larger than the coverage capability at
the current depth.

• Auto: If Angular Coverage is set to Auto, the maximum coverage (in meters) and the
maximum angles will set the swathwidth limit. The most limiting of the two criteria
will be used. If the system is not able to fulfil the above, it will reduce the swath
width further and as a consequence nearly all the beams will be valid. You may
observe this in the Numerical display, as the numbers of beams accepted should almost
equal to the number of beams available.

Sector Mode: This parameter controls the use of transmit sectors. The sector mode
parameter may have one of the following values:
• Normal: All sectors are transmitted simultaneously.
• Sngl port: When single port mode is selected the starboard RX head is automatically

turned off.
• Sngl cent: When single centre mode is selected only the centre sector is used.

298 342682/D



Parameter references

• Sngl stb: When single starboard mode is selected the port RX head is automatically
turned off.

•
• Scanning: One sector is transmitted per ping. This can reduce multipath problems

in areas with soft sediments together with strong reflectors. The negative effect is a
reduced ping rate.

Single sector and Scanning modes may use shorter pulse length to increase resolution.
When using the Port < - > Starboard: swap button, both for single and dual head
configurations, the sector mode port and starboard selections are also swapped
automatically.
Note

You must manually turn on the affected head when returning to SNGL CENT, NORMAL
or SCANNING selections.

Beam spacing: Depending on the purpose of the survey, you may define the distribution
of the beams on the seafloor.
• Equidistant: This setting gives a uniform distribution of soundings on the seafloor,

and it is the normal mode for a bathymetric survey.
• Equiangle: The beams are distributed with an equal angular spacing based on the

angular coverage used. This gives many soundings close to the centre of the survey
line, and few on the edge of the swath.

• High density Equidistant: In this mode the number of soundings are increased. This is
achieved by directing some of the beams closer to the centre of the survey line and
performing several soundings per beam on the edge of the swath. This results in an
equidistant distribution of the soundings.

Parameters – Depth settings
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Force depth (m): If there is a lot of acoustic interference or if the water is very aerated,
the echo sounder may not find the correct depths. In order to help, you can then enter the
approximate depth. This depth may be taken from your navigational charts, or from a
navigation sounder elsewhere on the vessel. Forcing the depth will cause the system to
set its gain and range windows accordingly, and ignore its own findings about where
the bottom is.

There is a short-cut to forcing the depth. In the Water column display you may select the
forced depth simply by holding down the Ctrl button while clicking at the selected depth
using right mouse button. This assumes that Force depth has been enabled in theWater
column→Show/Hide menu. See Water column – Show/hide on page 243.
Min./Max. depth (m): These parameters define the operational depth range. This range
should normally be wide enough to cover all depths encountered during the survey, as
only depths within this range will be accepted by the system.

A narrow range will help the system in bottom tracking under difficult conditions. In
some cases it may be necessary to temporarily narrow the range to assist the system in
bottom tracking. However, you must then monitor the actual depth closely, and adjust
the depth window as often as required.

Note

It is very important that valid depths are entered here when the echo sounder starts
“pinging”. If the bottom depth exceeds the limits with more than 10%, the sounder will
not lock. It may therefore be useful to enter larger values in the beginning to accept a
more dynamic depth, even though this may slow down the initial bottom detection when
the system is started.

If the bottom depth exceeds the limits given here it will simply loose track. The true
depth should therefore be monitored and compared with the settings during the survey.
• Minimum depth (m): Set the minimum limit of the depth range.
• Maximum depth (m): Set the maximum limit of the depth range.
Dual swath mode: Using dual swath implies that two fans are transmitted, one in front
of the other. The intention is to obtain a better coverage of the seafloor, for example
when the highest pingrate is already used and without decreasing vessel speed. The
following settings are available:
• OFF: Dual swath is disabled (i.e. standard single swath).
• FIXED The alongship angle between the two transmit fans is equal to the alongship

opening angle of each fan.
• DYNAMIC The alongship angle between the two transmit fans is determined based

on vessel speed, ping rate and depth in order to provide uniform alongship sampling
of the seafloor.

Note

Some modes or pulse lengths may not allow for dual swath.
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Ping mode: This parameter defines the operational frequency of the multibeam echo
sounder. Depending on your application you can select frequencies:
• 200 kHz – for deeper waters
• 300 kHz– for normal operation
• 400 kHz – for very high resolution inspection
• 300 kHz: Three transmit sectors are used per swath. Different frequencies are used

to separate the sectors. With short pulse length each sector needs a large bandwidth.
This means that frequencies used may be e.g. 260, 290 and 320 kHz. With long
pulses a reduced band width is required. To extend the coverage, low frequencies are
selected, like 270, 275 and 280 kHz. For each mode and pulse length the system is
tailored for optimum use of the bandwidth.

• 200 kHz: At 200 kHz the transmit sectors are wider, so only two sectors are needed
per swath. Compared to 300 kHz mode the maximum range is increased caused by
lower attenuation in the water, whilst the beam widths are increased by a factor of 1.5.

• 400 kHz: Due to the high frequency the beam opening angles becomes narrower, and
the range coverage is decreased, compared to 300 kHz. Shorter transmit pulses are
used. This requires correspondingly higher bandwidth and gives increased resolution.

Pulse type: The pulse can be set to be of the following types:
• Auto: When selected the system will automatically use a pulse length according to

current depth
• Short CW: Shortest CW (Contiuous Wave) pulse length for set frequency
• Medium CW: Medium CW (Contiuous Wave) pulse length for set frequency
• Long CW: Longest CW (Contiuous Wave) pulse length for set frequency
• FM: Frequency modulated pulses for deeper waters

Table 2 Pulse lengths

200 kHz 300 kHz 400 kHz
CW FM CW FM CW FM

Normal mode 70/200/600 μs 3/12 ms 70/200/600 μs 2/6 ms 50/100/200 μs N/A

Single sector mode 35/70/150 μs 1.5 ms 35/70/150 μs 1.5 ms 25/50/100 μs N/A

FM disable: This control button can be used to turn off the use of FM pulses. It is
recommended to keep this button unchecked. The FM pulses are used to extend the
detection range capability without losing range resolution. For the 400 kHz mode the
FM disable control has no effect.
Note

FM mode requires a 3D velocity input to compensate for a range shift caused by the
Doppler effect.

Detector mode: Select detector mode to optimize the systems ability to recognize the
bottom, wreck, structures, etc., depending on water condition. Select from:
• Normal: The normal bottom detection mode
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• Waterway: Suitable for shallow channels and rivers
• Tracking: A general shallow water mode for tracking of targets and sudden depth

changes
• Minimum depth: Designed for detecting wrecks etc.
The Waterway, Tracking and Minimum depth modes are mainly intended for use in
shallow waters. In shallow waters special TVG may improve the performance. A
tracking routine is used instead of the ping-ping filter. This means that the bottom
tracking does not depend that much on the previous pings and will easier track sudden
depth changes. Range gate, based on previous pings, still limits the search.

Note

Surveying on vertical objects should be done with a wide coverage setting. For the
Waterway, Tracking and Minimum depth modes it is important that the normal incidence
is within the receiver fan. Use at least 90 degrees coverage along pier walls to ensure
that strong normal incidence from the pier is detected.

Normalmode is based on the standard detector, but with improved multipath rejection. A
ping-ping filter is used to guide the bottom tracking. If there is a problem with aeration,
Normal mode is recommended. The ping-ping filter will then help the detector to keep
track of the bottom.

Parameters – Transmit control

302 342682/D



Parameter references

The maximum electronic tilt is limited to ±10 degrees. The ships attitude and the applied
transmitter tilt is always used to calculate the x, y and z parameters for each bottom
detection. This assures that the x, y and z values are correctly calculated, even if more
tilting was needed to do a full pitch and yaw stabilization.

Pitch stabilization: At open sea, the swath area on the bottom will move back and forth
following the vessel pitch. This will lead to loss of sampling regularity, and thus also
limit the vessel speed at which 100% bottom coverage is possible. To account for this
effect the system’s transmit angle may be set to vary with the pitch in order to stabilize the
direction of the emitted vertical transmit fan. This option should thus normally be ON.

Along Direction: This function can be used to tilt the transmit sector forward and
backwards. This can be used to avoid a too strong echo at the normal incidence.

Yaw stabilization: The yaw stabilization creates even alongship sounding spacings when
the vessel’s course is variable. The parameter is implemented with variable tilt angles
on the individual transmitter beams. Yaw stabilization is only possible with Dual Head
installations. With Dual Head the two transmit sectors are steered individually. The echo
sounder operates most efficiently when the transmission angle is as close to 0 degrees as
possible relative to the vessel’s heading.

Figure 20 External forces acting on a vessel

Mode: Three stabilization modes are available.
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• Off: No heading stabilization takes place. The transmitter sector follows the current
heading of the vessel. Unless the vessel’s heading is 100% straight you may
experience blind zones on the survey coverage when you operate in deeper waters
(exceeding 300 to 500 meters).

• Manual: The transmit fan is placed perpendicular to a manually selected course. This
course is selected with the Yaw Compensation parameter described above. The setting
should only be used on long and straight survey lines, but it is also useful if you need
to compensate for a crab angle caused by current or wind.

• Rel. mean heading: This setting places the transmitter sector perpendicular to a filtered
course corresponding to the vessel’s current mean heading. The course input is then
taken from the gyro, and filtered with the Heading Filter parameter described below.

Rel. mean heading is the recommended yaw stabilization mode. With this setting the
average yaw steering will be close to zero, avoiding an offset caused by e.g. a crab angle.
(Also the operator does not have to remember to set the course line.)
Heading: Allows you to enter the vessel’s heading manually.
Heading filter: This parameter specifies the level of filtering of the heading
Applying this filter will even out minor course adjustments due to wind, sea or current.
The filter strength required depends upon the vessel properties, and how well the vessel
is steered.
The heading filter controls how fast the filtered heading used during logging will follow
the actual heading of the vessel.
Max. Ping Freq (Hz): The ping rate is normally limited by the acquisition time (two
way travel time) of the receive data plus a little overhead. Dual swath can be enabled
to increase the alongship sampling rate. With the Max. ping freq setting is possible to
limit the maximum ping rate. This can be used to lower the amount of logged data, for
example when running at slow speed, or if 100% alongship coverage is not required.
Typical data rate (Mbyte/hour) per swath for one RX transducer:

Depth
below

transducer
Bathymetry Seabed

image
Water
column Velocity Mode

10 m 850 350 5500 43 Very shallow

45 m 225 165 3200 43 Shallow

200 m 100 50 1700 43 Deep (FM)

Minimum Swath Distance
Min. Swath Dist. (m): You can set a minimum swath distance, i.e. a minimum distance
between consecutive “footprints”' on the sea floor or river bottom in the direction of
the moving vessel.
The aim of this function is to ensure that a survey will contain logged data with a
minimum and constant data density. To obtain the required data density the PU will
adjust the ping frequency depending on the measured depth and the vessel speed. Dual
swath capability, available for some echo sounders, will also be taken into consideration.
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The default value is 0, indicating not used. The legal range is 0.1 — 1000.0 meter. The
resolution is 0.1 meter.

When the Min. Swath Dist. (m) has been set the actual achieved swath distance is
registered and displayed in the Numerical Display frame in the Swath Dist. item. The
displayed format is Requiered dist./Achieved dist. in meters.

A warning will be issued by default if the required data density can not be obtained. A
second warning can be issued if the data density is too high, this warning is disabled
by default. Configuration of these warnings is made in the Tools →Custom... →Set
Parameters →Logging menu.

External trigger
External Trigger: When selected, an external trigger signal causes the echo sounder to
send a ping. The Pinging on/off function must be on.

3D Scanning

This function allows the transmitter to be steered back and forth in the alongship
direction.

Enable scanning: Enables and disables the 3D Scanning function.

Min. (deg): The Min. (deg.) parameters sets the minimum scan angel relative to the
TX array.

Max. (deg): Max. (deg.) parameters sets the maximum scan angel relative to the TX
array.

Step. (deg): The Step (deg.) parameter sets step size. A step size of 0.0 stops the scanning
even if the Enable scanning selection is set.

When scanning is active a manually set Along Direction (deg.) and the Yaw Stabilization
settings are neglected (see both parameters in the picture above).

Note

Note that the Special mode functionality will affect the 3D Scanning operation: selection
of Passive mode will disable 3D Scanning.

Sound speed for EM 2040
Sound Speed is located on the Runtime parameters display view.

The accuracy of the depth data obtained from the system depends on the use of a correct
sound speed profile. You must ascertain that the applied profile always corresponds to
the real conditions. On the average, errors in the sound speed profile is recommended to
be kept below 0.5 m/s.
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Parameters – Sound Speed Profile

Use Sound Speed Profile: The Sound Speed Profile parameter allows you to select the
sound speed profile file to be used in the echo sounder’s depth calculations.

If you want to change to a different profile, click the browse button on the right-hand
side (button with three dots). When the correct profile is selected, press Use Sound
Speed Profile.

A standard sound speed profile file has the extension .asvp , but other formats with other
extensions are also supported. When a file is selected, an .asvp file will always be
generated if necessary. The ROV file format has the extension .actd. This file format
also contains a density profile necessary for automatic calculation of a “Scaling” factor.

If you manually select a sound velocity profile, or a profile is received for instant use (i.e.
S0x datagrams), SIS will check if the number of entry points in the profile satisfies the
criteria defined in the Sound speed profile format.

Note

If the profile is too big according to given criteria, a warning will be issued and the
profile will not be used.

If SIS is running several sounders, the maximum number of allowed entry points is set
according to the most restrictive echo sounder in use.

If the intended profile is too long, it must be thinned manually before use.

The used sound speed profiles (.asvp files) and the associated absorption coefficient
profiles (.abs files) are stored with the raw data files on the same directory. The files are
stored when the Use Sound Speed Profile button is pressed and the files will be named
using the current date and time preceding the original .asvp and .abs file names. The
file name 20110920_113610_ProfileName.asvp tells that the file ProfileName.asvp was
selected for use 20th of Sept. 2011 at 11 hours 36 min. and 10 sec. The used profiles will
be available for post processing purposes.

Absorption coefficient files: When selecting a new sound speed profile, this will affect
the absorption coefficient settings in the system. Each sound speed profile is associated
with sets of absorption coefficient files, either based on salinity input or based on CTD
input. The files may already exists, or they may be created at the moment new input of
salinity of CTD information is given. Salinity is input in the Filter and Gains tab in
the Runtime parameters frame.
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New input of CTD based absorption coefficients will normally be given through the
S0X datagrams. Input of salinity or CTD will create new directories for the Absorption
coefficient files. The paths are shown in the Sound Speed tab as
• Abs. coeff. files, salinity
• Abs. coeff. files, CTD
Note

A user provided sound velocity profile (with a user defined name) does not normally
have a set of associated absorption coefficient files initially. The files will therefore be
generated automatically based on the current salinity value. The name of the files will
contain salinity as a part of the file name, and this will show up in the salinity text field.
In this case the Sound Speed Profile text field will show the original user selection.

If a datagram of format S00, S01, S02, S03, S04, S05, S06 or S07 is received this implies
that the data should be used immediately. The Absorption coefficient files field are
updated automatically. The Use Sound Speed Profile text field will be updated with the
name of the new sound velocity profile. In the case of a S00 datagram it will contain
salinity as part of the name.

Parameters – Sound Speed at Transducer

When the sound speed in the surface area is rapidly changing with time and position,
it is recommended to install a sound speed sensor close to the transducer face. This
particularly applies to installations with tilted sonar head(s).
The sound speed at the transducer depth is used by the beamformer when calculating
the beamformer coefficients. The same sound speed is also used as a starting point in
the ray bending corrections. If a sound speed error is present only for a thin layer at the
transducer depth, the ray bending, using Snell’s law, will correct for the error made by
the beamformer as long as the array is horizontal. But if the array has a roll angle, there
will be an angular error that increases with the beam steering angle and the roll angle.
If the sound speed value at the transducer derived from the sound speed profile deviates
too much from the probe or manual values this will be indicated in the Numerical display
(Tr. svp and Tr. sensor).
Source: Select the source for the Sound Speed at Transducer. Choose between Manual,
Profile and Sensor/Probe.
• Sensor: The system will use a filtered sound speed value derived from the sound speed

sensor at the transducer. The filter is configured as described below. This option will
only be available if the sound velocity probe is used
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Note

Please note that the sensor must be enabled from the External Sensor setup.

• Manual: The echo sounder system will use the sound speed you define.

Caution

The manual setting is intended for experienced operators only!

• Profile: The system will use the sound speed profile to derive the sound speed near the
transducer/sonar head. If no matching depth is found in the profile, an interpolated
value is used.

Sound Speed (m/s): Set the sound speed at transducer directly to a fixed value. This
function is only available if Manual is selected.

Sensor Offset (m/s): This parameter is used to set a correction offset if Source is set to
Sensor. The offset will be added to the used sound speed values.

Note

When a new profile is taken into use, always set the offset so that the sensor value is
the same as that in the profile at the transducer depth. This is most easily done using
the values from Numerical display.

Filter(s): The length of the filtering of the sound speed sensor data can be selected.
This also sets the update rate i.e. how often a new sound speed value derived from the
filter is set. The filter is a median filter. Values outside 1300 to 1800 m/s are removed
before the filter is run.

Parameters – Depth/Pressure Sensor

Scaling and Offset: The Scaling and Offset parameters are used for ROV operation and
can be changed at any time during pinging and logging operations.

In addition to setting the parameters manually, these parameters may also be set
automatically:
1 SIS can receive Offset data (i.e. barometer) from an external source, via a serial

line, to the HWS. This input is converted from an external user defined format to an
internal format used by SIS. The conversion is currently performed by a separate
process which may easily be changed if the input format is changed. The resulting
input information is displayed in the Offset field.
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2 The Scaling may be automatically calculated based on an .actd file and the current
ROV depth and position. The result is displayed in the Scaling field.

Manual override: The automatic updates may be enabled/disabled by a Manual override
button for each parameter. These buttons may be operated independently. The PU is
updated with the Scaling and Offset parameters (whether set manually or automatically)
only when they are changed and with a minimum of 3 sec. intervals.
When mode is automatic the corresponding field (Scaling and/or Offset) is updated with
new calculated (Scaling) or received (Offset) values. When in manual mode, the value
set by the operator is displayed.

Note

The calculation of Scaling is only performed as long as an .actd file is selected in the
Sound Speed Profile field in the Sound Speed Profile group. That is if a standard .asvp
file, or any other file format, is selected, the calculation stops (as the necessary density
information will be missing).

Note

The Scaling and Offset parameters are only enabled as long as ROV depth input has been
selected on an input port in the Installation Parameters frame.

Reminder: ROV input selection must be confirmed using the OK button. When the
ROV, depth selection in the Installation parameters is turned off, the Scaling and Offset
settings are reset.

Before the barometer input can be received it is necessary to prepare the system by
setting the input serial port:
1 Stop pinging.
2 Select Tools→External Sensors from the Main menu bar.
3 Enable Barometer from the displayed window.
4 Select the relevant input port
5 Press OK.
The barometer input will be received by SIS on the selected port. See Numerical display
– Barometer item.

Related topics
• Numerical display on page 68
• Filter and gains for EM 2040 on page 310
• External sensors on page 371
• PU communication – Input setup on page 275
• Sound speed profile formats on page 544
• Implementation of absorption coefficients on page 504
• Handling of SSP datagrams on page 539
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Filter and gains for EM 2040
Filter and Gains is located on the Runtime parameters display view.

Parameters – Filtering

There is always a small risk of false detections in a multibeam echo sounder. This is
due to external factors such as fish shoals, acoustical interference from other systems,
passing over vessel wakes, etc. According to bottom conditions, you can apply the
included filters to assist the system in discriminating against erroneous measurements.
It is recommended to use different filter settings than those recommended only if the
occurrence of false detections is higher than expected.
The recommended settings are:
• Spike Filter Strength: Medium
• Range gate: Normal
• Phase ramp: Normal
• Special TVG: Off
• Slope: On
• Aeration: Off
• Sector tracking: Off
• Interference: Off
• Special amp detect: Off
Spike Filter Strength: Choose between OFF, WEAK, MEDIUM and STRONG.
This is used to define to what degree a non-smooth bottom is to be accepted. The filter
remove beams with depths that deviate too much from a smoothed bottom profile as
derived from the detected beams. The stronger filtering, the less deviation is accepted.
If you select OFF, no filtering will take place.
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For detection of objects in the water column, like free spans on a pipe line, it may be
better to reduce the spike filter strength.

Range Gate: Choose between SMALL, NORMAL and LARGE.

When the system detects the bottom, it will perform the search within a predefined depth
window, where the depth limits are based on the information from the previous pings.
The range gate setting is used to determine the size of this window.

If the depth varies considerably alongtrack it may be useful to select a large range gate,
but this may also increase the chance for false echoes from side lobes, interference or
other noise sources.

Selecting a large range gate may reduce the ping rate slightly.

Phase ramp: Choose between SHORT, NORMAL and LONG.

This parameter is used to specify the amount of range overlap between the detections.

When set to SHORT, the number of samples used for phase detection will be equal
to the range distance between the beam and it's neighbours. As a result, there will be
no averaging of phase detections between beams. (Note that this is provided that a
minimum number of phase samples are available to do proper phase detection.)

When set to NORMAL, the number of samples used for phase detection will normally be
equal to twice the range distance between the beam and it's neighbours. As a result, there
will be a slight averaging of phase detections between beams.

When set to LONG, a fixed portion of the phase curve, corresponding to ± 40 degrees
phase angle, is used for the phase detection. This will result in an increasing averaging
of phase detections between beams with increasing beam angle.

SHORT phase ramp gives the best resolution, but a side effect can be that the detected
bottom will have increased noise. Recommended setting is NORMAL.

In the bottom detector a Time Varying Gain is applied. Enabling the Special TVG option
in the Filter and Gains menu will normally reduce problems with multipath at shallow
water.

Note

Remember to turn Special TVG off when going to deeper water, if not, coverage will be
reduced caused by to little gain.

Slope: With this filter enabled, the system checks for bottom slopes that tilt inwards.
These slant towards the vessel, and they are removed because the filter requires that
the athwartships distance increases for every beam from the centre. Such detections
are normally false, and after removal a new bottom detection is performed searching
for a value with increased range

The slope filter should normally be enabled.
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Aeration: If the transducer installation suffers from air bubbles close to the transducer,
the system may have problems with bottom tracking. Activating this filter will force
the system to keep tracking the same depth for a longer period. If you have aeration
problems in areas with relatively constant depths, this filter will increase the performance
of the system. However, if the bottom depth varies considerably, the filter may have
an adverse effect.

Sector tracking: The transmitter operates with several pulses within each ping. Each
pulse covers different sectors of the total swath. This setting will turn on an automatic
gain compensation to avoid amplitude offsets between these sectors. During normal
operations, the Sector Tracking should be on. However, if the survey specifications
demand a fully calibrated system for sidescan image, this function should be turned off.

This setting does not affect the depth measurements, only the backscatter strengths.

Interference: If the vessel is equipped with other echo sounders or sonars operating
on frequencies close to the echo sounder, you may experience interference. The best
solution is to synchronize the operation of the different systems. If synchronization is
not possible, this filter may reduce interference problems.

Special amp detect: This button enables an alternative detection mode for beams close
to the normal incidence. This detector mode can reduce noise spikes in the data on
some bottom types.
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Parameters – Absorption coefficient

The absorption coefficient depends upon depth, water temperature, salinity and
frequency. A correct value is important with respect to the validity of the bottom
backscatter data measured by the system.
The absorption coefficient as a function of the depth must therefore be calculated for
the frequencies used by the echo sounder.
Source: There are three alternatives:
• Salinity – absorption coefficient based on salinity input.

If the source is set to salinity, the average absorption coefficient is calculated using
the current sound profile (to find the temperature profile), the depth based on the
previous pings and the specified average salinity. The average absorption coefficient
will then be calculated by SIS for the relevant frequency and it will be updated and
displayed with changing depths. If the salinity in the water is constant, this is the
recommended setting.

• CTD Profile – absorption coefficient based on profile input.
The absorption coefficient can be calculated from a sound speed profile that includes
information necessary to calculate an absorption profile.
The sound speed input datagram (SSP) must be used. When using a CTD profile from
an SSP datagram, the absorption coefficient profile will automatically be calculated
by SIS for the required frequencies.
It is also possible to specify the absorption coefficient directly in the SSP datagram,
but then one datagram must be made for each frequency used by the echo sounders
(i.e. the full range of 12, 31.5, 60, 70, 80, 90, 95, 100, 200, 250, 300, 350 and 400
kHz), and the frequency must be specified in each datagram. These datagrams
must have the same acquisition date and time and must be sent with no more than
10 seconds interval.
Using this CTD Profile option, which will increase the accuracy of the bottom
reflectivity data; SIS will calculate the average absorption coefficient through the
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water column. The absorption coefficient values displayed will change continuously
depending upon the depth.

• Manual – manually selected absorption coefficient
It is possible to manually specify the absorption coefficient for the relevant frequency.
This must be the average absorption coefficient for the water column.

Salinity (parts per thousand): If the source is set to Salinity, the average salinity can
be entered in this field.
200.0 / 250.0 / 300.0 / 350.0 / 400.0 kHz: If the source is set to Manual, the manual or
calculated absorption coefficient for each frequency from 200.0 to 400.0 kHz (in steps
of 50 kHz) can be entered in these fields.
If the source is set to Salinity or CTD, the frequency field is disabled (greyed), but it will
show the current value of the absorption coefficient (dB/km) used for the frequency.

Parameters – Normal incident sector

Angle from nadir [deg.]: This value is used to define the angle at which the bottom
backscatter can be assumed not to be affected by the strong increase at normal incidence.
The optimum crossover angle will vary with the bottom type.
For seabed imaging, it is important to adjust this angle so that a minimum of angle
dependent amplitude variation is seen. This is to give best use of its dynamic range. The
bottom backscatter strengths in the ping display are not affected by this setting.

Parameters – TX Power

TX power level (dB): TX power can be lowered 10 or 20 dB to avoid saturation in
shallow water.
The echo sounder will automatically reduce power level at shallow depths. You may
reduce the maximum power level by this setting. Recommended setting is Max. Using
-10 or -20 dB the max coverage will be limited.

Parameters – Water Column

Water Column Time Varied Gain (TVG) function.
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In active mode the applied TVG function is X log R + 2 alpha R + C. The X and C
parameters can be set by the operator. The log function can be set from 10logR up
to 40logR. The default value is 30. In the water column datagram the amplitude is
represented by 8 bits (to save storage space) with 0.5 dB resolution. The dynamic range
is -64 to +63.5 dB, well suited for normal bottom echoes. But echoes in the water
column can be weaker than -64 dB. To be able to record these echoes, an offset, C, can
be added. This offset is as default set to 20 dB. This means that the dynamic range
is changed to -84 to +43.5 dB.
The parameters are stored in the water column datagram. SIS corrects for the offset
(C), so the echo level in the display will remain unchanged when C is changed. To
utilize the increased dynamics, the water column color pallet (default -50 to 0 dB) must
be adjusted, for example to -70 to 0 dB.
log R: X, range is 10 – 40, default is 30.
dB Offset: Offset, range is 0 – 40, default is 20 dB.

Parameters – Special Mode

Sonar mode is a special mode intended for inspection purposes. The main output is the
water column. The multibeam sounder will act like a sonar with manually selectable
acquisition range and sector coverage. The bottom detector will still be active, but is
not used to automatically select sector width and range.
Sonar mode is controlled by using existing parameters in the Runtime →Sounder Main
menu:
• The sonar range is selected using the Depth setting →Max. Depth (m) parameter
• The sector width(s) is selected by using the Sector Coverage →Max Angle port and

starboard parameters
The WC display will, like a sonar, show the same range for all beams. The TX
pulselength and modes can be selected as in standard mode. If auto pulse mode is
selected, the pulselength is adjusted dependent on the operator set sonar range (Max
Depth parameter).
In sonar mode it is possible to select passive mode (this turns off the transmit pulse). The
water column TVG is then turned off. The echo level shown is the spectral isotropic
noise level. This means that receive transducer sensitivity, receive beam directivity
and receive bandwidth is compensated for (NL= EL – M + DI -10logBW). To be able
to keep the same colour scale in the water column display as in active mode (used for
BS), an offset of 100 dB is subtracted (45 dB noise level will then be displayed as -55
dB). Frequencies and RX bandwidth are used as in active mode. The RX beam patterns
are corrected for. The “display gain” can be selected in the SIS water column window
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as usual (Default = -50 to 0 dB). In passive mode the bottom detector is disabled. This
mode can for example be used to search for noise and interference sources (direction and
frequency). The ships flow noise and propeller noise can be checked.

The Special Mode selection status will be displayed in the main SIS display bar.

Sonar: This control button is used to turn Sonar mode on and off.

Passive: This control button is used to turn the Passive option on and off. The Passive
option is disabled when Sonar mode is off.

Note

Selecting Passive mode will disable 3D Scanning.
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Data cleaning
The Data Cleaning tab is located under the Runtime parameters display view.

The RTDC (Real Time Data Cleaning), uses rules to process the echo sounder data. A
rule is a set of parameters that controls the algorithms used in the processing.

Seabed image processing in the Grid Engine may also be set up from the Data Cleaning
frame

Note

The Real Time Data Cleaning module does not delete any depths, but flags depths that
are invalid according to the rules. You have full control of this processing at all times.

The data cleaning interface is organized in a basic setup display and an advanced setup
display.

Selecting predefined data cleaning levels

The basic setup allow you to choose the data cleaning level by a simple selection from a
range of predefined levels.

Slide selector: Used to select the level of data cleaning simply by using a slider within a
range going from None to High. The range consists of five levels where each level is
identified by a rule set predefined by Kongsberg Maritime. The rule sets are named
AUTOMATIC1, AUTOMATIC2 up to AUTOMATIC5. When a level has been selected the
corresponding rule set is sent to the Grid Engine where the RTDC operation is performed.

Rule set: A pull down list containing all the predefined rule sets and, in addition, any
custom made rule sets defined by the operator using the advanced setup display. See
below. When a rule set has been selected it is made active and it is transferred to the
RTDC module.

Advanced…: When this button is pressed the basic setup is replaced with an advanced
setup allowing you to define new rule sets and modify or delete existing rule sets.
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Advanced data cleaning

The RTDC (Real Time Data Cleaning) module processes the data in real time using
two different kinds of processing, ping based and grid based processing. Ping based
processing uses a buffer of the last pings to process current ping, also known as
line-based processing. Grid based processing uses all points from all lines, current and
all previous, to process the data in one grid cell. Various parameters are set to control
these processing types.

Note

The real time data cleaning uses additional parameters which are not available to the
user.

The advanced setup is organized with four different groups of rule parameters (ping
processing, DTM processing, grid processing and seabed image processing) and one
group for rule set administration/handling.
Rule set: A pull down list containing all rule sets, both predefined by Kongsberg
Maritime (i.e. the rule sets within the ’None’ to ’High’ range) and custom made rule sets
as defined by the operator. The parameter values for the selected rule set are shown in
the parameter fields. I.e. by selecting a rule set, it's parameter values may be inspected
or changed. Note however that the rule set is not automatically made active. Use the
Apply or OK buttons to activate the parameter settings.
Delete: Delete the current rule set.

Note

Predefined rule sets (i.e. the rule sets within the “None“ to “High“ range defined by
Kongsberg Maritime) or the current active rule set, can not be deleted. A warning is
issued on an attempt to delete such a rule set.
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Save as: When pressed a new rule set is created based on current rule set and parameter
values. A rule set name must be given in in the text field. The new rule set is made active
by pressing Apply or OK and transferred to the RTDC module.

Note

The names of the predefined rule sets are not legal names for saving. A warning is
issued on an attempt to use such a name.

OK:When pressed current settings will be saved to current rule set and the Advanced
setup will be closed.
Apply: When pressed current settings will be saved to current rule set.

Note

Predefined rule sets can not be changed. Save As must be use to make changes.

Cancel: When pressed the advanced setup is closed without any changes. If Apply was
pressed any changes since will not take effect.

Ping processing rules
Ping-based processing, flags wrong depths as early as possible in the processing chain.
Ping processing is performed right after the depths arrive into the RTDC module. The
Time rule and the Overhang rule use the current ping only.

• Overhang rule: This rule flags beams that create an overhang situation, illustrated in
the figure below.

Figure 21 Overhang rule

It is not unambiguously determined which beams to flag to remove the overhang.
E.g. in the figure, it is possible to flag either the dotted beam or the beam to the left
of the dotted beam. The strategy in SIS is to consider the alternatives that imply
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flagging the fewest beams, and to keep the points that most likely define the seabed by
minimizing the distances between the depths in the ping. If necessary, more than one
beam is flagged to remove the overhang.

DTM processing rules
When the gridding starts, the operator has already defined the minimum grid cell size for
the processing grid. However, the RTDC module checks if it needs to redefine this grid.
It can do so by collapsing several grid cells into larger grid cells called Cell Processing
Units. How many cells to process together is dependent on the median depth of the cells
and the parameter Split factor.

The DTM and grid processing rules are applied to all depths in each grid cell. A grid
cell defines an area, and all depths in this area are processed together regardless of the
survey line they belong to. Every time a new depth is added to the grid cell, all depths
(old and new) in the grid cell are reprocessed. Previous flagged out depths may be set to
valid and vice versa during this process.
• Min. no. points: The parameter Min. no. points defines number of points in a grid

cell. If a cell has fewer than this number of depths, all depths will be flagged out if
the check button Remove cells is enabled.

• Split factor: Defines how many cells to process together. The value depends on the
median depth of the cells.

• Remove cells: The parameter Min. no. points defines minimum points in a grid cell. If
a cell has fewer points than the minimum number defined, all depths will be flagged
out if this check button is enabled.

• Surface fitting: Sets parameters for a best fit plane. These parameters are discussed in
detail in Real time data cleaning on page 492.
– Polynomial order: This parameter controls the shape of the surface. This parameter

is normally set to 1. Setting the polynomial order to 2 may give a better surface,
but requires significantly more processing power. 3 may be used in very difficult
terrain.

– Tukey constant: This parameter controls the weight each point is given. Increasing
this value means that more points will be considered into the solution, but the
process will be slower.
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– Max. iterations: This parameter controls how many times the Tukey algorithm will
try to find a solution. 1 means that there will be only one pass. After 3 passes the
surface is normally well defined. The search for a solution will stop when the
algorithm has tried Max. iterations times.

– Conv. criterion: This parameter will stop the Tukey algorithm when the change in
the results from the current and the previous run is very small. Only points with
weight are considered, so the Tukey constant will have an influence on this.

Grid processing rules

When the surface fitting for each Cell Processing Unit has been performed, points can be
flagged out based on the following rules:
• Residue depth rule: Each depth in the Cell Processing Unit is multiplied with a Factor.

The result is a limit, and if the residue is larger than this limit, the point is flagged out.
This rule will adapt to changing depths, the factor is recommended set approximately
to the accuracy of the echo sounder.

• Residue vertical error rule: Each depth has a vertical error estimate. This error
estimate is multiplied with Factor and the result is a limit. If the residue is larger than
this limit, the point is flagged out. This rule is also adaptive because the vertical error
will change with the range and beam pointing angle.

• Residue vertical avg. error rule: In each cell the average vertical error is calculated,
and the average vertical error for the Cell Processing Unit is then calculated. Further,
a limit is calculated from the average vertical error in the Cell Processing Unit
multiplied with Factor. If the residue is larger than this limit, the point is flagged out.
Note that it is the average vertical error for the Cell Processing Unit that is used,
not the cell’s value.

• Residue std. rule: The standard deviation of the residue is also calculated. This is
the standard deviation in the Cell Processing Unit, not the cell. A limit is set by
multiplying Factor to this standard deviation. Residue larger than the limit are flagged
out.
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• Grazing angle rule: For each depth the angle between the beam and the bottom surface
is calculated. Then the parameter Min. angle can be set to flag out all depths where
the angle is less than this limit.

Seabed Image processing

When Seabed Image Processing in GridEngine is selected the seabed image data is also
sent to the GridEngine and a seabed image mosaic is created.

• Grid size factor is used to set the size of the sonar grid cells relative to the processing
grid cells. E.g. if Grid size factor is set to 4, there will be 4 sonar grids for each
processing grid.

• Merger type determines what action to be taken when more than one line fills a cell:
– Average will calculate the average sidescan values for all passings over a cell
– Last Wins will use last value only

• Interpolator type: Sometimes data is missing in an area. This can be filled with data
from the surroundings using an interpolator. The interpolator type used is Top Hat.

• Interpolator radius determines the distance from an empty point in terms of number of
cells that will be used in the interpolation. The less distance, the less interpolation
will be done.

• Fill in only determines the interpolation to be carried out. If enabled, empty points
only will be filled. If not enabled, the entire dataset will be smoothed.

Related operational procedures
• How to display seabed imagery data in the Geographical view on page 162

More information
• Real time data cleaning on page 492
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GPS and delayed heave
The GPS and delayed heave parameters are located on the Runtime parameters display
frame and contain options for logging of data files related to position and attitude data.
These data can be used in post processing to improve the final seabed data.
The GPS and delayed heave options are the following:
• Javad and Trimble setup for setting up logging of raw observation data from either

a Javad or a Trimble type GPS receiver. The Javad or Trimble raw data are logged
in the RTCM 3.0 raw data format that can be used in post processing to improve
the position data.
Note

SIS does not support Precise Point Positioning based on Javad or Trimble raw data.

• RTCM log parameters for setting up logging of GPS raw data in the RTCM 3.0 raw
data format from a Seapath 300 system. The logged GPS raw data is automatically
formatted into RINEX format. SIS then offers a set of utility programs that further can
be used to post processed the GPS data to obtain sub-decimetre position data. In this
process, the post processing software TerraPOS is used for applying precise clock
and orbit corrections to the position data.
This method of improving the position accuracy is generally referred to as Precise
Point Positioning (PPP).
For description of Precise Point Positioning in SIS and description of how to use this
utility, please refer to Precise Point Positioning (PPP) in SIS on page 476.

• ATH log parameters used to configure raw data logging from the Applanix POSMV
True Heave system.

• SRH log parameters used to configure Seapath Real Heave (SRH) logging
• PPP log parameters for setting up logging of GPS raw data in thePPP raw data format

from an Applanix system.
The logged GPS raw data is stored as PPP files and must be converted to RINEX
format.
Note

The Rinex conversion is currently not available in SIS. This means that PPP
processing is currently not fully implemented using PosMv-data even though the raw
satellite data is logged.

If you attempt to change any of the parameters, the background colour of that field will
change to yellow. The parameters are applied and used by pressing the Apply button,
whereby the parameters are transferred to the logging process. The yellow background
colour is removed.
When applying any parameter changes the any open log file is completed. The file
interval timer is reset. If you want to continue the logging a new file is started according
to the set parameters.
The Cancel button is used to revert any changes before using the Apply button
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Parameters – Javad and Trimble setup

• Start Javad/Trimble logging: Enable/disable logging of stored Javad or Trimble GPS
raw data.

• To specify the directory, use the browse button […] to find or make the relevant
directory.

Note

Note that the Javad/Trimble directory initially has a default setting. It is initially
shown in the text field and it is also entered when the browse button is pressed.

• Height on: This tick button is used to turn fixed height on or off. Fixed height is on
when ticked.

More information
• Javad and Trimble details on page 520

Parameters – RTCM log

• Start Seapath RTCM logging: Enable/disable logging of GPS raw data in the RTCM
3.0 raw data format from a Seapath 300 dual frequency GPS system.

• To specify the directory, use the browse button […] to find or make the relevant
directory for storing the GPS raw observations.

• Interval for new line (min): Specifies interval in minutes between consecutive stored
files, i.e. file size/length.

• Source port for Seatex RTCM data: UDP port number for the source data to be logged
(according to Seapath configuration)

• Apply and Cancel buttons: Apply is used to confirm and activate the set parameters.
Cancel is used to reset any changes before Apply is pressed.
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When SIS is running the Numerical display frame, current RTCM logging status is
displayed by selecting RTCM Log. The status is updated when a new file is created or
as a result of changed RTCM logger parameter settings. When turning logging on for
the first time the ON indication will not be displayed until the first RTCM signal is
received from the Seapath.

A warning (pop-up) is issued if no logging input is received by the RTCM logger
within 20 seconds.

More information
• Precise Point Positioning (PPP) in SIS on page 476
• TerraPOS data format on page 556

Parameters – ATH log

Note

ATH logging requires very accurate timing in the PU and it is recommended used only if
ZDA clock and 1PPS is interface.

The SIS ATH process is designed to log the POSMV output on port 5602. A network
connection between the POSMV and SIS must therefore be established. Please use the
second network card in the HWS for this purpose, not the one connecting the HWS
and the PU.

• Start Applanix POSMV True Heave logging: Enable/disable logging of ATH raw data
from a POSMV attitude system.

• To specify the directory, use the browse button […] to find or make the relevant
directory for storing the ATH observations.

• Interval for new line (min): Specifies interval in minutes between consecutive stored
files, i.e. file size/length.

• Source port for ATH data: Port number for the source data to be logged (according to
POSMV configuration)

• Apply and Cancel buttons: Apply is used to confirm and activate the set parameters.
Cancel is used to reset any changes before Apply is pressed.
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ATH file format
The naming format of the logged files stored by the ATH logging process is as follows:

ATH_YYYY_MM_DD_SSSSSS_.ath

Where
• YYYY_ = Year (four digits)
• MM_ = Month (two digits)
• DD_ = Day (two digits)
• SSSSSS_ = Seconds since start of week (six digits)
e.g.:
ATH_20060915_123456.ath

More information
• ATH data format on page 551

Parameters – SRH log

Seapath Real Heave (SRH) data is delayed by a few minutes due to internal processing. It
can be logged by SIS and subsequently used in post processing. The SRH logging facility
consists of two components: the SRH logger process and the SIS SRH logger interface.
SRH logging must be started and controlled from the SIS SRH logger interface.
When SIS is started an SRH logger process is also started. Whether the actual logging
operation is started or not depends on the last logger setting used.
When SIS is stopped the SRH logger process is also stopped.
• Start SRH logging: Enable/disable logging of realtime heave data from a Seapath

system.
• To specify the directory, use the browse button […] to find or make the relevant

directory for storing the realtime heave observations.
• Interval for new line (min): Specifies interval in minutes between consecutive stored

files, i.e. file size/length.
• Source port for SRH data: Port number for the source data to be logged (according to

Seapath configuration)

326 342682/D



Parameter references

• Apply and Cancel buttons: Apply is used to confirm and activate the set parameters.
Cancel is used to reset any changes before Apply is pressed.

When SIS is running the Numerical display frame, current SRH logging status is displayed
by selecting SRH Log. The status is updated when a new file is created or as a result of
changed SRH logger parameter settings. When turning logging on for the first time
the ON indication will not be displayed until the first SRH signal is received from the
Seapath.
A warning (pop-up) is issued if no logging input is received by the SRH logger within 20
seconds.
Note that there is no initial 200 sec. wait for the SRH data to arrive, it is assumed that the
Seapath system is up and running before logging starts (if not the 20 sec. warning will
be issued, one or several times).

SRH file format
The name of the logged SRH file has the following format:
SRH_YYYYMMDD_EPOCSEC.srh

where the date and time is the current UTC time at the time of file creation and
EPOCSEC is the number of seconds since the epoch, 1970–01–01, fetched from the first
signal logged in the file.
The format of the information stored in the file is the length of the received signal
(unsigned short, i.e. 2 bytes) and then the signal itself.

More information
• SRH data format on page 555

Parameters – PPP log

Precise Point Positioning (PPP)

• Start Applanix PosMV PPP (raw GPS) logging: Enable/disable logging of PPP files.
• To specify the directory, use the browse button […] to find or make the relevant

directory for storing the realtime heave observations.
• Interval for new line (min): Specifies interval in minutes between consecutive stored

files, i.e. file size/length.
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• Source port for ATH data: Port number for the source data to be logged (according to
PosMV configuration)

• Apply and Cancel buttons: Apply is used to confirm and activate the set parameters.
Cancel is used to reset any changes before Apply is pressed.

When SIS is running the Numerical display frame can display the current PPP logging
status by selecting PPP Log. item. The status is updated when a new file is created or
as a result of changed PPP logger parameter settings. When turning logging on for the
first time the ON indication will not be displayed until the first PPP signal is received
from the POSMV.

A warning (pop-up) is issued if no logging input is received by the PPP logger within a
defined interval, currently set to 20 sec.

A warning is issued if the signal input rate falls to an unacceptable level.

More information
• Precise Point Positioning (PPP) in SIS on page 476
• TerraPOS data format on page 556
• Sensor options on page 348
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Simulator for EM 2040
Simulator is located under the Runtime parameters frame.

Parameters – Simulation setup

Enable Simulation: Select this parameter to enable simulation mode in the echo sounder.

Simulator min. depth (m): Set the minimum depth for simulation.

Simulator max. depth (m): Set the maximum depth for simulation.

Note

The simulation generates range samples only. All other inputs to the PU (Processing
Rack in the Transceiver Unit) must be supplied via the normal PU input ports. Most
important is the position data and roll, pitch and heave (i.e. attitude data).

Step along (%): The change in depth between each ping given in percent. The depth
will vary within the set min/max range.

Slant across (deg.): The tilt of the sea bottom across track in degrees.

342682/D 329



Seafloor Information System

Figure 22 Step along

Figure 23 Slant across

When simulation is enabled (i.e. active), the transmit (TX) circuits in the processing unit
will be disconnected and it is not possible to operate the echo sounder.

A red bar indication above theMain toolbar in the SIS application window will notify the
operator when the system is running in simulator mode.
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Parameters – Beam no. for Scope Display

Beam no.: Set beam number to be displayed in the Scope Display. Set beam number to
zero (0) if you want to turn off this feature.

Swath no.: Set which swath number to be displayed. Set swath number to zero (0) if you
want to display a scope beam from the foremost swath.

RX transd.: Select Port or Starboard transducer for the scope beam.
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Survey Information
Survey Information is located under the Runtime parameters frame. The Survey
Information tab displays survey parameters for the active survey. The information is
automatically selected.

Note

The Survey Information for GPS do not show the Grid cell size and Number of cells:

For more information about Survey parameters see:

Parameter references
• Survey parameters on page 263

332 342682/D



Parameter references

SIS parameters – Set parameters
This section contains a description of the dialog boxes and parameter settings that are
used to control the behaviour of SIS.

These parameters are all found from the main menu by selecting Tools→Custom...→Set
Parameters.

Select a topic on the branch in the tree to the left, and the window to the right will expand.
Select this topic To
Ship Define the appearance of the ship in the Geographical view
Positions Error limits and filter settings for positions
Turn parameters For planning turns in the Planning module

Passwords Passwords for different users
Display Parameters controlling the Geographical view
Logging Define logging parameters. Select grid engine (GridEngine/CUBE)
Autopilot Set autopilot parameters

Sound speed Set sound speed masks
Network licence Identify your license server
Error model parameters Parameters for Total Propagation Error

APOS Relay position computed by APOS software to SIS

Sensor options Alarm threshold setting for loss of attitude data

Startup options for system Set configuration of start-up behaviour in SIS and the PUs
Projections Set location for Gauss-Krüger projection file
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Ship parameters

It is recommended to set the appearance of the ship to visualize the actual size of your
ship. When the display is zoomed out beyond a set limit, the ship will appear as a
position marker, i.e. a triangle, with a spear. The following ship parameters can be set:
• Fill
• Line width in pixels
• Position marker spear length – the length of the spear, in cm on the screen, when the

ship is displayed as a position marker
• Position marker body length – the size of the position marker (triangle base and

length) when the ship is displayed as a position marker
• Minimum length of ship hull – the scaled size of the ship, in cm on the screen, where

the position marker will take over at further zooming
• Distance from reference point to the keel, to the deck, to starboard, to port, to stern

and to bow – the actual size that defines your ship. Input the values in cm. E.g. if
the distance from the reference point to the stern is 40 meters, 4000 centimetres
must be entered.

• Length of the bow spear – the bow spear is a imaginary line in front of the ship to
assist in steering it straight.

Note

The geographical view needs to be closed and reopened to effectuate any changes.
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Note

The ship size will be scaled according to actual scale in the geographical view. The
position marker size will remain unchanged.

Note

When a projection with scale factor is applied, e.g. UTM projection, the ship size will be
scaled accordingly.

Note

Enter the values of the parameters according to the type shown for each field, i.e. integer
number, float number or text.

Positions

The following masks related to position input can be set:
• Max age for ROV depth datagram (sec.). Time before a missing ROV depth input

datagram to the echo sounder (PU) is flagged in the numerical display. Must never be
set to 0.

• Dead reckoning on or off. (off=0, on=1). If position input stops the dead reckoning
feature will calculate predicted positions for a preset time interval before stopping.
The predicted positions are based on the two last positions received and the (still)
incoming heading, if available. If not, the last heading will be used
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• Position jump filter on or off. (off=0, on=1). This filter is used to remove single
spikes in the position input. If a position spike occur this position is disregarded and a
predicted position used instead. This predicted position is based on the two previous
(legal) positions and the heading.

• Time difference too big (sec): If the time difference between the timestamp and the
time in the clock datagram is bigger than this value, an error is generated.

• Change in time difference too big (millisec): There is always a time difference
between the timestamp and the time in the clock datagram. However, this time
difference is expected to be almost constant. If there is a sudden change in the
difference, an error is generated.

• Position quality too low (error) (cm): Lowest acceptable limit for the computed
position quality (see position datagram output in the corresponding echo sounder
manual).

• Position quality too low (warning) (cm): Warning limit for the position quality.
• Too few satellites: Lowest number of satellites before an error is generated.
• Few satellites: Lowest number of satellites before a warning is generated.
• Error position jump (m/s): Highest possible speed of the ship. This is used to generate

error messages for position jumps.
• Suspicious position jump (m/s): Warning message is generated when position jump

exceeds this limit.
Note

SIS needs to be restarted to effectuate any changes.
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Turn parameters

These parameters are used to control how generate turns from one planned line to the
next in the SIS planning module
• Lead in: Extend each planned line to allow the ship to stabilize before entering the

survey line.
• Turn radius: The minimum turn radius in meters that the ship can do.
Note

SIS needs to be restarted to effectuate any changes.
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Password

The installation parameters may be password protected. These parameters control the
use of passwords in SIS.
• Password for BIST
• Password for installation menu, valid as long as the frame is shown
• Password for installation menu, valid once
• If 1: Installation menu is password protected: Set this parameter to 1 to enable the

use of passwords, 0 to disable
Note

SIS needs to be restarted to effectuate any changes.
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Display

The Display parameters can be set as follows
• Default Font Size in the Helmsman Display. Control the font size in the Helmsman

Display, both the display in SIS and the display in the Remote Helmsman application.
• Max number of pings in realtime depths tail. The length of the realtime depth tail

behind the ship in the geographical view.
• Auto screen dump file (full path). File default extension is .gif. The file is updated

with the interval defined above. The file is readable by e.g. a WEB application for
periodic display

• Auto screen dump interval (in seconds) defines how often a screen dump of the SIS
GUI is performed

• Turn off gridding – it is possible to turn gridding off when logging data.
• Helmsman Survey folder. Empty if same as SIS.

If the Remote Helmsman run on a separate computer, the survey folder on the SIS
computer where the shipstrack and coverage files are stored, has to be shared and
mapped on the remote PC. If the folder is mapped to a different drive letter on the
Helm PC, the folder has to be set. The format of the folder name has to be ”Drive
Letter”:\sisdata\grids or the complete folder name in front of the survey name. If
the folder is g:\sisdata\grids on the SIS PC and accessible as h:\sisdata\grids on the
Helm PC, you must enter h:\sisdata\grids.
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• Missing input from ROV depth sensor during logging (0=no flash, 1=flash). SIS
flashes red if set to 1 and ROV depth data is lost.

• Missing input from active motion sensor during logging (0=no flash, 1=flash). SIS
flashes red if set to 1 and attitude data is lost.

• Missing input from active position sensor during logging (0=no flash, 1=flash). SIS
flashes red if set to 1 and position input data is lost.

• Margin (%) for issuing warning when depth approaches min/max values. A warning
will be given when you are within given margin of the min/max depth thresholds.
The margin is entered as a percentage of the depth limit.

• Alarm threshold for min. depth below keel within swath (0=disabled). An alarm will
a depth within the swath are below given threshold.

• Alarm threshold for minimum depth below keel (0=disabled). An alarm will appear if
you are in too shallow waters.

• Alarm threshold for max depth below keel (0=disabled). An alarm will appear if you
are in too deep waters.

• Crosstrack depth re. 1=waterline, 2=transducer. Depth text optionally shown in the
Crosstrack view will be referred to either of the parameters selected here.

• Font in NumDisp: 0=normal, 1=14pt, 2=18pt, 3=24pt; 11,12,13: Bold type. The font
size used in Numerical Display can be changed. The following options are available:
– 0 = Normal font
– 1 = 14 points font size
– 2 = 18 points font size
– 3 = 24 points font size
– 11 = 14 points font size, bold
– 12 = 18 points font size, bold
– 13 = 24 points font size, bold

• Safety Contour Range Minimum (cm). This parameter sets the minimum depth value
of the Safety Contour range. This is the minimum value in the range and is generally
a negative number which indicates that the value is above the waterline.

• Safety Contour Range Maximum (cm). This parameter sets the maximum range value
of the Safety Contour. The maximum depth value of the Safety Contour range is
computed by subtracting the current Tide value from this parameter.

• Enable or disable depth safety contours (0=disabla, 1=enable). This parameter
enables the Safety Contour feature in Geographical view. The Safety Contour feature
is enabled as default.
This feature provides a means to define a range of depth below which it is deemed
too shallow for the survey vessel when accounting for the current tide. This range of
depths can be shown in any single colour.

Note

SIS needs to be restarted to effectuate any changes.
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Logging

The following logging parameters can be set:
• Interval for line counter in sec.: Control when new survey lines are automatically

generated.
• Put all depths in grid if set to 1, save selected depths if set to 0: The operator can

choose to put all depths into the real time terrain model or not. If not, there is a
maximum value of 25 soundings per grid cell, which normally is more than enough,
but if set, this limit is overridden.

• Selection of hotkeys for pinging/logging/new-line.
• Enable/Disable support for raw data logger in PU.

Raw data logging can be performed by the PU itself to a local hard disk in parallel
with the logging operation in SIS.

• Eiva compatible start/stop datagram = 1. SIS default = 0.
Eiva is a third party Remote Helmsman that requires a different start/stop identification
than SIS Remote Helmsman uses.

• Water column disk. (Default: raw data disk)
It is possible to log the separate water column files to a separate disk instead of using
the same location as for the raw data (‘.all’) files. This will prevent fragmentation of
both the raw data files as well as the water column files.

• SVP change should generate new logged line. Yes=1, No=0
Automatic creation of new logged line when a new SVP is activated. A new sound
velocity profile is activated either when the user manually select it from Runtime
Parameter→Sound Speed or when an SSP datagram for immediate use (S00 - S07)
is received by SIS.

• Enable EA raw data logging (No=0, Yes=1): Must be enabled to do logging of raw
data from the interfaced singlebeam system.
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• Gives current data cleaning method, 1=GridEngine, 2=CUBE: This parameter
controls if SIS shall use GridEngine or CUBE to generate terrain models.

• Send range and bearing for objects to address (IP:port): When the operator uses the
Distance-tool (i.e. The Compass button) in the map-window to measure range and
bearing to objects, this information is sent to an external port. This address can be
set here.

• Initial water coloumn logging off or on (0=off, 1=on): If initial logging is turned on
(1=on), SIS will always start with water column logging enabled. However, the
operator is still allowed to disable water column logging at any time, if required.

• Highest approved swath density in percent of requested density: This parameter
controls if and when a warning should be issued if the data density is to high. The
default value is 0, which means no warning. The legal range is 110–2550% in 10%
increments.

• Lowest approved swath density in percent of requested density: This parameter
controls if and when a warning should be issued if the required data density can
not be obtained. A value of 0 indicates that no warning for this feature are issued.
The default warning limit is a swath density of 90% of the requested density. The
legal range is 10–90% in 10% increments.

Note

SIS needs to be restarted to effectuate any changes.

Related operational procedures
• How to interface a singlebeam echo sounder in SIS on page 156
• How to log water column data on page 170
• How to enter survey parameters on page 114

Related topics
• Hotkeys on page 46
• Geographical – Compass button on page 223
• CUBE on page 464
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Autopilot

The following Autopilot parameters can be set:
• NMEA APB Talker Identifier, 2 letters: The NMEA datagram start with an address

field that identifies the sender (talker). You can change the this field according to
your requirements.

• NMEA version to use determined by readability in the autopilot system
• Heading M or T: The output from SIS to the AP is normally true heading, T. However,

sometimes the AP requires this to be Magnetic, and then this can be set accordingly,
Note that the heading calculated in SIS is still True heading, so this is just to be used
in case the AP cannot use True heading.

• XTE factor: the XTE value in the NMEA APB datagram is multiplied with this
factor. This can cause the autopilot to react more quickly, but it can make the ship
oscillate along the line. This factor must be used with care.

Note

SIS needs to be restarted to effectuate any changes.
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Sound speed

The following sound speed parameters can be set:
• Big difference between sound speed at transducer from profile and probe – limit for

generation of warning
• Too big difference between sound speed at transducer from profile and probe – limit

for error generation
• Automatic start of Sound Speed Editor. Enable/disable
• Max. no. of samples in a sound velocity profile to be used by the old types of echo

sounders.
• Max. no. of samples in a sound velocity profile to be used by the new types of echo

sounders.
• Extend received sound speed profile automatically to 12000m (0=No, 1=Yes). This

parameter enables automatic extension of the sound speed profile.
All sound velocity profiles received by SIS must extend to 12000 meter. If this
function is enabled SIS will provide the extension automatically if the received sound
velocity profile is shorter than 12000 m. The extension will be performed from the
last depth available in the received profile, and a simple algorithm will be employed
to give a smooth transition. In addition the profile will also be extended upwards to
0 m if not already present. The upwards extension is done by using the first sound
speed sample found.

Note

SIS needs to be restarted to effectuate any changes.
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Network license

The following network licence parameters can be set:
• Port number of licence server
• IP-address of licence server
Note

SIS needs to be restarted to effectuate any changes.
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Error model parameters

Enter the error estimates for the attitude sensor, SVP and tide. The error estimate values
refers to the Total Propagation Error described in Real time data cleaning on page 492.
The values are specific to the sensor types and must be set according to the system
specifications. These parameters are used in calculating the error estimate for the depth
values.

Note

Parameters will be updated when a new survey is started.
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APOS

APOS is a Kongsberg Maritime acoustic positioning operating station - a computer with
a Windows based operating software. Position computed by APOS based on reference to
a fixed transponder on the seabed can be relayed to SIS and be used as position reference
for the echo sounder. To enable the use of APOS positions, the following procedure
must be used (Windows platform only)
1 Run findDDSPort from a command prompt window to find the UDP port where

the APOS positions are sent to
Use that port and the SIS PC’s IP address when configuring APOS

2 Enter the Transponder ID in the text field as shown in the figure above
3 Open the Installation parameter frame for the desired echo sounder and under “Input

Setup – Port Settings” enable GGA on UDP2. On “Sensor Setup”, select UDP2
as the active position system

4 Enable GGA on UDP2 from Input setup→Port settings

5 Select UDP2 as active position system from Sensor setup

Note

SIS needs to be restarted to effectuate any changes.
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Sensor options

The following sensor related settings parameters can be set:
• NMEA DPT Talker Identifier. 2 letters. This parameter defines the 2 characters to

identify the type of equipment that sends the NMEA datagram.
• ATH. Expected receiver frequency (Hz) (0=disable). This parameter defines the

expected reception rate of the TrueHeave (ATH) input. The default expected reception
rate is 90 Hz, and the warning can be disabled by selecting 0.
The ATH receive frequency can be monitored from the ATH logger to give a warning
if it falls 90 % below expected rate. If a low reception rate is detected this is indicated
by a warning. The checking of the ATH reception rate is done in a cycle of 10 seconds
active monitoring followed by a pause of 50 seconds. This implies that one minute
might pass before a low reception rate is reported.

• PPP. Expected receiver frequency (Hz) (0=disable). This parameter defines the
expected reception rate of the Precise Point Positioning (PPP) input. The default
expected reception rate is 1 Hz, and the warning can be disabled by selecting 0.
The PPP receive frequency can be monitored from the PPP logger to give a warning if
it falls 90 % below expected rate. If a low reception rate event occurs this is indicated
by a warning. The checking of the PPP reception rate is done in a cycle of 10 seconds
active monitoring followed by a pause of 50 seconds. This implies that one minute
might pass before a low reception rate is reported.

• SRH. Expected receiver frequency (Hz) (0=disable). This parameter defines the
expected reception rate of the RealHeave (SRH) input. The default expected reception
rate is 90 Hz, and the warning can be disabled by selecting 0.
The SRH receive frequency can be monitored from the SRH logger to give a warning
if it falls 90 % below expected rate. If a low reception rate event occurs this is

348 342682/D



Parameter references

indicated by a warning. The checking of the SRH reception rate is done in a cycle of
10 seconds active monitoring followed by a pause of 50 seconds. This implies that
one minute might pass before a low reception rate is reported.

• RTCM. Expected receiver frequency (Hz) (0=disable). This parameter defines the
expected reception rate of the RTCM input. The default expected reception rate is
1 Hz, and the warning can be disabled by selecting 0.
The RTCM receive frequency can be monitored from the RTCM logger process to
give a warning if it falls 90 % below expected rate. If a low reception rate event
occurs this is indicated by a warning. The checking of the RTCM reception rate is
done in a cycle of 10 seconds active monitoring followed by a pause of 50 seconds.
This implies that one minute might pass before a low reception rate is reported.

• Attitude/Velocity. Expected receiver frequency (Hz) (0=disable). This parameter
defines the expected reception rate of the Attitude/Velocity input. The default
expected reception rate is 90 Hz, and the warning can be disabled by selecting 0.
The Attitude/Velocity receive frequency on echo sounder ports UDP5 and/or UDP6
can be monitored to give a warning if it falls 90 % below expected rate. If a low
reception rate event occurs this is indicated by a warning indication (Yellow) in
the PU sensor status display for the Attitude/Velocity sensor on the relevant port
(UDP5 or UDP6). In addition a warning message is generated. The checking of the
Attitude/Velocity reception rate is done in a cycle of 10 seconds active monitoring
followed by a pause of 50 seconds. This implies that one minute might pass before
a low reception rate event is reported.

• Attitude. Expected receiver frequency (Hz) (0=disable). This parameter defines the
expected reception rate of the Attitude input. The default expected reception rate is
90 Hz, and the warning can be disabled by selecting 0.
If a reception rate below 90 % of expected rate occurs this is indicated by a warning
indication (Yellow) in the Pitch, Roll and Heave items in the Numerical display. In
addition a warning message is generated. This warning mechanism is used only for
the currently active attitude sensor. Note that 100 Hz is the maximum reception
rate that should be used for the Attitude sensors. Rates set higher might result in
undetected low rate events. The checking of the Attitude reception rate is done
based on a message received by SIS from the echo sounder containing the received
attitude samples. The message arrives in SIS once every second or when it contains
max 100 samples.

• Create DPT datagrams for each head. 1=enable. This parameter enables separate DPT
datagrams to be generated for each sonar head. Default value is 0, select 1 to enable
separate DPT datagrams. Applicable for EM 2040 dual RX and EM 2040C dual head.

Note

SIS needs to be restarted to effectuate any changes.
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Startup options for system

The Startup option for system parameters can be set as follows
• Perform full range of self test at start of echo sounder (0=No, 1=Yes). When enabled

SIS will automatically run all defined BISTs (Built In Self Test) for the echo sounder
when started. Default setting is off, i.e. BISTs are not run automatically.
When changed it is not necessary to restart SIS.

• Automatic start of echo sounders (0=off, 1=on). When enabled SIS will automatically
start the echo sounder if no changes since last run is detected.

• Enable initial repeatable scanning for echo sounders (0=No, 1=Yes). Normal scanning
operation at startup of SIS lasts for maximum 10 seconds, and is performed once. By
enabling the initial repeatable scanning option SIS will continue scanning (5 sec on, 5
sec off) until an echo sounder is detected on the network. This feature is useful in
the case where e.g. the SIS and the Processing Unit (PU) is turned on and started
simultaneously. The PU has longer startup time than SIS, and by enabling this feature
SIS will always detect the echo sounder.

• Disable RTCM logger (yes=1, no=0). The RTCM logger can be set to start only if
desired. Select 1 to disable the RTCM logger. The default value is 0, RTCM logger
enabled.
To disable the process from running, use SetParameters and set Disable RTCM logger
to 1 in Startup options for system.

• Current language, 1-Norwegian, 2-German, 3-English, 4-Spanish. It is now possible
to select a new language after initial SIS installation.

Note
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Only the English and Norwegian language selections are complete. Selecting German
or Spanish will result in a mixed language presentation were English is used when
no native translation is available. This is most noticeable for the German language
selection.
Also note that due to differences in word lengths, length of abbreviations etc. some
SIS GUI elements will vary in size and layout depending on selected language.

Projections

Gauβ-Krüger projections for Germany and Austria can be selected as one of the standard
projections in SIS. The file projectionGK.data is used to control the parameters for the
datum transformation and transverse Mercator projection.

The following projections parameters can be set:
• Projection directory for Gauss-Kreuger file projection.data. This parameter defines

the folder where the file projectionGK.data is stored.
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File menu parameters
The File menu gives you the following choices:
• Import/Export on page 352
• Export xyz file on page 361
• Remove survey on page 362
• Remove sounder on page 362
• Save settings on page 363
• Save settings as... on page 363
• Delete settings on page 364
• Set startup settings on page 364
• Export PU parameters... on page 364
• Import PU parameters... on page 366
• Set PU factory settings... on page 367
• Export user settings... on page 368
• Import user settings... on page 369
• Create CUBE grid on page 369
• Quit on page 370

Related operational procedures
• How to enter survey parameters on page 114
• How to export survey results after a survey on page 207
• How to create and use a GeoTIFF background image in the Geographical view on

page 166
• How to exit the SIS software on page 207
• How to shut down the HWS on page 208
• How to shut down the Processor Unit (PU) or the Transceiver Unit on page 208

Import/Export
The Import/Export dialogue is accessed from the File drop-down menu.
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The following options are available in the Import/Export dialogue:
• Data types: The following data types can be imported:

– 3D Models: You can import AutoCAD (*.dxf), Inventor (*.iv) or VRML (*.wrl)
– Surveys: You can import either raw data files or already gridded data

Note

It is possible to reprocess data based on user defined rules if importing raw data
files.

– KSGPL: Imports background KSGPL files (*.bgksgpl)
– Background Images: Imports a GeoTIFF background image

• Import: Press this button to import the selected data type
• Raw Data Files: Import raw data files
• Background grid from file: Create a background grid
• Export Selected: Press this button to export data (more details below)
• Remove Selected: Loaded or set to be loaded data can be unloaded by selecting the

listed data items to the right and clicking this button
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Note

No files will be deleted on disk even if e.g. a survey has been reprocessed.

KSGPL background data can not be unloaded

• Undo All: Undo actions

Note

No files will be deleted on disk even if e.g. a survey has been reprocessed

• Delete Processing Data: A gridded survey consist of many different file types. One of
these types is called Processing Files. These files are used internally when creating
a new grid or adding to an existing one. The files may use a lot of memory and
hard disk space, but are generally not needed if the survey is closed and used for
visualisation only. Thus, the Processing Data can be deleted. This is done by selecting
the loaded surveys to be handled and pressing the Delete Processing Data button.

• Press OK to apply
• Press Cancel to abort

Data types
Depending on your selected data type pressing the Import button will launch the different
import dialogue boxes:
• 3D Models: Browse for the wanted 3D model file(s). Please wait some time to allow

the 3D model to be processed. This may take a while depending on the size of the file.
The imported 3D model(s) will be listed to the right if successfully processed/loaded.

• Surveys (already gridded): Browse for the directory where the already gridded survey
is located. It is possible to select more than one survey for import, so multiple surveys
can be imported in a single step.

Note

The grid may fail to be loaded if the GridEngine is not running or if a valid license
is not present.

• KSGPL: Browse for a KSGPL background file.
• Background Images: Background images can be imported by selecting Background

Images and pressing the Import button. This will launch a dialog box where you can
import a GeoTIFF file. This is an ordinary TIFF image file with the geo-reference
information in the TIFF file header, which also will be shown on the screen.

• GeoTIFF Support: Support for GeoTIFF files is summarized in the table below. ESRI
world are not supported. Max file size is limited by available memory.

TIFF Tag Name Support Values
PhotometricInterpretation Grayscale, RGB, and Palette

Samples PerPixel 1, 2, 3 and 4

BitsPerSample 8
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PlanarConfig Chunky format (contiguous)

Compression Uncompressed and LZW

Note

A background image can only be imported when a survey is loaded.

The Delete Processing Data and the Background Images will only be enabled if at
least one of the given surveys is linked to Processing Data.

• Press OK to apply
• Press Cancel to abort

Raw Data files
Raw data files can be reprocessed/gridded with different settings.

• Import Raw Data Files field
– Survey name: Give a name of the survey to be gridded.
– Existing Surveys: Import raw data into a selectable existing survey. GridEngine

parameters, projection, grid folder and user will be given by the existing survey
and your raw data will be imported as defined by this.

– Select survey-template: Select a survey templates defined in the New Survey or the
Survey Administration

frames.
Note

Settings done in Raw Data File import dialog box will NOT update the selected
survey template.
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– Comment: Write your own comment for the survey in the text field.
– Raw data path: Browse for the directory containing your raw data files to be

processed. The files contained in this directory will be listed in the list box below.
From this list raw data files can also be added one by one by pressing the Add raw
data files button.

– Tide File: Browse for tide file to be used, if any.
– Geoid File: Browse for geoid file to be used, if any.
– Grid Folder: Select where to store the survey files when imported and gridded.
– User: Select a user from the combo box. To add new user(s) select User handling in

the Survey administration frame.
– Projection: Select a projection from the drop-down combo box. If a projection

already has been set in the New survey frame, this field is greyed out.
• GridEngine Parameters field
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– Depth variable: Which depth value to be processed
If you are applying real time data cleaning, select what depth to use in the
processing.
The real time data cleaning module will use the given depth plane to identify
outliers in the data and remove them.
Note

We recommend that you set the real time data processing depth to either tide
corrected depth, Zt, or to geoid and RTK corrected depth, Zv, in order to avoid
unwanted depth rejections caused by natural variations such as the tide.

– Number of cells: Number of cells in one sub grid used by the GridEngine. The
numbers of cells must be a power of 2 and between 16 and 512
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– Cell size (cm): Size of each cell in the lowest (the most detailed) level of detail.
Min = 10 cm, max = 15,000 cm.
Select resolution of your grid, i.e. number of cells and cell size, suitable for your
depth and expected coverage.
Note

The grid resolution applies to displayed data only, the raw data is not affected.
The grid resolution can not be changed during the survey, and should therefore be
carefully set to apply to the whole survey area.

If the cell size is set too large the resolution in your geographical view will be
poorer than necessary. If you set the cell size too small you may experience that
there are not sufficient data points in the cells to compute a valid depth value, and
no depth value is displayed. Too small cell size may also overload the computer
and give you delays in the real time display.
The following factors have influence on the selection of the cell number and cell
size:
* Depth
* Achieved swath width (shown in numerical display)
* Survey speed
* Coverage area per beam (footprint)
The following rule of thumb have proven to be reasonable:

Normal resolution
* Cell size = average swath width/100
* Number of cells in processing grids: 64x64

High resolution
* Cell size = average swath width/200
* Number of cells in processing grids: 128x128
Example: If depth is 100 meters and sector coverage is set to ±70°, the swath width
is 550 meters. Cell size computed from above rule of thumb for may then be set to
5.5 meters for normal resolution and 2.8 meters for high resolution.
Note

The cell size settings applies to highest possible display resolution, i.e. LOD0.

– Processing parameters: By pressing this button you will be forwarded to the Real
Time Data Cleaning menu.
The real time data cleaning uses rules, i.e. a set of parameters that controls the
algorithms used in the real time processing of echo sounder data.
By default, the real time data cleaning is set off.

• Press OK to apply
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• Press Cancel to abort
KSGPL: Browse for the wanted KSGPL background file.
Note

One KSGPL file may override any other currently loaded KSGPL data.
KSGPL background data can not be unloaded

Background grid from file
Data generated from File→Export xyz or generated from File→Import/Export→Export
selected can be used to create a background grid. Activating the Background grid form
file menu, brings up a file selection box where you can choose a file with the extension
DAF.xyz. A survey will be created from the file, using the projection and grid parameters
from the current survey. When created, this survey will appear in the survey list, and later
be loaded using the Import button. The name of the survey is created from the filename.
Note

The data in LoD 0 may appear sparse because of the resolution in the dataset. Normally
LoD 1 displays the grid without “holes”.

Export of the selected data files
1 Select File→Import/Export
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2 Select the survey data you want to export
3 Press the Export... button to launch the Export Survey dialogue box

Survey name: Name of the survey to be exported.
Raw Data Location: This selection applies to export of a Neptune Rule file only. Browse
for the disk location where the raw data files (.all files) are stored for the survey you
want to export.
Output Type field: Select output file format to export the data to. The options are:
• Little Endian: Binary PC format file.
• Big Endian: Binary Unix format file.
• ASCII: Format details are written into the file itself.
• Neptune Rule: Create a rule file to be imported into Neptune post-processing. This

setting overrides the Point Set and Variable settings described below.
• DAF Geo. coord: Creates a ASCII file with geographical coordinates in DAF format.
• DAF Contours: Creates at an ASCII file with contour lines in DAF format.
• Background XYZ: Creates an ASCII XYZ-file which can be used to create background

grids.
Note

When exporting DAF formats the only available Point Set choices are Min, Max or
Median.

Point Set field: Select whether you want all, valid or invalid points is to be exported.
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Variable field: Select the Depth type to export. See the Depth settings in the Geographical
window and the Geoid chapter.
Press OK to apply.
Press Cancel to abort.

DAF Export
When exporting either of the DAF formats, three additional Point Set variables are
enabled. Select one of these to create the file. Level of Details (LoD) may also be set.
When selecting DAF Contours, you must select how to create the contours. Select from
the Depth List or edit or create a new set.
For instance, you may choose to create contours at 1, 5,10 and 15 meters, every 2
meters, every 5 meters and so on. The predefined sets can be altered or new ones can
be added by editing the right-most Depth List field and pressing New or Save. Pressing
Delete removes the selected set.
DAF contours can be displayed in Neptune and other applications that supports the
DAF format.

Related operational procedures
• How to enter survey parameters on page 114
• How to import a Neptune grid to SIS on page 159
• How to export survey results after a survey on page 207

Parameter references
• Data cleaning on page 317
• Projection parameters on page 269

Related topics
• Export xyz file on page 361
• Export formats on page 531
• Geographical view on page 57
• Geoid on page 515

Export xyz file

To export an ascii file of data from the current survey, press File→Export xyz-file.
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The settings used to create the ascii xyz file are the same as used when exporting the
survey.
The settings used are the DAF Geo. Coordinates, the Point Set is Median and the LoD
(default setting is 0, the highest resolution). The variable Z is used by default. The
latest value used, will be used by default.
The generated file will be placed in the grid directory of the survey
(C:\sistdata\grids\<surveyname>) and the name of the file is
<surveyname>_xyzZ.DAF.xyz where Z is the variable used. The file is in
ascii lat/long format, and can be zipped and transferred to other systems.

Remove survey
Surveys can be permanently deleted from the database. Logged data is not affected.
File→Remove survey from database

Remove sounder
All echo sounders on the network, detected by SIS during SIS start-up or Rescan, will be
instantiated and permanently registerred in the SIS database. To remove any obsolete or
unwanted echo sounders from the database File→Remove sounder from database must
be used.
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When selecting this item a new list is displayed containing all registered echo sounders
that are eligible for deletion. When you make a selection from the list you will be asked
for a confirmation before the echo sounder is deleted from the database.

Note

It is not allowed to remove the currently displayed (active) echo sounder or any started
echo sounders, so these will not be included in the list.

Surveys, logged data or any stored PU parameter files etc. belonging to the removed
echo sounder will not be deleted.

Save settings
Save Settings is accessed from the File drop-down menu. It will automatically save the
current frame settings. If the current frame settings cannot be saved under the chosen
name, you are prompted to use the Save settings as... option.

Save settings as...
The Save Settings As... is accessed from the File drop-down menu.

You can choose to save different frame setting combinations by giving them different
names.

Press Accept to add the new frame setting.

Press Cancel to abort.
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Delete settings
The Delete Settings is accessed from the File drop-down menu.

This is used to delete one of your predefined frame setting combinations.

Setting Name: Select the survey setting to be deleted.

Press Accept to add the new frame setting.

Press Cancel to abort.

Set startup settings
You can choose the default start-up window settings:
File→Set Startup Settings.

When SIS starts up, the selected window set will be used.

Export PU parameters...
Note

It is recommended that the parameters for an echo sounder is saved as soon as the
initial configuration (i.e. installation and runtime parameters) has been completed and
stored in the database.
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Note

Whenever the OK button is pressed from the Installation parameters
frame a backup file containing current PU parameters is generated.
The backup file can be Imported through File→Import PU parameters....
The backup files are stored in \sisdata\common\backup-settings
with the naming convention Backup_<echo_sounder_name>_<serial
number>_ <YearMonthDay>_<HourMinuteSecond>.txt e.g.Backup_EM
2040_402_20090430_105852.txt.

The Export PU parameters... operation is accessed from the File drop-down menu.
It is used to save the Installation and Runtime parameters for the current echo sounder to
file in an ASCII readable format.
The file may later be imported whereby the saved settings are restored.
The file name and storage location can be specified in the standard Save... pop-up
window displayed when Export PU parameters... is selected. A default storage location
for such files is defined by SIS, but you are free to choose another location.
The default file extension is .txt, but any user defined extension is allowed.
When saving the file a User comment pop-up window will appear. You may enter
any comments in this field. There are no limitations to amount of text. No graphical
information or pictures may be included.

The OK button is used to complete and accept the entered text. The text is stored in the
heading of in User comments brackets in the exported PU parameter file.

Note

The saved parameters file can be edited. However, this is not recommended and must
only be performed by users with intimate knowledge of SIS.

Related topics
• Current echo sounder on page 36
• Import PU parameters... on page 366
• Installation parameters on page 274
• Runtime parameters on page 297
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Import PU parameters...
The Import PU parameters... operation is accessed from the File drop-down menu.

It is used to read a previously saved parameters file for a specific echo sounder and restore
the parameter settings for this echo sounder to the same status as when the file was saved.

The import operation can be performed without consideration of which echo sounder is
currently set as active or whether the relevant echo sounder is started or even detected
on the network.

Note

The echo sounder will not be automatically updated with imported settings. Only the
database (SISDB) will be updated. It is therefore necessary to manually initiate an
update of the echo sounder (PU) by starting it (if not previously started) or by using the
Installation Parameters - or the Runtime parameters frame.

The file name and storage location of the PU parameter file can be specified in the pop-up
window displayed when Import PU parameters is selected.

The Import PU parameters operation is typically used to avoid having to re-enter all
set-up parameters manually after reinstalling SIS and the database.

When importing PU parameters a pop-up dialog box will be used to allow you to specify
another serial number to replace the serial number in the imported file. This will
effectively allow you to copy a parameter setup from one configuration to another e.g.
when replacing/changing a main sonar head.
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Note

Remember to save the parameters if changing serial number.

OK button indication

When importing PU parameters the OK button in the Installation parameter frame is set
to yellow to indicate that the PU must be updated with the new settings.

The OK is only set yellow when the selected active echo sounder is the same as the echo
sounder that the PU parameters are imported for.

Related topics
• Current echo sounder on page 36
• Export PU parameters... on page 364
• Installation parameters on page 274
• Runtime parameters on page 297

Set PU factory settings...
Currently selected echo sounder (PU) can be reset/restored to it's original factory default
parameter settings by selecting File→Set PU factory settings.... The Installation and
Runtime parameters are included in this action.

Note

To avoid loss of your original parameter values, you may export current parameters to
file by selecting File→Export PU parameters....

If you select Yes to continue the action, another pop-up is displayed asking whether you
would like to change the serial number (e.g. for preparing the setup of a future system).
You may also cancel the operation at this stage by pressing the Cancel button, or loading
the factory settings by pressing either the Yes or No button.

The factory default parameter values are defined independently for each type of
multibeam echo sounder. The parameters are stored in a file of the same format as used
by Export PU parameters... and Import PU parameters... functions.
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Note

In order to effectuate the reset parameters for the selected echo sounder, the parameters
must be transferred to the PU. The parameters are transferred only when the echo
sounder is started or when the OK button is pressed in the Installation window. The OK
button in the Installation parameters frame will be set to yellow until pressed.

Related topics
• Export PU parameters... on page 364
• Import PU parameters... on page 366

Export user settings...
The Export User settings... operation is accessed from the File drop-down menu.

It is used to save current database settings for later retrieval.

The following Export selections can be made:
• User parameters: Stores the entries set in the Set Parameter menu
• Datagram subscription: Stores a list of the datagrams subscribed to in current database

settings
• Survey template: Stores the survey definition
• Projections: Stores the name and definitions for selected projection
• Frame settings: Stores current frame setting definitions
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Related topics
• SIS parameters – Set parameters on page 333
• Frame toolbars parameters on page 209
• Survey parameters on page 263
• Projection and datum parameters on page 384

Import user settings...
The Import User settings... operation is accessed from the File menu.

It is used to restore earlier exported database settings.

The following Import selections can be made:
• User parameters: Restores entries set in the Set Parameter menu
• Datagram subscription: Restores the datagrams subscribed to
• Survey template: Restores survey definition
• Projections: Restores projection
• Frame settings: Restores frame settings

Related topics
• SIS parameters – Set parameters on page 333
• Frame toolbars parameters on page 209
• Survey parameters on page 263
• Projection and datum parameters on page 384

Create CUBE grid
When logging is completed, a CUBE grid may be generated:
File→Create CUBE grid.
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The same survey template from which the current survey was created, is set as default.
The first tide and geoid file, found in the raw data folder, is displayed in the menu. The
buttons at the right hand side can be used to browse for other tide and geoid files.

Pressing the OK button starts the processing, and a progress box appears. The whole SIS
application is locked while the CUBE grid is generated and as long the Create CUBE
Grid box is active. The Create CUBE Grid box will be visible for a while, after the SIS
progress box disappear, to complete the necessary calculations.

If the CUBE grid is to be shown, SIS must be set to CUBE mode. Start Set
Parametersfrom the Tools→Custom menu, select Logging and set the data cleaning
method to CUBE. SIS has to be restarted, and no echo sounders have to be started before
the grid is imported to SIS.

Parameter references
• Logging on page 341

Related topics
• CUBE on page 464

Quit
Quit is accessed from the File drop-down menu.

This will shut down the SIS program without any further confirmation of your choice.

The SIS program can also be shut down by using the Close button on the right hand side
of the SIS title and info bar (i.e. upper right corner of the SIS application window).

Note

Closing down may take some seconds. Do not try to restart SIS until the SIS application
window has disappeared.

Related operational procedures
• How to exit the SIS software on page 207
• How to shut down the HWS on page 208
• How to shut down the Processor Unit (PU) or the Transceiver Unit on page 208
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Tools menu parameters
The Tools drop-down menu gives you the following choices:
• External sensors on page 371
• Instrument combinations on page 377
• Remove instruments on page 378
• C-MAP – Licence administration on page 379
• AutoCalib Wizard on page 380
• SeaCal results on page 381
• Extract IFF on page 381
• Custom menu on page 106

Related operational procedures
• How to save data on page 169
• How to define a new projection and datum transformation on page 122
• How to enter the waterline for a single beam system on page 139
• How to collect the sound velocity profile on page 141
• How to convert your sound velocity profile to SIS format on page 143
• How to modify and load a sound speed profile into SIS on page 151
• How to run the PU simulator on page 203

External sensors
External sensors is accessed from the Tools menu.

This is where you define the interfaces to your external sensors that are attached directly
to the Hydrographic Work Station (HWS) computer or sensors sending their data on
Ethernet to the HWS computer.

Note

Interfaces to external sensors that are attached to the Processing Unit (PU) are defined
in the Installation parameters.

342682/D 371



Seafloor Information System

372 342682/D



Parameter references

Input setup
• Sound Velocity Probe type

This is where you interface a sound velocity probe that is to be instantaneously read
by SIS, typically a sound velocity probe installed at transducer depth. The following
probes are supported:
– AML SV (C) - only sound velocity
– AML SV&T (C+T) - sound velocity and temperature
– AML SV&P (C+P) - sound velocity and pressure (pressure not significant)
– AML Micro SV (C)
– AML Micro SV&T
– AML Micro SV&P
– Valeport Mini SVS
– Ext. datagrams (C+T) - sound velocity and temperature
See format description in Sound speed profile formats on page 544

Sound speed sample frequency rate
The sample rate expected from the sound velocity sensors (SV, SV&T, SV&P) is 10
Hz. The sample rate of the external datagrams is 1 Hz.
These rates are used in the sound speed filtering. For more details on filtering see the
Sound Speed entry in the Runtime parameters setup.

• Real time tide:

SIS can receive real time tide information on serial lines. Select Realtime Tide
available and set the communication parameters for the selected line.
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• Heading parameters: Applies in situations where you are interfacing the heading
sensor directly to the HWS. Normally, you will interface the heading sensor to the
PU, but in rear cases where you are running SIS without any multibeam echo sounder
PU, you may use this option.

– Sensor name: Display name
– Serial/Port: When serial interface is enabled the com port number must be set
– Ethernet/IP address/port: When ethernet interface is enables IP address and local

port number must be set
– Add: Must be pressed for each system you configure
– Compass deviation file: Use the browse button (three dots) to find the desired file.

• Position parameters: Applies in situations where you are interfacing the positioning
sensor directly to the HWS. Normally, you will interface the positioning sensor to
the PU, but in rear cases where you are running SIS without any multibeam echo
sounder PU, you may use this option.

– Sensor name: Display name
– Serial/Port: When serial interface is enabled the com port number must be set
– Ethernet/IP address/port: When ethernet interface is enables IP address and local

port number must be set
– Position delay (sec): Enter any known position delay.

The accuracy of the position sensor is vital for the data accuracy, and it is therefore
important that the relative timing of vessel position data and system depth data is
correct. To define the duration of life of the positioning system input data, you can
enter a position delay.
A position delay is required if the position that is output on the port applies to an
observation that was done a significant number of seconds ago. The position delay
may be significant for systems where the internal computation and processing of
the position takes time.

– Add: Must be pressed for each system you configure
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– Location offset (m): Use the text fields to enter the location of the GPS antenna
relative to the vessel's reference point.

Caution

The positioning system may have internal offset parameters set. Make
sure that the antenna offsets are not applied both in the position
system and in SIS.

• SVP Logger

Selects a serial line and sets the parameters. The SVP Logger is started from the
SVP editor..

• Barometer

Set if barometer input is available and select HWS input port (serial line).
• Geodimeter

This setting applies if a Geodimeter position system is being used. Set whether a
Geodimeter is available, select HWS input port (serial line) and select the echo
sounder where the position input is to be sent to.

Output setup
• Auto Pilot parameters:

Select Auto Pilot available if you want data to be sent to the auto pilot. Choose a
serial line from the combo box.
Enabling or disabling of NMEA APB output is done in the Show/Hide menu of the
Helmsman display. See Helmsman display – Show/hide on page 237
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• Dyn Pos parameters:

Select Dyn. Pos. available if you want data to be sent to the dynamic positioning
system. Choose a serial line from the combo box.

• Depth below keel:

The Centre depth output is always sent as a NMEA DPT datagram on UDP to port
number 4310. The NMEA depth output from SIS is coded. The two aa’s in the string
$aaDPT are set according to sounder type, see table below.
Refer to Depth under keel output format on page 534 for description of the format.
If depth below keel is selected in the External sensor user interface the NMEA
datagram is sent out to the selected serial line.

Echo Sounder Model NMEA String

EM 2000 $KADPT

EM 3000 $KBDPT

EM 3002 $KCDPT

EM 1002 $KDDPT

ME70/BO $KJDPT

EM 710 $KEDPT

EM 300 $KFDPT

EM 302 $KHDPT

EM 120 $KGDPT

EM 122 $KIDPT

Other parameters
• Port: Choose the port you want to set communication parameters for
• Baud rate: 1200, 2400, 4800, 9600 or 19200
• Data bits: 7 or 8
• Stop bits: 1 or 2
• Parity: None, Odd or Even.
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Waterline

Enter the vessel’s waterline vertical location (in normal trim) in the vessel’s reference
coordinate system. It is recommended to use an average of two measurements; one on
each side of the vessel. The measurement must be made at the same alongship location
as the physical location of the motion sensor.

Note

If the vessel’s deplacement or trim changes during a survey, the Waterline value must
be updated accordingly.

Related operational procedures
• How to setup the input from external sensors on page 137
• How to setup the output to external sensors on page 139
• How to enter the waterline for a single beam system on page 139
• How to use SVP Logger on page 144

Parameter references
• Sound speed for EM 2040 on page 305

Related topics
• SVP Editor on page 395
• Barometer input on page 574
• External datagram (C+T) format on page 550
• Helmsman display view on page 70
• Depth under keel output format on page 534

Instrument combinations
Instrument combinations is accessed from the Tools menu.

Through the Instrument combination you may add interfaces to equipment that does not
communicate through the echo sounder PU and does not broadcast on the Ethernet.
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The equipment can be GPS, compass or single beam echo sounder (SBES) type
equipment.

You have to give the instrument an ID number. This number must be unique for each
type of equipment. The ID number is treated the same way as the serial number for
equipment with a PU (Processing Unit).

After the instruments are registered they will appear in the Not Started combo box and
the Current echo sounder combo box on the main toolbar.

Add instrument parameters

GPS + Compass: Give the new instrument a name and an ID number to GPS and
compass type equipment

SBES + GPS + Compass: Give the new instrument a name and an ID number to SBES,
GPS and compass type equipment

Existing instruments: A list of the instruments that have been defined.

Related topics
• Remove instruments on page 378
• Echo sounder – Not started list on page 35
• Current echo sounder on page 36

Remove instruments
The Remove Instruments is accessed from the Tools menu.

Select the instrument you want to remove, and press OK.
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C-MAP – Licence administration
Note

This menu choice will only be visible if C-Map is installed.

C-MAP is accessed from the Tools menu and contains the following administrative sub
menus:
• LicenceAdm – giving you the opportunity to administrate the C-MAP licence in SIS
• GDBAdmin – for administration of the C-MAP database
• Update charts – administration of C-MAP chart updates

LicenceAdm

Note

C-MAP licensing is not included in standard SIS delivery and must be ordered separately.
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The following options for C-MAP Licence Administration are available:
• Add License manually: You may enter your license manually by entering the

alphanumeric string in the License string text field. The license string is issued by
C-MAP Norway.

• Get expired licenses: Press this button to see whether earlier versions of C-MAP have
been installed and when the subscription date exceeded.
May be of interest for C-MAP trouble shooting.

• License list: Gives you an overview of the C-MAP licenses, i.e. zones, that your
system subscribes to.

• Add license from file: You will normally have received you C-MAP license both
as an alphanumeric string and contained in a file. The file is by default named
PASSWORD.USR. Browse for this file and press OK to apply.

• License order: This view gives you an overview of what licenses your system
subscribes to.

Related topics
• C-MAP CM-93/3 on page 443
• C-MAP detail level on page 41
• Geographical – C-MAP manipulation mode on page 225

AutoCalib Wizard
Before running the AutoCalib Wizard, ensure that the survey you want to run the
calibration on is loaded, and that the raw files are available.
From the Tools menu, select AutoCalib Wizard... to start the calibration process. The
AutoCalib Wizard window will appear, and a further set of dialogue boxes will be
available. Respond to them according to how you want to run the calibration.
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After the last dialogue box has been displayed, the calibration process will start in the
background. You may continue working while the process is running. When the process
is finished you will be prompted to open the result file and inspect the result. You can
also open the file and inspect the result later by selecting Tools→SeaCal Results. (The
SeaCal program is used by AutoCalib.) The results may be applied to the echo sounder’s
installation parameters or saved to a file for later use. If you want to apply the result, you
must open the Installation Frame, and press OK to activate the result, as when storing the
manual calibration values.

Related topics
• Calibration parameters on page 260
• Seacal auto calibration on page 261
• SeaCal results on page 381
• SeaCal on page 409

SeaCal results
The SeaCal Results is accessed from the Tools menu.

Use this option to browse for and open SeaCal result files (*.res).

Related topics
• Calibration parameters on page 260
• Seacal auto calibration on page 261
• AutoCalib Wizard on page 380
• SeaCal on page 409

Extract IFF
The Extract IFF is accessed from the Tools menu. From this menu, Position→All and
Position→New can be chosen.
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Position→All will create Intermediate File Format files of all position datagrams in
the survey lines. Position→New will extract positions from new files not previously
processed.

The positions can be colour-coded by the quality indicator in the GGA datagram. The
quality factor will identify where the position quality is based on 2D or 3D GPS position
determination, i.e. where a valid height is computed or not.

Note

Logging must be Off for the IFF functionality to be activated

The quality factor of the positions can be view in the Geographical view. Processed
positions must be selected from the Option button in the Geographical view, see Options
on page 211.

Configure...
The Configure... item is accessed from the Custom sub-menu found in the Tools main
menu.

The Configure dialogue box is used to manage existing applications in the Custom
sub-menu. It is possible to add, hide or delete applications, or change the sequence in
which they appear in the Custom sub-menu. Note that it is not possible to delete any of
the factory defined applications.
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A new application is added by pressing the Add button in the dialogue box. Fill in all
text fields marked in yellow. Press the Apply button to add the new application to the
Custom sub-menu.

Program arguments can be added, e.g. a text file if the application is a text editor.

Click the Hide application box to hide a console application when starting SIS. The
application will then only be visible in the Task Manager.

Press the OK button to store changes.

Press Esc to cancel.

Related topics
• Custom menu on page 106
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Projection and datum parameters
When selecting Tools→Custom→Projection setup the Projections window opens.
The Projection setup must be used to define the following geodetic parameters:
• The datum your input positions refer to
• The datum you want your output positions to refer to
• The datum transformation parameters to apply to the input positions
• The projection for the plane coordinates (map coordinates)
Note

If your projection and datum transformation is already defined in SIS, you do not have
to enter the Projection setup. The correct projection can be directly selected through
the Survey Administration or the New Survey setup pages.

This Projection window contains two tabs:
• The Define projections tab is where you define the datum transformation and projection:

– Projection (and datum transformation) may be selected from a PROJ.4 file, or
– Projection (and datum transformation) may be selected from the SIS database, or
– You may enter your datum transformation and projection parameters manually

• The Test selected projection tab allows you to test the selected datum transformation
and projection.
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Select projection file
• Select projection file from disk opens a file selection box where you can selects files

in PROJ.4 format.

Note

PROJ.4 format is a generic format for definition of projection of geographical
coordinates to plane coordinates. The PROJ.4 format may also contain datum
transformation parameters.

• Select projection in file is then used to select the projection in the selected file. The
name of the selected projection appears below.

• Put projection into database; a projection from the file is inserted into the database.
The database tables are updated. It is not possible to change a projection if it is used
by any surveys unless the user specifies it.

Projections in the database
• Select projection in the database; you can also select a projection from the database. It

is not allowed to change a projection used by a survey unless you specify it.
• Write projection to file; selected projection is stored to file in PROJ.4 format.

Projection definition

You may input, edit or delete your own definitions of projection and datum transformation
parameters by using the New, Edit and Delete buttons.
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Test selected projection
Test selected projection allow you to test the selected projection. You can choose the
format of the geographical coordinates to decimal degrees, decimal minutes or decimal
seconds. You can then input geographical coordinates and press Calculate in that window
to see the projection coordinates in the window below, or vice versa.

Available ellipsoid definitions in SIS
Ellipsoid name Major axis (a) Reverse flattening (rf) /

Minor axis (b)
Description

MERIT a=6378137.0 rf=298.257 MERIT 1983

SGS85 a=6378136.0 rf=298.257 Soviet Geodetic System
85

GRS80 a=6378137.0 rf=298.257222101 GRS 1980 (IUGG, 1980)

IAU76 a=6378140.0 rf=298.257 IAU 1976

airy a=6377563.396 b=6356256.910 Airy 1830

APL4.9 a=6378137.0 rf=298.25 Appl. Physics. 1965

NWL9D a=6378145.0 rf=298.25 Naval Weapons Lab.,
1965

mod_airy a=6377340.189 b=6356034.446 Modified Airy

andrae a=6377104.43 rf=300.0 Andrae 1876 (Den.,
Iclnd.)

aust_SA a=6378160.0 rf=298.25 Australian Natl & S.
Amer. 1969
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Ellipsoid name Major axis (a) Reverse flattening (rf) /
Minor axis (b)

Description

GRS67 a=6378160.0 rf=298.2471674270 GRS 67(IUGG 1967)

bessel a=6377397.155 rf=299.1528128 Bessel 1841

bess_nam a=6377483.865 rf=299.1528128 Bessel 1841 (Namibia)

clrk66 a=6378206.4 b=6356583.8 Clarke 1866

clrk80 a=6378249.145 rf=293.4663 Clarke 1880 mod.

CPM a=6375738.7 rf=334.29 Comm. des Poids et
Mesures 1799

delmbr a=6376428 rf=311.5 Delambre 1810
(Belgium)

engelis a=6378136.05 rf=298.2566 Engelis 1985

evrst30 a=6377276.345 rf=300.8017 Everest 1830

evrst48 a=6377304.063 rf=300.8017 Everest 1948

evrst56 a=6377301.243 rf=300.8017 Everest 1956

evrst69 a=6377295.664 rf=300.8017 Everest 1969

evrstSS a=6377298.556 rf=300.8017 Everest (Sabah &
Sarawak)

fschr60 a=6378166 rf=298.3 Fischer (Mercury Datum)
1960

fschr60m a=6378155 rf=298.3 Modified Fischer 1960

fschr68 a=6378150 rf=298.3 Fischer 1968o

helmert a=6378200 rf=298.3 Helmert 1906

hough a=6378270.0 rf=297 Hough

intlh a=6378388.0 rf=297 International 1909
(Hayford)

krass a=6378245.0 rf=298.3 Krassovsky, 1942

kaula a=6378163 rf=298.24 Kaula 1961

lerch a=6378139 rf=298.257 Lerch 1979

mprts a=6397300 rf=191 Maupertius 1738

new_intl a=6378157.5 b=6356772.2 New International 1967

plessis a=6376523 b=6355863 Plessis 1817 (France)

SEasia a=6378155.0 b=6356773.3205n Southeast Asiae

walbeck a=6376896.0 b=6355834.8467 Walbeck

WGS60 a=6378165.0 rf=298.3 WGS60

WGS66 a=6378145.0 rf=298.25 WGS66

WGS72 a=6378135.0 rf=298.26 WGS72

WGS84 a=6378137.0 rf=298.257223563 WGS84

Available projections in SIS
• UTM – Universal Transverse Mercator.
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When selecting UTM you will be prompted for UTM zone and whether you are on
northern or southern hemisphere

• UPS – covers the polar regions

• Mercator

You will be prompted for latitude and longitude of origin, false northing and false
easting.

• Transverse Mercator (TM)

Same parameters applies to the Transverse Mercator as for the Mercator. In addition
a scale factor for the central meridian must me input
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• User defined – selected by number from in the static and dynamic libraries. These
projections are identified by a unique number known to the user. You can choose
this number in the User’s projection dialogue. If this number is not implemented,
the selection procedure will exit.

By selecting =1 the Gauss Krüger projection will be selected. See Gauß Krüger
on page 390

• PROJ.4 definition – enables input of programmable datum transformation and/or
projection parameters

The PROJ.4 style must be entered in the following format:
+init=my_file_with_proj4_projections:my_projection

Note

The following will fail:
+init=c:\mydir\myfile.txt:my_projection

because the first : is not allowed. This means that your projection file have to be
on the same disk
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Support user defined projections

Gauß Krüger
Enter User’s projection number = 1 in the dialogue window. The parameters for the
projection can be controlled in a file named projection.data like this:
GK_AUSTRIA GK_AUSTRIA tells Software to use Gauß-Kruger

for Austria

Transformation parameters for WGS84 to
Gauss-Krüger coordinates according to Datum MGI

-603.919 Translation in x [m]

-71.656 Translation in y [m]l

-433.142 Translation in z [m]

-4.377582 Scale

0.757332 Rotation in x [”]

0.334161 Rotation in y [”]

-1.604013 Rotation in z [”]

6377397.155 Major axis [m] (Bessel)

299.152815 Flattening (Bessel)

12.0 Central Meridian (Bessel)

6378137.0 Major axis (WGS84)

298.257223563 Flattening (WGS84)

4500000 Zuschlag Rechtswert

0 Zuschlag Hochwert

0 Fixed height used in projections

Hungary
User projection number = 2. This is a projection for the Budapest area.

Related operational procedures
• How to define a new projection and datum transformation on page 122

Related topics
• Projection parameters on page 269
• Projections on page 513

Help menu dialogs
The Help drop-down menu gives you the following choices:
• Help on page 391
• Build info on page 391
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• OpenGL settings on page 392
• About SIS... on page 392

Help
Help is accessed from the Help menu.

It will open the online-help manual applicable to your system.

Build info
The Build Info message box is accessed from the Help menu.

It contains information about the current SIS software build.
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OpenGL settings
The OpenGL Settings message box is accessed from the Help menu.

It provides the following information about the OpenGL settings:
• Driver information
• Display mode
• Available extensions

About SIS...
The About SIS message box is accessed from the Help menu.

It contains general information about the SIS software and the release version of the
supported echo sounder.
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This message box can also be accessed by pressing the SIS icon on the status bar in
lower right corner .
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SIS utilities

This chapter provides description of operation and parameter setup of utility programs
related to SIS. Some are accessed directly from SIS.

Topics
• SVP Editor on page 395
• Raypaths chart on page 401
• SeaCast on page 405
• SVP Logger on page 406
• SeaCal on page 409
• SIS Objects on page 417
• Logging utilities on page 435
• C-MAP CM-93/3 on page 443
• Global event marker on page 447
• PU simulator and playback on page 449
• Create grid from ASCII files on page 451
• KSGPL on page 453
• Input of S-57 formatted chart files on page 458
• How to use SIS on an AUV/ROV on page 460
• CUBE on page 464
• Precise Point Positioning (PPP) in SIS on page 476
• GSF support in SIS on page 483
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SVP Editor
The SVP Editor is used to load and edit the sound speed profiles logged in .asvp or .actd
formatted files. This is a utility program to SIS and holds a number of tools to assist in
creating a good sound velocity profile, including manual editing.

The main user interface for the SVP Editor is shown in figure below.

Main menu

The main menu of the SVP Editor holds the following selections:
• File menu, see File menu on page 397
• Tools menu, see Tools menu on page 398
• Help menu
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Buttons
Select To

Copy selected row in the table. This allows you to add values to
the profile because a copied row can be edited.

Delete all selected rows in the table

Reset all selections that you have done

Redraw the profiles.
You have to use this button after selecting rows in order to identify
the selected value.
Redraw the profile using the depth scale that fills the display
window.
The profiles are by default drawn using 100 metres maximum
depth.
Recalculate an absorption coefficient in a cell from previous and
next values in that column.

Select your primary sound velocity profile.
All loaded profiles can be selected from the pull-down menu.
The primary SVP is drawn using red circles and white lines.

Select a secondary sound velocity profile.
Showing a second sound velocity profile is useful for quality
controlling the primary SVP.
The secondary using blue circles and green lines.
Set the start and maximum depth to be displayed.
When set the display window can be scrolled up and down
remaining the same relative scale.

The difference between minimum and maximum depth have to be
5 meters or more.

Set the minimum and maximum speed to be displayed.
The setting of these parameters can be useful to scroll the display
in the speed direction.

Automatically compute the best fit for minimum and maximum
speed.
The From speed and To speed settings are overridden.
Show the Raypaths chart, a tool for visualizing the effect a given
sound velocity profile has on propagation of the echo sounder
beams.

The graphical display

The loaded profiles will be displayed in a graphical display having depth and sound
velocity speed as vertical and horizontal axes.

The Numerical display

The numerical table to the right shows the data from the primary svp. You can at any
time change the values in this table. Press Return to see the effects in the profile.

When selecting a value in the profile, the row in the table will be selected as well. Note
that the table may be too big to fit in the window. You may have to scroll the table
to see the selected row.
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Raypaths chart

Raypaths chart is a tool for visualizing the effect a given sound velocity profile has on
propagation of the echo sounder beams. SVP effects will display nine sample beams
throughout the swath. The Raypaths chart also gives the opportunity to compare the
effect the use of two different sound velocity profiles will have on the beam propagation.

Raypaths chart on page 401

Note

The former SVP effects tool is now replaced by this functionality inside the SVP Editor.

File menu
• Open: Open a .asvp or .actd file and make the profile primary
• Open in editor: Open selected file in a separate raw editor program
• Save as: Save the primary svp with a name of your choice
• Save primary svp: Save the primary svp to its original file.

Note

The original file will be overwritten.

• Send primary svp to echosounder: Information about the primary svp is sent to SIS
where all mean absorption coefficients are recalculated using the depths found in
the .asvp file
If the selected profile have no associated absorption coefficients files a warning
message will be issued, and no absorption coefficients file updates will be performed.
Note

The svp must be selected in the Sound Speed frame in the Runtime parameters view,
for active use.

• Close primary svp: Close primary svp and remove it from the editor. Note that it
will not be saved.

• Close all: Close all profiles and remove them from the editor. Note that the profiles
are not saved.

• Exit: Exit the program. Note that unsaved profiles are not saved.
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Tools menu
• Check profile: Check that the primary sound speed profile not contains upwards

bends in the depth
• Check profile automatic: Automatic check for depth bends.
• Extend profile...: The current profile can be extended with values read from a file.

Note

The profiles must be of the same type, i.e. they must all be without absorption
coefficient files. A warning is given if svp’s of different types are used.

Note

Extending actd files may require manual work to verify the extended values are
correct.

• Extend profile: The profile will be extended down to 12,000 meters. Note that the
profile must be continuous for this operation to be carried out. If not all depths in the
profile are ascending, the rows where the depth is equal or above the previous row
will be selected. You can then press Delete rows and delete them. Now this operation
can be carried out. Extending an .actd file may require manual work to verify that
the extended values are correct.

• Extend2: The sound speed profile will be extended according to Leroy et. al. 2008:
“A new equation for the accurate calculation of sound speed in all oceans”. The
equation in Leroy et. al. calculates the sound speed profile from input of latitude,
temperature, salinity and pressure.

• Replace primary with data from secondary: If the primary svp contains depths from 0 to
12,000 meters and the secondary contains data from 0 to 100 meters, the values from 0
to 100 meters in the primary svp will be replaced with the data from the secondary svp.

• Thin profile: Thin the profile by removing some points. You have to enter a thinning
factor (0.01 to 3.0). The smaller the factor, the less thinning will be done. The results
from the thinning is then presented in a table, see the figure below. Note that this
operation requires that the profile is extended.

Thinning results table

The thinned primary svp is written to a file with thinned appended to the filename of the
primary svp. The thinned profile is then automatically read into SVP Editor.

The Thinning results table shows the results from using the original and the thinned
profile. Each table has selected beam pointing angles as columns and selected depths as
rows. The approximate depth used is listed in the column to the left.

Note that the depth used in the calculations will differ from this depth because the
raypath routine requires time as input, and the time is computed from the depth and the
average sound speed in the profile, which will be different from the true profile.
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In the first table the depths from the two profiles are shown, and in the second table the
horizontal placement is shown using both profiles.

In the text field on top you can set the difference between the two profiles to be shown.
If the difference between the original and the thinned profile is larger than the values
set (remember to press Return for the value to take effect), the background of the cell
will be set to red.

You can save these results to file by pressing the Print... button.

Press OK to return to the SVP Editor.
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Note

When receiving SSP datagrams from external sound velocity sensors the following
should be noted:
• S0x format types intended for immediate use and containing no errors will never start
the SVP Editor. If an error in detected the SVP Editor will be started only when
enabled.

• All other format types will start the SVP editor when received if the startup is enabled.

Related operational procedures
• How to collect the sound velocity profile on page 141
• How to use SmartTalk on page 142
• How to use csv2asvp on page 143
• How to use SVP Logger on page 144
• How to use SVP Manager on page 145
• How to use SVP Editor to convert an SVP file to .asvp format on page 147
• How to modify and load a sound speed profile into SIS on page 151

Related topics
• Raypaths chart on page 401
• SVP Logger on page 406
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Raypaths chart
Note

This functionality inside the SVP Editor is replacing the SVP effects tool in the previous
versions of SIS.

Raypaths chart is a tool for visualizing the effect a given sound velocity profile has on
propagation of the echo sounder beams. SVP effects will display nine sample beams
throughout the swath. Raypaths chart also gives the opportunity to compare the effect the
use of two different sound velocity profiles will have on the beam propagation.

Topics
• User interface on page 401
• What you see on page 404

Related operational procedures
• How to collect the sound velocity profile on page 141
• How to use SmartTalk on page 142
• How to use csv2asvp on page 143
• How to use SVP Logger on page 144
• How to use SVP Manager on page 145
• How to use SVP Editor to convert an SVP file to .asvp format on page 147
• How to modify and load a sound speed profile into SIS on page 151

Related topics
• SVP Editor on page 395
• SVP Logger on page 406

User interface

How to open Raypaths chart

Raypaths chart is a functionality in the SVP Editor:
1 In the SVP Editor click on the Show Raypaths Chart button. An area for the ray

paths will be shown in the in the SVP Editor together with the buttons Hide Raypaths
Chart and Update Raypaths Chart.

2 Click on the Update Raypaths Chart button and the beams for the selected primary
and secondary .asvp files will appear.
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How to use Raypaths chart
The File menu contains the following options:
1 Select File→Open.

This will bring up a file selection dialog where you select an asvp formatted sound
velocity profile file to use as primary or secondary sound speed profile.

2 Select your Primary SVP .asvp filename and press the Open button.
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The following window will be displayed.
3 Select File →Open.

This will again bring up the file selection dialog.
4 Select an asvp formatted sound velocity profile file again.
5 Click on the Primary SVP pull-down menu and select your primary sound velocity

profile.
6 Click on the Secondary SVP pull-down menu and select your secondary sound

velocity profile.
7 Click on the Update Raypaths Chart button and the beams for the selected primary

and secondary .asvp files will appear.

Zooming in and out
Zoom in by pressing the left mouse button on the top-left corner, hold down the mouse
button while dragging it to the lower-right corner and release the mouse button.

Zoom out by pressing the left mouse button in the lower-right corner, hold down the
mouse button while dragging it to the upper-left corner and release the mouse button.

Note

Zooming operations applies both to the Sound speed plot and the Across coverage plot.

Quick menu
By pressing right mouse button in the Raypaths chart area in the SVP Editor dialog box a
Quick menu will appear. This menu contains the following options:

• Properties: Allows you to set up the chart properties, such as labels, fonts, colours etc.
• Save as: Brings up a dialog that allows you to saves the plots as a PNG graphic file.
• Print: Opens a Page setup dialog where you can set your print preferences and print

the view.
• Zoom in/out: You can select to zoom in/out either the domain axis, the range axis

or both. Zooming will apply to where your mouse was positioned when the Quick
menu was opened.

• Auto range: Can be selected for either the domain axis, the range axis or both.
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Note

Zooming operations applies both to the Sound speed plot and the Across coverage plot.

What you see
For each sound velocity profile, either the reference or the compare SVP, the across
propagation for nine beams are displayed.

The nine beams are 0 degrees (straight down), then 10, 20, 30, 40, 50, 60, 70 and 80
degrees to the side. The depths and the across values are calculated for each beam for
each travelling time.
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SeaCast
SeaCast is a Windows based program that provides a user interface to AML’s latest
generation of water instrumentation.

SeaCast is not a Kongsberg Maritime software.

For further information please visit http://www.amloceanographic.com.

Note

The SmartTalkapplication from AML has been replaced with SeaCast. It is used to
interface with probes from AML and can be installed together with SIS or by launching
the installer from the Seacast folder on the SIS CD.

Related topics
• SVP Editor on page 395
• Raypaths chart on page 401
• SVP Logger on page 406

What it does
SeaCast is used to configure AML instruments, monitor data in real-time, and review
logged data.

How to install
The program can be installed using the SIS CD.

How it works
Normally the SeaCast program is located under C:\Program Files\SeaCast. If the .exe file
is not routed to the desktop, the SeaCast program can be started from this location.

The SeaCast user interface is divided into 3 pages or tabs:
• Instrument page: The Instrument page is the starting page for SeaCast. This page

allows the user to connect to and identify an instrument and its sensors.
• Setup page: The Setup page allows the user to view and modify the sampling and

logging settings of the instrument.
• View Data: The View Data page allows the user to view data in graphical or table

format.
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SVP Logger
SVP Logger logs raw data from Morse and AML SVP sensors and converts the data
to .asvp format

Related operational procedures
• How to collect the sound velocity profile on page 141
• How to use csv2asvp on page 143
• How to use SVP Logger on page 144
• How to use SVP Manager on page 145
• How to use SVP Editor to convert an SVP file to .asvp format on page 147
• How to modify and load a sound speed profile into SIS on page 151

Related topics
• SVP Editor on page 395
• Raypaths chart on page 401

Running the program
This program is an interface program for handling the Morse and AML SVP sensor.

For setting up the communication parameters for the probe, please refer to External
sensors on page 371

406 342682/D



SIS utilities

Using the program

The main user interface holds the following:
File to log raw data to...: Select the raw data destination file for the data from the SVP
sensor.
SVP file to write...: Set the filename the SVP will be written to. This file should end
with .asvp.
AML-format instead of Morse: If the button AML-format is enabled and not Morse, AML
and Valeport formats are accepted instead. Then this program can be used to create
sound speed profiles from these sensors as well.
Input format is meters not Bar: If the input format is meters, enable the checkbox Input
format is meters, not dBar. This will disable the conversion from dBar to meters. You
have to know in which format your sensor has been set up.
Send profile to SVP Editor: When you press Send profile to SVP Editor, SVP Editor will
load the .asvp file if the SVP Editor is up and running. Note that pressing this button
twice will NOT reload the file in the SVP Editor. If you want to send it again, you have
to close the file in the SVP Editor first and then press this button again.
Latitude in degrees: Enter the latitude in degrees. It is used to calculate the correct depth.
Surface pressure in bars: Enter the surface pressure in bars. It is used to calculate the
correct depth.
When you press Start, the values from the COM port will be displayed in the SVP
window. When you press Stop, the contents of the .asvp file is shown.
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Note

The .asvp file should be edited afterwards. The time and the location in the header is not
correct and must be corrected.

You must also make sure that the profile contains a values at exactly 0.0 and at 12,000
meters depth.

If the file contains a great number of values, you should consider thinning the values.
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SeaCal
SeaCal is a program used to compute the calibration values of the multibeam echo
sounder.

Related operational procedures
• How to determine calibration values using SeaCal automatic calibration on page 184

Related topics
• AutoCalib Wizard on page 380
• SeaCal results on page 381
• Seacal auto calibration on page 261

What it does
Reliable data from the multibeam echo sounder can only be acquired after proper
calibration of the static offsets in system parameters such as roll, pitch, heading,
eccentricity of the transducer relative the antenna of the positioning system etc.

This calibration method is based on global match of the calibration lines. It does not
presume that we have information about the true relief of the seafloor. The method
computes the calibration parameters from least squares adjustment, and it offers a broad
range of static offset parameters to be computed and the derivation of the correlation
between them. The program computes calibration parameters from parallel or crossing
lines. The calibration lines must follow straight lines, i.e., curved calibration lines are
not allowed. The number and the length of the lines are limited by the amount of
computer memory and the speed of the computer processor. The figure below shows
the coordinate axes used.

Figure 24 Definition of the coordinate axes
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Calibration parameters
SeaCal is able to compute several kinds of calibration parameters. The two main groups
of parameters are those common and individual for the lines. The following calibration
parameters are defined:

Symbol Definition

Roll ΔΦ Φ' = ΔΦ + Φ

Pitch Δω ω' = Δω + ω

Heading Δκ κ' = Δκ + κ

Translation in x Δx x0' = Δx + x0

Translation in y Δy y0' = Δy + y0

Relative tide correction Δh0 h0' = Δh + h0

Roll scale factor mΦ Φ' = mΦΦ

Horizontal scale factor my y' = myy

x is measured along the line and y is perpendicular to x, so y is measured in the swath
direction.

Factor mΦ is a kind of parameter related to the inner calibration of the multibeam echo
sounder, but it can also be explained by uncertain computation of the refraction of the
beams, i.e., the accuracy of the sound speed profile. Parameter my is a horizontal scale
factor in the swath direction. It is motivated from the influence of errors in the sound
speed.

Design of the calibration lines
The accuracy of the calibration depends on the topography of the seafloor, and the
configuration of the calibration lines. Therefore, the calibration lines should be located
in an area with satisfactory relief and they should follow a certain pattern, i.e., a
configuration that allows the computation of the parameters.

The Effect of offset figure below illustrates the effect of offsets in the calibration
parameters. From the figure we observe that calibration for heading and the two scale
factors require lines with parallel displacement. Offsets in roll, pitch, x and y are best
computed from lines in opposite directions which overlap each other 100%.
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Figure 25 Effect of offsets in the calibration parameters

Roll and roll scale have a vertical and a horizontal component. Their vertical component
makes it possible to calibrate them even in a flat area.

The horizontal component of ΔΦ has very similar influence on the measured depth
values as Δy. This correlation is not a problem in field calibration, since the vertical
component of ΔΦ separates it from Δy.

Offsets in pitch and x have also very similar error patterns. Therefore, the two parameters
are often highly correlated. Their separation depends on the relief of the seafloor. They
can be separated if the seafloor has satisfactory depth variation.

Pitch, heading and x calibration require that the lines run in the direction of the terrain
slope, whereas y and Y-scale calibration require terrain slope across the run direction.

Based on the geometric interpretation of the Effect of offset figure above, we can conclude
that we need at least three calibration lines in order to compute all the parameters, i.e.,
two 100% overlapping lines for the computation of ΔΦ, Δω, Δx and Δy, and a third
line for Δκ, mΦ and my.

Since the random measurement errors of the multibeam echo sounder and the relief of
the seafloor have great impact on the accuracy of the parameters, calibration lines in
addition to the minimum required will strengthen the calibration. For example, we can
apply four, eight or twelve lines as illustrated in the Configurations figure below. How
many lines to measure, depends on the relief of the seafloor, the period of time available
for the calibration etc., but as a rule eight crossing lines is recommended. Eight crossing
lines balance the requirement of accuracy and the cost of running the calibration lines.
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How to run SeaCal
There are several ways to run SeaCal, but to get a safe and fast verification of the
calibration parameters, the following procedure is recommended.
1 Apply eight crossing calibration lines as defined in the Configurations figure below.
2 Run the calibration with all parameters
3 Run the reliability computation
4 Introduce the calibration values with green reliability factor into the multibeam

system
5 Run a new calibration to verify the new settings
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Figure 26 Different configurations of calibration lines

Resolution
The resolution of the grid model applied in the calculation effects the computing time.
The option auto asks SeaCal to compute the resolution, but you can also define the
resolution manually.
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Maximum number of iterations
Usually, SeaCal needs two or more iterations to compute the calibration. You can define
the maximum number of iterations manually, or you select auto, i.e., SeaCal iterates
until the solution is stable.

More on the field calibration method
A strength of our approach is that all the survey lines are utilized in an optimal way, i.e.,
survey lines which cannot determine a parameter, will have minor influence on the
computation. For a thorough description of the method see [2].

Often the eccentricity of the transducer is measured by land surveying methods. Since
our calibration method considers the horizontal offsets in x and y, it can control that the
horizontal eccentricity values are loaded correctly into the multibeam system.

SeaCal computes calibration parameters based on least-squares adjustment as:

V =
(
ATP1A

)− 1
ATP1L1 (1.1)

where V is a vector of the unknown parameters, A a coefficient matrix, P1 a weight
matrix and L1 a vector of observations.

Since the stability of the system of equations depends on the relief of the seafloor and the
configuration of the calibration lines, restrictions are put on the unknown parameters by:

V =
(
ATP1A+ P2

)− 1 (
ATP1L1 + P2L2

)
(1.2)

where P2 is a weight matrix of the unknown parameters and L2 a vector of a priori
parameter value.

The variance-covariance matrix of the unknowns are computed from:

QV =
(
ATP1A+ P2

)− 1
(1.3)

Here, the diagonal elements define the variance of the parameters and the other elements
their covariance. Therefore, the variance σ2vi of parameter Vi is derived as:

σ2
vi = Qvii

and the covariance σvivj of the two parameters Vi and Vj is computed as:

σvivj = Qvij
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The correlation coefficient σVivj measures how separable two parameters Vi and Vj are
and is derived from QV as:

ρvivj =
σvivj
σviσvj

(1.4)

In multibeam echo sounder calibration we usually have limited knowledge of the
stochastic properties of the observations. Therefore, the standard deviation of the
parameters we compute from (1.3), will be too optimistic. For this reason, we define
a reliability factor R which measures the ability of the geometry to determine the
calibration parameters.

The computation of R is done in a simulation procedure. In the first round the calibration
V' is computed. Thereafter, the measurements are corrected according to vector ε of
offset values and a new calibration V'' is computed with ε as the start value of the
computation. Ideally, V' and V'' should be equal, but due to many error sources, the two
may be different. The reliability factor for parameter v is computed as:

R =
{

1 −
∣∣∣v
′− v′′
εv

∣∣∣ for |v′ − v′′| < |εv|
0Otherwise

(1.5)

From the definition we recognize that R is defined on the interval [0,1]. Factor 1.0 means
that the simulated offset is completely determined, but from the factor value considered,
we cannot draw the conclusion that the parameter is computed with no uncertainty. The
maximal factor value only tells us that we have a strong geometry. In general, we can
say that for low values of the reliability factor we should supplement the configuration
with additional calibration lines.

The interpretation of R must also consider the weight of the parameters. If R≈1, it may
happen that the parameter is given high weight. This is the case if the parameter is to be
fixed to its initial value.

The reliability test is very important since it gives a comprehensive control of the
calibration. Generally, it is hard to prove that a computer program works as it should, but
the reliability test covers both the implementation of the calibration procedure as well as
the configuration of the calibration lines.

The calibration lines must follow straight lines, i.e., curved calibration lines are not
allowed. The number and the length of the lines are limited by the amount of computer
memory and the speed of the computer processor.
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SIS Objects
This section describes how to operate SIS Objects. SIS Objects is a tool for adding points,
lines, images, text, polygons, video and html into the map in SIS.

Related topics
• Geographical – Display options on page 211
• Geographical – KSGPL edit mode on page 223

How to use SIS Objects

Basic concepts

SIS Objects must be configured before use. You must define your object types first. An
object type is based on one of the following basic types: line (2D), line (2.5D), i.e. depth
contours, area (polygon), point (2D), point (3D), image, video or HTML.

From one of the basic types, you create a new object type with a name and a definition
describing how that object type shall be drawn in the map. As and example, a new
object type can be coastline, which will be based on line (2D), and it may be drawn as a
solid green line two pixels wide.

Once all the object types have been defined, they can be written to a file. This file can
then be imported later. This means that you only have to define your object types once,
later you simply import them.

You can in the Geographical view use the Option button and select KSGPL in the left hand
tree structure to turn on/off object types to display. you can turn on/off all objects or
choose which types to see.

You can add, delete and select objects in the Geographical view by turning the KSGPL
objects on, and then enabling the K button in the frame toolbar. The K button turns the
Geographical view into KSGPL mode and allows you to edit the objects.

Starting SIS objects

SIS Objects is started from the Tools menu in SIS. Select Tools→Custom...→Objects The
following window will appear:
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SIS Objects will automatically try to connect to current active echo sounder and the
Geographical frame. If depths or positions are not received from the echo sounder, the
buttons DPT and POS to the lower left in above figure will be red, whilst they are green
when depths and positions are received. Connection to the Geographical frame shown by
red or green button labelled SIS. The SIS button is green when connection is established.
It will go red if there is no activity in the Geographical frame for a while, but will turn
green again as soon as the view changes.
SIS Objects uses a server application to talk to the Geographical view. This server must be
running. The button CNT will be green when the server is alive an well, red when it's
not. If the CNT button is red, restart SIS Objects.

Adding objects
1 Select the Geographical view.
2 Click the Option button from the toolbar.
3 Select KSGPL in the left hand side tree structure.
4 Make sure that KSGPL is enabled.
5 Select the object types you want to see by checking the appropriate check boxes in

the dialog on the right hand side.
6 Press the K button from the toolbar of the Geographical frame to add objects

This puts the Geographical view into KSGPL mode where you can edit objects.
7 Use Right Mouse button to pop up a menu in the Geographical view where you add

line or point objects.
8 Use Crtl+Left Mouse button to create the point or the line.
9 Press Right Mouse button to accept or cancel your point or line.
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Lines

Once the object is created SIS Objects dialog will appear. If you added a line, see
procedure above. There you can select which line type you want your line to be, i.e.
coastline, depth contour, dryfall etc. If you know you are going to be working with the
same object type for some time, like when you are adding a lot of coastlines, you can
check the button Use this type as default for all new lines and you will not see SIS Objects
dialog again as it will assume that all lines are of the selected type.

If the line is a 2.5D line (i.e. depth contour), you can set the depth for the line in the
text field.

Press Apply to accept the changes.

Points

If you added a point, SIS Objects will look like this:

This works the same way as for lines.
1 Choose the point type you want to add
2 Make it the default for all later points if you want to add many points of the same

type
3 Set the depth if the point type is 3D

The point type can always be Text. You may enter a text in the text field at the bottom of
the dialog and that text will appear where you added the point in the Geographical view.

If the type is of HTML or Video type, the complete path to the HTML or video must be
entered into the text field.
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Note

Remember to put “ ” around if the path name contains spaces.

Press Apply to accept the changes.

Markers
You can use Markers if an echo sounder is attached and operational.

1 Select the tab named Markers and the above dialog will appear.
2 choose which marker type you want the marker to be.

It can be any point type except for Text.
If the type is a 2D point, only the position will be used, 3D point types use the depth
below the waterline to find the z value. All these markers store the time from the
position together with the data so it is possible to later correct for tide, if necessary.

When you pressMARK NOW! the current position and the current depth will be used to
create an object of the selected type, and the object will appear in the Geographical view

Info/Select
You can select object in the Geographical View.
1 Enable the K button.
2 Move the mouse over the object and press right mouse button.

The selected objects will be sent to SIS Objects.
You can then see the selected objects in the tab labelled Info/Select.
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You may choose to delete the selected objects from this dialog.

Import and export of objects

You can import objects from file by pressing File→Read from file…. Then you select the
file with the data and the objects will appear in SIS Objects.

Note that this requires some synchronization with the object types in the database. Also
note that if you have added objects, they may be lost if the objects in the file have the
same id as your objects.

Objects can be exported to file by pressing File→Write to file…. You then choose the
name of the file you want to write to.

Additional information

Sometimes it may be necessary to resend all the object definitions to SIS. You do this by
pressing View→Update SIS with object types. This is necessary if the object types do not
appear in the Option→KSGPL list in the Geographical View.

Configuration of SIS Objects
In SIS Objects, select View→Advanced settings and two more tabs will appear.
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Settings

Here you can select the host where the database server is running. Note that this database
is different from the one SIS uses.
The selected objects are always passed on to the host:port defined here.
If an object of video type is selected, the video file will be passed as the first argument to
the video player application listed here. Note that “ ” are needed to avoid confusion with
spaces in the filename.
Objects of HTML type are likewise sent to the HTML viewer listed here.

Database

The tab named Database is where you define your object types.
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1 Define the main object type in the menu Select object type.
Choose from Line (2D), Line (2.5D), Area, Point 2D, Point 3D and Image.

2 Give the object type a name, e.g. Coastline, Manual Depth, etc.
3 Press the KSGPL… button to set the parameters for how to display objects of this

type.
4 Press OK to save the object type.

Different parameters which controls the display of object types:
• Line (2D) and Line (2.5D)

Line type can be either solid or dotted. The colour can be chosen from a palette that
appears when pressing Color….

• Area

Transparency sets the transparency of the area. The fill colour is chosen, and the line
type, width and colour for the surrounding polygon are also set.

• Point 2D and Point 3D
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The colour and the point size in pixels are defined for 2D and 3D points.
• Image

An image type is defined by which image it displays. Note that the file type is *.sgi,
i.e. Silicon Graphics File Format.

• Two more types, HTML and Video can also be defined. The KSGPL for these types
is the same as for a 2D point.

Object types can be saved to file by pressing Save object definitions to file… . Then select
the filename and the object definitions are stored.
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Object types can be read from file by pressing Read object definitions from file… . Then
select the file name and the object types are loaded into the database. Note that existing
object types with the same name as one in the file, will be deleted and the definition
in the file will be used.
It is also possible to delete and edit object types. Note that deleting an object type,
automatically deletes all objects of that type as well.

Press Delete object type to delete the object type. Note that the objects will still be
displayed in the Geographical View until SIS is restarted. Press KSGPL to change the
way the object type is displayed; line type solid/dotted, line with, point type, etc.

Technical references
SIS Objects cannot be used if some other application is using KSGPL at the same time.

Selected object datagram format
When the operator selects an object in SIS GeoView, SIS Objects will send information
about the selected object to the UDP host:port defined. The format is:
0 27 MyPoint 59.32114415 18.10475915 2008-04-11T15:01:08

• First item in the message is the basic type (see the database definition file below),
then the database id, then the name of the type as defined by the operator. The rest
is depended upon the basic type. For 0 above, the position (latitude in degrees and
longitude in degrees) and time is given as shown.

1 6 Kaidybde 59.32112343 18.08118750 33.00000000
2008-04-11T09:29:14

• 3D points also have the depth after the position.
8 23 Nyheter "usatoday.com" 59.32681627 18.08416633

• HTML objects have the web-address before the position.
7 9 MyVideo "C:/12angrymen_trailer.mov" 59.32295218 18.08355627
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• Video objects have the path to the video. Note that the directory separator is /, not \.
5 8 bilde 59.32028155 18.09755164

• An image
4 7 59.32223918 18.08571897 Survey this area with EM3002

• Text object
2 3 TopasTracline -999999.000000 2008-04-15T12:46:50
-9 -9 59.33072409 18.08834272 59.32890464 18.10877874
59.32121934 18.11104439 59.32034466 18.13219046
59.31490604 18.13276897 59.31145264 18.11383809
59.30930524 18.09206320 59.31259050 18.07563680

• A 2D line has -999999.000000 as depth, and -9 -9 after the timestamp. The positions
are latitude and longitude in degrees.

3 33 Dybdekurve 55.800000 2008-04-16T12:34:06
-9 -9 59.31115771 18.0 1625823
59.29008772 18.04918203
59.28745531 18.11027601

• A 2.5D line has a depth different from -999999.000000
Right before or right after a line/polygon object, this message is sent:
PICKED_POS 59.18845234 18.23549827 PICKED_POS_DONE

This message contains the exact position where the operator pressed the mouse when he
selected the line. This can be used for accurate positioning within the selected line.

File formats
There are two file formats used by SIS Objects. The files are ascii XML files, and the
XML format is defined using XML schemas, aka.xsd files.
There are three schema definitions:
• Objects
• Object type definitions
• Database definitions
The formats of these schema definitions are described in the following.

Objects
<rule:schema xmlns:rule="http://www.w3.org/2001/XMLSchema">

<rule:annotation>
<rule:documentation xml:lang="en">

Object file for SIS Objects
Copyright: Kongsberg

</rule:documentation>
</rule:annotation>

<rule:annotation>
<rule:documentation xml:lang="en">

This is the structure of the definition file.
First there is a header, then a list of object types

</rule:documentation>
</rule:annotation>
<rule:element name="ObjectFile">

<rule:complexType>
<rule:sequence>
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<rule:element name="FileVersion" type="rule:integer"/>
<rule:element name="Created" type="rule:dateTime"/>
<rule:element name="ObjectFileItem" type="ObjectFileUnion"

minOccurs="0" maxOccurs="unbounded"/>
</rule:sequence>

</rule:complexType>
</rule:element>

<rule:annotation>
<rule:documentation xml:lang="en">

Point 2D
</rule:documentation>

</rule:annotation>
<rule:group name="Point2D">

<rule:sequence>
<rule:element name="Point2D_ID" type="rule:integer"/>
<rule:element name="Point2D_Objtype" type="rule:string"/>
<rule:element name="Point2D_Time" type="rule:dateTime"

minOccurs="0" maxOccurs="1"/>
<rule:element name="Point2D_NorthDegr" type="rule:double"/>
<rule:element name="Point2D_EastDegr" type="rule:double"/>

</rule:sequence>
</rule:group>

<rule:annotation>
<rule:documentation xml:lang="en">

Point 3D
</rule:documentation>

</rule:annotation>
<rule:group name="Point3D">

<rule:sequence>
<rule:element name="Point3D_ID" type="rule:integer"/>
<rule:element name="Point3D_Objtype" type="rule:string"/>
<rule:element name="Point3D_Time" type="rule:dateTime"

minOccurs="0" maxOccurs="1"/>
<rule:element name="Point3D_NorthDegr" type="rule:double"/>
<rule:element name="Point3D_EastDegr" type="rule:double"/>
<rule:element name="Point3D_DepthMeters" type="rule:double"/>

</rule:sequence>
</rule:group>

<rule:annotation>
<rule:documentation xml:lang="en">

Line, 2D. Also areas are created here; typename defines how
this line is used.

</rule:documentation>
</rule:annotation>
<rule:group name="Line">

<rule:sequence>
<rule:element name="Line_ID" type="rule:integer"/>
<rule:element name="Line_Time" type="rule:dateTime"

minOccurs="0" maxOccurs="1"/>
<rule:element name="Line_Coordinates2D" type="Coordinates2D"

minOccurs="2" maxOccurs="unbounded"/>
<rule:element name="Line_Objtype" type="rule:string"/>

</rule:sequence>
</rule:group>
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<rule:annotation>
<rule:documentation xml:lang="en">

Line 2.5D
</rule:documentation>

</rule:annotation>
<rule:group name="Line25D">

<rule:sequence>
<rule:element name="Line25D_ID" type="rule:integer"/>
<rule:element name="Line25D_Time" type="rule:dateTime"

minOccurs="0" maxOccurs="1"/>
<rule:element name="Line25D_Depth" type="rule:double"/>
<rule:element name="Line25D_Coordinates2D" type="Coordinates2D"

minOccurs="0" maxOccurs="unbounded"/>
<rule:element name="Line25D_Objtype" type="rule:string"/>

</rule:sequence>
</rule:group>

<rule:annotation>
<rule:documentation xml:lang="en">

Text
</rule:documentation>

</rule:annotation>
<rule:group name="Text">

<rule:sequence>
<rule:element name="Text_ID" type="rule:integer"/>
<rule:element name="Text_Objtype" type="rule:string"/>
<rule:element name="Text_Time" type="rule:dateTime"

minOccurs="0" maxOccurs="1"/>
<rule:element name="Text_NorthDegr" type="rule:double"/>
<rule:element name="Text_EastDegr" type="rule:double"/>
<rule:element name="Text_text" type="rule:string"/>

</rule:sequence>
</rule:group>

<rule:annotation>
<rule:documentation xml:lang="en">

Image
</rule:documentation>

</rule:annotation>
<rule:group name="Image">

<rule:sequence>
<rule:element name="Image_ID" type="rule:integer"/>
<rule:element name="Image_Objtype" type="rule:string"/>
<rule:element name="Image_Time" type="rule:dateTime"

minOccurs="0" maxOccurs="1"/>
<rule:element name="Image_NorthDegr" type="rule:double"/>
<rule:element name="Image_EastDegr" type="rule:double"/>

</rule:sequence>
</rule:group>

<rule:annotation>
<rule:documentation xml:lang="en">

Video
</rule:documentation>

</rule:annotation>
<rule:group name="Video">

<rule:sequence>
<rule:element name="Video_ID" type="rule:integer"/>
<rule:element name="Video_Objtype" type="rule:string"/>
<rule:element name="Video_Time" type="rule:dateTime"

minOccurs="0" maxOccurs="1"/>
<rule:element name="Video_NorthDegr" type="rule:double"/>
<rule:element name="Video_EastDegr" type="rule:double"/>
<rule:element name="Video_path" type="rule:string"/>

</rule:sequence>
</rule:group>
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<rule:annotation>
<rule:documentation xml:lang="en">

Html
</rule:documentation>

</rule:annotation>
<rule:group name="Html">

<rule:sequence>
<rule:element name="Html_ID" type="rule:integer"/>
<rule:element name="Html_Objtype" type="rule:string"/>
<rule:element name="Html_Time" type="rule:dateTime"

minOccurs="0" maxOccurs="1"/>
<rule:element name="Html_NorthDegr" type="rule:double"/>
<rule:element name="Html_EastDegr" type="rule:double"/>
<rule:element name="Html_path" type="rule:string"/>

</rule:sequence>
</rule:group>

<rule:annotation>
<rule:documentation xml:lang="en">

This is a union of all object types.
</rule:documentation>

</rule:annotation>
<rule:complexType name="ObjectFileUnion">

<rule:sequence>
<rule:choice>

<rule:group ref="Line"/>
<rule:group ref="Line25D"/>
<rule:group ref="Point2D"/>
<rule:group ref="Point3D"/>
<rule:group ref="Image"/>
<rule:group ref="Text"/>
<rule:group ref="Video"/>
<rule:group ref="Html"/>

</rule:choice>
</rule:sequence>

</rule:complexType>

<rule:annotation>
<rule:documentation xml:lang="en">

2D coordinate
</rule:documentation>

</rule:annotation>
<rule:complexType name="Coordinates2D">

<rule:sequence>
<rule:element name="NorthDegr" type="rule:double"/>
<rule:element name="EastDegr" type="rule:double"/>

</rule:sequence>
</rule:complexType>

</rule:schema>

Object type definitions
<rule:schema xmlns:rule="http://www.w3.org/2001/XMLSchema">

<rule:annotation>
<rule:documentation xml:lang="en">

Object definition file for SIS Objects
Copyright: Kongsberg

</rule:documentation>
</rule:annotation>

<rule:annotation>
<rule:documentation xml:lang="en">

This is the structure of the definition file.
First there is a header, then a list of object types

</rule:documentation>
</rule:annotation>
<rule:element name="ObjectDefinitionFile">

<rule:complexType>
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<rule:sequence>
<rule:element name="FileVersion" type="rule:integer"/>
<rule:element name="Created" type="rule:dateTime"/>
<rule:element name="ObjectDefinition" type="ObjectUnion"

minOccurs="0" maxOccurs="unbounded"/>
</rule:sequence>

</rule:complexType>
</rule:element>

<rule:annotation>
<rule:documentation xml:lang="en">

Line 2D
</rule:documentation>

</rule:annotation>
<rule:group name="Line2D">

<rule:sequence>
<rule:element name="ObjectTypeNameLine2D" type="rule:string"/>
<rule:element name="LineType" type="rule:string"/>
<rule:element name="Width" type="rule:integer"/>
<rule:element name="Color" type="rule:string"/>

</rule:sequence>
</rule:group>

<rule:annotation>
<rule:documentation xml:lang="en">

Line 2.5D
</rule:documentation>

</rule:annotation>
<rule:group name="Line25D">

<rule:sequence>
<rule:element name="ObjectTypeNameLine25D" type="rule:string"/>
<rule:element name="LineType" type="rule:string"/>
<rule:element name="Width" type="rule:integer"/>
<rule:element name="Color" type="rule:string"/>

</rule:sequence>
</rule:group>

<rule:annotation>
<rule:documentation xml:lang="en">

Area
</rule:documentation>

</rule:annotation>
<rule:group name="Area">

<rule:sequence>
<rule:element name="ObjectTypeNameArea" type="rule:string"/>
<rule:element name="LineType" type="rule:string"/>
<rule:element name="Width" type="rule:integer"/>
<rule:element name="AreaColor" type="rule:string"/>
<rule:element name="AreaTransparency" type="rule:integer"/>
<rule:element name="Color" type="rule:string"/>

</rule:sequence>
</rule:group>

<rule:annotation>
<rule:documentation xml:lang="en">

Area 3D
</rule:documentation>

</rule:annotation>
<rule:group name="Area3D">

<rule:sequence>
<rule:element name="ObjectTypeNameArea3D" type="rule:string"/>
<rule:element name="LineType" type="rule:string"/>
<rule:element name="Width" type="rule:integer"/>
<rule:element name="AreaColor" type="rule:string"/>
<rule:element name="AreaTransparency" type="rule:integer"/>
<rule:element name="Color" type="rule:string"/>

</rule:sequence>
</rule:group>
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<rule:annotation>
<rule:documentation xml:lang="en">

Point 2D
</rule:documentation>

</rule:annotation>
<rule:group name="Point2D">

<rule:sequence>
<rule:element name="ObjectTypeNamePoint2D" type="rule:string"/>
<rule:element name="Width" type="rule:integer"/>
<rule:element name="Color" type="rule:string"/>

</rule:sequence>
</rule:group>

<rule:annotation>
<rule:documentation xml:lang="en">

Point 3D
</rule:documentation>

</rule:annotation>
<rule:group name="Point3D">

<rule:sequence>
<rule:element name="ObjectTypeNamePoint3D" type="rule:string"/>
<rule:element name="Width" type="rule:integer"/>
<rule:element name="Color" type="rule:string"/>

</rule:sequence>
</rule:group>

<rule:annotation>
<rule:documentation xml:lang="en">

Image
</rule:documentation>

</rule:annotation>
<rule:group name="Image">

<rule:sequence>
<rule:element name="ObjectTypeNameImage" type="rule:string"/>
<rule:element name="ImagePath" type="rule:string"/>

</rule:sequence>
</rule:group>

<rule:annotation>
<rule:documentation xml:lang="en">

Point with video
</rule:documentation>

</rule:annotation>
<rule:group name="Video">

<rule:sequence>
<rule:element name="ObjectTypeNameVideo" type="rule:string"/>
<rule:element name="Width" type="rule:integer"/>
<rule:element name="Color" type="rule:string"/>

</rule:sequence>
</rule:group>

<rule:annotation>
<rule:documentation xml:lang="en">

Point with html
</rule:documentation>

</rule:annotation>
<rule:group name="Html">

<rule:sequence>
<rule:element name="ObjectTypeNameHtml" type="rule:string"/>
<rule:element name="Width" type="rule:integer"/>
<rule:element name="Color" type="rule:string"/>

</rule:sequence>
</rule:group>

<rule:annotation>
<rule:documentation xml:lang="en">

This is a union of all object types.
</rule:documentation>

</rule:annotation>
<rule:complexType name="ObjectUnion">
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<rule:sequence>
<rule:choice>

<rule:group ref="Line2D"/>
<rule:group ref="Line25D"/>
<rule:group ref="Area"/>
<rule:group ref="Area3D"/>
<rule:group ref="Point2D"/>
<rule:group ref="Point3D"/>
<rule:group ref="Image"/>
<rule:group ref="Video"/>
<rule:group ref="Html"/>

</rule:choice>
</rule:sequence>

</rule:complexType>

</rule:schema>

Database definition

Here is the sql file used to define the database used by SIS Objects. The connection to the
database is assumed to be an ODBC-connection named KSGPLDB where the database
name is KSGPLDB. The user is KSGPL and the password is simrad0. If objects are
added to the database outside of SIS Objects, i.e. by an external application, a datagram
can be sent to force SIS Objects to redraw all objects so that also the new object can be
seen. Then send this datagram on UDP to
localhost:5688 $KSSIS,8802\n\r
/* ------------------------------------------------------------------------------- */
/* */
/* Create tables and views for KSGPLDB used by SIS_objects */
/* */
/* This file is for SIS 3.6 and used by SIS_Object */
/* */
/* For later releases new files: ksgpldef_v*.sql has to be made */
/* */
/* KSGPLDB runs on a Postgres server on both Windows and Linux */
/* */
/* Terje Pedersen Mar-2008 */
/* */
/* Berit Horvei 28-Mar-2008 */
/* ------------------------------------------------------------------------------- */

/* Don't drop the tables, in later SIS releases than SIS 3.6, the database can be kept*/
/* The user can select to delete the database*/
/* drop view if exists line25d;
drop view if exists text3d;
drop table if exists boundingbox;
drop table if exists timed;
drop table if exists image;
drop table if exists texts;
drop table if exists polygon;
drop table if exists polygon3D;
drop table if exists line2d;
drop table if exists video;
drop table if exists html;
drop table if exists z3;
drop table if exists timed;
drop table if exists point2d;
drop table if exists point3d;
drop table if exists keys;
drop table if exists name_type; */
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/* This is the name of the type, i.e. depthcontour, coastline, etc.
type = 0: point2d
type = 1: point3d
type = 2: line2d
type = 3: line25d
type = 4: texts
type = 5: image
type = 6: polygon3D
type = 7: video
type = 8: html
type = 9: polygon2D

*/

create table ksgpl_version (current_version int NOT NULL,
current_versionname varchar(20) NOT NULL);

insert into ksgpl_version (current_version, current_versionname) values (1,'1.0');

create table name_type (name varchar(200) unique primary key, obj_id int unique not null,
type int not null check(type >= 0) check(type <= 9), ksgpl varchar(200) not null);

/* All objects in the database MUST have a unique integer identifier.
Therefore all objects must link to the table keys for their id.
For each id there must be a connection to the name_type. */

create table keys (id int unique primary key, name varchar(200) not null,
foreign key(name) references name_type);

/* 2D points go here. They are linked to name_type, of course. */
create table point2d (id int unique primary key, northDegr double precision not null,

eastDegr double precision not null, foreign key(id) references keys);

/* 3D points. */
create table point3d (id int unique primary key, northDegr double precision not null,

eastDegr double precision not null, zMeters double precision not null,
foreign key(id) references keys);

/* 2D lines. Note that lines may be very long, and the coordinates are stored in a character string.
Because this string may be longer than 2048, the length of one row in this table,
several rows may be used for one line.
Each line is thus split into segments, and when put together, all the coordinates
from all the segments will be the whole line.
Note that it is the responsibility of the programmer to put the coordinates in the right segments.*/

create table line2d (id int, sequence smallint not null, coordinates varchar(2048) not null,
foreign key(id) references keys);

/*2.5D lines are line2d where the id has a corresponding id in z25d. */

/* Polygon, note that this polygon is 2D.
This is only a reference to line2d */

create table polygon (id int unique primary key, foreign key(id) references keys);

/* Polygon, note that this polygon is 3D, which only means the the coordinates contain z as well */
create table polygon3D (id int unique primary key, foreign key(id) references keys);

/* Here is the depth value of the 2.5D lines, z-value for text (if present) */
create table z3d (id int unique primary key, zMeters double precision not null,

foreign key(id) references keys);

/* Here are texts. They may be 3D in which case they have a reference to z25d. */
create table texts (id int unique primary key, northDegr double precision not null,

eastDegr double precision not null, text varchar(200) not null, foreign key(id) references keys);

/* Images to be dislayed goes here */
create table image (id int unique primary key, northDegr double precision not null,

eastDegr double precision not null, foreign key(id) references keys);

/* Videos goes here */
create table video (id int unique primary key, northDegr double precision not null,

eastDegr double precision not null, path varchar(500) not null, foreign key(id) references keys);
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/* HTML-pages goes here */
create table html (id int unique primary key, northDegr double precision not null,

eastDegr double precision not null, path varchar(500) not null, foreign key(id) references keys);

/* Some objects may be registred with a timestamp.
If so, the timestamp is here. */

create table timed (id int unique primary key, yyyymmdd int not null, hhmmss int not null,
foreign key(id) references keys);

/* To find objects in an area more easily, a bounding box for lines and areas are created */
create table boundingbox(id int unique primary key, minNorthDegr double precision not null,

minEastDegr double precision not null, maxNorthDegr double precision not null, '
maxEastDegr double precision not null, foreign key(id) references keys);

/* View to find all 2.5D lines */
create view line25d as select z3d.id, sequence, coordinates, zMeters from line2d,

z3d where line2d.id = z3d.id;

/* 3D texts */
create view text3d as select z3d.id, northDegr, eastDegr, zMeters from texts,

z3d where texts.id = z3d.id;

/* This table contains two files, the schema files used to define the xml-format
for object types and objects. */

create table xsd (id int /* 1 means object types, 2 means object definition schema */
not null, xsd_schema varchar (20000) not null);
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Logging utilities
Any data that is input across the computer network to either the SIS computer or to the
PU can be logged using the utilities described in this section.

Topics
• Logging of input on SIS sockets on page 435
• Logging of input on PU sockets on page 438

Logging of input on SIS sockets
This is a feature primarily intended for support and maintenance activities, e.g. to verify
reception of input on sockets and further to validate the received data content.
The logged input data is presented in an hexadecimal format with an additional ASCII
representation where all unprintable characters are represented by a dot.
There are two logging alternatives:
• SIS Data Logger for SIS sockets logging on page 435
• Command based SIS sockets logging on page 436

SIS Data Logger for SIS sockets logging

This alternative for logging of incoming data on a SIS socket is based on the use of an
separate utility program, SIS Data Logger:

The program is started from Tools→Custom...→SIS Data Logger.
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The program will send a command to the relevant socket for start and stop logging.
When logging is active the data received on the SIS socket will be re-transmitted out on
another socket and received by the logger program. The logger program is responsible
for decoding, displaying and storing the data.

In contrast to alternative 2 below the operator may now get a running update of the
received data in the display while the data is being logged.

The following input parameters and controls are available:
• Host: This is the IP address of the HWS where SIS is residing. Currently this should

always be the 127.0.0, i.e. the SIS Data Logger program must always run on the
same computer as SIS.

• Port: This is a drop down list of some fixed SIS sockets. In addition the user may
manually enter a SIS socket, however see Remarks about SIS sockets on page 437
below.

• Use default storage:
When selected (ticked) a predefined set of storage options are used:
– The default directory is:

...sisdata/common/maintenance

– The default file name is:
SIS_yyyymmdd_hhmmss.log
where the date and time is the UTC time when logging is started.

When the operator un-ticks this selection a pop-up is displayed allowing the user to
select an alternative storage location and a file name. Note that if the file already
exists the new logged information will be appended to the existing file.

• Log File: This element contains currently selected storage folder and is used for
display only.

• Log button: The logging operation is turned on and off on the set socket using the
log button.
When logging is active all user selections are inactive (i.e. gray coloured). To change
the host and port settings as well as the storage settings the logging must be turned off.

• Options→Show Datagram Prefix is used to turn the info line printed at the head of
each datagram packet on or off.
The info line contains packet size and a time tag.

Command based SIS sockets logging

This alternative is a low level solution based on internal SIS functionality for decoding
and storing received data. No running update of logged data is available. This is in
contrast to alternative 1 in SIS Data Logger for SIS sockets logging on page 435 which
uses an external program for this purpose.
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The logging activity is started or stopped by sending the relevant socket a command
message.
A perl script, portlog.pl, has been implemented to assist the operator in sending these
commands. The portlog.pl script is found in the SIS installation ...bin directory.
To run the portlog.pl script open a command window and start the script using the
following syntax:
portlog <port no> <ON or OFF> <dir name> <file name>

Where:
• <port no> is the SIS port to log
• <ON or OFF> turns logging on or off respectively.
• <dir name> is optional. This is the directory used to store the logged file.
• <file name> is optional. This is the name of the logged file.
e.g.: portlog 4001 ON

If the directory and/or file names are omitted the following default values will be used:
• The default directory is:

...sisdata/common/maintenance

• The default file name is:
SIS_Input_yyyymmdd_hhmmss.log
where the date and time is the UTC time when logging is started.

Remarks about SIS sockets

Note that the sockets used by SIS are of two types:
• Fixed sockets used by invariant SIS modules (like SIS main GUI, CCU etc.)
• Sockets allocated dynamically when new echo sounders are detected for the first time
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In some cases the operators may also specify ports dynamically for e.g. logging purposes.
The former (fixed) type may use permanently allocated port numbers whereas the latter
type uses port numbers allocated sequentially from a set start point (currently 16000).
The following are some standard fixed and explicitly defined port numbers:
• Port 4001 is used by the SIS module called CCU for receiving messages from other

SIS modules and in addition the following external input:
– SSP datagrams (i.e. S00–S53 currently) containing sound velocity and CTD

profiles
– $KSSIS,80 with sound velocity at transducer
– $ATIDE datagrams with tide
– R20 remote datagram

• Port 4002 is used by SIS main GUI for receiving messages from other SIS modules,
in addition to the following external input:
– R00, R10, R12 remote datagrams for controlling SIS pinging and logging
– Port 5602 is used for Applanix PosMV TrueHeave logging. See Runtime

parameters→GPS and Delayed Heave
• Port explicitly defined by user for Seapath Real Heave logging. See Runtime

parameters→GPS and Delayed Heave.
• Port explicitly defined by user for Seapath RTCM logging. See Runtime

parameters→GPS and Delayed Heave.
Note

Dynamically allocated port numbers associated with specific echo sounders are defined
in the SIS database and requires specialist knowledge to be found. They are therefore as
a consequence omitted in this description.

More information
• GPS and delayed heave on page 323

Logging of input on PU sockets
This feature is primarily intended for support and maintenance activities e.g. to verify
reception of input on PU sockets and further to validate the received data content.
The logged input data is presented in an hexadecimal format with an additional ASCII
representation where all unprintable characters are represented by a dot.
Logging of PU sensor input is only available on the new generation of echo sounders:
• EM 122
• EM 302
• EM 710
• EM 2040
• EM 2040C
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• EM 3002
Note

Always remember to turn logging off when finished. No automatic shut off is provided.
Neglecting to terminate logging will increase the load on the PU and HWS system and
the disk capacity for storage of logged data will suffer.

SIS Data Logger for PU sockets

This alternative for logging of incoming data on a SIS socket is based on the use of an
separate utility program, SIS Data Logger:

The program is started from SIS using Tools→Custom...→SIS Data Logger.
The program will send a command to the relevant PU for starting and stopping logging.
When logging is active the PU will transmit the data from the sensor input out on a
port received by the external program. The external program will be responsible for
decoding, displaying and logging the data.
In contrast to alternative 2, PU sensor input logging on page 440, you may now get a
running update of the received data in the display as the data is being logged.
The following input parameters and controls are available:
• Select Echo Sounder: This drop down list will contain currently started echo sounder(s)

only. (It is only possible to log on echo sounders that have been started by SIS).
• PU Sensor Port: The PU sensor input port to log from. The possible port selections

are normally the same as listed in the top row in PU sensor status→PU sensor input
status frame.
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• Use default storage: When selected (ticked) a predefined set of storage options are
used:
– The default directory is:

...sisdata/common/maintenance

– The default file name is:
PU_yyyymmdd_hhmmss.log
where the date and time is the UTC time when logging is started.

When the operator un-ticks this selection a pop-up is displayed allowing the user to
select an alternative storage location and a file name. Note that if the file already
exists the new logged information will be appended to the existing file.

• Log File: This element contains currently selected storage folder and is used for
display only.

• Log button: The logging operation is turned on and off using the log button whereby
all necessary logging information is sent to currently selected PU.
When logging is active all user selections are inactive (i.e. gray coloured). To change
the PU sensor port setting and the storage settings logging must be off.

• Options→Show Datagram Prefix is used to turn the info line printed at the head of
each datagram packet on or off.
The info line contains packet size and a time tag.

PU sensor input logging

This alternative is a low level solution based on internal SIS functionality for decoding
and storing received data. No visual update of the decoded stored data is provided. This
is in contrast to alternative 1 in SIS Data Logger for PU sockets on page 439 where a
separate program is used giving a running update when logging.

The operator interface for controlling this alternative is located in the PU sensor status
→PU sensor input logging frame:
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The PU sensor input logging interface is enabled and displayed using the following key
combination for the above listed type of echo sounders:
Shift+Ctrl+Alt+RightMouseButtonRelease:

The following input parameters and controls are available:
• Port: The PU sensor input port to log from. The possible port selections are normally

the same as listed in the top row in PU sensor input status interface.
• Use default storage:

When selected (ticked) a predefined set of storage options are used:
– The default directory is:

...sisdata/common/maintenance

– The default file name is:
PU_Input_yyyymmdd_hhmmss.log
where the date and time is the UTC time when logging is started.

When the operator un-ticks this selection a pop-up is displayed allowing the user to
select an alternative storage location and a file name. Note that if the file already
exists the new logged information will be appended to the existing file.

• Log folder: This element contains currently selected storage folder and is used for
display only.
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• Log button: The logging operation is turned on and off using the log button whereby
all necessary logging information is sent to the currently active PU. The button colour
and text reflects current logging status:
– Red: Not logging
– Green: Logging
When logging is active the Port selection and Use default storage tick button is inactive
(i.e. gray coloured). To change the PU sensor port setting and the storage settings
logging must be off.

Note

The maximum log file storage size is 2Gb. If this limit is reached logging to file stops.
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C-MAP CM-93/3
Note

C-Map features are visible in SIS only if C-Map is installed.

Related topics
• C-MAP detail level on page 41
• C-MAP – Licence administration on page 379
• Geographical – C-MAP manipulation mode on page 225

What it does
The C-MAP CM-93/3 Professional is a global chart database intended for use on
advanced electronic charting and navigation systems.

CM-93/3 supports all the new object classes and attributes defined by S-57 Ed. 3.0, as
well as the S-57 data model and updating mechanism.

Note

The information in this chapter originates from C-MAP technical documentation.

Specification of minimum performance
The C-MAP CM-93/3 Software Development Kits (version 3.0) have been designed to
allow manufacturers to implement the various C-MAP CM-93/3 chart databases into
their navigation and land based systems. In order to ensure that the CM-93/3 cartography
is used and displayed correctly within manufacturers systems, the Specification of
Minimum Performance document to which we will run a system audit on completion of
the software development.

C-MAP S-57 Verifier and CM-93/3 Compiler

Installation

The S-57 verifier and CM-93/3 compiler (hereafter called the compiler) is installed
together with the software distributed by the manufacturer. When this software is
installed you should ensure that the eToken (part number: CM-eToken-S57) is inserted
into one of the available USB sockets. This eToken is used to unlock the compiler
and to license CM-93/3 charts. Once the software is installed clicking on the icon will
start the compiler.

The compiler main screen looks approximately as follows:
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Using the compiler
Browse to the location of the stored S-57/3 charts in the left hand window (normally in
an ENC_ROOT directory), and enter the issuing Hydrographic Office at the top of the
right hand window. The issuing Hydrographic Office code is always the same as the first
two letters of the file name. For example a Norwegian ENC may read something like
“NO2B0412.000” and therefore the issuing HO code is “NO”.
Enter the destination path for the compiled database. This should be an existing directory
on the hard disk (for example C:\ENC).
Click on Execute to compile the S-57/3 charts to CM-93/3. If the S-57/3 is fully
compliant with the IHO specification, the charts will be compiled into a local CM-93/3
database and automatically registered in the database administrator. They can then be
viewed on the screen by either setting the ENC database as default or by opening the
application and go to the Add Database option to add the recently imported S-57/3
into the current view.
During the verification phase it may become evident that the S-57 files being imported
are not fully compliant with the S-57/3.1 specification. If this is the case then one
or more warnings or errors will be displayed and the user will be given the choice to
CONTINUE (in which case the compiler will continue verification but not compiler the
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database), to SKIP (the database will be compiled but may contain serious errors) or to
CANCEL. In general warning messages will not stop the compilation process but errors
may cause the database to be incorrect or even the system displaying them to crash.

The C-MAP Cartographic Service

Overview

The system that you are now using has the capability of using and displaying the latest
C-MAP CM-93/3 worldwide vector chart database. These charts are fully compliant
with the latest IHO S-57 3.1 specifications and, when using the CM-93/3 ENC database
in an approved ECDIS, are considered equivalent to the navigational charts required by
the SOLAS (Safety Of Life At Sea) convention.

In order to prepare the system for use with the C-MAP CM-93/3 database, there are a
number of things that will first need to be carried out: -

Registration of the system at C-MAP Norway

When a system is installed that has the capability to use the CM-93/3 database, it is
required that an Aladdin eToken supplied by C-MAP is connected to the system (if
the system has and supports USB). The eToken provides the system with a unique
System ID that enables C-MAP to issue correct licenses. The actual System ID can
be found on the eToken itself, on the back of the installation CD box or on a sticker
placed on the equipment. This ID must be quoted on all chart orders, either by email
(license@c-map.no) or by fax +47 51 46 47 01.

When a system does not have a USB port or does not have support for the eToken, a
file called USER.USR will be automatically created during initial installation (normally
in the Program Files\CM93v3 SDK directory). This file contains the Company ID and
System ID assigned to the ECDIS/ECS system when it is installed. These ID’s can be
found on the back of the installation CD box or on a sticker placed on the equipment.
This file must always be sent to C-MAP Norway by email (license@c-map.no) when
installing the software. Licenses can only be generated once this file has been received
and registered by C-MAP. It is important to note that the software may need to be
reinstalled and reinitialised if the operating system or hardware is upgraded (see the
troubleshooting section).

Please note that in some cases the manufacturer of the system will have already
pre-registered the system by sending the USER.USR file to C-MAP.

If during installation you do not know your Company ID or System ID, please contact
C-MAP Norway before continuing installation of the software.

Ordering charts

A chart order may be sent together with the registration of the system as described above.
It is essential that the required information is sent to C-MAP when ordering charts for
a system. C-MAP has issued order forms specifying the information that is required,
and contains vital information that will allow us to monitor and maintain your licenses
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throughout the lifetime of the system. Charts can be ordered by Zone, Area or Cell and
these can be seen on Internet pages at www.c-map.no or by downloading the Chart
Product Catalogue also available on the web site. Price quotations can be obtained via
your chart dealer or direct from your local C-MAP office. Once the license order has
been prepared it should be emailed to license@c-map.no or faxed to C-MAP Norway
AS (+47 51 46 47 01).

Applying licenses

Once the order has been received at C-MAP, a license will be generated and transmitted
back to the user. This may be in the form of a single alphanumerical string (16
characters), or in the form of a file called PASSWORD.USR. Once this license has
been received it should be input using the License Administrator software designed and
supplied by the ECDIS/ECS manufacturer. There are two types of licenses, purchase and
subscription. Purchase licenses are valid indefinitely while subscription licenses need
to be renewed each 12 months from the start of the subscription. Failure to renew a
subscription will result in the charts becoming unavailable.

Troubleshooting

If you are having problems installing your software or charts please check the following
before calling C-MAP: -
• You are installing on Windows NT, Windows 2000 or Windows 98 second edition.

The system will not normally run under Windows 95 or Windows 98 first edition.
• That you have registered the WORLD database in the GDBADMIN application.
• That the registered WORLD database is available. If you are running the database

from the CD drive, the CD-ROM must be loaded.
• That you have correctly typed the license string.
• That you have not reinstalled Windows or any major hardware components. If you

have done this you will probably need to reinstall your software (only required for
systems that are not using eToken).

Contact Information

For information or help please call your nearest C-MAP Office (details can be found on
the reverse side of the C-MAP chart CD box) or contact C-MAP Norway: -

C-MAP Norway ASPost Box 212Hovlandsveien 524379 EgersundNorwayTel: +47
51464700Fax: +47 51464701technical@c-map.no
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Global event marker
The Global Event Marker system consists of two programs:
• One server that runs on an Operator Station (for example the HWS) connected to a

multibeam echo sounder (EM) Processing Unit (PU)
• One or more clients on Windows PCs in the network

The Global Event Marker Handler (GEMH) needs two inputs; position datagrams from
an EM PU, and events from Global Event Marker clients on the network.

Note that the position datagrams needed by GEMH must be subscribed to using the
Request datagrams from an echosounder utility found in Tools→Custom→Datagram
distributions. See Request datagrams from an echo sounder on page 559

Use the IP address of the GEMH HWS and a free port address. This port address must be
used in the GEMH options setting (see below).

The PU will send position datagrams to GEMH even when the EM is not pinging.

GEMH will send events to other SIS installations on the network, including Helmsman
Displays. The IP addresses of these installations must be set in GEMH.

GEMH will also send CS datagrams to single beam echo sounders (EA). CS datagrams
are sent as broadcasts on the network, so only the UDP port must be set in GEMH.

All events are logged to a file, normally events.ksgpl. In the File menu you can open any
file. When the file is opened, all events in that file is sent to all SIS installations.

You can also at any time resend all events to all SIS installations from the View menu.

The last event is displayed in the textfield together with the IP address of the sender.

Options in GEMH are found in the File menu. The first lines set the UDP port where
events arrive. This port number must be the same as the port number in the file Events.ini
used by the Global Event Marker clients (see below).

Events are sent to a list of SIS programs. The format of this list is
xxx.xxx.xxx.xxx:nn,xxx.xxx.xxx.xxx:nn,...

xxx.xxx.xxx.xxx is the IP address and nn is the UDP port number, normally 4012.
Remember to use a comma (,) to separate the addresses.
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Positions are read from a UDP port. The port is the same as set when the position
datagram subscription is defined (see above.)

EAs listen for CS datagrams on a port, normally 10183.

The last event is also sent as broadcast to all Global Event Marker Clients (GEM). All of
them will then display the time the event arrived and the associated text.

The GEM can be installed on any Windows PC in the network. Simply copy the files
Events.exe and Events.ini to a directory and run Events.exe from that directory. The file
Events.ini can be used to set the parameters and texts for this window. Note that the IP
address in Events.ini is the IP address of the PC running GEMH.

You can then send an event to GEMH simply by pressing the button. A text is optional
and can be sent together with the event.

The last event on the network is displayed in the textfield below, together with the IP
address of the sender and the time the event occurred.
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PU simulator and playback
The PU Simulator is a replay program using logged raw data from EM multibeam echo
sounders. The program is launched from the menu Tools→Custom→PU Simulator.

The PU Simulator is launched in the background and then waits for command signals.

When the PU Simulator is launched, a directory selection box is opened where you
select the directory where the .all data files are located. This directory is written in the
textfield Raw Data Path.

The PU Control holds the following parameters:
• Raw Data Path is the path to where the .all files are located.
• Reduce speed: Choose between None, Some, More and Most to set the update rate of

the play-back from as natural speed to slower speed in order to be able to better
identify data details. By default set to None.

• Press Start to start the simulation.
• Press Pause to pause the output of datagrams from the selected raw data file.
• Press Stop to terminate the PU Simulator.
• No looping: this is required for replay of data with GGK positions. The date and time

in the original datagram are then not replaced by current time during replay.
• Free run: to set the update rate of the play-back as fast as possible (depending on

your PC).

The PU simulator will read all the .all files in the directory over and over again, and send
out the datagrams as if they were sent from an EM echo sounder. However, there are
some differences:
• The time in the header of all datagrams will be set to the current time in UTC. Also

the time in the GGA text string in the position datagrams will be set to this time.
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• The simulator will not broadcast datagrams to SIS before it has received the
information about which directory to read from. Therefore SIS must be started after
pressing Start in the simulator.

• Other data in the datagrams will not change. This means that the Numerical display in
SIS will display the original time information from the datagrams.

• The PU Sensor status frame will not contain any information during play-back.
• The Installation parameters frame and the Runtime Parameters frame have no effect if

the user tries to change any parameters.

Related operational procedures
• How to run the PU simulator on page 203
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Create grid from ASCII files
This tool can be used to create terrain models in SIS from ASCII files.

The format of the ASCII file is as the following example.
*** Neptune Ascii file from Kongsberg Simrad A/S ***
Survey name: EM710_Blucher_2005_02_23
Processing operator name: tp
Datum: WGS84
Half axis: 6378137.0000000
Flattening: 1/298.25722356300
Coordinate system: Lat/Long
Latitude min.: 59.66354720
Longitude min.: 10.59076500
Latitude max.: 59.70350375
Longitude max.: 10.62006250
Latitude cell size: 5.00 meter
Longitude cell size: 5.00 meter
Median depth of each cell

10.6148669 59.6635847 40.14
10.6149773 59.6635844 45.31
10.6150679 59.6635841 50.54

The first lines defines the header. The first empty line ends the header, and the header
must always be present. This means that the data in latitude, longitude, depth must
follow after an empty line. Latitude and longitude are in decimal degrees and the depth
is in meters.

The file format can be created by Neptune (BinStat) to output geographic coordinates
in ASCII format. Normally the median value for the grid cell is written in this format,
which makes it faster to generate the grid in SIS. If the grid cell size in BinStat is e.g. 2
meters, 400 cm can be used as the grid cell size in SIS.
1 Select Tools→Custom...→Create grids from ascii files
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2 Select the projection of your current SIS survey, i.e. the projection you want
the imported Neptune grid to appear in. The datum is given by the header of the
Neptune file.

3 Set Grid size in meters and Number of cells in processing grid according to depth and
coverage of your data.

4 Press Select grid output directory... to specify where to store the grid. Note that this
directory must exist and be accessible for writing.

5 Type a descriptive Grid name.
6 Select ascii input files opens a file selection dialog where you can browse for the

Neptune files to import.
7 Select Remove files in list if you want to remove a selected file from the list.
8 Press OK to start the process.
9 Select File→Import/Export... from the SIS main menu.
10 Press the Import button.
11 Browse for the directory where you selected to store the grid and select the directory

having the grid name that you entered.
12 Press OK to return to the Import/Export dialog box.
13 Highlight the survey to import and press OK.
14 In the Geographical view, press Zoom to world to display the grid.
Note

The GridEngine must be running for this program to work.

Note

If the process causes GridEngine to stop you may have to kill the Import from the process
manager and restart the GridEngine.
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KSGPL
The Kongsberg SIS Graphical Programming Language (KSGPL) is a powerful extension to
SIS allowing the user to display geographical information in the Geographical window.

Related topics
• Geographical – Display options on page 211
• Geographical – KSGPL edit mode on page 223
• Geographical – Load background data on page 224

Overview
The KSGPL protocol defines a set of ASCII datagrams that are sent between a user
programmed application and the Geographical window in SIS. The user application
opens a network connection (UDP) to the Geographical window and writes ASCII text
string to this connection. These KSGPL strings can be used to send lines, points and
pictures to the Geographical window, and to define the position of an earlier defined
object such as a ship. These objects will then be drawn in the Geographical window.
A lot of attributes can be set by the operator and the user application to control these
objects, both at the time they are sent to the Geographical window and afterwards.
You may edit objects sent to the Geographical window. You can split, join, add, delete
and move lines, as well as add, delete and move points. The user’s actions are sent back
to the user application, which then can decide what to do next.
The user application is responsible for storing the data. This allows the programmer to
decide where the data is stored, in a file or in any database system already in use. The
user application can also decide to add its own user interface so that more information
can be added to the objects added by the operator. KSGPL is used to add background
data to the Geographical window. This background data can not be edited.

KSGPL language reference
The following datagrams are sent from the outside to the Geographical window.
OBJECT <id>

POSITIONTYPE <GEO| SCREEN | RELATIVE>
[TYPE <number>]
[INFO <text>]
[LINE [ [WIDTH <number>] [SOLID|DOTTED] [COLOR <number>]
[TRANS <0-100>] ] <POS2D|POS3D> <positions>]

[POLYGON [ [BORDERWIDTH <number>] [SOLIDBORDER1DOTTEDBORDER]
[BORDERCOLOR <number>][BODYCOLOR <number>]
[SHOWBORDER|NOSHOWBORDER] [SHOWBODY|NOSHOWBODY]
[trans <0-100>] ] <POS2D|POS3D> <positions>]

[POINT [ [SIZE <size>] [COLOR <number>] [TRANS <0-100>] ]
<POS2D|POS3D> <position>]

[TEXT <text> [ [SIZE <number>] [COLOR <number>]
[ORIENTATION <0.0-360-0>] [TRANS <0-100>] ] <POS2D|POS3D>
<position>][IMAGE <file> [ [GRAVITYPOINT<0-100> <0-100>]]
<POS2D|POS3D> <position>]
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OBJECT END
OBJECT <id> DELETE OBJECT_END

The two tables below show the internal datagram descriptions
Datagram Description Required

POSITIONTYPE <GEO> Use geographical
coordinates

POSITIONTYPE <SCREEN> Centimeters on the screen
(float) relative to the
lower left corner of the
Geographical window.
This object will always stay
in its position on the screen

POSITIONTYPE <RELATIVE> Meters relative to origo
(0.0m, 0.0m) in the world

Yes, either GEO, Screen or
RELATIVE

INFO <text> Name or description of this
object

No

TYPE <number> The id of the type this
object belongs to

No

LINE [[WIDTH <number>]] Width of the line in pixels No. Default is 1.

LINE [[SOLID|DOTTED] Solid or dotted line No. Default is SOLID.

LINE [[COLOR <number>]] Colour of the line No. Default is black.

POLYGON [[BORDERWIDTH
<number>]]

Width of the border in
pixels

No. Default is 1.

POLYGON
[[SOLIDBORDER|DOTTEDBORDER]]

Solid or dotted border No. Default is SOLIDBORDER.

POLYGON [[BORDERCOLOR
<number>]]

Colour of the border No. Default is black.

POLYGON [[BODYCOLOR <number>]] Colour of the polygon
border

No. Default is red.

POLYGON
[[SHOWBORDER|NOSHOWBORDER]]

Show the border or not No. Default is SHOWBORDER

POLYGON
[[SHOWBODY|NOSHOWBODY]]

Show the body of the
polygon or not

No. Default is NOSHOWBODY.

POINT [[SIZE <number>]] Size of the point in pixels No. Default is 1.

POINT [[COLOR <number>]] Colour of the point No. Default is red.

TEXT [[SIZE <number>]]* Font size No. Default is 9.

TEXT [[COLOR <number>]] Colour of the text No. Default is red.

TEXT [[ORIENTATION<0.0—360.0>]] * Orientation of the screen
aligned text in degrees.
Positive value is counter
clockwise

No. Default is horizontally aligned

IMAGE [[GRAVITYPOINT <0–100>
<0–100>]] *

Gravity point of the picture
in percent (i.e. where on
the picture the coordinate
is given). Horizontal and
vertical values

No. Default is lower left corner.
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Datagram common for all objects Description Required

OBJECT <id> A unique identifier. The old
object will be deleted if the
corresponding identifier
already exists in the
system.

Yes.

<TYPE> <id> What kind of type this
object is.

No

<POS2D|POS3D> <position> Position(s) f the object.
POS2D = (x,y)
POS3D = (x,y,z)

Yes

[[TRANS <0–100>]] Transparency of the object. No, Default is 0. (No transparency
at all.)
The polygon border will not be
affected by the transparency
setting.

Note
Transparency is disabled for
images.

OBJECT_END Datagram end. Yes

Note

* — Not yet supported.

If the object sent into the system is missing required fields, the object is disregarded.
No output is given.

An object has always an identifier that must be unique within the application. If an object
with the same id exists in the Geographical window, that object is deleted (no message
given as output) and the new object is put in. The object may consist of one or more
instances of lines, polygons, points, texts and images.

A position has either two or three floating-point numbers and is enclosed in parentheses
like: (1.1 2.2 3.3). Comma and semi-colon may be used to separate the tokens, i.e.:
(1.1;2.2;3.3;t) to make the file more readable.

An object may be of a type. Object without types will be entered into the system in a
default container. An object of a nonexistent type (if given) will be ignored.

Objects may be deleted from the Geographical window by the DELETE datagram. The
corresponding id will be deleted.

KSGPL output from the Geographical window
The Geographical window will have line and point editing capabilities on objects that
consists of one line only or one point only. Composite objects consisting of several lines
and/or points cannot be edited. When the user has edited data that have been put in via
KSGPL, the Geographical window will output these KSGPL datagrams:
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ACK <status> ACK_END
OBJECT <id>
MARKED OBJECT_END
OBJECT <id> MARKED OBJECT_END
OBJECT <id> DELETED OBJECT_END
OBJECT <id> CREATED OTYPE <type_id> POINT <POS2DT|POS3DT> <position>

OBJECT_END
OBJECT <id> CREATED OTYPE <type_id> LINE <POS2DT|POS3DT><positions>

OBJECT_END
OBJECT <id> EDITED POINT <POS2DT|POS3DT> <position> OBJECT_END
OBJECT <id> EDITED LINE <POS2DT|POS3DT> <positions> OBJECT_END
OBJECT <id> JOINED_LINES <second_line_id> <POS2D|POS3D>

<positions> <POS2D|POS3D> <positions> OBJECT_END
OBJECT <id> SPLIT_LINES <POS2D|POS3D> <positions>

<POS2D1POS3D> <positions> OBJECT_END

The table below shows the external datagram descriptions:
Datagram Description

ACK <status> ACK_END An acknowledge message sent whenever a datagram
has been received by the Internal KSGPL Handler.
’status’ is an integer informing about status of the
datagram just received.

– 1 = Datagram failed to be recognized
0 = Reserved
1 = Datagram successfully recognized

OBJECT <id> A unique identifier. This will be 0 for new (CREATED)
objects

POS2D <position(s)>
POS3D <position(s)>
POS2DT <position(s)>
POS3DT <position(s)>

Position(s) of the object:
POS2D = (x,y)
POS3D = (x,y,z)
POS2DT = (x,y,t)
POS3DT = (x,y,z,t)

MARKED The object has been marked by the user. No changes
are done to the graphics. The External KSGPL Handler
can now take proper customized action(s).

DELETED The object has been deleted by the user and removed
from the scene.

CREATED OTYPE <type_id> <POINT|LINE> The user has created a new point or line of a given type.
The object has been removed from the scene.

EDITED POINT|LINE The user has edited the given point or line.
The object has been removed from the scene.

JOINED LINES <second_line_id>
<POS2D|POS3D> <positions_of_line_one>
<POS2D|POS3D> <positions_of_line_two>

The user has joined two lines into one.
The preceding OBJECT <id> is the ID of the first line.
<second_line>is the ID of the second line. The lines are
connected together between the last vertex in the first
line and the first vertex in the second line.
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SPLIT_LINE
<POS2D|POS3D> <positions_of_line_one>
<POS2D|POS3D> <positions_of_line_two>

The user has split an existing line into two line
segments. The preceding OBJECT <id> is the ID of the
original line before being split.

Note
The user has removed one vertex in the original line
(and not only deleted a sub line segment).

OBJECT_END Datagram end.

A position has either two or three floating-point numbers and a time field enclosed in
parentheses like: (1.1 2.2 3.3). POS2DT or POS3DT positions also have a time field
’t’ which is given in the format: yyyyMMddhhmmSS.sss (year, month, day, hour,
minute, seconds and decimal seconds.) POS2DT or POS3DT are only used when the
user has EDITED or CREATED something in the scene. If the user has EDITED e.g.
an existing POS2D line by moving one of the vertices, the unmoved vertices will have
the time field set to ’00000000000000.000’ when sent out. POS3D(T) are only sent if
the original object was inserted into the system using POS3D coordinates. Respectively
the same with POS2D(T).

Objects are assumed to be sent to an external program and deleted from the Geographical
window as soon as they are CREATED or EDITED and then sent back to the
Geographical window. After that, line objects may be split (SPLIT_LINES) or joined
(JOINED_LINES). These operations are then only allowed on lines that have been put
into the Geographical window from an external source

Selected objects remain in the Geographical window, but CREATED, EDITED,
JOINED_LINES and SPLIT_LINE are deleted from the Geographical window when
these datagrams have been written to socket. It is assumed that the receiving program
will handle the necessary storage of the changed items and then send them back to
the Geographical window to be redrawn in a new state. This will assure the user that
the data have been successfully stored.

For an edited line or point the position(s) are the new, changed position(s). A line may
also get new vertices inserted into the line (both at the ends of the line and between
vertices in the line) and have vertices deleted. The output will be written when the user
has completed the editing of the line, not while he is editing.

New objects will have id=0. For a split line the id will be the id of the original line.
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Input of S-57 formatted chart files
Note

This procedure may be very slow if very accurate models are to be made for large areas.
However, remember to keep the ascii file that is created, as this can be reused later in
case a new terrain model is to be created. Then simply create a new terrain model
from this ascii file.

You may use some of the data in an S-57 chart file as background data in SIS directly.
Coastlines and dryfall (a depthcontour with depth 0.0 meters) are extracted into KSGPL
formatted files which can be displayed in SIS. The depth contours are also used to
construct a 3D terrain model.

How to convert S-57 chart files to SIS input data
1 Select Tools →Custom →S-57 converter and a new window opens up:

2 Press Select S-57 file and select the S-57 file in the file selection dialog window.
3 Choose the map projection from the pulldown menu. The projections listed are the

projections registered in SIS.
4 Press Select output file and choose the output file name.
5 You may want to press Advanced options if you are not happy with the results from

the first run:

Here you can set the parameters defining how the to construct the terrain model.
GridEngine multiplier is a factor used to define the grid cell size in the GridEngine.
It should normally be set to 2 or higher.

6 Press Convert and wait.

Note

Note that this procedure may take several hours depending on the parameters.
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The output is two files, one .ksgpl and one .s57. To use this data in SIS, follow the
procedure below.

How to use the output from S57ToSIS
1 Open File →Import/Export and select KSGPL as the data type.
2 Open the .ksgpl file generated above and press OK.
3 Open Tools →Custom →Create grid from ASCII files.
4 Select the .s57 file as input and create a terrain model.
5 Open File →Import/Export and select Surveys as the data type.
6 Select the terrain model created above.

The first procedure must be run only once. The output is one .ksgpl file and one ascii file.
These files do not need to be regenerated unless the S-57 file is changed. This means that
this procedure can be run in the office and the output can be sent anywhere. Also the
generation of grid from ascii files needs to be done only once. When the terrain model
is created, it can be reused. This can also be done in the office, and then simply send
the complete terrain model to other users.

Note

The projection is locked once the terrain model is created so everyone who uses this
terrain model, must have the same projection defined.
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How to use SIS on an AUV/ROV
This section explains how to use SIS on an Autonomous Underwater Vehicle (AUV) or
on a Remotely Operated Vehicle (ROV), where an EM 2000/EM 3000 echo sounder is
installed.
The EM 2000/EM 3000 on board an AUV is controlled via Ethernet communication as
indicated in figure below. When SIS starts up, it will search for all echo sounders on the
network, and the EM 2000 or EM 3000 will broadcast its existence, detected by the SIS.

How to set up the EM 2000/EM 3000 on the AUV from SIS
1 Attach the internal disk in the EM 2000 / EM 3000.
2 Open SIS
3 Open the Installation Parameters
4 Enable PU logging to local disk as described in How to enable PU logging to local

disk on page 461
5 Set PU parameters as described in Default or current settings at PU startup on

page 462
6 In Installation Parameters there are four UDP port numbers, labelled UDP 1-4.

When using EM 2000/EM 3000 logging to internal disk, UDP4 is renamed to PU
Logging. Note the UDP port number in use by UDP2; this is the port number where
the third party software shall listen for data.

7 Shut down SIS
8 Restart the EM 2000/EM 3000
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When the EM 2000/EM 3000 is powered on again, it will start with the installation
parameters set. Datagrams will be sent to the UDP ports as defined, and any
software can be used to read these datagrams.

9 Send datagram P10 to port 2012 to the PU To turn logging on
10 Send P02 to stop logging.

In the figure below it is shown how the EM 2000 is set up after above procedure has been
carried out. P10 and P02 control datagrams are used to start and stop the logging to disk.

Figure 27 How the EM 2000 on and AUV/ROV is set up

How to enable PU logging to local disk

Note

This feature is only available for EM 2000 and EM 3000.

1 The SIS user can turn logging on and off by using a simple tick button in the
Installation parameters→Output Setup frame. When this tick button is set, the Host
UDP4 port entry in the UDP Host Port combo box is substituted with a PU Logging
port. By selecting the PU Logging port it is possible to select which datagrams to
log to the PU hard disk. Initially a default datagram selection is presented, but it is
modifiable as indicated.

2 When PU logging is set the port number displayed is 2999. This is just a dummy
number signifying that the PU is logging to disk.

3 The selected PU logging setup is activated (i.e. PU logging turned on or off) when
the OK button is pressed.
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Note

When the PU is logging to disk it will not send ANY datagrams out on the Host UDP4
port.

When the PU logging feature is turned off (i.e. tick button deselected) the normally
configured settings for Host UDP4 will be used again. Remember to press the OK button
to activate the new setting.

Default or current settings at PU startup

Note

This feature is only available for EM 2000 and EM 3000.

When the PU is turned on, this feature will enable the PU to use a standard (factory)
parameter setup or a setup previously configured and installed in the PU by SIS.

In the latter case the PU may subsequently be started independently, without SIS
connected. This capability will allow an AUV/ROV operator to use SIS to initialize the
PU with a specific setup before disconnecting SIS and launching the AUV/ROV into
the water.

You can control this feature by a radio buttons found in the Installation parameters,
ROV Specific frame: Installation Parametes→Sensor Setup→ROV Specific. The radio
buttons are labelled Use default settings at PU startup and Use current settings at PU
startup respectively.

The procedure for setting the PU to use the current parameter setting is as follows:
1 The PU must have been started by SIS
2 Configure the required installation and runtime parameters as required using the

normal configuration procedure

Note

Make sure to press the OK button in the Installation Parameters frame.

3 In the Installation parameters, ROV Specific frame press the Use current settings at
PU startup radio button.
The PU is now configured and the current setting stored for use when the PU
is turned on again.

How to set the PU to use default parameters
The procedure for setting the PU to use the default (factory) parameter setting is as
follows:
1 The PU must have been started by SIS
2 In the Installation parameters→ROV Specific frame press the Use default settings at

PU startup radio button
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The PU will now use the default (factory) settings when it is turned on the next time
and it will normally require that SIS is connected to initialize and control it.

Note

When the radio buttons are pressed a signal is sent directly to the PU without the need to
press the OK button (as for normal installation parameters). Therefore, when the Use
current settings at PU startup radio button is pressed the required setup must already be
present in the PU using the procedure above.

Note

Note that after the Use current settings at PU startup radio button has been pressed, the
PU parameter setup at that time is remembered and used during next startup. If further
installations and runtime configurations are performed, without pressing the radio
buttons, the changed configuration will be used until the PU is turned off and on again.

Fetch and delete data from the internal harddisk

FTP can be used to fetch and delete data from the internal hard disk, or replace the disk
with another and insert it in another PC to read the data.
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CUBE
The CUBE (Combined Uncertainty and Bathymetry Estimator) algorithm is developed
at The Centre for Coastal and Ocean Mapping (C-COM)/Joint Hydrographic Centre
(JHC) at University of New Hampshire. The algorithm is available as a library and is
used inside a separate module in SIS. The CUBE algorithm can be used as an alternative
data gridding and data cleaning method in SIS. The gridding and data cleaning is a
default process done by the GridEngine.

Related topics
• Create CUBE grid on page 369

About the implementation of CUBE in SIS
CUBE is not available when logging data. CUBE grids are created by importing raw
data files in the Kongsberg Maritime .all-format. Already gridded surveys can be
reimported at a later time.

The CUBE module in SIS receives ping data on UDP where depth and angle gate are
applied to the data. The horizontal and vertical error estimate for each beam is calculated
using the Kongsberg Maritime error model and not the error models included in CUBE.
The default processing parameters for the CUBE algorithm are used.

The GridEngine holds both a processing grid and a display grid. The display grid is split
up in six levels of details, LODs, to speed up the display in the geographical view when
features as automatic update or ship in centre are turned on. In CUBE it is the processing
grid that is displayed and an automatic update or ship in centre can give slow response
when updating the geographical view.

The implementation of LOD in the GridEngine also results in less sensitivity to the grid
cell size when displaying grids - see the next four figures. With a small grid cell size a
lot of nodes get no depth value assigned.

SIS must chose between either GridEngine or CUBE grids. This selection is done from
the Tools→Custom→Set paramenters→Logging menu.
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Figure 28 GridEngine, LOD3
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Figure 29 GridEngine, LOD1
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Figure 30 CUBE, grid cell size 10 m
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Figure 31 CUBE, grid cell size 2.5 m

CUBE also need some amount of data density to do the gridding. The grid in the next
figure is from one survey line. The grid width is measured to 19 metres. With one more
survey line the same distance is measured to 32 metres.
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Figure 32 Grid width 19 m
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Figure 33 Grid width 32 m

In SIS only depth are extracted from the CUBE processed data. In addition to the
depth, CUBE can return uncertainty, number of hypothesis and hypothesis strength
in each grid node.

User interface differences when CUBE is used
Only the differences in the user interface between CUBE and the GridEngine is treated
hereafter.

Import raw data

Please refer to Import/Export on page 352 for details.

The parameters for the gridding is entered in the window at the bottom of
theFile→Import/Export...→Raw Data Files user interface.
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Figure 34 Raw data import - CUBE parameters

CUBE needs to know the geographical coordinates of the survey area before any
processing can start. The centre location for the grid width, height and cell size must be
given. Western or southern values have to be entered as a negative value.

A large survey area requires a coarser grid cell size. You are notified if the grid size is
too small for the requested survey area. In that case the grid size has to be increased or
the survey area has to be reduced.

Export CUBE Survey data

GridEngine surveys can be exported to ASCII-files, which can be imported in Neptune.
This feature is not supported for CUBE generated grids.

The CUBE grids are however stored as GUTM-files on disc.

See
http://www.ccom.unh.edu/vislab/GeoZui3D/
FileFormats.html#GUTM

for a specification for the file format.
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Figure 35 CUBE Export options
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Figure 36 GridEngine Export options

CUBE Geographical window

The Geographical window in CUBE mode differs slightly from that of the GridEngine
mode. Instead of the Option button as used in GridEngine mode, the Geographical
options in CUBE mode are set using the Show/Hide button.

The main menu in CUBE mode also holds a Geographical menu which is not found
when in GridEngine mode.

The Show/Hide button together with the Geographical menu in CUBE mode give the
same options as found in the Geographical Option button in GridEngine mode. However,
CUBE holds less options as fewer features are supported.

Show/Hide button
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Geographical menu
The Geographical menu holds the following parameters:
• Light Source: To set the light source for the geographical display
• Grid: To set parameters for how to present the CUBE grid, i.e.

– Drawstyle (points, triangles, filled, text and text overlay)
– Shading (on/off)
– Triangulation (centre or true point)
– Smoothing (Level 0 to Level 3)

Level of detail
The GridEngine has six Levels Of Details, LOD, in its display grid. For CUBE only the
processing grid is available for display and the choice is removed from the user interface.

Dynamic colors
For CUBE grids, only depth can be used as a colour map for the dynamic colours.
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Related topics
• Geographical view on page 57
• Main menu on page 103

Other functions not supported by CUBE

Calibration

This is not available when using CUBE. The GridEngine must be run to calibrate the
echo sounder.

Projection

CUBE grids in SIS can only hold UTM projected data.

Related topics
• Calibration view on page 100
• Projection and datum parameters on page 384
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Precise Point Positioning (PPP) in SIS
Precise Point Positioning in SIS is a set of utility programs to SIS that gives you the
opportunity to apply precise GPS orbit and clock correction data to your GPS raw
data to obtain position accuracy in the centimetre to sub-decimetre range. The post
processed positions are made available through an updated position data file in the KM
binary file format.
The following steps will provide you with sub-decimetre position data:
1 Logging of dual frequency GPS data in the RTCM 3.0 format (from the Seapath

300 system)
2 Automatic formatting of the GPS raw data into RINEX format
3 File handling to prepare for post processing
4 Running the PPP software (TerraPOS) to obtain the high precision positions
Note

PPP in SIS can currently be applied to raw data from the Seapath 300 dual frequency
GPS receiver. The term GPS is therefore used when referring to the PPP application in
SIS, whilst the GNSS term, which is the general term for all Global Navigation Satellite
Systems (including GPS, Glonass, EGNOS, etc) is used in the general descriptions.

Topics
• Precise Point Positioning (PPP) – General description on page 476
• TerraPOS on page 477
• How to do Precise Point Positioning in SIS on page 478

Precise Point Positioning (PPP) – General description
Precise Point Positioning (PPP) is a method that performs precise position determination
using a single GNSS receiver.
The approach is to apply GNSS orbit and clock data products with centimetre accuracy
to reduce the errors in the broadcasted GNSS satellite orbits and clocks, two of the most
significant error sources in GNSS positioning. Combining precise satellite positions and
clocks with a dual-frequency GNSS receiver (to remove the first order effect of the
ionosphere) and advanced modelling of other error sources in the GNSS observables,
PPP is able to provide position solutions in the centimetre to sub-decimetre level.
PPP is different from RTK and traditional DGNSS in that there is no need for data
from local or regional reference stations.
Precise post processed orbit and clock data are determined by e.g. NASA's Jet Propulsion
Laboratory (JPL) and available from e.g. the International GNSS Service (IGS). The
correction data is freely available for download via the Internet.
The accuracy and reliability of the clock and orbit data depends on the age of your
data. The longer you await the post processing, the higher accuracy and reliability the
available clock and orbit data will have. The table below shows the expected latency
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before the results of various IGS processing levels becomes available. The highest
possible accuracy and reliability Final data is available after 12 to 18 days after your data
was logged. The quoted accuracy for Rapid data that is available after 14–41 hours is the
same as for the final data, but with slightly smaller reliability figures.

Refer to table below for accuracy figures for 2009, or refer to the IGS Products on
http://igscb.jpl.nasa.gov/components/prods.html for updated figures.

Table 3 IGS Product Table – updated for 2009

GPS Satellite
clock and orbit

data

Latency IGS quoted accuracy

Orbits Satellite clock
Broadcast real time ~ 100 cm ~ 5 ns RMS / 2.5 ns sDev
Ultra-rapid
(predicted half)

real time ~ 5 cm ~ 3 ns RMS / 1.5 ns sDev

Ultra-rapid
(observed half)

3–9 hours ~ 3 cm ~ 150 ps RMS / 50 ps sDev

Rapid 14–41 hours ~ 2.5 cm ~ 75 ps RMS / 25 ps sDev
Final 12–18 days ~ 2.5 cm ~ 75 ps RMS / 20 ps sDev

The clock and orbit correction data can be applied to GNSS raw data logged in the
RINEX format.

TerraPOS
The Precise Point Positioning utility in SIS makes use of the TerraPOS software
developed by TerraTec AS. TerraPOS is a GNSS (GPS+Glonass) post processing
software that makes use of GNSS raw data files and precise post processed orbit and
clock data to compute accurate positions.

To use the TerraPOS software, the following conditions must be recognized:
• TerraPOS is based on post processing, the accurate positions is not available online
• Your post processing computer must have an Internet connection to download the

precise clock and orbit data
• Dual-frequency GNSS data is required
• Due to the nature of GNSS phase measurements, where the phase's integer ambiguities

must be estimated, a certain time span of continuous observations must be allowed for
before the highest accuracy requirements are met. For Precise Point Positioning in
SIS 30 minutes of extra data is recommended.

• Obtained accuracy depends on satellite geometry and signal reception conditions
• Observations must be provided in RINEX format

Please refer to www.terratec.no for further details.

In SIS the TerraPOS user interface is hidden to the user.

342682/D 477

http://igscb.jpl.nasa.gov/components/prods.html


Seafloor Information System

How to do Precise Point Positioning in SIS
In SIS the following steps will provide you with sub-decimetre position data:
• Logging of dual frequency GPS data

See Logging raw data on page 478
• Run the post processing software Terrapos Manager to manage the raw data files

and to compute the accurate positions
See Terrapos Manager on page 479.

Logging raw data

Precise Point Positioning in SIS can be used if you have a dual frequency GPS receiver
capable of supplying GPS raw data in the RTCM 3.0 standard raw data format.

Note

The RTCM SC–104 standard applies to Differential Global Navigation Satellite Systems
(DGNSS). Version 3 was developed for RTK operations, i.e. raw data that includes
phase observables.

The dual frequency GPS receiver Seapath 300 will output GPS raw data to SIS in the
required RTCM 3.0 format.

The name of the logged RTCM file has the following format:

RTCMYYYYMMDD_HHMMSS.rtcm

where the date and time is the current UTC time at the time of file creation.

The format of the information stored in the file is the length of the received signal
(unsigned short, i.e. 2 bytes) and then the signal itself.

Each logged .rtcm file is automatically formatted into a RINEX (ASCII coded satellite
position data) .08o file as soon as a log file is closed after a user entered period. This
formatted file will be used in the post processing. The original .rtcm file is retained.
The naming format of the RINEX file is

YYYYMMDD_HHMMSS.08o

where the date and time is fetched from the first datagram in the file.

Note

RINEX – Receiver Independent Exchange Format is a standardized data interchange
format for raw satellite navigation system (GNSS) data that often is used in post
processing. The RINEX format allows the raw GNSS data to be post processed using
different methods, independent of product type and software, and correction data that
origin from elsewhere than the original receiver can be applied.

More informations
• GPS and delayed heave on page 323
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Terrapos Manager

Terrapos Manager is the name of the SIS application that assists in applying clock
and orbit correction data to your GPS raw data. The Terrapos Manager performs the
following automated processes:
• Locates and copies the RINEX raw data files along with the survey definition data

from the survey computer to a portable storage device, such as a USB memory stick
• Copies the RINEX raw data files from the portable storage device to the correct

location on the post processing computer
• Runs the TerraPOS post processing application using precise clock and orbit data

fetched via the Internet.

Terrapos Manager
Terrapos Manager is opened by selecting Tools→Custom...→TerraPos Manager from
the SIS main menu.
The following dialog opens.

The software will perform a search for Internet access. If Internet access is found, the
program will assume it is being run from the Office and prepare for running the Terrapos
application. If Internet access is not found it will be assumed that it is being run from the
Survey computer and prepare for copying data from the computer to a memory stick.

Terrapos Manager menu
The main menu of Terrapos Manager holds the following selections:
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• Options
• Help

The Options menu contains the following:

• Survey/Office: If you need to force the program into either Survey or Office mode,
select Options from the Terrapos Manager main menu and tick off Survey or Office
as appropriate.

• Cut: The raw data is by default Cut, i.e. deleted from original source as they are
copied onto the destination. If you do not want to remove the data from its original
storage, deselect Cut from the Options menu.

• Exit: Closes Terrapos Manager.

The Help menu contains a labelled sketch description Terrapos Manager.

Terrapos Manager buttons
Select To

Browse for the portable storage device to copy raw data to or from,
depending on whether you are in Survey or Office mode.

Start copying the files. The button will be disabled until a valid
survey containing RINEX raw data is selected.

Start the Terrapos application, i.e. start generating the post
processed position data file.

Survey selection list
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• Select Survey name from the list of surveys found in the database of SIS running
on your computer. Selecting the survey will tell Terrapos Manager what survey
parameters to apply during post processing.

• Other...: You can also select a survey that is not loaded in the SIS database by
selecting a folder with .all files corresponding to the RINEX files. Click Other... to
browse for the .all folder to select survey information from.

• Output: If you select the Output tab all internal activity of the program will be
displayed.

Status display

This window will display information related to current status of Terrapos Manager.

The output tab
In the output tab view all internal activity of the program will be displayed.

How to copy the raw data files from the survey computer to a USB memory stick
1 Browse for the memory stick storage location to copy data to by pressing the File

Folder button.
2 Select correct survey from the list

or
Select Other... to browse for the raw data folder for that survey

3 Press the Copy files button.
Program status will be shown in the status window.
Note

If you would like to follow into details the program's processes, go to the Output tab.

When all files have been successfully copied the following message will be
displayed in the status window:
FILES COPIED SUCCESSFULLY FROM <from_folder> TO
<to_folder>

4 Remove the USB memory stick.
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How to copy the raw data from the USB memory stick to the post processing
computer
1 Browse for the memory stick storage location to copy data from by pressing the

File Folder button.
2 Press the Copy files button.

Program status will be shown in the status window.
Note

If you would like to follow into the program's processes details , go to the Output tab.

When all files have been successfully copied the following message will be
displayed in the status window:
FILES COPIED SUCCESSFULLY FROM <from_folder> TO
<to_folder>

3 Press the Terrapos button to start position post processing using the Terrapos
application.

Note

A Terrapos license along with a full SIS installation is required.

Program status will be shown in the status window.
Note

If you would like to follow the program's processes into details , go to the Output tab.

When completed the following message will appear in the status window:
Finished. See survey folder for resulting files.

If TerraPOS was run successfully, a *.terrapos file was
created and a copy of it can be found in the Rawdata
path.

4 Use Windows Explorer to verify that the .terrapos files is copied to
\sisdata\survey\<survey_name>\Terrapos\<input_file_names>\
and to \sisdata\raw\<survey_name>.
Also note that in the
\sisdata\survey\<survey_name>\Terrapos\<input_file_names>\
the Terrapos generated files are stored. These are:
• *.clk, *.eph and *.erp files. These are the clock and orbit correction files

that are downloaded from the Internet.
• The merged RINEX file used as input to the Terrapos calculations
• A Terrapos generated log file containing summary of the computation results,

including statistical figures that may give you required quality control.
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GSF support in SIS
SIS supports the Generic Sensor Format (GSF) from SAIC. The .all-files can be
converted to this format using the tool GSF Converter.

Topics
• How to use GSF Converter on page 483

How to use GSF Converter
The GSF Converter is started by running the file GSF_converter.exe located under
C:\Program Files (x86)\Kongsberg Maritime\SIS\Gsf
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Click Select raw data directory... and select the directory containing the .all-files.

Note

Note that the file sis_proj.txt must be present in the directory containing the .all-files,
and it must contain a projection named SIS_Projection:
<SIS_Projection>
ellps=WGS84
proj=utm
zone=32
north
units=cm

If the file sis_proj.txt is missing from the directory, an error message is displayed.

The file sis_proj.txt is normally created when defining a survey in SIS, you can copy
it from a SIS-survey and rename the projection in that file.

The program all2gsf will traverse the directory tree and convert all files found using
the same projection file for all files. This makes it possible to convert many surveys in
one operation.

In addition to the GSF-files, a file with the suffix .ext is created. This file contains extra
information that may be helpful when reading the GSF-files back:

The GSF-files uses relative positioning for the soundings. Each ping has a position in
latitude and longitude, and then the position to each sounding is given as along and
across distance from that position. To convert along and across back to latitude and
longitude, SIS uses two factors. Multiplying the delta values in the GSF with these
factors, will give the correct latitude and longitude. Note that the factors in the file
converts between degrees and centimeters, and the GSF uses meters.
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GSF specifies the time in seconds since epoch. To be sure there are no errors done
when converting back to the time in the .all-file, SIS outputs the time in the .all-file of
some soundings in the file. These can be used to verify that the time has been converted
correctly back to the time in the .all-files. Here is an example of an .ext-files:
11141696.406487 5533467.822988 20081128 70856007
11141698.467512 5533261.885997 20081128 70916165
11141700.455559 5533063.233643 20081128 70976414
11141702.530323 5532855.908620 20081128 71036828
11141704.637373 5532645.349463 20081128 71097227
11141704.637373 5532645.349463 20081128 71097227

The first ping is always written, and the last ping twice. Then there is one line with
approximately one minute between the positions.

The first number is the factor used to convert between centimeters and degrees latitude,
the second is the factor to convert centimeters to degrees longitude. Then comes the date
in YYYYMMDD format, and then the milliseconds since midnight that day.

SIS calculates these factors for every ping, but these files only contain these factors with
a one minute resolution.

The depths have been corrected using the WGS 84 datum which should be applicable
even if other datums are used by the positioning system. This means that there is no need
for further datum corrections in these GSF-files.

Kongsberg Maritime can assist with source code examples showing how to read the
GSF-files correctly using the extra safety in the .ext-files. Please contact Customer
Support if this is needed.
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Technical references

This chapter provides basic reference information useful to understand settings and
parameters used throughout the SIS system. The chapter is intended for users who would
like a deeper knowledge of the technical background for and the data flow inside SIS.

Topics
• SIS architecture on page 487
• Real time data cleaning on page 492
• The vessel coordinate system on page 496
• Timing on page 498
• Sound speed formulas on page 502
• Implementation of absorption coefficients on page 504
• Artefacts causing errors and variations in the sea floor depth detections on page 509
• The absorption coefficient equation on page 512
• Projections on page 513
• Geoid on page 515
• Tide on page 518
• Javad and Trimble details on page 520
• Dead reckoning and position jump filter on page 525
• Checking of legal beam pointing angles on page 527
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SIS architecture

SIS processes

Figure 37 SIS main architecture

SIS contains six main processes. This is the start-up sequence:
1 The GUI is the main application, and is started first.
2 The CCU is started by the GUI. When the EM Processing Unit power is turned on it

starts broadcasting messages on the network. The CCU will pick up these messages
and display the EM availability in a list in the main GUI.

3 The operator chooses which echo sounders to start from the list in the main GUI.
4 The CCU will be informed which echo sounders to start, and then launch one DDS

and one HDDS for each of the echo sounders.
• The DDS reads datagrams received from the Processing Unit sockets and stores

them as raw data on disk
• The HDDS reads raw data from disk and generates xyz data that is sent to the

GridEngine
5 The GridEngine receives xyz-data from the HDDS and generates a real time terrain

model
6 The main GUI with the Geographical Display will now receive xyz-points from all

echo sounders, and it will request the GridEngine for a terrain model to display.
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Main GUI (Graphical User Interface)
The main application is called SIS and it contains the main graphical user interface (GUI).

There are three main tasks for the Main GUI:
1 To display the terrain model with quality information and provide a geographical

view of the surveyed data
2 To display status information about the echo sounder
3 To control the echo sounder

Display and quality information in the Geographical view

The Geographical window gets xyz-data from the HDDS process. It will then display
all these xyz-depths as they appear, but only the last pings will be shown. They will
appear as a tail of soundings behind the ship.

The Geographical window also reads the terrain model generated by the GridEngine.
The GridEngine contains five depth values for each observed depth. The user can choose
which reference level to display.

The GridEngine also generates several levels of display detail, making it possible for
the Geographical window to always display the most suitable level of details based
on the current scale.

Note

The HDDS process reads data from the disk, meaning that the data displayed by
Geographical window is just a subset of the raw data that remains safely stored on
disk by the DDS process.

Status of the echo sounder

The Status windows get data directly from the echo sounders. This means that Status
windows such as the Beam intensity window and Sound speed profile window all get the
data directly. Hence the Status windows will be active when the echo sounder is active,
and can always be used to monitor the current status of the echo sounder.

Controlling the echo sounder

Controlling and setting up the echo sounder is done by the Installation parameter
window and the Runtime parameter window. Also Pinging, Logging and Line Counting
will invoke the control of the echo sounder. Messages are not sent from the main GUI
directly, but to the CCU process. The CCU is then responsible for sending the messages
to the right echo sounder (remember that the CCU can control several echo sounders).
See CCU (Central Command Unit) on page 489.

Messages concerning the system operation (errors, warnings, information) are stored
in SISDB, and the main GUI provides a window where you can see all messages as
they appear.

488 342682/D



Technical references

CCU (Central Command Unit)
The CCU process is responsible for detecting all echo sounders on the network, and to
make sure that the communication is established between the different processes. Also,
if a new echo sounder is found during rescan, the GUI will be informed.

DDS (Data Distribution System)
The DDS process is responsible for logging all the datagrams sent by the echo sounder.
The CCU will tell the DDS where to store the data (complete filename). The DDS can
also distribute datagrams to other processes on the network, both to SIS processes and
to external processes. In SISDB you can define what datagrams to receive from the
DDS process, and when to receive them (every time they come or with a certain time
interval between).

HDDS (Handle Data Distribution System)
The HDDS process is informed by the CCU process where the DDS process stores
it's files. The HDDS will read the raw data files and create xyz-data. For every depth
observation the HDDS process will try to generate five depth types:
• Z: Depth, sea surface to seafloor distance
• Zt: Tide file corrected depth, vertical datum to seafloor distance
• Zv: Geoid and RTK corrected depth, vertical datum to seafloor distance
• Zg: Seafloor to geoid distance
• Zr: Seafloor to ellipsoid distance
• The depth measured by the echo sounder (waterline to seabed).
Note

If a tide file is available, look up the tide in that file and create a tide corrected depth.

If heights are available from a Real Time Kinematic GPS, and a geoid model is available,
then the distance from the vertical reference to the sea floor will be generated. In
addition, the distance from the sea floor to the geoid and the distance from the sea floor
to the ellipsoid will be generated.

These depths will be sent to the GridEngine.

The HDDS will also read all the sidescan data from the echo sounder and make
geo-referenced sidescan data (x, y, reflectivity). This is also sent to the GridEngine.

The HDDS process will do wild point editing of the positions (removing position jumps).
Every position is converted from geographical coordinates to projection coordinates
before it is sent to the GridEngine.
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GridEngine
The GridEngine will receive data from both single beam echo sounders (EA) and
multibeam echo sounders (EM). The data format is different in these cases. EA data is
strictly xyz. This makes it possible for the GridEngine to read many kinds of xyz-data,
and they may be from different sources such as ASCII-files. EM data is five depths for
each measured depth, and optional sidescan data.

The GridEngine uses two different grids, one called Processing grid and the other is
called Display grid. The Processing grid has a user defined resolution of its grid cells,
and the user must define how many cells to keep in memory at one time. This is done
by specifying the number of grid cells in x and y direction for the Processing grid. A
maximum of four Processing grids can be stored in memory at any time.

The Processing grid will contain a lot of data: all the xyz-points and every xyz consists
of five z-values. It will also contain all the sidescan data for all lines in that area, and it
will keep track of which lines having data inside the area.

The Display grid is what the user actually sees. The Display grid is organized in a
hierarchical tree structure called levels. The grid cell size of Level 0 of the Display grid
is the same as the grid cell size of the Processing grid, so Level 0 Display grid will
display everything from the Processing grid.

Level 1 in the Display grid is computed from four grid cells of Level 0, Level 2 is created
from four cells of Level 1 and so on. All this is taken care of by the GridEngine.

The Processing grid is used in the Real Time Data Cleaning module, and the result is an
updated Display grid. The Geographical window will calculate the maximum resolution
necessary to display the data, based on the current map scale selected by the operator. In
a very large scale (close view) Level 0 will be used, whilst in a smaller scale a higher
Level of Detail will be used.

This means that the Geographical window will display only the necessary amount of
data at any time, which again means that the rendering will be faster. The zoom and pan
operations will also benefit, as the Geographical window will always get a pre-processed
dataset to display.

The GridEngine is written in C# and is run as a a standard application.

Note

A minimized console window is visible when SIS is running. This is where the
GridEngine is running. Do not close this window!

Note

Grids created with the old Java based Grid Engine can not be imported using the new
C# based GE.
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SISDB
To store parameter settings used in SIS a database called SISDB is created. The database
server is SQLite. Logged data is not stored in the database, only parameters settings and
system messages.

This makes it possible to exchange data between different applications that use database,
and to use standard applications and tools to browse the contents of the database.
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Real time data cleaning
When data arrives the GridEngine, it may be cleaned in real time. Depths may be flagged
out, but never deleted. Their status can always be changed if necessary. The Real Time
Data Cleaning (RTDC) module operates in two steps:
1 As the data arrives, it will be organized as pings in an array. Then some processing

will be carried out to these pings in the array. This is known as Line Based Data
Cleaning (LBDC) because the processing only looks at data from current line.
LBDC is not sufficient for proper data cleaning because errors caused by i.e. sound
speed profiles will not be found. However, LBDC can be used for flagging out
gross errors (spikes).

2 After LBDC the data will be put into the Processing grid. If you later return to the
same survey area, the data from the previous lines will be read back and reprocessed
together with the new data. This is called Area Based Data Cleaning (ABDC)
because all data from the same area is processed together. ABDC makes it possible
to find errors in e.g. sound speed profiles and installation angles.

Before starting the ABDC routine, the GridEngine will try to split and merge the
processing cells into Cell Processing Units, which is used to create a surface. If a
processing grid cell has very few points, it will be tried to merging it with its neighbour
cells to create a bigger area with enough points. If there are too many points, the cell is
split. The figure below shows examples of cells that are empty and cells that contain
enough points. On the edge of the processing area there are some cells with too few
points to do a good processing. The user can choose to automatically delete all points
inside such cells.

Figure 38 Process grid split into processing units
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The first thing to do in ABDC is to create a most likely reference surface in each
processing unit. Traditionally this has been simply the mean depth value for the
cell which means that the reference surface always will be a flat surface. In SIS the
GridEngine constructs a much more reliable surface that will model the terrain much
better. The surface is curved and constructed by using a first, second or third degree
polynomial.

The method used to construct the reference surface is called Iterated Reweighted Least
Squares (IRLS). The surface is created to be as close as possible to most of the points
(best fit).

Figure 39 Best fit surface

Each point is initially considered to be equally important. The algorithm assigns a
weight to each point. All points get the same weight. Then a polynomial surface is
created. The distance from each depth to this surface is called the residual. Then the
sum of all the residuals is calculated. Since all points have the same weight, this sum
is only the sum of the residuals.

Now the Tukey estimator kicks in. Rather than giving each point the same weight, each
point gets a new weight based on how far away from the surface it is. Points far away
from the surface get lower weight than the ones close to the surface. The parameter
Tukey constant controls how fast points loose their weight. Below are some examples.
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Note that the “r” in the figure below is the median residue in the Cell Processing Unit. As
the “c” (Tukey constant) changes, the curve gets broader as “c” increases and narrower
as “c” decreases. This means that points loose weight faster when the Tukey constant is
small. The effect of losing weight fast is that points are not used in the construction of
the surface the next time the algorithm is run.

Figure 40 Tukey algorithm

This algorithm will run several times and every time new weights are given to each
point. There are two ways this algorithm will stop; Either it has tried Max. iteration of
time to create a surface, or the change from previous run is very small. If this happens,
the algorithm is said to converge, which means that the best possible result has been
found. The parameter Conv. criterion controls when the algorithm converges.
To summarize, the algorithm for the Iterated Reweighted Least Squares (IRLS) method
is given as follows:
1 Start with equal weights for all points
2 Loop until convergence or maximum iterations

a Fit the surface using weighted least squares
b Calculate residuals
c Check for convergence
d Adjust the Tukey estimator
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e Evaluate new weights

When the polynomial surface has been successfully created, various rules can be applied
to flag out depths.

Related topics
• Data cleaning on page 317
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The vessel coordinate system
In order to relate the GPS antenna position to the seabed observations SIS needs to
know the relative positions of the various sensors in use. This includes position sensors,
attitude sensors and transducer heads.

The location of each sensor must be referred to a chosen reference point for the vessel.
A cartesian right-handed coordinate system - as shown in the figure below - must be
defined with its origin in the reference point. The location of this reference point has no
physical significance - it may be anywhere on the vessel. The placement of the various
instruments must be identified with forward, starboard and downward coordinates in
this coordinate system.

Figure 41 The vessel coordinate system

A Downward position is defined on the Z-axis (refer to the illustration above).
Locations below the reference point are positive

B Starboard position: If a sensor location is on the starboard side of the reference
point, the Y value will be positive.

C Forward position is defined on the X-axis (refer to the illustration below). Locations
further forward than the reference point are positive.

The forward axis (X) must be parallel to the vessel keel, and the downward axis (Z) must
be vertical when the vessel is trimmed normally. The plane defined by the forward and
starboard axes will then be horizontal, and the attitude sensor should then, if properly
installed and calibrated, measure zero roll and pitch with a normally trimmed vessel
lying still.
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Figure 42 Example of sensor locations

A Transducer (+Z, +X)
B Motion sensor (-X, -Z)
C GPS antenna (-Z, -X)
D Draft (-Z)
E Waterline (-Z)
F Reference point
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Timing
Topics
• Introduction on page 498
• Internal clock on page 498
• Time stamping on page 499
• Time difference PU-ZDA and PU-POS indications on page 500

Introduction
Time synchronization between the echo sounder, the motion sensors and the positioning
system is vital in order to achieve the best possible accuracy. The requirement for time
synchronization accuracy is better than 5 ms for attitude, with roll being the most critical
parameter. For the positioning, the required timing accuracy depends upon required
position accuracy and the vessel’s speed.

Example: With a vessel speed of 10 knots or 5 m/s, 100 ms timing accuracy is required
for 0.5 m position accuracy.

Internal clock
An internal clock in the PU is used to time stamp all time critical data. It is a software
clock with 1 millisecond resolution, and it is synchronized to an internal hardware
counter. An interrupt is generated in the PU at each ping as a reference for the time of
ping, and the clock is read at the reception of external sensor data. The internal clock
is stable and jitter free, excepting a long-term drift of the hardware counter (typically
a few seconds per 24 hours), and possible 1-2 millisecond jumps due to the internal
counter not operating at exactly 1 kHz.

The software clock may be synchronized to an external 1PPS (one pulse per second)
signal. This signal is normally available from a GPS receiver, and this is the preferred
method to synchronize the echo sounder to an external clock. At the reception of a 1PPS
pulse the millisecond field of the internal clock is set to zero. If it was larger than 200 ms,
the second is incremented (with a possible incrementation of time and date if required).
Note that this method of synchronization implies that loss of a few 1PPS pulses has no
significance. However, spurious noise recognized as 1PPS pulses will offset the clock
forward, 1 second for every spurious signal accepted.

The internal clock’s time and date is adjustable to that given by an external clock, the
positioning system or the operator station. However, this is only possible if the system is
not logging data. Adjustment of the internal clock during data logging is not allowed as
it would cause loss of synchronization between depth and attitude data.

If an external clock is connected on a serial line the input data is time stamped and
logged as any other external sensor data. This allows a continuous estimation of any
drifts between the two clocks. The setting of the internal clock will be to the time and
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date from the source, including milliseconds as available. Note that the GGA positioning
datagram does not contain any date entry. Setting from the operator station allows a
manual setting of the clock.

Time stamping
For each datagram of attitudes (roll, pitch, heave and possibly heading), a time stamp is
generated at the reception of the first byte of the datagram. As the attitude data may be
delayed due to processing time in the motion sensor, an adjustable time delay may be
applied. The attitude data are applied to the acquired ranges and beam angles to derive
xyz coordinates of the soundings after bottom detection.
The only significant uncertainty in the time synchronization of attitude and depths will
thus be due to possible variations in the time delay or a wrong estimation of it. However,
with most motion sensors the risk of errors are small. The manufacturer’s estimate of
delay should be used, and a possible prediction facility in the sensor should not be used.
As the attitude data may be logged as a continuous time record, it is possible to post
process the data to determine and correct for any error in applied time delay.
As for the attitude data, a time stamp is generated at the reception of the first byte of each
position datagram, and an adjustable time delay may be applied to this time stamp. If
the real variation in this time delay is sufficiently small with respect to the position
accuracy and vessel speed, the internal time stamp will give sufficiently accurate time
synchronization. Time delay must of course be determined to a sufficient accuracy which
is done by comparing data from survey lines run at different vessel speeds in the same
direction up or down bottom slopes or over significantly distinctive bottom features. Any
necessary correction of the applied time delay may be done in post processing.
If the variation in the time delay of the positions is too large with respect to the desired
accuracy, even after position filtering during post processing, an alternative satisfactory
solution will require two things: that the positioning system’s own time stamp in the
position datagram has a sufficient accuracy; and that the clocks of the echo sounder and
the positioning system are synchronized. When post-processing, the positioning system’s
time stamp must be used, which is possible as both time stamps are retained in the
logged data. If the positioning time stamp is not good enough, the positions will have
to be filtered during post processing to diminish the effect of the variable timing. The
inertia of the vessel will set the limit of accuracy achievable by such filtering.
The absolute setting of time in the echo sounder is usually not critical with respect to
other sensors. It is recommended to synchronize the echo sounder to a 1PPS signal, if
available. It is also recommended not to reset the echo sounder clock, except for at the
start of a survey. This will ensure that any time delays remain constant during a survey.
If an external clock is additionally connected and logged , this will allow a check of
clock consistency during post processing, but this is usually not worth the effort.
The conclusion and recommendations are as follows:
• It is recommended to synchronize the echo sounder to a 1PPS signal if available
• The delay in the data from the motion sensor must be constant and known to within

5 ms
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• If the delay in the position data is known within an accuracy commensurate with the
position accuracy and vessel speed, no synchronization of clocks is required.

• If the delay in the position data is variable and cannot be filtered to a sufficient
accuracy in post processing, or the positioning is required to also be accurate
for realtime displays, the echo sounder and positioning system clocks must be
synchronized.
The synchronization of the two clocks must be done from a common 1PPS signal
(which may be contained in the positioning system). The echo sounder must be set
up to use the positioning system time stamp (datagram time) to which any position
time delay will be applied. The post processing system must also be set up to use the
positioning system time stamp (a time delay may have to be applied to either the
position or depth data).

Time difference PU-ZDA and PU-POS indications
The Numerical display can be set to monitor the PU-ZDA and PU-POS time differences.
The colour indications used are based on the 1PPS setting, the Time to use setting and the
clock source selection. All these parameters are set in the Installation parameter frame.

See Installation parameters on page 274.

In most situations the acceptable time difference is +/- 1 sec, but with 1PPS off and time
tag from the system the acceptable time difference is considerably larger.

The time delay limitations are system parameters and can not be changed by the operator.
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Related topics
• Numerical display on page 68
• Installation parameters on page 274
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Sound speed formulas
The echo sounder computes bottom depth, taking full account of the ray bending caused
by the variation of sound speed in the water column. The Sound speed profile is entered
manually, automatically from a sound speed profile probe, from an external computer, or
by a combination of these methods.
If measured sound speed values are not available, they may be derived from tables, or, if
the temperature and salinity profiles are known or estimated or calculated from a formula.
While many formulae exist, the one from UNESCO Technical Paper in Marine Science,
No. 44, is usually regarded as being authoritative. However, it is cumbersome and recent
experiments showed that it has errors in the 1000-4000 m depth range. Therefore, a
simpler formula with adequate accuracy is as follows (from Coppens, JASAMarch 1981,
with a modified very deep water correction which follows the recent experimental data).
• For the surface:

c (0, T, S) = 1449.05 + T (4.57 − T (0.0521 − 0.00023T ))
+ (1.333 − T (0.0126 − 0.00009T ) (S − 35))

where:
– T is temperature in °C
– S is salinity in ppt

• For depths to 200 m in fresh water and 1000 m in the ocean:

c (Z, T, S) = c (0, T, S) + 16.5Z

where
– T is temperature in °C
– S is salinity in ppt
– Z is depth in km

• For depths to 2000 m in fresh water and to 11000 m in the ocean (assuming that
the water is very cold at great depths):

c (Z, T, S) = c (0, T, S) + Z
(

16.3 + Z
(

0.22 − 0.003Z
√
T + 2

))

where
– T is temperature in °C
– S is salinity in ppt
– Z is depth in km

• For depths greater than 5000 m, a latitude correction should be applied:

c (Z, T, S) = c (0, T, S) + Z ′
(

16.3 + Z
(

0.22 − 0.003Z
√
T + 2

))

where
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– Z’ = Z(1 - 0.0026 cos2Φ)
– Φ is latitude in degrees
– T is temperature in °C
– S is salinity in ppt
– Z is depth in km

342682/D 503



Seafloor Information System

Implementation of absorption coefficients

Overview
The absorption coefficients in SIS may be set using three different sources:
• Salinity
• CTD profile
• Manual

In principle SIS can handle several echo sounders, each with its own source setting.

As a consequence SIS must maintain and control two different sets of profiles: One based
on the currently set salinity value and one based on the CTD (Conductivity, Temperature
and Depth) information received in an SSP datagram. The third alternative, Manual,
results in the user entered absorption coefficient values being used immediately.

Absorption coefficients are dependent on the used frequency. All profile sets must
therefore contain one absorption coefficient file for each frequency used by the
multibeam echo sounders.

Today the required range of frequencies for the complete range of multibeam echo
sounders are 12, 32, 60, 70, 80, 90, 95, 100, 200 and 300* kHz. (* used to calculate for
297 and 307 kHz internally in EM 3000 and EM 3002 Processing Units).

Parameter references
• Filter and gains for EM 2040 on page 310

Related topics
• Handling of SSP datagrams on page 539

Salinity based absorption coefficient profiles
This type of absorption coefficient profiles is based on a depth and sound speed profile
and the currently set salinity value. The depth and sound speed profiles can be obtained
from two sources:
1 Reception of an SSP datagram of format S00 or S10 from the network. (All SSP

datagrams results in the generation of an .asvp file which contains the necessary
profile.)

2 The operator may select an ordinary SVP from Runtime parameter→Sound Speed
Profile.

In both cases a set of absorption coefficient files are generated. All files in a set use the
same naming convention: In case of a SSP datagram, the date and time contained in the
datagram becomes first part of the file name. In case of an operator selected SVP file the
original file name is used instead. Next, the currently set salinity is included together
with the frequency for which the file is valid. See example sets below
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Note that there is an .asvp file in each file set containing the depth and sound speed data
used in the calculations. This file is named the same as the rest of the set of files, except
that the frequency part is absent. This file is constructed based on the SSP input or the
user selected SVP. In the latter case the file contains exactly the same data as the original
SVP file, e.g. ’Horten20050304.asvp’ and ’Horten20050304_salinity_03900.asvp’
contains exactly the same data. See example below. The duplication and renaming of the
original user selected .asvp file is done so that it is simple to retrieve a complete file set
including the .asvp file using only the basic file name as key.

Note

The absorption coefficient file with frequency 32 kHz is actually for the 31.5 kHz system
(EM 300).

Example of salinity file set based on SSP datagram:
20051230_183344_salinity_03900.asvp
20051230_183344_salinity_03900_12kHz.abs
20051230_183344_salinity_03900_32kHz.abs
20051230_183344_salinity_03900_60kHz.abs
20051230_183344_salinity_03900_70kHz.abs
20051230_183344_salinity_03900_80kHz.abs
20051230_183344_salinity_03900_90kHz.abs
20051230_183344_salinity_03900_95kHz.abs
20051230_183344_salinity_03900_100kHz.abs
20051230_183344_salinity_03900_200kHz.abs
20051230_183344_salinity_03900_300kHz.abs

Example of salinity file set based on user selected SVP called ’Horten20050304.asvp’:
Horten20050304_salinity_03900.asvp
Horten20050304_salinity_03900_12kHz.abs
Horten20050304_salinity_03900_32kHz.abs
Horten20050304_salinity_03900_60kHz.abs
Horten20050304_salinity_03900_70kHz.abs
Horten20050304_salinity_03900_80kHz.abs
Horten20050304_salinity_03900_90kHz.abs
Horten20050304_salinity_03900_95kHz.abs
Horten20050304_salinity_03900_100kHz.abs
Horten20050304_salinity_03900_200kHz.abs
Horten20050304_salinity_03900_300kHz.abs

A new salinity based absorption coefficient file set is generated in the following instances:
• When a new SSP datagram for immediate use (S00 – S07) is received from the

network.
• When the user selects a new SVP from the runtime parameter Sound Speed Profile

interface.
• When the Source is Salinity and the salinity value is changed and no existing file

set is found for the new salinity.
• When the user selects Salinity as Source and no existing file set is found for the

currently set salinity value.
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Parameter references
• Sound speed for EM 2040 on page 305

Related topics
• Handling of SSP datagrams on page 539

CTD based absorption coefficient profiles
CTD based absorption coefficient profiles are only generated based on SSP datagrams
with formats other than S00 and S10. These other datagrams may contain the absorption
coefficient directly (with appropriate frequency listed) or they contain the necessary CTD
data to calculate the absorption coefficient profiles for all frequencies.
• See Handling of SSP datagrams on page 539

Note that when the SSP datagram contains the absorption coefficient directly (datagrams
S13, S23, S33, S43, S53) this datagram is valid for one frequency only. To be able to
generate a full set of absorption coefficient files one SSP datagram of the same type for
each used frequency must be received. The interval between the reception of individual
datagrams must be max 10 sec. (currently). The internal date and time in the SSP
datagrams must be the same for all in the received set.

Note again that the requirement is that one such SPP datagram must be received for each
of the frequencies 12, 32, 60, 70, 80 90, 95, 100, 200 and 300 kHz.

When received by SIS, the SSP datagrams S01, S02, S03, S04, S05, S06 and S07 will
result in an automatic and immediate use of the confined information. Therefore it is not
necessary for the operator to make a manual selection for the associated SVP.

The name of CTD based absorption coefficient file sets is constructed in the same way as
for S00/S10 based sets without the salinity part.

Example of a CTD file set, based on SSP datagrams different from S00 and S10:
20051230_183344.asvp
20051230_183344_12kHz.abs
20051230_183344_32kHz.abs
20051230_183344_60kHz.abs
20051230_183344_70kHz.abs
20051230_183344_80kHz.abs
20051230_183344_90kHz.abs
20051230_183344_95kHz.abs
20051230_183344_100kHz.abs
20051230_183344_200kHz.abs
20051230_183344_300kHz.abs

The CTD file set also contains an .asvp file. This file is generated (directly or calculated)
based on the contents in the SSP datagrams.

Note that when selecting an SVP from the runtime parameter Sound Speed Profile
interface it is regarded as a CTD file set only if the file name does not contain salinity
and all frequency files are present.
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In all circumstances a new salinity based file set is also generated from the selected SVP
and current salinity. That is when a CTD based file set is used immediately (S01, S02,
S03, S04, S05, S06, S07) selected or a corresponding file set for the currently selected
salinity is also made.

Mode of operation
When the system is initialized the first time a system provided default file set is used both
for the salinity based and the CTD based absorption coefficients. It is therefore important
that realistic file sets are generated and selected as soon as possible when using SIS.
However the current salinity and CTD based file sets will always be remembered and
used e.g. after a restart.

When new file sets are generated upon reception of SSP datagrams the information about
the new file set is sent to the SVP Editor. This editor may be used to modify the data
contents of the file set (e.g. thinning). The operator may subsequently select the modified
file set using the runtime parameter Sound Speed Profile interface.
• See SVP Editor on page 395

A file set that has been thinned, using the SVP editor, will contain ’thinned’ in the file
name, e.g.
20051230_183344_thinned_03900.asvp
20051230_183344_thinned_12kHz.abs
20051230_183344_thinned_32kHz.abs
20051230_183344_thinned_60kHz.abs
20051230_183344_thinned_70kHz.abs
20051230_183344_thinned_80kHz.abs
20051230_183344_thinned_90kHz.abs
20051230_183344_thinned_95kHz.abs
20051230_183344_thinned_100kHz.abs
20051230_183344_thinned_200kHz.abs
20051230_183344_thinned_300kHz.abs

The PUs are updated with new absorption coefficients according to the following
principles:
• The depth measured by each echo sounder is received by the CCU (which handles the

core functionality of the absorption coefficient system), currently every 15 sec.
• If the current selected Source is Salinity or CTD-profile an absorption coefficient

deviation value is calculated for each frequency used by the echo sounder. This
deviation value is based on the previous and current absorption coefficient for each
frequency and a max range estimated from the received depth. If the found deviation
for any frequency is greater than a preset limit (currently 0.2 dB) the new absorption
coefficient for each frequency are sent to the PU.

• When calculating the absorption coefficients the current Source selection determines
if the Salinity based file set or the CTD based file set is used.

In any case, when a new set of absorption coefficients are sent to the PU the values for
each frequency used by the PUs are displayed in the runtime parameter’s Filter and
Gains frame.
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Also, the currently used salinity and CTD-based absorption coefficient file sets are
displayed in the runtime parameter Sound Speed Profile interface.

Note

Initially SIS is configured to use and store the Salinity and CTD based absorption
coefficient file sets in one pre-defined directory. This can be changed by selecting a
Salinity or CTD based file set from another location by using the runtime parameter
’Sound Speed Profile’ interface. All new (i.e. generated) file sets of the specific type
selected above (Salinity or CTD) will be stored in this new location. Thus, Salinity and
CTD based file sets can be stored in different locations.

Note

When using an external removable storage media like a USB stick to carry an .asvp
profile or a CTD-file set etc. the files must be copied to a local HWS directory before
selecting them for usage (Runtime parameters > Sound speed). Never select a file for
use directly from a removable medium.

Note

SIS will never remove any absorption coefficient file set from it’s storage location(s). If
any clean-up/removal is performed by the operator, care must be taken not to remove the
currently used Salinity or CTD based file set as listed in the display.

Note

The system provided default absorption coefficient file set, called ’default’ must never be
deleted or moved from its original position.
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Artefacts causing errors and variations in
the sea floor depth detections

Introduction
Sound waves need a compressible medium (like water) for propagation. Sudden changes
in this medium (i.e. changes in the sound speed or changes in the acoustic impedance)
bends or reflects the sound waves. Changes like these are present in the transition (or
boundary) between water and the sea bottom, and are necessary for depth detection when
using an echo sounder.

When the boundary is smeared or stretched out, the sounder may have problems
determining the accurate numeric value representing the sea depth. These conditions
vary with frequency.

While bedrock gives a distinct echo for most frequencies, the situation is more
complicated for sedimentary seabed. E.g. Sometimes the upper part of the seabed
consists of a liquid like layer, changing to more solid with depth. The boundary between
this layer and water can be indistinct for sufficient registration at certain frequencies.

Low frequency sonars (like 12 kHz) can penetrate the boundary of this layer with
almost no reflections, whilst higher frequencies, (say 100 kHz and above) usually give
reflections sufficient for detection. The result is differences in the numerical depth
readings when different frequencies are used.

The registration of the sea floor may also vary with the incidence angle of the sound
beam, specially when the sounders are using different frequencies.

Sea bottom penetration
The seabed is an interface between water and earth, i.e. a transition between liquid and
solid materials. Usually, on the accuracy scale to which the depths are to be measured,
the interface is sufficiently clearly defined. However, in some cases this is not so, usually
because the interface is not distinct enough with the top sediment being partly solid and
partly water. Then the echo reflected back to the sounder is a combination of echoes both
from the seabed and reflectors beneath the seabed. The echo sounder might then have
problems distinguishing where the bottom really is, causing too deep and hence erroneous
detections, as is not unusually observed on dual frequency single beam echo sounders.

342682/D 509



Seafloor Information System

Figure 43 The echogram from an EA 600 single beam sounder

The seabed reflects a part of an incoming sound wave due to the change of the acoustic
impedance, between the sea bottom and water. Most of the sound energy not going
into the bottom will be reflected away as a specular reflection (i.e. as if the bottom is a
mirror), but some of the energy will be scattered in other directions (hopefully with some
backscattering to the echo sounder). The angular response of the seabed will depend
upon its material and its smoothness (in relation to the sound wavelength). A smooth
bottom (such as silt or mud) will have a narrow specular region of a few degrees with a
very weak signal reflected in other directions. On a rough bottom (such as gravel), the
specular peak will be quite wide and not very strong, and the reflected signal in other
directions will not be much weaker. Reflected signal strength will however always
decrease with increasing angle away from the specular direction.

Penetration will usually be a bigger problem on soft bottoms than on hard, due to the
impedance contrast being less. Sound penetrating into the bottom may be reflected from
objects such as large rocks or from layers if different material energy will just dissipate
away due to bottom losses. The absorption coefficient of soft sediments has been shown
experimentally to usually increase approximately linearly with frequency. Typical values
at for example 12 kHz is in the range of 1-5 dB/m with the lowest values encountered
when the bottom has a very high porosity (> 65%) which implies a very small particle
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size (< 10 mm). Assuming that signals attenuated more than 20 dB within the seabed,
will not affect the bottom detection, penetration of up to about 10 m could be possible
at 12 kHz and up to 30 cm at 300 kHz.

When there is a problem with penetration, it will mainly affect the centre of the swath. In
the outer parts of the swath the penetration range may be of the same order as for the
centre, but the depth is lessened due to the incidence angle. In the specular region,
usually at or very close to the vertical, the degree of penetration might not be problematic
due to the strong specular reflection, but this might not be consistent over a large survey
area. It might also be noted that when the sub-bottom of fine particles, penetration
and hence too deep detections may happen all over the swath, fairly independent of
beam pointing angle, although probably more often the erroneous detections will be
concentrated to the centre.

The bottom detection process is aimed at avoiding false detections and only providing
correct ones. However, when the bottom is such that the echoes received from the
sub-bottom are stronger than those from the seabed surface, too deep detections may
invariably occur. Usually this will mostly only happen on fairly smooth bottoms, which
could be handled in post-processing by filtering, but unfortunately only by removal
of any fine bottom features or object from the data. If this is not acceptable, the only
possible alternative in an area where penetration is problematic, is to see whether any
parts of the swath are less affected by others, and to only use data from these parts in
the processing. The disadvantage of this procedure is of course the unavoidable large
penalty in extra surveying time required
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The absorption coefficient equation
The mean absorption coefficient of the water column is used in the gain setting in the
receiver.

The absorption coefficient is important in determining the correct backscattering strength
of the seabed used in the seabed imaging. Setting a correct value is therefore always
recommended if the backscatter data are to be used, especially if the results are to be
compared with those from other areas. The absorption coefficientα is given by the
following equation:

α =
A1f1f

2

f2 + f2
1

+
A2P2f2f

2

f2 + f2
2

+ A3P3f
2

where

A1 =
8.86× 10(0.78pH − 5)

c

A2 =
21.44S (1 + 0.025T )

c
A3 = 4.937× 10− 4

− T
(
2.59× 10− 5 − T

(
9.11× 10− 7 − 1.5× 10− 8 × T

))
,

T ≤ 20°C
A3 = 3.964× 10− 4

− T
(
1.146× 10− 5 − T

(
1.45× 10− 7 − 6.5× 10− 10 × T

))
,

T ≥ 20°C
P2 = 1 − Z (0.137 − 0.0062Z)

P3 = 1 − Z
(
0.0383 − 4.9× 10− 4Z

)

f1 = 2.8

√
S

35
× 10[4− 1245

273+T ]

f2 =
8.17× 10[8− 1990

273+T ]

1 + 0.0018 (S − 35)

Here, α is given in dB/km, the sound speed c in m/s, the temperature T in °C, the depth
Z in km, the salinity S in ppt, and the frequency f in kHz. The pH of the ocean is
in the order of 7.6-8.2.

The mean values are the mean absorption coefficient from the surface to the depth
indicated, and is the value to be entered in the menu.

The absorption coefficient equation is from R. E. Francois and G. R. Garrison, “Sound
absorption based on ocean measurements: Part II: Boric acid contribution and equation
for total absorption,” J. of Acoust. Soc. Am. 72(6), Dec. 1982, p 1886.
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Projections

Scope
This section gives in-depth information on the Projection component. The purpose with
the section is to describe how to program a projection and how a projection can be
defined using the projection library.

Programming a projection
On the Installation DVD there is a directory called UserSrc. This directory contains a
template for programming your own projections. On a Windows system use usersrc.dsp
and program the projection in Microsoft Studio.
On a Windows PC the output is a dynamic link library, userProj.dll. Copy this file to the
location where SIS is installed and replace the existing file.
You create your own projection in the file userProj.cpp. Follow the example in the file:
1 Create the routines you want to use. You have to define three routines, one for

initialization of the projection, one for the projection and one for the inverse
projection. It is important that the parameters are correct, see the example.

2 Edit the routine InitUserProjection. In the switch statement add a number and call
your initialization routine. The number is important. You must choose a number
larger than 1000 as SIS is already using the numbers below 1000. Each projection
must have a unique number.

3 Edit the routine ForwardProjection. In the switch statement call your forward
projection.

4 Edit the routine InverseProjection. In the switch statement call your inverse
projection.

5 Compile and install the shared library.
6 Start SIS. Open the Survey templates window and find the tab where you define the

projection. Then choose Create new projection and this program starts.
7 Choose New... and give the new projection a proper name.
8 Choose the projection type to be User defined. The number you enter must be the

same as the one you just programmed.
You have now created your own projection.

Note

If you later reinstall SIS, this projection will be lost. You have to save the shared library
file and install it after you install or upgrade SIS.

Using PROJ.4
You can also define a projection using the projection library PROJ.4. A 7-parameter
datum transformation is already available in SIS.
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The following text file defines a PROJ.4 projection:
<MyProjection>
ellps=WGS84
proj=utm
zone=32
units=cm

The parameter ellps must be defined, and units=cm must be used.

To add a 7-parameter datum transformation, the setup is like this:
<MyProjection>
ellps_from=Bessel
rotXrad=0.0000001
rotYrad=0.0000002
rotZrad=0.0000003
dXm=150.0
dYm=160.0
dZm=170.0
scale=0.9998
ellps=WGS84
proj=utm
zone=32
units=cm

Note that rotXrad, rotYrad and rotZrad are expressed in radians, and that dXm, dYm and
dZm are expressed in meters. The primary ellipsoid is defined after ellps_from and the
secondary ellipsoid will be defined by ellps.

The to and from definition of the ellipsoids are the names of the ellipsoids found in the
list of ellipsoids. You see this list when you define the projection.

The transformation parameters themselves must be entered by the operator.

The operator must save this setup in a text file. He can then define a PROJ.4 projection as
described above. In the text field where he types the PROJ.4 projection, type something
like this:
+init=/mydir/somefile.txt:my_projection

This means that the projection is named my_projection and is defined in the file
\mydir\somefile.txt.

For PROJ.4 details see C:\Program Files\Kongsberg Maritime\SIS\doc.
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Geoid
If high accuracy antenna heights (e.g. RTK GPS or other high accuracy position systems)
are extracted, predefined geoid models can be used to obtain the distance from the sea
floor to your vertical reference plane (e.g. Mean Sea Surface).
The figure below shows the various distances used in the calculating the depth to the
seafloor relative to the vertical reference.

Figure 44 Computation principles

A Distance from the echo sounder to the sea floor
B Distance from the antenna to the ellipsoid
C Motion corrected distance (depth) from water surface to sea floor

The measured distance from the echo sounder to the sea floor is corrected for
transducer offset and motion (heading, roll, pitch and heave) to obtain the distance
from the water surface to the sea floor.
Because the heave sensor only reacts to fast changes, the water surface is in reality
defined by the 0-level of the heave sensor.

D Motion corrected distance (height) from water surface to ellipsoid
The position system gives the distance from the antenna to the ellipsoid B. This
distance is corrected for antenna offset and motion to give D, which is the distance
from the sea surface to the ellipsoid
Note that both the corrected echo sounder depth C and the GPS based height above
the ellipsoid D is now referred to the same vertical level, the sea surface.

E Distance from the sea surface to the vertical reference (tide)
The tide E is computed as E = D - F - G.

F Distance from the ellipsoid to the geoid (geoid undulation), positive if the geoid
is above the ellipsoid.
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This value is given by the geoid model.
G Distance from the geoid to the vertical reference, positive if the vertical reference is

above the geoid.
This value is given by the geoid model.

H is the distance from the vertical reference to the sea floor and can be computed
as H = C - E

I is the distance from the sea floor to the geoid and is computed as I = G - H

The geoid file
The geoid file geoidmodel.geoid must be stored together with the background data. See
Survey parameters on page 263.
The next figure shows the layout of the geoid file. This layout is chosen to fit to rivers
where the geoid undulation and vertical reference is known at cross profiles along the
river (the vertical lines are the riverbanks). It is possible to define several “rivers” in one
file thus allowing general areas to be defined.

The file format is as follows:
1 latitude(degrees) longitude(degrees) F(meters) G(meters)
2 latitude(degrees) longitude(degrees) F(meters) G(meters)
3 latitude(degrees) longitude(degrees) F(meters) G(meters)
where F is distance from the ellipsoid to the geoid and G is distance from the geoid
to the vertical reference.
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The line starting with 2 is optional. The cross profile may be defined using two or three
points, the first point with id 1 and the last point id 3. If there is a middle point, it has the
id 2. Latitude and longitude are positive north of the Equator and east of Greenwich,
negative on the other side.

An area is defined between two cross profiles. A model (river) must always have at
least two cross profiles. Several models (rivers) in the same file must be separated by
an empty line.

The geoid undulation F and the vertical reference G is interpolated using straight lines
between cross profiles.
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Tide
Tide input to SIS can be of two types: Real time tide or predicted tide.

Realtime tide
Realtime tide is sent to SIS as discrete tide datagrams using a serial link or by the
network using UDP port 4001. The format of the tide datagram is as follows:
$ATIDE,20040512073406,1.74*00

The header is always $ATIDE. Next comes the time YYYYMMDDhhmmss, and then
the tide in meters.
The checksum is currently not used, but must be present.
Note

The tide is added to the depths.

The tide input using a serial line is set up in Tools→External sensors. See External
sensors on page 371
Note

The file realtime.tide will be created every time SIS is restarted.

Predicted tide
A tide file with the name predictedtide.tide can be stored together with the background
data for the survey, see Survey parameters on page 263.
The format is like this:
(Tide)
20040512073655 1.74
20040512073755 3.42
20040512073855 5.00
20040512073955 6.43
20040512074055 7.66
20040512074155 8.66
20040512074255 9.39
20040512074355 9.85
20040512074455 10.00
20040512074555 9.85
20040512074655 9.40
20040512074755 8.67
20040512074855 7.67
20040512074955 6.44
20040512075055 5.01
20040512075155 3.43
20040512075255 1.75
20040512075355 0.02
20040512075455 -1.72
20040512075555 -3.40
20040512075655 -4.98
20040512075755 -6.41
20040512075855 -7.65
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20040512075955 -8.65
20040512080055 -9.39
20040512080155 -9.84
20040512080255 -10.00
20040512080355 -9.85
20040512080455 -9.41
20040512080555 -8.67

The first line is a header enclosed in parenthesis. The first word must be Tide.

Next comes the tide data. The time format is YYYYMMDDhhmmss and the tide is in
meters.

Note that the tide is ADDED to the depths.
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Javad and Trimble details
You have to start the necessary modules to enable logging from a Javad or Trimble
GPS receiver. Each module is described in sub-sections, after the following manual
start-up procedures.

Note

The “(space)” remark indicates space key in the start-up commands; the letters are not
a part of the commands.

Fill in the constituent data file or port number between the brackets <...>.

Mean Sea level module

sisMSL -d “C:\Program Files\Kongsberg Maritime\SIS\ bin” -i
9044 -o 9041

Real time tide module

sisTide -f<constituent data> F tide5.dat -i 1 -p(space)
9041 -p 4001

Here the Mean Sea level module is set up to receives GGA messages from the Javad
receiver and the Real time tide module sends data to the gpsraw module logging data
from the Javad receiver.

Javad GPS receiver
• RStoUDP -com <port number>,19200,8,0,1 -udpin(space) 9049
-udpout localhost,9050 -bin

• gpsraw -p 1 -t JAVAD -i 9050 -u 9049 -c 9041 -e(space)
4002 -n 4002 -g 9044

Trimble GPS receiver
• RStoUDP -com <port number>,19200,8,0,1 -udpin(space) 9038
-udpout localhost,9039 -bin

• gpsraw -p 2 -t TR4000SSE -i 9039 -u 9038 -c 9041(space)
-e 4002 -n 4002 -g 9033

Raw GPS data logging module
The raw GPS data logging module enables the user to log raw GPS measurements from
a high quality GPS receiver, thus enabling the user to post process the data using any
available tool, for example TerraPos from Terratec AS.

At the moment, two different GPS receivers are supported, Javad and Trimble 4000
series (tested with Trimble 4000 SSE).
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Starting the programme with the option -h (i.e. gpsraw -h) gives the following output,
which should be self explanatory:
gpsraw $Revision: 1.4 $
Usage gpsraw [options]

-p <1–3> Set positioning system number

-t <gps receiver type> (JAVAD or TR4000SSE)

-i <portnum> Reads data from this port [in]

-c <portnum> Control port [in]

-e <portnum> Port for error messages [out]

-u <portnum> Port for messages to gps receiver [out]

-g <portnum> Port to receive GGA NMEA messages [out]

-n <portnum> Port to receive all NMEA messages [out]

-d Show debug messages
-v Show version and exit

-h Show this help

This programme reads raw gps data from one UDP port, interprets and logs the data to
a file, extracts NMEA messages which may be distributed to other programs. It may
control the GPS receiver by writing control datagrams to the gps receiver. It reads control
datagrams which may start or stop logging to file, or set fixed height (if supported by
the receiver).

NMEA messages may be distributed to multiple ports, by repeating the options -g
and/or -n.

For output ports the port may be given as port, name:port or ip:port. A control port
(-c) and an inport (-i) are required options.

The control datagrams that are understood are:

$KSSIS,102,dirname,ON Start logging in given directory

$KSSIS,102,dirname,OFF Stop logging

$KSSIS,103,ON Set fixed height

$KSSIS,103,OFF Reset fixed height

$KSSIS,105,23.45 Geoidal separation in meters

$ATIDE,20051225123022,2.45 Time and tide value [meters]

<Installation datagram> To get antenna height

The error messages which may be returned to the port given by -e have the form:
• $KSSIS,104, ; message text which may be long...
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Mean Sea level module
The mean sea level module calculates the Mean Sea Level (in many places almost the
same as Geoid) from a set of input files and interpolates accordingly to a position
received as a GGA message on an input (UDP) port. It sends the MSL value in the given
position to those who need it, in particular the raw GPS logging module, which needs it
for calculating antennae height when too few satellites are visible.
The programme is started from a command file or from a terminal window and using the
-h option gives the following information:
Usage sisMSL <options>

Where options are:
-h Prints this help

-d <directory> Where to search for data files (required)

-p <pattern> Pattern used in search. Default: .grid

-i <portnum> Where to receive GGA messages from (required)

-o <portnum> Where to send geoide separation (Can be repeated. At least
one is required)

-D Prints debug information

This programme reads geoid separation files from a directory and interpolates in the files
from a position received on a port with NMEA GGA messages The ports can be given as
either hostnum:port, ip:port or just port.

Real time tide module
The real time tide module calculates the tide from a set of input files. One normally
called tide5.dat, can be generated, and the other contains the constituents for the nearest
harbour. The programme can calculate the tide using phase and amplitude offsets as well
as correcting for the current air pressure (given that the correct tide is known). The
internal clock of the computer must be correct for this real time module to work correctly.
The programme has also the capability to make a prediction file, using other options.
A typical usage for the programme, with typical options which gives the tide corrected to
LAT are:
sisTide -f stavanger.xdo -F tide5.dat -p 4001 -s 1.1(space)
-t 12 -l 0.05 -z 0.65 -i 10

By using the -h option the following help message is returned:
use sisTide [options]

-h Show this message and return
-v Show version and return
-c Show copyright notice
-q Show file formats and return

-f <filename> Read constituent data from this file
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-F <filename> Read Foreman data from this file

-i <number> Interval for sending or calculating data [min] (default 60)

The following two options are for sending real time predictions:
p <portnum> Send to port (default localhost:4001)

The following two options are for generating predictions for a date:
-D<YYYYMMDD> Start date for predictions

-d <number of days> Number of days to give predictions for (default 1)

Note

If -D is given, -p ignored.

Options for changing the calculations:
-a Amplitude factor (default 1.0)

Multiply the result with this factor.

-t Secondary harbour time correction [min] (default 0)
Added to time before calculating tide (delaying tide)

-l Level correction [m] default 0.0
Add to tide after calculations

-z Use this level (positive number) [m] for Z0 (default 0.0)
Add to tide after calculations

Note

Z0 value from file is never used.

Constituent (-f) and Foreman (-F) files must always be given.

Note

Predicted tides are always referring to UTC (GMT). This can be changed using -t option
(-t60 gives MET).

Environment variable TZ must be correctly set to get correct real time predictions. (e.g.
TZ = MET - 1METDST).

Predicted tides are calculated relative to mean sea level unless Z0 (-z) and/or level
corrections (-l) are given.

The results are negated so ADDING the results to measured depths should give
tide-corrected depths.

RStoUDP
The RStoUDP module makes it possible to control/receive data on UDP from equipment
attached to RS232 serial lines:
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Usage RStoUDP -com
<prt>,<baud>,<databit>,<parity>,<stopbit> -udpin <port>
-udport<ip,port> -udpout[1-4]<ip,port> -ts -distudp
-log <logfile> -confsock <port> -bin <buf size> -t
<timeout(usec)>

Legal values for parity is 0=none, 1=odd and 2=even, where:
• -com (Comm port to use)
• -udpout (Port nr. for incoming data)
• -ts (Add timestamp to ASCII data)
• -udpout[n] (Additional output sockets)
• -distudp (Distribute incoming udp data to all udp out sockets)
• -confsock (Socket for incomming config messages)
• -bin <size> (Binary mode and buffer size)
• -t (Timeout value when reading binary data)

Example: RStoUDP -com 4,9600,8,0,1 -udpout(space) localhost, 2020 -log log.dat
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Dead reckoning and position jump filter
The Dead reckoning calculation and Position jump filter functionality described here,
are used to avoid temporary stops and position jumps when updating the ship symbol in
the Geographical view.

Missing positions and unstable position input will typically occur when the positioning
system antenna(s) is obstructed by e.g. bridges or other structures.

Both Dead reckoning and Position Jump filter can be enabled/disabled independently
using the Tools→Customs→Set parameters→Positions menu.

Note

Position jump filtering is also performed in another context. It is used for gridding
purposes and the objective is to avoid erroneous data being used in the gridding
operation and subsequently displayed in the gridded data in the Geographical View.
This operation is automatic, but the parameters to use can be changed using the
Tools→Customs→Set parameters→Positions menu.

Dead Reckoning
If the position input stops for more that 0.5 second, SIS will predict all subsequent
missing positions for a set period of time, currently 30 sec. The prediction is based on
the last two good positions which are used to calculate the speed. In addition the last
good heading is used in the calculations to determine the direction.

When the set prediction period expires, or if a new good position is received, the
prediction stops.

Note

If the position update frequency is 1 Hz, the current setting will imply that a predicted
position is generated 0.5 seconds (approximately) after a real position, giving an update
frequency of the boat symbol of 2 Hz.

Position jumps
A position filter is used to remove excessive jumps in position. If a jump is detected,
a predicted position is calculated and used instead. The criteria for a position jump is
that the speed exceeds a set limit, currently 30 m/sec. Also, a position jump is assumed
if the heading calculated from the last two positions exceeds a ± 20 degree corridor
scaled according to the position quality.
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Note

The position jump filter only removes one erroneous position (the first) if several
consecutive erroneous positions are received.

The predicted positions (from Dead Reckoning calculations or Position jump filter)
are never logged. They are used to update the boat symbol in the Geographical View.
The predicted position datagrams are not distributed to external recipients that have
subscribed to position datagrams.

Missing position input will be indicated in the PU sensor status display and in the PU
status lamp in Main menu bar. A message is also logged in the Message service when
positions are missing.

Related topics
• Request datagrams from an echo sounder on page 559
• PU sensor status view on page 86
• Main toolbar on page 33
• Message service view on page 69
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Checking of legal beam pointing angles
Checking of legal runtime sonar head beam pointing angles is performed when changing
the sonar head installation angles. This function is only relevant for the EM 2040,
EM 2040C, EM 3000 and EM 3002 echo sounders.
When changing the sonar head installation angles this will affect the validity of the sonar
head beam pointing angles set in the Runtime parameters→Sounder Main frame. The
new installation angles will modify the allowed maximum and minimum settings for the
sonar head beam pointing angles and the currently used values may therefore, as a result,
be outside the legal range. The test aims to inform the operator about this situation so
that corrective action may be taken. The figure below shows the relevant angles for a
dual head system (e.g. a dual EM 3002).

When calculating and setting these angles the following rules apply:
• All angles are referenced to the vertical downward axis, i.e. 0 deg. is downward
• The installation angles are positive to port and negative to the starboard (applies

to both heads).
• The port beam pointing angle is positive to the port whereas the starboard beam

pointing angle is positive to the starboard (applies to both heads).
• The maximum allowed beam pointing angle relative to the head is dependent on

the type of sounder and in some cases on the serial number (i.e. EM 3002 shallow
and deep water heads). This information is used when performing calculations to
determine maximum and minimum allowed beam pointing angles relative to the
vertical downward axis.
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The algorithm to determine the minimum and maximum allowed beam pointing angles
for EM 3002 / EM 2040 / EM 2040C echo sounders are as follows:

The EM3002 minimum sector width is used to make sure that the port and starboard
beams on a head do not “close”. This Minimum sector width is set to 10 degrees. The
EM3002 max angle ref. head is 60 deg or 65 deg, depending on deep or shallow head type.
HEAD 1
The maximum legal beam pointing angles:
Sonar head 1 port max angle (Pmax) =

EM3002 max angle ref. head
+ ’Inst. ang. sonar head 1’

Sonar head 1 starboard max angle (Smax) =
EM3002 max angle ref. head
- ’Inst. ang. sonar head 1’

The minimum legal beam pointing angles:
Sonar head 1 port min angle (Pmin) =

’Sonar head 1 port max angle (Pmax)’
- (2*EM3002 max angle ref. head)
+ EM3002 minimum sector width

Sonar head 1 starboard min angle (Smin) =
’Sonar head 1 starboard max angle’
- (2*EM3002 max angle ref. head)
+ EM3002 minimum sector width

HEAD2
Same calculations as for HEAD 1. Remember
installation angle for HEAD 2 is normally
negative (i.e. pointing to starboard).
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Datagram and file formats

This chapter provides a description of some of the datagram and file formats used by SIS.

Topics
• TPU – Error estimate logging format on page 530
• Export formats on page 531
• Depth under keel output format on page 534
• Depth profile output on page 535
• Terrain referenced position on page 536
• Survey plan file format on page 538
• Handling of SSP datagrams on page 539
• Sound speed profile formats on page 544
• External datagram (C+T) format on page 550
• ATH data format on page 551
• SRH data format on page 555
• TerraPOS data format on page 556
• Changing behaviour of notification messages on page 558
• Request datagrams from an echo sounder on page 559
• Request datagrams – manual set-up on page 561
• Data distribution on page 567
• Remote datagrams on page 568
• Notification of SIS pinging and logging activity on page 570
• Difference in log file formats on page 573
• Barometer input on page 574
• K-Sync interface on page 575
• Port allocation on page 576
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TPU – Error estimate logging format
This option is only available when importing raw data into SIS. There are two possible
formats:
• basic format: the simple format which outputs: Beam number, horizontal error and

vertical error.
• extended format: a more complete format which outputs: Beam number,

latitude[degrees], longitude[degrees], north[cm], east[cm], depth, horizontal error[cm]
and vertical error[cm]

At the top of the file, a header is written, explaining the format of the file: The TPU files
are placed on the same disk as the grids in the folder sisdata/surveyName/sf and are
named lineNumber_date_time.tpe (0010_20060907_130302.tpe).

TPU logging is enabled by selection from the SIS parameters Logging option which are
located under Tools→Custom...→Set parameters→Logging.

See Logging on page 341.
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Export formats
When data is exported from SIS, different export formats can be chosen.

The ASCII output contains an entry describing the file contents. Note that positions are
in projection coordinates and in centimetres. Depths are also in centimetres. Time is in
milliseconds since epoch 0 UTC 1 January 1970.

The binary output also contains this information. The following is an example code
of how to read the binary files:
//h+//////////////////////////////////////////////
/*!
// \file readSISBinaryOutput
//
// \brief Example of how to read the binary output
// from SIS
// \author Terje Pedersen
//
// \date 10-OCT-2003
//
// \par Copyright:
//
// Copyright by Kongsberg Simrad
//
//
// \par Revision History:
//
// \par 01 10-OCT-2003 tp
//
// Original Version.
//
//
*/
//h-///////////////////////////////////////////////
#include <stdio.h>
#include <stdlib.h>
#include <time.h>
#include <string.h>

//! Little endian cell data
#ifdef WIN32
typedef __int64 i64;
#else
typedef long long i64;
#endif
typedef struct {

int m_lEastCm, m_lNorthCm;
int m_iDepthCm;
int m_iFlag;
int m_iResidualCm;

}SLittleEPointRec, *SLittleEPointPnt;

typedef struct {
int m_lEastCm, m_lNorthCm;
i64 m_lDate;// millisec. since epoch
int m_iPingno, m_iBeamno;
int m_iDepthCm;
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int m_iFlag;
int m_iResidualCm;

}SLittleEPointExtraRec, *SLittleEPointExtraPnt;

//f+////////////////////////////////////////////////
//
/*!
// \brief Convert milliseconds since epoch to date
//
// \param mtime, milliseconds since epoch
// \param year, month, day, hour, min, sec, millisec
//
// \return void
//
// \author Terje Pedersen
//
// \date 10-OCT-2003
//
// \note
*/
//f-////////////////////////////////////////////////

/void convertMsecToDate(i64 mtime, int *year,
int *month, int *day, int *hour, int *min,
int *sec, int *msec)
{

i64 t;
time_t nt;
struct tm stm, *ptm;
if (year == NULL || month == NULL || day == NULL ||

hour == NULL || min == NULL || sec == NULL ||
msec == NULL) return;

t = mtime/1000;
*msec = (int)(mtime - (t*1000));
nt = (time_t)t;
ptm = localtime(&nt);
if (ptm == NULL) return;
memcpy(&stm,ptm,sizeof(stm));
*year = stm.tm_year+1900;
*month = stm.tm_mon+1;
*day = stm.tm_mday;
*hour = stm.tm_hour;
*min = stm.tm_min;
*sec = stm.tm_min;

}

//f+///////////////////////////////////////////////
//
/*!
// \brief Read the binary output from SIS
//
// \param type, what type of file to read
// \param filename, name of file to read
//
// \return void
//
// \author Terje Pedersen
//
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// \date 10-OCT-2003
//
// \note
*/
//f-////////////////////////////////////////////////

int readSISBinaryOutput(int type, char *filename)
{

FILE *fd;
SLittleEPointRec le;
SLittleEPointExtraRec lex;

if (type < 1 || type > 2) return -1;
//printf(”%d %d\n”,sizeof(le),sizeof(lex));

fd = fopen(filename,”rb”);
if (fd == NULL){
fprintf(stderr,”Cannot open file: %s\n”,filename);
return -1;
}

if (type == 1){// Little endian point data
while(fread(≤,1,sizeof(le),fd)){
printf(”East %d cm, North %d cm, Depth %d cm, Flag %d,

Residual %d cm\n”,le.m_lEastCm, le.m_lNorthCm,
le.m_iDepthCm, le.m_iFlag, le.m_iResidualCm); }//while

}//if type == 1
if (type == 2){// Little endian point data with extras

int year, month, day, hour, min, sec, msec;
while(fread(&lex,1,sizeof(lex),fd)){

convertMsecToDate(lex.m_lDate,&year,&month,&day,
&hour,&min,&sec,&msec);

printf(”East %d cm,North %d cm,
Date %I64d %04d%02d%02d %02d%02d%02d.%d,
Ping no. %d,Beam no. %d,Depth %d cm,Flag %d,
Residual %d cm\n”,lex.m_lEastCm,lex.m_lNorthCm,
lex.m_lDate,year,month,day,hour,min,sec,msec,
lex.m_iPingno,lex.m_iBeamno,lex.m_iDepthCm,
lex.m_iFlag,lex.m_iResidualCm);

}//while
}//if type == 2
return 0;

}

int main(int argc,char*argv[])
{

if (argc != 3){
printf("\n\nUsage:%s<type><filename>\n\n"argv[0]:
printf("Types:\n!);
printf(”1: little endian point data without time.\n”);
printf(”2: little endian point data with time.\n”);
printf(”Long must be 8 bytes, it is %d bytes\n”,sizeof(i64));
printf(”\n\n”);

}//if

return readSISBinaryOutput(atoi(argv[1]), argv[2]);
}
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Depth under keel output format
NMEA 0183 (V 3.01) DPT – Depth Below Transducer

$KBDPT,x.x,x.x,x.x*hh<CR><LF>

Maximum range in use is always 12000.0.

The Centre depth output is always sent as a NMEA DPT datagram on UDP to port
number 4310.
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Depth profile output
The datagram is sent from the HWS.

This datagram is sent to IP:port using UDP, defined in Datagram subscriptions, token
NMEA_MDM.

Transmit depth profiles format
These are the internal datagrams:

$KSSIS,x—x,c—c\n\r

There is only one NMEA-style datagram. The datagram identifier is SIS, and the
manufacturer is always KS. The first number is an integer, which identifies what comes
in the rest of the datagram. Since c–c is a string of characters, and since comma and \n\r
are reserved characters in this format, it is understood that any text enclosed in double
quotes are treated as one block of text which then may contain commas and \n\r.

30
ModelNo,SerialNo,
date(YYYYMMDD),
time(millisecond. since midnight),
NoRealtimeDepths,SprojCoord*

Datagram sent from the HandleDDS to the GeoView
containing all the XYZ points.

As an example the datagram from the time; 08:12:51, January 5. 2010, can be like this:

$KSSIS,30,710, 345, 20100105,29571234, 45,...\n\r

where ... are binary data of the type SprojCoord:

struct SProjCoord
{

int m_iEastCm, //!< East in projection
coordinates (centimetres)

m_iNorthCm, //!< North in projection
coordinates (centimetres)

m_iDepthCm, //!< Depth in centimetres.
m_iTideCorrCm, //!< Depth Tide corrected.
m_iVRefCm, //!< Depth ref. vref. using

geoid model.
m_iGeoidCm, //!< Seafloor to geoid
m_iEllipsCm; //!< Seafloor to ellipsoid.

};

Note

m_iDepthCm will always be valid. If not the other information are available, they will
not be valid.
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Terrain referenced position
Range and bearing to objects: This will be sent from the HWS to IP:port using UDP,
where IP:port is set in SIS parameters. SIS shall use NMEA sentences BWR and WPL
for this purpose.
There are two scenarios:
1 The operator selects a target relative to the current ship position, where the ship

position is the reference point.
See The vessel coordinate system on page 496 for reference point definition.
The output shall then be range and bearing from the current ship position to the
selected target:
$PKBWR,hhmmss.ss,llll.llllll,a,yyyyy.yyyyyy,a,x.x,T,x.x,
M,x.x,N,c--c,a*hh<CR><LF>

Where the letters specifies:
hhmmss.ss, hh is for hours, mm is for minutes and ss.ss is for seconds.

The time of observation
llll.llllll,a, The waypoint latitude, N/S
yyyyy.yyyyyy,a, Waypoint longitude, E/W
x.x,T, Bearing, degrees TRUE

x.x,M, Bearing, degrees Magnetic

x.x,N, Distance, nautical miles
c- -c, Waypoint ID
a, Mode indicator:

A = Autonomous mode
D = Differential mode
E = Estimated (dead reckoning) mode
M = Manual input mode
S = Simulator mode
N = Data not valid

$--WPL,llll.llllll,a,yyyyy.yyyyyy,a,c - - c*hh<CR><LF>

Where the letters specifies:
llll.llllll,a, The waypoint latitude, N/S
yyyyy.yyyyyy,a, Waypoint longitude, E/W
c- -c, Waypoint ID

The operator selects a target in the geographical display. When he decides to send
this target to IP:port using UDP, the current ship's position is found. The time in this
datagram is the time from that position. Bearing is only calculated for true bearing,
T; magnetic bearing is NOT calculated and the value is left blank. The waypoint
identifier is also left blank, and the mode indicator (a) is always M.

2 The operator selects two points and the output shall be range and bearing from the
first point to the second point.
$PKWPL,llll.llllll,a,yyyyy.yyyyyy,a,c--c*hh<CR><LF>
$PKBWR,hhmmss.ss,llll.llllll,a,yyyyy.yyyyyy,a,x.x,T,x.x,
M,x.x,N,c--c,a*hh<CR><LF>

First a WPL message is sent. This message contains the position of the first
waypoint. The identifier field is now set to “WP1”. Then a BWR message is sent.
The position is the second waypoint, and the identifier is “WP1”, the identifier
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of the waypoint in the first message. The distance is from the first to the second
waypoint, and the bearing is from the first to the second waypoint. Only true
bearing is calculated.
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Survey plan file format
The survey plan file can be stored as a binary file with extension *.sisplan or as ASCII
files in the existing Neptune format.

The first line gives information about the Latitude/Longitude format used in the file.
There are four different options:

DEG – Degrees, decimal degrees

MIN – Degrees, minutes and decimal minutes

SEC – Degrees, minutes and seconds

PROJECTION – Projection coordinates

The next line is a comment or text that follows the job.

The following is an example of the format to define a planned line:
_LINE <Line Name> <Line Number> <Time of creation>
<Flag><N><E><N><E>'<Comment>

The time of creation is the HWS time given in the following format:
YYYYMMDDhhmmss

where:
• YYYY – The Year
• MM – The month of the year
• DD – The day of the month
• hh – The hour of the day
• mm – The minutes in the hour
• ss – The second of the minute

The polygon has a similar format, except:
• Starts with _POLYGON
• The name is always polygon
• The line number is always 0
• The flag is always 0
• It is not possible to attach information to a polygon
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Handling of SSP datagrams
Topics
• Overview on page 539
• Usage on page 541
• Reception handling of SSP format input on page 542

Overview
The SSP datagram format is used for input of depth or pressure profiles containing:
• Sound speed (m/s)
• Temperature (°C)
• Salinity (parts per thousand)
• Absorption coefficient

SSP datagrams are sent to the HWS on port 4001.

The SSP format is a generic format and the actual type of information conveyed is
defined by an identifier. Currently the following are defined:
Identifier Input data Data to be used Comment

S00 D,c D,c Same
as S10,
but used
immediately

S01 D,c,T,S D,c,a(D,T,S,L) Same
as S12,
but used
immediately

S02 D,T,S D,c(D,T,S,L), a(D,T,S,L) Same
as S22,
but used
immediately

S03 D,T,C D,c(D,T,C,L), a(D,T,S,L) Same
as S32,
but used
immediately

S04 P,T,S D(P,T,S,L), c(P,T,S,L), a(P,T,S,L) Same
as S42,
but used
immediately

S05 P,T,C D(P,T,C,L), c(P,T,C,L), a(P,T,C,L) Same
as S52,
but used
immediately

S06 D,c,a D,c,a Same
as S11,
but used
immediately
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Identifier Input data Data to be used Comment

S07 P,c,T,C D(P,T,C,L), a(P,T,C,L,c)[1] Same
as S14,
but used
immediately

S10 D,c D,c

S11 D,c,a D,c,a

S12 D,c,T,S D,c,a(D,T,S,L)

S13 D,c,a,f D,c,a Frequency
dependent

S14 P,c,T,C D(P,T,C,L), a(P,T,C,L,c)[1]

S20 D,T,S D,c(D,T,S,L)c

S21 D,T,S,a D,c(D,T,S,L),a

S22 D,T,S D,c(D,T,S,L),a(D,T,S,L)

S23 D,T,S,a,f D,c(D,T,S,L),a Frequency
dependent

S30 D,T,C D,c(D,T,C,L)

S31 D,T,C,a D,c(D,T,C,L),a

S32 D,T,C D,c(D,T,C,L),a(D,T,C,L)

S33 D,T,C,a,f D,c(D,T,C,L),ai Frequency
dependent

S40 P,T,S D(P,T,S,L),c(P,T,S,L)

S41 P,T,S,a D(P,T,S,L),c(P,T,S,L),a

S42 P,T,S D(P,T,S,L),c(P,T,S,L),a(P,T,S,L)

S43 P,T,S,a,f D(P,T,S,L),c(P,T,S,L),a Frequency
dependen

S50 P,T,C D(P,T,C,L),c(P,T,C,L)

S51 P,T,C,a D(P,T,C,L),c(P,T,C,L),a

S52 P,T,C D(P,T,C,L),c(P,T,C,L),a(P,T,C,L)

S53 P,T,C,a,f D(P,T,C,L),c(P,T,C,L),a Frequency
dependentÿ

Legend

a Absorption coefficient

c Sound speed

C Conductivity

D Depth

f frequency

1. The datagram contains measured sound speed as well as parameters required to compute the sound
speed. The measured sound speed is used in the sound velocity profile and to compute the absorption
coefficient.
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P Pressure

L Latitude (always present)

S Salinity

T Temperature

The notation a(D,T,S,L) means that the absorption coefficient (i.e. a) is calculated from
depth, temperature, salinity and latitude.

Usage
The use of absorption coefficients from SSP datagrams are available for all types of
echo sounders.

Upon reception of SSP datagrams, SIS will always generate a sound velocity profile file
(.asvp), either directly (e.g. if S00, S11 is received) or by performing the necessary
calculations to determine the sound speed (c) from the supplied data.

An absorption coefficient profile file (.abs), based on the supplied data, will also be
generated for all frequencies used by the echo sounders.

There is a special case for the SSP datagrams S13, S23, S33, S43 and S53. These
datagrams has been extended to also include a frequency for which the contained data is
valid. This makes it possible to specifically set all absorption coefficients to be used for
the relevant frequency.

Note

When one of these particular datagrams are used SIS will require one datagram for each
of the frequencies used by the echo sounders (i.e. 12, 31.5, 60, 70, 80, 90, 95, 100,
200, 250, 300, 350 and 400 kHz). They must be sent within 10 sec. of each other and
have the same acquisition date and time.

A subset of the SSP datagrams, specifically S00, S01, S02, S03, S04, S05, S06 and
S07, will be used immediately. That is, the corresponding sound velocity profile and
absorption coefficients will be sent to the PU(s). The Runtime parameters frame, if
displayed, will be updated with the new file set information.

When SSP datagrams are received by SIS, the SVP Editor will always be informed.

If the SVP Editor is not running, it will be started automatically if enabled by the
Tools→Custom→Set Parameters→Sound speed menu.

You may edit the .asvp and .abs files and store the edited files using the SVP editor.
You can use these files by selecting the .asvp file, i.e. sound profile, from the Runtime
parameters→Sound Speed.

Parameter references
• Sound speed for EM 2040 on page 305
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Related topics
• SVP Editor on page 395

Reception handling of SSP format input
Up until SIS version 3.8 it has been assumed that the SSP format input (i.e. Sxx format
type datagrams) has been correct when received. Only a minimum of error checks have
been performed before use. From SIS 3.8 the following basic problem situations in the
received SSP datagram will be reported:
1 Illegal no. of samples (legal 1-1000)
2 Illegal time of acquisition (legal 000000-235959)
3 Illegal date of acquisition (legal 1-31)
4 Illegal month of acquisition (legal 1-12)
5 Illegal year of acquisition (legal 0000-9999)
6 Number of set samples don't correspond with found no. of samples
7 End of datagram not found
8 Illegal sound speed value (legal 1400-1700 m/sec)
9 Illegal depth value (legal 0-12000.0m)
10 Decreasing depth value
11 Multiple similar depth values.
12 Sound speed profile is not extended to 12000m (accepts depths in the range

11900m-12000.0m as legal extension)
13 Depth values less than 1cm apart (i.e. 3 or more decimals resolution is not legal)
14 Profile contains too many samples. Max 570 samples for EM 120, EM 300, EM

1002, EM 2000, EM 3000. Max 1000 otherwise.
If a vessel uses a combination of echo sounders allowing both 570 and 1000
samples, e.g. an EM 120 and an EM 710, the smallest number restricts the max
sample limit (i.e. 570 in this case). The reason is that the same profile is used on all
active (started) echo sounders.

15 Unknown error.

In addition an incoming SSP datagram (format type Sxx) will be rejected in the SIS
network input function, with no operator warning, if the basic datagram format is
violated, i.e. when it is impossible to recognise a legal datagram, e.g.:

• Message format is not correct, e.g. missing '$' in header start, alignment problems
in header, etc.

• Undefined format type (identifier) i.e. where Sxx is not a defined SSP format (e.g
s00 or S99).
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Generally, if a received SSP datagram is correct it will be accepted by SIS and handled
according to its type. S0x format types (identifiers) will always be used immediately
implying that all started echo sounders (PUs) will be updated with the new profile and
the new absorption coefficients will be applied when requiered. All non S0x format types
will be prepared for manual selection using the Runtime parameters→Sound Speed frame.

However, if the received SSP datagram is recognized, but contains errors the use of the
datagram will be stopped at different stages depending on the seriousness:

• If the error is in the range 1–7 (see above) this is a serious problem and the processing
is always aborted. The indicated problem must be corrected and the datagram re-sent
to SIS.

• If the error is in the range 8–15 the problem is less serious and it may be corrected by
using the SVPEditor that will be automatically started if enabled. Alternatively the
problem may be corrected outside the SIS context and the datagram re-sent to SIS.

Regarding the use of the SVPEditor when receiving an SSP datagram the following
should be noted.
• S0x format types intended for immediate use and containing no errors will never

start the SVPEditor. If an error in detected the SVPEditor will be started only when
enabled.

• All other format types will start the SVP editor when received if the startup is enabled.

Related topics
• SVP Editor on page 395
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Sound speed profile formats
Internally SIS uses sound speed data in the ASVP format only. The ASVP format is an
ASCII format described in this section.

All sound speed profiles must be converted to the ASVP format before they can be
applied by SIS. Several methods for converting a sound speed file into the ASVP format
exists.

In addition, several sound speed probes can be directly interfaces and instantaneously
applied by SIS. The supported formats are described in this section.

Finally, SIS also reads the ACTD format. This applies to special profile containing
water density in addition to the sound speed. It is used in ROV operations where the
scaling factor is automatically calculated.

Topics
• ASVP format on page 544
• Supported sound velocity probes on page 546
• ACTD format on page 548

Related operational procedures
• How to collect the sound velocity profile on page 141
• How to convert your sound velocity profile to SIS format on page 143
• How to modify and load a sound speed profile into SIS on page 151

Parameter references
• Sound speed for EM 2040 on page 305

Related topics
• External sensors on page 371
• SVP Editor on page 395

ASVP format
The standard sound speed profile used in SIS has the file extension .asvp (ASCII sound
velocity profile). The file layout is as follows:

Header (the first line enclosed in brackets)

( SoundVelocity Version Id Time Lat Long Radii Valid_from
Valid_to Src Hist No_val )

Note

Note the space character after the leading bracket and before the closing bracket.
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SoundVelocity: An identification of the file type (sound speed profile file)

Version: The file format version number (usually 1.00)

Id: A possible identifier

Time: The time of creation for this file (YYYYMMDDhhmm or YYYYMMDDhhmmss)

Lat: The latitude of the profile location (decimal degree)

Long: The longitude of the profile generation (decimal degree)

Radii: The radii around the lat/long position for which this profile is valid (m).

Valid from: The time interval in the year from which this profile is valid (YYYYMMDDhhmm)

Valid to: The time interval in the year to which this profile is valid (YYYYMMDDhhmm)

Src: The source of the profile (e.g. probe name, database name, editors name etc.)

Hist: The history of modifications on the profile (P=probe, E=edited, M=merged,
N=new)

No val: The number of values that are used in the profile

Data
Depth: The water depth (m)

SounVelocity: The sound speed (m/s) at the corresponding depth

ASVP file format example
( SoundVelocity 1.00 12 200605290813
22.3452678 66.4483298 4500 200605290813
200605301210 SVP-16 PE 8 )
0.1 1483.6
5.0 1484.2
7.0 1485.3
12.0 1488.1
20.0 1485.7
25.0 1484.0
40.0 1483.8
12000.0 1509.6

Data restrictions
• Legacy echo sounders (i.e. EM 120, EM 300, EM 1002, EM 2000 and EM 3000,) can

handle maximum 570 data entry points.
• The new generation of echo sounders (i.e. EM 122, EM 302, EM 710, ME70/BO and

EM 3002,) can handle maximum 1000 data entry points.

Error checking
The sound speed profile selected from Runtime parameters→Sound speed is checked for
possible errors before it is being used. If applicable, an error message is reported to
the user for the following errors:
• Sound velocity out of range (legal range [1400-1700] m/s
• Depth out of range legal range [0-12000] m
• Depth inconsistency, i.e. depth decreasing
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• Depth inconsistency, i.e. multiple similar depths
• Depths not extended to 12000 m
• Unknown format in file
• Missing or unknown creation time
• Unknown conversion error

Even though SIS supports several types of sound speed profiles, the checking will be
performed to the file after is has been converted to .asvp format.

Before the profile is accepted by SIS all reported errors must be corrected for, e.g. using
the SVP Editor.

Supported sound velocity probes
SIS supports the following sound velocity probes directly:
• AML SV
• AML SV&T
• AML SV&P
• AML Micro SV
• AML Micro SV&T
• AML Micro SV&P
• Valeport Mini SVS

The probe is selected from the External sensors located in the Tools menu.

AML SV

The AML Micro SV output message is an ASCII character string that includes the sound
velocity (in m/s) and a carriage return\line feed message termination pair.

"SV\r\n" // example: "1484.92\r\n"

AML SV&T

The AML SV&T output message is a space delimited ASCII character string that
includes the temperature (in degrees C), sound velocity (in m/s), and a carriage
return\line feed message termination pair.

"T SV\r\n" // example: "11.739 1484.92\r\n"

AML SV&P

The AML SV&P output message is a space delimited ASCII character string that
includes the pressure (in dbar), sound velocity (in m/s), and a carriage return\line feed
message termination pair.

"P SV\r\n" // example: "000.40 1484.92\r\n"
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AML Micro SV
The AML Micro SV output message is an ASCII character string that includes the sound
velocity (in m/s) and a carriage return\line feed message termination pair.
"SV\r\n" // example: "1484.92 \r\n"

AML Micro SV&T
The AML Micro SV&T output message is a space delimited ASCII character string that
includes an (optional) date (MM/DD/YY), an (optional) time (HH:MM:SS:hundreths
of seconds), the sound velocity (in m/s), temperature (in degrees C), and a carriage
return\line feed message termination pair.
"DATE TIME SV T\r\n" // example: "05/14/03 14:23:06:02
1484.92 11.739\r\n"

SIS will accept the message with or without the date and with or without the time.

AML Micro SV&P
The AML Micro SV&P output message is a space delimited ASCII character string that
includes an (optional) date (MM/DD/YY), an (optional) time (HH:MM:SS:hundreths
of seconds), pressure (in dbar), the sound velocity (in m/s), and a carriage return\line
feed message termination pair.
"DATE TIME P SV\r\n" // example: "05/14/03 14:23:06:02
000.40 1484.92\r\n"

SIS will accept the message with or without the date and with or without the time.

For all AML probes
SSV (surface sound velocity) is a 6 digit number which gives the sound velocity in m/s
(for example 1500.03).
T (temperature) is a five digit signed number which gives temperature in degress celcius
using the following format: ±00.000. No sign is displayed for positive temperatures.
P (pressure) is a five digit signed number which gives the pressure in decibars using the
following format ±00.000 (or ±000.00) depending on the pressure.

Valeport Mini SVS
The Valeport Mini SVS probe supports a large number of output formats.
SIS only supports three of these formats; the default format and two alternate
formats.
•

Valeport standard (default) format
The default output message is an ASCII character string that includes a leading space
followed by the sound velocity (in mm/s), and a carriage return\line feed message
termination pair.
" SV\r\n" // example: " 148492\r\n"
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•

Valeport Alternate Format #1
The alternate #1 output message is an ASCII character string that includes a leading
space followed by the sound velocity (in m/s), and a carriage return\line feed message
termination pair.
" SV\r\n" // example: " 1484.921\r\n"

•

Valeport Alternate Format #2
The alternate #2 output message is an ASCII character string that includes a leading
space followed by the sound velocity (in m/s), and a carriage return\line feed message
termination pair.
" SV\r\n" // example: " 1484.92\r\n"

ACTD format
This is a special profile containing water density in addition to the sound speed. It is used
in ROV operations where the scaling factor is automatically calculated.
The file extension is .actd (Ascii density profile).
The error checking as described in Sound speed profile formats on page 544 also applies
to the .actd format.

Note

The ctd term in the file extension is not entirely accurate in this case. It is used as
a general term to indicate that the file contains additional parameters to depth and
sound speed.

The file layout is as follows:

Header (the first line enclosed in brackets)
( ACTD Version Id Time Lat Long Radii
Valid_from Valid_to Src Hist No_val )

Note

Notice the space character after the leading bracket and before the closing bracket.

ACTD: An identification of the file type.

Version: The file format version number (usually 1.0)

Id: A possible identifier

Time: The time of creation of this file, (YYYYMMDDhhmmss) seconds (i.e. ‘ss’)
are optional

Lat: The latitude of the profile location (decimal degree).

Long: The longitude of the profile generation (decimal degree).
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Radii: The radii around the lat/long position for which this profile is valid (m)

Valid from: The time interval in the year from which this profile is valid (YYYYMMDDhhmm)

Valid to: The time interval in the year to which this profile is valid (YYYYMMDDhhmm)

Src: The source of the profile (e.g. probe name, database name, editor’s name
etc.).

Hist: The history of modifications on the profile (P=probe, E=edited, M=merged,
N=new)

No val: The number of values (i.e. sample sets) that are used in the profile

Note

All elements in the header must be represented. The ‘Time’, ‘Lat’, ‘Long’ and ‘No val’
must always have real valid values.

Data

This is the file body which consist of No val number of sample sets, each sample set is
placed on a separate line
Depth: The water depth (m)

SoundVelocity: The sound speed (m/s) at the corresponding depth

Density: The water density (kg/l) at corresponding depth

An example:
( ACTD 1.00 12 20060529081355 22.3452678 66.4483298
4500 200605290813 200605301210 SVP-16 PE 7 )
0.20 1496.18 0.890
6.10 1491.51 0.890
41.97 1474.97 1.02
165.77 1480.02 1.14
271.28 1481.57 1.15
427.28 1484.42 1.15
12000.00 1669.00 1.19

Note

This header will eventually (in later releases) get the same format as the .asvp file type.h

Note

The same restrictions regarding number of data entry points in the profile applies to
the .actd file type as to the .asvp file type.
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External datagram (C+T) format
If Ext. datagrams (C+T) is selected UDP is used.

The format of the external UDP datagram used with the Ext. datagrams (C+T) sensor
selection is as follows:
$KSSIS,80,c.c,t.t,\n\r

where
• $KSSIS specifies that this is a Kongsberg proprietary datagram format
• 80 is the datagram number indicating that this is an external sound speed sample
• c.c is the sound speed at transducer represented as an ASCII text string e.g. 1460.95
• t.t is the temperature at transducer represented as an ASCII text string e.g. 19.25
• \n\r is the closing sequence (linefeed, carriage return)

This datagram must be sent to port 4001 on the HWS computer.
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ATH data format
The Applanix POSMV True Heave (ATH) data format is defined below. Note that the
output is binary data.

Header:
// Time and distance fields (part of header), see [1] 4.2.3

// POSMV Header, see [1] 4.2.3
groupStart[4]; $GRP
groupID; Group Member
byteCount; Group Dependent
time1; seconds
time2; seconds
distanceTag; meters
timeTypes;
distanceType;

Data:

GROUP 1 - Vehicle navigation solution, see [1] 4.3.1.1
latitude; (-90.90] degrees
longitude; (-180,180] degrees
altitude; (,) meters
northVelocity; (,) meters/second
eastVelocity; (,) meters/second
downVelocity; (,) meters/second
vehicleRoll; (-180,180] degrees
vehiclePitch; (-90,90] degrees
vehicleHeading; [0,360) degrees
vehicleWanderAngle; (-180,180] degrees
vehicleTrackAngle; [0,360) degrees
vehicleSpeed; [0, ) meters/second
vehAngRateLong; Vehicle angular rate about

longitudal axis (,)degrees/second
vehAngRateTrans; Vehicle angular rate about

transverse axis (,)degrees/second
vehAngRateDown; Vehicle angular rate about down

axis - (,) degrees/second
vehAccLong; Vehicle longitudal acceleration

- (,) meters/second^2
vehAccTrans; Vehicle transverse acceleration

-(,) meters/second^2
vehAccDown; Vehicle down acceleration

- (,) meters/second^2
alignmentStatus;

GROUP 102 - Sensor 1 position, Velocity, Attitude, Heave & Dynamics, see [2]
3.3.2.2
latitude; (-90.90] degrees
longitude; (-180,180] degrees
altitude; (,) meters
alongTrackVelocity; (,) meters/second
acrossTrackVelocity; (,) meters/second
downTrackVelocity; (,) meters/second
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roll; (-180,180] degrees
pitch; (-90,90] degrees
heading; (-180,180] degrees
wanderAngle; (-180,180] degrees
heave; (,) meters
angRateLong; angular rate about longitudal

axis - (,) degrees/second
angRateTrans; angular rate about transverse

axis - (,) degrees/second
angRateDown; angular rate about down

axis - (,) degrees/second
accLong; longitudal acceleration - (,)

meters/second^2
accTrans; transvers acceleration - (,)

meters/second^2
accDown; down acceleration - (,)

meters/second^2

GROUP 103 - Sensor 2 Position, Velocity, Attitude, Heave & Dynamics, see [2]
3.3.2.3
latitude; (-90.90] degrees
longitude; (-180,180] degrees
altitude; (,) meters
alongTrackVelocity; (,) meters/second
acrossTrackVelocity; (,) meters/second
downTrackVelocity; (,) meters/second
roll; (-180,180] degrees
pitch; (-90,90] degrees
heading; (-180,180] degrees
wanderAngle; (-180,180] degrees
heave; (,) meters
angRateLong; angular rate about longitudal

axis - (,) degrees/second
angRateTrans; angular rate about transverse

axis - (,) degrees/second
angRateDown; angular rate about down

axis - (,) degrees/second
accLong; longitudal acceleration - (,)

meters/second^2
accTrans; transvers acceleration - (,)

meters/second^2
accDown; down acceleration - (,)

meters/second^2

GROUP 104 - Sensor 1 Position, Velocity and Attitude Performance Metrics, see
[2] 3.3.2.4
NPositionRMS; [0,) meters
EPositionRMS; [0,) meters
DPositionRMS; [0,) meters
alongTrackVelocityRMSError; [0,) meters/second
acrossTrackVelocityRMSError; [0,) meters/second
downTrackVelocityRMSError; [0,) meters/second
rollRMSError; [0,) degrees
pitchRMSError; [0,) degrees
headingRMSError; [0,) degrees
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GROUP 105 - Sensor 2 Position, Velocity and Attitude Performance Metrics, see
[2] 3.3.2.5
NPositionRMS; [0,) meters
EPositionRMS; [0,) meters
DPositionRMS; [0,) meters
alongTrackVelocityRMSError; [0,) meters/second
acrossTrackVelocityRMSError; [0,) meters/second
downTrackVelocityRMSError; [0,) meters/second
rollRMSError; [0,) degrees
pitchRMSError; [0,) degrees
headingRMSError; [0,) degrees

GROUP 110 - MV General Status & FDIR, see [2] 3.3.2.6
SPOSMVGroup110; User logged in - bit 0 : set

reserved - bit 1 to 31

GROUP 111 - Heave & True Heave Data, see [2] 3.3.2.7
trueHeave;
trueHeaveRMS;
status;
heave;
heaveRMS;
heaveTime1;
heaveTime2;
rejectedIMUDataCount;
outOfRangeIMUDataCount;

GROUP 112 - NMEA Strings, see [2] 3.3.2.8
variableGroupByteCount; [0,)
NMEAStrings;

GROUP 113 - Heave & True Heave Performance Metrics, see [2] 3.3.2.9
heaveTime1; seconds
qualityControl1;
qualityControl2;
qualityControl3;
status; Quality Control 1 Valid - bit 0 : set

Quality Control 2 Valid - bit 1 : set
Quality Control 3 Valid - bit 2 : set
reserved - bit 3 to 31

Footer:

POSMV Footer, see [1] 4.2.3
pad[2]; 0
checksum;
groupEnd[2]; $#

342682/D 553



Seafloor Information System

References
• [1]: POS TNG3 Core User Control,Display,Data and Logging Port Interface Control

Document, Applanix, Rev. 8
• [2]: POSMV V4 User ICD, Applanix, Rev.2.0

554 342682/D



Datagram and file formats

SRH data format
The Seapath Real Heave (SRH) data format is defined below. Note that the output is
binary data.
cHeader1; !< I.e. 0xAA
cHeader2; !< I.e. 0xXX (0x52=Real Heave)
iEpocSec; !< Seconds since start of epoc (19700101).

MSB is index 0, i.e. Big Endian representation.
nFracSec; !< 0.0001 fractions of a sec. MSB is index 0,

i.e. Big Endian representation.
iHeave; !< Heave in cm. Big Endian representation.
cStatus; !<
cChecksum1; !< MSB of checksum (Checksum is an unsigned short,

the split is done to handle alignment probl.)
cChecksum0; !< LSB of checksum
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TerraPOS data format
The TerraPOS data format is defined below. Note that the output is binary data.
1 SfFileMainHeadRec , Main head record
1 SfPosHeadRec, Private head records
n SfPosRec, IFF position records.

//------------------------------------------------------------
// Survey format File headers
//------------------------------------------------------------

//------------------------------------------------------------
// At the start of a surveyformat file there is always a FileMainHeadRec
// This record is the same for all survey format files
//------------------------------------------------------------
noSwap; /* Parameter to check swapping */
pid; /* Process id (not used) */
formatVersion; /* Fileformat version */
noHist; /* SPARE: Number of history elements */
sizeof_myHeadRec; // sizeof header following the main file header
sizeof_myDataRec; // sizeof the data records in file
spare;
comment[128];

//----------------------------------------------------------
// Position data needs specified info into its head rec
// Position data head rec
//----------------------------------------------------------
firstHead; header of first datagram
startTgmHead; header of start datagram
sensor;
version;
active; set if this sensor is the active one.
spare2; align
datum; /* The datum of the positions */

/* nytta ved makeXyz naar djup skal plasserast */
/* Faar ein initiell romslig verdi, og kan setjast vha regel */

maxDistDiff; /* Max diff. in distance for interp. [cm] */
maxTimeDiff; /* Max diff. in time for interp. [ms] */
sensID; /* 0,1,2,3 */
spare3;
spare4[2];
// ref Terrapos: More info about datum

ref_frame[64];

//------------------------------------------------------------
// Position data record
//------------------------------------------------------------
// The survey format positon record is a COPY of the raw data positioning datagram.
// The only change is that the ascii data string is exchanged with a binary record
// of position extra info.

// Latitude in decimal degrees *20000000 (negative in southern hemisphere)
// Longitude in decimal degrees *10000000 (negative in western hemisphere)

// NOTE: DO NOT CHANGE THIS FORMAT!!!
// It will cause problems for modules which treats SfPosRec as an EmXPosRec.

/* telegram head */
head; /* 16 bytes */
latitude;
longitude;
posQuality; for Terrapos: HRMS
speed;
course;
heading;
sysId; /*Id: bit 0-2 number, bit 4 decode Sim90, bit 7 active*/
noRawBytes; /* SF: Always sizeof sfPosExtraRec */
id[2]; /* two first letters of ascii datagram,

Added because of alignment needed */
data; /* SF: Ascii string removed, sfPosExtraRec added instead. */

556 342682/D



Datagram and file formats

/* telegram end */
etx;
checksum;
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Changing behaviour of notification messages
Notification messages are used in SIS when something is being reported or brought to
the attention of the operator. Several levels of notification are available:
• Information
• Warning
• Error

All can be used with or without pop-up and sound. All notification messages results in
an entry in the SISDB database, which can be viewed using the Message Service. See
Message service view on page 69.

Notification messages generated in SIS are defined in a file found in the directory where
SIS is installed.

The following directory and file name typically defines all messages and the behaviour in
SIS as they occur:

C:\Program Files\Kongsberg Maritime\sis\bin in a file called
messages_R_Sy.uni.

This file is in UNICODE and must be edited in an editor that supports UNICODE, like
WordPad. You can change both the text message and the type of the message.

The header of this file describes the valid types. Each message has a type field which can
be set to the operator’s preferences. Simply change the type field for the messages you
want and save the file. Make sure you save it as UNICODE.

Then open a terminal window in the directory where you saved this file. Issue the
following command:
osql -Usisuser -Psimrad0 -imessages_R_Sy.uni

SIS will now react to the messages as described in the file.

Note

These settings may be lost when SIS is upgraded or reinstalled. If you want to make sure
you always have these settings, save this file somewhere on your system. Reapply it
when SIS is reinstalled.

Note

When SIS is upgraded the settings must be re-entered manually as described above. This
is because SIS will use new upgraded database files, and any new content will be lost if
the old saved file is reapplied.
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Request datagrams from an echo sounder
When an echo sounder is registered on the network in SIS, and started, datagrams can be
routed from the echo sounder to selected IP addresses on the network.
The echo sounder must have been configured and started in the normal manner. Then
start the Request datagrams program: Tools→Custom→Datagram distributions.

1 Select the echo sounder from the first pull-down menu
2 Select datagram from second pull-down menu
3 Select the output interval of the datagrams from the third pull-down menu
4 Fill out the text field IP:Port with IP address and UDP port number to send the data to

Remember the colon between the address and the port number
5 Press Subscribe
6 Repeat for all datagrams required

342682/D 559



Seafloor Information System

7 Restart SIS for the setting to take effect

When the echo sounder is started again, the requested datagram type(s) will be sent to
the specified address(es) at the set interval.

To stop sending datagrams, select the datagram from the list and press Unsubscribe.

Note

Never try to “Unsubscribe“ the factory defined datagrams.

Sending options

The options for sending out the datagrams are as follows:
1 All – meaning distribution whenever a datagram is received
2 Interval – distribution when datagram is received and later with a specified interval

(from 1 sec to 1 minute)
Note

It is the latest datagram received in an interval that will be distributed at the end of the
interval (i.e. when selecting no 2 above).

Also, when the datagram arrival frequency is low and the distribution interval is short
the last received datagram may be sent several times. This set-up is normally not
appropriate for e.g. Position datagrams, but may serve better for Installation datagrams.

Datagram selection

The majority of the datagrams that can be selected for distribution, are datagrams
generated and sent from the echo sounders.

Currently there are three datagrams that are not of this category, these are the remote
datagrams R00, R10 and R12. In this case these datagrams are NOT the remote
datagrams generated by an external system for the purpose of controlling SIS as
described in Remote datagrams on page 568.

Rather, these datagrams are generated locally in SIS as a result of the operation of the
pinging and logging buttons. Please see description in Notification of SIS pinging and
logging activity on page 570

The intention is that an external system may be able to follow (i.e. shadow) the SIS
pinging and logging operations.

Note

The R-datagrams must always be selected with the “All“ option to avoid multiple
retransmissions of the datagrams.
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Request datagrams – manual set-up
Note

This chapter is intended for advanced users only. It is simpler to subscribe on datagrams
by selecting Tools→Custom→Datagram distribution. See Request datagrams from an
echo sounder on page 559.

Overview

The subscription setup of datagrams from the DDS can be performed in two ways:
1 By using a provided utility (see note above) specifying the relevant echo sounder,

datagram and subscriber IP address. These entries are semi permanent i.e. valid
until the database is completely rebuilt.

2 By updating the database tables manually. These changes will be permanent.
Currently this option requires that the database is completely rebuilt.

Manual update of database tables

The SIS DDS has the ability to distribute (i.e. retransmit) datagrams received from the
Processing Unit (and other sources) out to external recipients. This distribution is done
according to settings in the SIS database. Therefore, in order for an external recipient
to subscribe to a particular datagram, the SIS database must be updated to distribute
the datagram.

Note that SIS contains several DDS applications of different types. Each type is adapted
to handle a specific type of Processing Unit or equipment. Currently three DDS types
are of interest:
1 A generic multibeam type (EM 3000, EM 3002, EM 2000, EM 1002, EM 710,

EM 300, EM 120)
2 A generic NMEA single beam type (receiving NMEA DPT or NMEA DBT, NMEA

GGA, NMEA HDT or NMEA HDM)
3 A GPS and compass (receiving NMEA GGA, NMEA HDT or NMEA HDM)

The SIS Database

The SIS database contains several tables which defines the datagram distribution set-up
in DDS. These tables can be divided into four categories:
1 A category with one table defining the datagrams and the distribution parameters
2 A category with one table defining sockets used for sending datagrams
3 A category with one table linking the two, i.e. defining which datagram to be sent

on which socket
4 A category with several tables organizing datagrams and sockets according to type

of DDS process
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Table ’dds_datagrams_send’ (category 1)

This table is used to define all datagrams which can be distributed by a DDS. Each entry
(i.e. row) is identified by a datagram id (’id_datagram’) which must be unique.

The dds_datagrams_send table normally only needs to be updated when new datagrams
are defined or new DDS types are added. However, when a datagram subscription is
defined it is necessary to know the correct id_datagram value as this value is used
in other tables.

Figure 45 Relevant SIS database tables for subscription configuration

id_datagram

Note that the datagram identifiers are organized in ranges or sets, one for each type of
DDS (i.e. PU or equipment type) - see user_pid below. The generic EM multibeam set
currently has an id_datagram range from 36 to 302 (with some holes). NMEA singlebeam
has a range from 400 to 475 and the GPS compass type has a range from 500 to 575.
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datagram_type

The datagram_type parameter defines the type of datagram (e.g. Depth =’D’ = 68)
associated with the specific datagram id. The same datagram type may be used in all
ranges, if relevant, but only once in each range.

interval, seconds

These parameters are used to define how to distribute the associated datagram. The
interval parameter may have the following values:
• 0 - Distribute signal when received
• 1 - Distribute signal repeatedly with a set interval defined by the seconds parameter.
• 2 - Distribute signal when received and repeat, as above
• 3 - Distribute signal only upon request (currently not implemented).

user_pid

This parameter identifies the DDS type associated with the id_datagram parameter.
The correct user_pid value is found in the process table as the pid parameter (marked
with bold in entries below):
1 DDS generic multibeam type (EM 3000, EM 3002, EM 2000, EM 1002, EM 710,

EM 300, EM 120) is entry: (10,’DDS_GENERIC_EM’)
2 Generic NMEA single beam type is entry:

(14,’DDS_GENERIC_SINGLEBEAM_NMEA’)
3 For GPS and compass is entry: (13,’DDS_GENERIC_GPS’)

The range scheme and the use of the same datagram type in several ranges allow
datagrams to be handled differently for each DDS type (i.e. PU/equipment type).

Table ’dds_periodic_datagrams’ (category 4)

This table defines which datagrams, (defined in dds_parameters_send) belong to which
DDS type. Each entry (i.e. row) defines such a relation. The dds_periodic_datagrams
table normally only needs to be updated when new datagrams are defined or new DDS
types are added.

id_dds

This parameter identifies the DDS type. The correct value is found in the process table as
the pid parameter (marked with bold in entries below):
1 DDS generic multibeam type (EM 3000, EM 3002, EM 2000, EM 1002, EM 710,

EM 300, EM 120) is entry: (10,’DDS_GENERIC_EM’)
2 Generic NMEA single beam type is entry:

(14,’DDS_GENERIC_SINGLEBEAM_NMEA’)
3 For GPS and compass is entry: (13,’DDS_GENERIC_GPS’)
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id_datagram

Id of datagram from the correct range in the dds_datagrams_send table according to
DDS type.

Table sockets (category 2)

This table defines all sockets in the SIS system including all sockets used by DDS.
If a subscription is added or changed it may be necessary to define a new socket or
change an existing socket. The socket will be used by DDS for sending the subscribed
datagrams to the recipient.

id

Each socket in SIS must have a unique id. This is an integer number. Before selecting
an id for the socket make sure it is below 1000 and not already used (make a search
in the SISDB_v3.sql and any other SISDB_vX.sql file with a higher version than X=3).

port, ip

This is the net address for the recipient of the subscribed datagram(s).

udp_tcp

0 = UDP, 1 = TCP

The UDP protocol must always be used. This setting shall therefore be 0.

server_client

0 = server, 1 = client, 2 = unused

SIS is a server. This setting shall therefore be 0.

read_write

= 0 read, 1 = write, 2 = read and write

The socket is always write. This setting shall therefore be 1.

pid

This parameter gives an id to the recipient on the other side of the link. For the purpose
of distributing datagram from the DDS to an external recipient the pid value must
be set to 76 - NOTE this value.

Table ’process_socket’ (category 4)

This table defines which sockets, (defined in ’sockets’) that belong to which process.
Each entry (i.e. row) defines such a relation.

The process_socket table needs to be updated when new datagrams are defined or new
DDS types are added.
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process_id
This parameter identifies the process using the socket; in this case that is a DDS type.
The correct value is found in the process table as the pid parameter (marked with bold
in entries below):
1 DDS generic multibeam type (EM 3000, EM 3002, EM 2000, EM 1002, EM 710,

EM 300, EM 120) is entry: (10,’DDS_GENERIC_EM’)
2 Generic NMEA single beam type is entry:

(14,’DDS_GENERIC_SINGLEBEAM_NMEA’)
3 For GPS and compass is entry: (13,’DDS_GENERIC_GPS’)

socket_id
Id of the socket used to distribute datagrams to the recipient. The socket_id is found in
the sockets table as the id (see above) of the relevant socket definition.

Table ’dds_socket_send’ (category 3)
The table is used to connect datagrams with sockets, i.e. it tells which datagrams
(identified by ’id_datagram’) that should be sent out on which socket.

This is the essential routing information necessary to be able to distribute the datagrams
to the correct recipient.

In essence, all the other tables are only help tables necessary to define the datagrams and
sockets (and who they belong to), whereas the routing information in dds_socket_send is
what we really want to specify.

id_datagram
A defined datagram id belonging to a DDS type which is the same as for id_socket below.

id_socket
A defined socket id belonging to a DDS type which is the same as for id_datagram above.

When making entries in this table, care must be taken to pair only datagrams
and sockets associated with the same DDS type (identified by ’process_id’ in
’the ’process_socket’ table and ’id_dds’ in the ’dds_periodic_datagrams’ table
respectively).

Procedure for setting up a datagram subscription
The tables to be modified are located in the SISDB_v3.sql file.
1 Check if the datagram to be subscribed exist in dds_datagram_send table for the

relevant DDS type. If not, define it. Remember the id_datagram value.
2 Check if the datagram exist in the dds_periodic_datagrams table for the correct DDS

type. If not, define it.
3 Make a socket for the recipient, in the sockets table using correct IP address.

Remember the id_socket value.
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4 Make an entry in the process_socket table with the new id_socket value and the
relevant DDS type.

5 Make an entry in the dds_socket_send table with the correct combination of
id_datagram and id_socket. Note that one socket can be used for several datagrams.

6 The SIS database must be re-built and SIS restarted.

Important notes and restrictions
• All entries in the tables described above are currently done with reference to three

DDS types. These types are regarded as templates used to instantiate database entries
for new echo sounders detected on the network. Instantiation is necessary due to the
fact that several echo sounders can not use the same data and the same objects (e.g.
sockets.) Each echo sounder will therefore get a separate set of sockets and datagram
ids, which mean that the specific values entered in the tables above, are not actually
used for any echo sounder.

• However, the IP address for the recipient of a datagram is a value that can not be
instantiated. This implies that the DDSes for e.g. EM 3000, EM 3002, EM 2000,
EM 1002, EM 710, EM 300, EM 120 will send a datagram to the same recipient if
they are detected in the same SIS system.

• When the changes in the SIS database are performed the database must be
re-built and SIS restarted.

• The settings will be semi permanent, i.e. they will be in effect until the database is
completely rebuilt.
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Data distribution
The DataDistrib program is included with SIS. This is a Windows application that can
be used to route or distribute UDP datagrams to various destinations on the local PC or
to other networked PCs.

The application has a graphical user interface where you can set up distribution of data
from up to 10 different sources. In a grid you set up the incoming sockets from where
to listen to data and up to four different destinations for each source. It also possible to
store incoming data to a file and later replay that file. If you want to replay data, a file
name is entered instead of a source port.

Make sure that you enter a Source port that is not used by any other applications, e.g.
rstoudp, as two application cannot use the same port simultaneously.

Only the DataDistrib.exe file must be installed on the PCs where the application should
run. Settings are stored in DataDistrib.ini.

Figure 46 DataDistribution user interface
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Remote datagrams
These datagrams allow external systems a minimal amount of control of SIS. The
datagrams are received by SIS in port 4001 and 4002, from the connected network
using the UDP protocol.

Datagram Received on port Description

R00 4002 SIS to stop pingning (and logging if on)

R10 4002 SIS to stop all logging, but continue or start pinging

R12 4002 SIS to start logging on new line

R20 4001 Echosounder to send installation, runtime and sound
speed profile (I, R and U) datagram

Note

The Rxx datagrams must always contain the sounder type i.e. EMX=dddd . “dddd” is
described in Model number – code mapping table on page 572.

SIS supports for the following remote datagrams:

R00, R10 and R12
R00, R10 and R12 closely mimic the use of the logging and ping buttons. There are
no restrictions on the sequence in which these datagrams can be sent. The following
is typical:
• To start pinging: R10
• To start logging: R12 (Note that it is not necessary to start pinging with R10 first)
• To stop logging: R10 or R00. (Note R00 also stops pinging)
• To stop pinging: R00
When the remote Rxx datagrams are received the sounder type indicated in the datagram
is made current. The SIS GUI is updated accordingly so that the ping and logging
buttons will show the correct status.

The PLL parameter in the R12 datagram can now be used to set the line number to
be logged. The line number must be 4 digits between 0000 and 9999. Any non digit
characters in the line number will result in PLL being disregarded. If no specific line
number is wanted PLL should be set to empty, i.e. PLL=,

Note

No characters between the equal sign and comma

Note

The relevant echo sounder must have been started for the R00, R10 and R12 datagrams
to have any effect. SIS will behave as if the ping and logging buttons have been used,
including line counter increment.
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R20

R20 is used to get an echo sounder (PU) to transmit the setup parameters currently used
(i.e. I, U, R datagrams). These parameters are normally distributed by the PU to the
external system(s) using its UDP4 port.

Note

The relevant echo sounder must have been started for the R20 datagram to have any
effect.
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Notification of SIS pinging and logging
activity
It is possible for an external system to subscribe to the pinging and logging status
changes in SIS. This makes it possible for the external system to mimic (shadow) these
SIS operations.

A simple scheme to notify external systems of the pinging/logging status changes is to
use the remote R-datagrams as these will give the necessary information:
• R00 System to stop pinging (and logging if on)
• R10 System to stop logging (but continue or start pinging)
• R12 System to start logging on new line

See Remote datagrams on page 568

Note

The original purpose of the R-datagrams is to be able to remotely control the SIS pinging
and logging activity. However, using the R-datagrams for status change notification as
described in this chapter does not conflict with this purpose.

SIS will prepare and send R-datagrams according to changes in logging and pinging
status. External systems that require notification of these events must subscribe to these
datagrams by using the datagram distribution feature in SIS.

See Request datagrams from an echo sounder on page 559

Note

The “All“ send option must be used for the R-datagrams when setting up the parameters.

The use cases below indicate which R-datagrams an external system may receive due to
pinging/logging status changes in SIS. Note that this is not a complete list.

SIS turns logging on
• Case 1: R12 (logging on)
• Case 2: R10 (pinging on) + R12 (logging on)

SIS turns logging off
• Case 1: R00 (pinging off logging off)
• Case 2: R10 (logging off, pinging still on)

SIS logs several consecutive lines (without breaks)
• Case 1: R12 + R12 + ... + R12 + ...
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Note

It is important, in order to get a correct and complete status of the SIS logging activity,
that all R-datagrams, including R00, must be subscribed to. R00 will indicate stop of
pinging, but as a consequence, logging will also stop.

The format of the R-datagrams are defined in the Datagram formats document (reg nr
850 – 160692). For simplicity it is shown below, however always refer to the document
in mention for a valid format.
Data Description Format Valid range Note

Start identifier = $ Always 24h — —

Talker identifier aa Capital letters —

Datagram identifier Rxx, R00 to R20 1

EM model number EMX=dddd, — —

Responsible operator ROP=a–a, — —

Survey identifier SID=a–a, — —

Survey line number PLN=d..d, — —

Survey line identifier (planned line no) PLL=d–d, — —

Comment COM=a–a — —

Optional checksum *hh — —

End of datagram delimiter = \CRLF 5Ch 0Dh 0Ah — —

The following parameters are not used in this context, i.e. no values are supplied by
SIS for:
• ROP
• PLL

The rest of the parameters are used and contain parameters as described in the format.

Example, for an EM 3002 echo sounder:
$KMR12,EMX=3020,ROP=,SID=Fallback_3002_121_1,PL
N=0006,PLL=,COM= Serial number: 121*cc\CRLF

Where cc are two hex characters calculated by XOR’ing all characters between $ and *.

The Talker identifier will be set to “KM”.

The format description above is inadequate to handle several echo sounders
simultaneously, as it has no parameter to list the serial number of an echo sounder.
This number has been put in the comment field (COM=) for completeness (e.g. COM=
Serial number: 121 in the example above).
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Model number – code mapping table

The EM model number “dddd” is coded as follows:
System Code Note

EM 120 0120 —

EM 122 0122 —

EM 300 0300 —

EM 302 0302 —

EM 710 0710 —

EM 1002 1002 —

EM 2000 2000 —

EM 3000 3000 —

EM 3002 3020 NB!

ME70/BO 0850 NB!

Note

The codes for EM 3002 and ME70/BO differs from their respective system names.

Performance requirements

The interval between the distributed R-datagrams is undefined, i.e. the datagrams are
asynchronous. The initial (startup) status may be assumed to be pinging and logging
both off.

External interface requirements

The datagram distribution mechanism in SIS uses UDP. Note that SIS, in future releases,
may operate several echo sounders in parallel. This implies that SIS can distribute the
pinging/logging status from several echo sounders simultaneously (see the remark about
the comment field (COM=) above).

In case of several echo sounders the information (i.e. R-datagrams) from each echo
sounder can be distributed to separate IP:port address or alternatively all can use the
same address. This must be decided before setting up the datagram subscription (i.e.
distribution) parameters in SIS.

It is the responsibility of the external operator and the external system to set up and
handle the incoming flow of pinging/logging status data from SIS. The EM model
number can be used, if necessary, to distinguish between echo sounders using the same
IP:port address.
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Difference in log file formats
SIS logs various types of datagrams from the echo sounder in a continuous stream. Each
time you start a new line, a new survey data file is created which results in a break in
the data stream such that a depth datagram may be located at the end of one file with its
associated position datagram located at the beginning of the next.

When SIS generates xyz-data from these files, if it encounters a depth datagram at the
end of the file for which there is no corresponding position datagram, it looks for the
missing position datagram in the next survey file. However, when Neptune generates
xyz-data from these files, if it can’t find a valid position datagram after the last depth
datagram, it will reject the depth datagram resulting in a hole in the data.

Previous versions of the Merlin logging system handled this situation by storing duplicate
position datagrams in both survey files, but this is no longer done. Therefore, to eliminate
this type of hole when generating xyz-data, Neptune will be updated with a tool that will
insert the missing position datagram at the proper location in the survey data files.
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Barometer input

Preparations for use
If automatic update of the barometer (Offset) parameter is required (used in ROV
operation for EM 3002) it is necessary to prepare SIS to receive this information.

The external barometer equipment/system must be connected to a vacant RS232 input
port on the SIS HWS. This serial port must be configured: Tools→External Sensors

Barometer input format
The (current) format of the data received on the serial port is as follows:
*ddsspppp.ppp<cr><lf>

Where:
* The format always starts with an asterisk (*)

dd a two digit destination identifier

ss a two digit source identifier
pppp.ppp pressure in mbar. Number of digits before and after the

decimal point may vary

<cr><lf> Terminating carriage return and line feed charactersft W

If this input format needs to be changed it is possible to adapt SIS to the new format
without a full SIS upgrade. A separate conversion process is used for this purpose.
This process is implemented using Perl, a programming language which can be used
with all SIS installations. An editor and knowledge of Perl is all that is needed to adapt
the conversion process:
1 Stop SIS if running
2 Go to the SIS program installation directory (e.g. ”C:\Program Files\Kongsberg

Maritime\SIS\bin” on Windows). Locate the file barometerconv.pl and open it in an
editor. Do the necessary changes to adapt to the changed input format.

3 Save and close the edited file
4 Start SIS

The required output from the conversion process is a string of the following format:
$KSSIS,134,ss,dd,pppp.ppp\n\r

where the pressure has been converted to decibar of format pppp.ppp, and the number of
digits before and after the decimal point may vary.

“\n\r” is linefeed and carriage return.

Parameter references
• ROV Specific for EM 2040 on page 291
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K-Sync interface
The numerical display frame in SIS contains an element for showing status information
from the K-Sync (Synchronization Unit) product.

K-Sync is used to control the pinging operation of several echo sounders on the same
vessel to avoid interference between them. K-Sync consists of a dedicated embedded
computer that generates time critical trigger control signals and receives feedback from
each managed echo sounder. The embedded K-Sync computer is controlled by a K-Sync
application program running on a separate computer.
SIS and the K-Sync application program are normally installed on different computers.
As a consequence it is of interest to be able to show the K-Sync status information
directly in the SIS GUI environment. The K-Sync status is therefore sent to SIS via the
Ethernet network using UDP and receiver port 4002 on the SIS HWS. The status is
updated whenever a change occurs, and at least every 5th second. If a status message
from an echo sounder is not received by SIS within a 10 second interval the status
element for that echo sounder is blanked, i.e. set to the background colour.
In the SIS GUI the K-Sync status information is displayed in the Numerical frame.
Initially, there is no K-Sync status information visible. This information will only be
displayed after having received the first K-Sync status message. This is done to avoid
having to configure SIS for the situation where a K-Sync installation is not used and
hence no K-Sync display elements should be present.
The SIS K-Sync status display in SIS consists of seven colour elements. The colour
indicates the K-Sync status according to the following scheme:
• Background (grey) – Disabled
• Green – Ready
• Dark green – Trigger and Busy after Trigger
• Yellow – Busy (explicit Busy status, not as a result of Trigger)
• Red – Error
Note

Some of the status colours used in SIS do not correspond to the colours used for the same
status in the K-Sync application program. This is due to different colouring schemes.
In SIS red is used for errors and off situations, whereas in K-Sync this is Busy. In SIS
Dark green is used for both Trigger and Busy after Trigger.

By positioning the cursor on top of one of the coloured status elements the echo sounder
name associated with that element will be shown.
Note

The K-Sync product is able to control up to 16 different synchronization elements (e.g.
echo sounders). SIS will currently only be able to report/display the seven first. This will
normally be adequate for most configurations.

342682/D 575



Seafloor Information System

Port allocation
The network ports listed in the following are allocated for SIS and the echo sounder
system, and must not be used by other systems on the network.

SIS ports
SIS allocates ports dynamically from port number 16000 and upwards. Number of
dynamically allocated ports depends on number of detected echo sounders.
Port number Defined for
2012 Simulator input to PU.exe
4001 Internal datagrams to CCU from other SIS modules
4001 External SSP datagrams
4001 External $KSSIS.080 sound velocity at transducer datagrams
4001 External $ATIDE realtime tide datagrams

4001 R20 remote datagram, used to request currently used setup parameters from
the PU

4002 Internal datagrams to GUI from other SIS modules
4002 R00, R10 and R12 datagrams for remote control of the PU
4002 K-Sync status information
4003–4007 Miscellaneous allocated sockets for internal SIS use
4006 Internal use by PU.exe

4008 Internal use by CUBE
4009 Internal use by Helm.exe

4012 Not fixed, but normally used for the Global Event Marker Clients
4310 NMEA DPT datagram output
4312 Internal use by ShapeFiles Reader
4043–4445 Internal use by SVP Logger
4603 Internal use by HDDS
5050 DDS to Helmsman display
5051 Helmsman display to autopilot
5052 Helm.exe
5053 Helm.exe
5055 CCU to SSV (Surface Sound Velocity)
5056 SSV to CCU
5057 SSV to RStoUDP
5058 RStoUDP to SSV
5060 Internal use by CCU and SVP Editor
5061 Internal use by CCU
5558 Licence server
5689 Internal use by KSGPL/SIS Objects
7010 HDD to GridEngine
8080 GridEngine
9001–9013 Miscellaneous allocated sockets for internal SIS use
10183 EA listens for CS datagrams
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Port number Defined for
15052 Internal use by Helm.exe
15201 Internal use by RStoUDP
15800 Internal use by CUBE
16xxx– Dynamically allocated ports

PU ports
Port number Defined for
1999 EA input

1999 PU broadcast

2012 Remote control of PU
2022 UDP2

2032 UDP3

2042 UDP4

2999 Dummy port number displayed to indicate the the PU is logging to disk. For
internal use.

Dynamical Host UDP port 1. Used by SIS for PU command responses and status.

Dynamical Host UDP port 2. Used by SIS for logging of survey data (to .all files). See PU
communication – Output setup on page 279.

Dynamical Host UDP port 3. Used by SIS for update of realtime display info, e.g. beam
intensity, time series, etc.

Dynamical Host UDP port 4. Used by SIS for user defined logging purposes. See PU
communication – Output setup on page 279.

Attitude sensors
Port number Defined for
3000 CodaOctopus F180
3001 Seapath 200 default (configurable)
5602 POSMV output

ATH (Applanix True Heave)
Port number Defined for
5070 ATH to CCU
5071 CCU to ATH
5602 POSMV output

SRH (Seapath Real Heave)
Port number Defined for
5075 SRH to CCU
5076 CCU to SRH
31102 Input from Seapath
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RTCM Logging
Port number Defined for
5081 CCU to RTCMLogger
5082 RTCMLogger to CCU
31103 Input from Seapath
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Appendix A
Terminology and

abbreviations

Terminology
All multibeam echo sounder systems use transducer arrays but in some models the
transducers are integrated in sonar heads.
→Refer to the installation manual to find out more about your system .

Abbreviations
The following abbreviations are used in this document:
1PPS
One Pulse Per Second synchronization signal
ABDC
Area Based Data Cleaning
APB
NMEA Autopilot format B sent by SIS/planning stations to allow them to be used to
control an autopilot unit
AUV
Autonomous Underwater Vehicle
BD
Bottom detection
BIST
Built-In Self Test
BS
Backscatter
BSP
Beamforming and Signal Processing
CCU
Central Command Unit, a SIS background process that controls all echo sounders
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CMG
Course made good, course from beginning of planned line
COG
Course over ground
CPU
Central Processing Unit
CUBE
Combined Uncertainty and Bathymetry Estimator, an alternative data gridding method
CW
1 Clockwise
2 Continuous Waves (describing pulse properties)
CCW
Counterclockwise
DBS
NMEA datagram; Depth below surface
DBT
NMEA datagram; Depth below transducer
DDS
Data Distribution System; a SIS background process responsible for logging datagrams
sent by the echo sounders
DPT
NMEA datagram; Depth
DST
Distance to end of line
DTK
Desired track, direction of planned line
DTM
Digital Terrain Model
DXF
Data Exchange File, a three-dimensional graphics file format
EA
A type of singlebeam echo sounder
EM
A type of multibeam echo sounder
ETA
Estimated time of arrival
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GGA
NMEA position datagram
GGK
NMEA position datagram
GMT
Greenwich Mean Time
GPS
Global Positioning System (in this manual GPS includes all kinds of positioning systems)
GUI
Graphical User Interface
HDDS
Handle Data Distribution System; a SIS background process that reads data from disk
and process the data to xyz for SIS gridding
HDM
NMEA datagram; Heading, magnetic
HDOP
Horizontal Dilution Of Precision read from position datagrams
HDT
NMEA datagram; Heading, true
HWS
Hydrographic Work Station; the SIS operator PC
IP
Internet Protocol
IRLS
Iterated Reweighted Least Squares
KSGPL
Kongsberg SIS Graphic Programming Language
LBDC
Line Based Data Cleaning
LOD
Level Of Detail
ODBC
Open DataBase Connectivity, a standard database access method
OpenGL
A 3-D graphics language
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PU
Processing Unit (for multibeam echo sounders with a Transceiver Unit, the PU is
included in the TRU)
RAM
Random access memory
RGB
Red, green and blue (primary colours on a computer monitor)
ROV
Remotely Operated Vehicle
RTDC
Real Time Data Cleaning, the real time processing tool in SIS
RTK
Real Time Kinematic
RX
Receiver
SCSI
Small Computer System Interface, a parallel interface standard
SH
Sonar Head
SIS
Seafloor Information System, the front-end for all echo sounders
SISDB
SIS Database, the database used by SIS to store parameters
SOG
Speed over ground
SQL
Structured Query Language, a standardized query language for requesting information
from a database
SSP
Sound speed datagrams used by SIS (Sxx datagrams)
SV
Sound velocity
SV&P
Sound velocity and depth (pressure) sensor
SV&T
Sound velocity and temperature sensor
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TCP

Transmission Control Protocol
TRU

Transceiver Unit
TVG

Time Variable Gain
TVG FG

TVG Fixed Gain
TVG NIB

TVG Normal Incidence Backscatter
TVG OB

TVG Oblique Backscatter
TVG RN

TVG Range To Normal Incidence
TX

Transmitter
UDP

User Datagram Protocol, a connectionless protocol
UPS

Uninterrupted Power Supply
UTC

Universal Time Coordinated
UTM

Universal Transverse Mercator (a common projection used in map presentations)
VRML

Virtual Reality Modeling Language, a specification for displaying 3-D objects
WGS84

World Geodetic System 1984
XTE

Cross track error, measured, distance to planned line
ZDA

NMEA datagram; UTC and local date/time data
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Appendix B
INDEX (Interactive)
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Index

A
About SIS, 392
About this manual, 13
Absorption coefficient, 504
Equation, 512

actd, 548
Advanced parameters, 297
AHT logging, 323
Angular offsets, 274
EM 2040, 290

Annotation colours, 49
APOS, 347
Artefacts causing errors, 509
asvp, 544
ATH data format, 551
ATH logging, 325
Attitude velocity, 276
Auto pilot, 375
Output setup, 375
Parameters, 343

Automatic
BIST, 154
Startup, 154

Autostart, 154
AUV/ROV, 460

B
Barometer, 574
Input setup, 375

Beam intensity, 61
Buttons, 61
Show/Hide, 227
Toolbar, 61

Beam pointing angles, 527
BIST, 293
Built-In Self Test, 293
Buttons, 35
Annotation colours, 49
Beam intensity, 61
Calibration, 100
Colour coded depth, 63
Common, 48
Cross track, 64
Dynamic colours, 50
Geographical, 57
Helmsman Display, 70
Print, 51
Scale, 53
Scope display, 81
Seabed image, 66
Sensor layout, 98
Sound velocity, 79
Stave display, 83
Time series, 72
Water column, 78
Waterfall, 73
Zoom and view, 51

C
C-Map, 443
Cartographic service, 445
CM-93/3 compiler, 443
Detail level, 41
Installation notes, 16
Licence Administration, 379
Manipulation mode, 225
Min performance, 443
S-57 verifier, 443
What it does, 443

Calibration, 100
Area, 171
AutoCalib Wizard, 380
Automatic, 180
Buttons, 100
Dual head, 188
Edit mode, 224
Enable calibration mode, 181
Heading offset, 176
How to use SIS
Calibration, 181
Keyboard, 46
Mouse, 46
Outer beam angle
calibration, 178–179
Parameters, 260
Pitch offset, 174
Principles, 171
Roll offset, 173
SeaCal, 409
Seacal parameters, 261
Seacal results, 381
Show/Hide, 261
Sound velocity quality
inspection, 178
Time delay, 174
Toolbar, 100
Verification, 180

Changing behaviour of
notification messages, 558
Colour coded depth, 63
Buttons, 63
Show/Hide, 227
Toolbar, 63

Colour palette, 41
Common display buttons, 48
Annotation colours, 49
Dynamic colours, 50
Print, 51
Scale, 53
Zoom and view, 51

Convention, 496
Coordinate system
Vessel, 496

Create terrain models, 451
Cross track, 64
Buttons, 64

Display options, 227
Modeless operation, 64
Toolbar, 64

CUBE, 464
Create grid, 369
Description, 464
Export survey data, 471
Features not supported, 475
Geographical view, 473
Import raw data, 470
User interface, 470

Current echosounder, 36
Custom menu, 106

D
Data cleaning, 317
DTM processing rules, 320
Grid processing rules, 321
Ping processing rules, 319
Reference, 492
Seabed Image
Processing, 322

Data distribution, 567
Datagram formats, 529
Distribution, 567
Remote, 568
Request, 559
Request manually, 561
SIS pinging and logging
activity, 570
SSP datagrams, 539

Datum transformation, 384
Dead reckoning, 525
Delayed heave, 323
Depth below keel, 376
Depth profile output, 535
Depth under keel format, 534
Detecting the echo sounder
on the network, 157
Display, 25
Annotation colours, 49
Auto scale once, 54
Colour palette, 41
Dynamic colours, 50
Fixed scale, 54
Frames, 27
General, 212
Gridded data, 220
Icons, 40
KSGPL, 222
Neptune based survey, 219
Pause, 53
Point data display, 221
Print, 51
Reset view, 53
Scale, 53
SIS based survey, 216
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Sonar display grid, 218
Survey, 214
The application window, 25
Zoom, 51
Zoom out, 52
Zoom reset, 53

Display options, 209
Beam intensity, 227
Calibration, 261
Colour coded depth, 227
Cross track, 227
Geographical, 211
Helmsman Display, 237
Scope display, 247
Seabed image, 231
Sensor layout, 258
Ship definition, 334
Sound velocity, 247
Stave display, 249
SVP Editor, 396
Time series, 238
Water column, 243
Waterfall, 241

DP, 376
DPT format, 534
DTM processing rules, 320
Dynamic colours, 50
Dynamic positioning, 376

E
Echo sounder
Current, 36
Not started, 35

EM 2040
Angular offsets, 290
BIST, 294
Filter and gains, 310
ROV specific, 291
Scope display
parameters, 330
Simulator, 329
Sound speed, 305
Sounder main, 297
System parameters, 292

Error estimate format, 530
Error estimates, 346
Events, 447
Exit, 370
Export data, 206
Export formats, 531
Export survey results, 207
External datagram (C+T)
format, 550
External sensors, 371
Heading and position, 138
How to, 137
Input setup, 372

Output setup, 375
Sound velocity probe, 137

Extract IFF, 381

F
File
Background grid, 359
Create CUBE grid, 369
Delete settings, 364
Export, 352
Export data files, 359
Export PU parameters, 364
Export user settings, 368
Import, 352
Import PU parameters, 366
Import user settings, 369
KSGPL, 359
Parameters, 352
Raw data files, 355
Remove sounder, 362
Remove survey, 362
Save settings, 363
Save settings as..., 363
Set startup settings, 364
xyz file, 361

File formats, 529
actd format, 548
asvp format, 544
ATH, 551
Barometer input, 574
C+T format, 550
Depth profile output, 535
Depth under keel, 534
Difference in log file
formats, 573
DPT, 534
Error estimate formats, 530
Export formats, 531
Notification messages, 558
Sound speed and density
profile format, 548
Sound speed profile
format, 544
SRH, 555
Survey plan, 538
Terrain referenced
position, 536
TerraPOS, 556
TPU formats, 530

File menu, 104
Filter and gains, 297
EM 2040, 310

Frames, 27
Beam intensity, 61
Calibration, 100
Colour coded depth, 63
Contents, 55

Cross track, 64
Geographical, 57
Helmsman display, 70
Installation parameters, 94
Message service, 69
New survey, 89
Numerical display, 68
Parameters, 209
Planning, 93
PU sensor status, 86
Runtime parameters, 95
Runtime parameters
Mini, 96
Scope display, 81
Seabed image, 66
Sensor layout, 98
Sound velocity profile, 79
Stave display, 83
Survey administration, 91
Tear-off windows, 39
Time series, 72
Toolbar, 35
Water column, 75
Waterfall, 73

G
Generic Sensor Format, 483
Geodimeter, 375
Geographical, 57
2D or 3D, 223
Buttons, 57
C-Map manipulation
mode, 225
Calibration edit mode, 224
Compass, 223
CUBE features, 473
Display smooth surface, 165
Display sound vel. at
TD depth, 163
Follow ship, 224
General display, 212
Geotiff background data, 166
Grid shading, 222
Gridded data display, 220
Information field, 225
Inspection mode, 223
Keyboard, 44
KSGPL display, 222
KSGPL edit mode, 223
Level of detail, 225
Load background data, 224
Look for artefacts, 165
Modeless operation, 58
Mouse, 44
Neptune based survey, 219
Options, 211
Planning mode, 224
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Point data display, 221
Quick menu, 59
Save background image, 224
Seabed imagery display, 162
Show depth under
cursor, 222
Show position under
cursor, 223
SIS based survey
display, 216
Sonar display grid, 218
Survey display, 214
Toolbar, 57
Zoom to active survey, 52
Zoom to given region, 52
Zoom to ship, 52
Zoom to world, 52
Zooming, 52

Geoid, 515
Global event marker, 447
GPS, 323
GPS raw data logging
RINEX, 476
RTCM 3.0, 476

Graphical, 25
Frames, 27
The application window, 25
Windows, 27

Grid, 341
Create from ASCII, 451
CUBE parameters, 273
GridEngine, 490
GridEngine parameters, 269
Set data cleaning
method, 341

Grid processing rules, 321
GSF
Support in SIS, 483

GSF Converter
How to use, 483

H
Heading input, 374
Helmsman Display, 70
Buttons, 70
How to, 206
Show/Hide, 237
Toolbar, 70

Help menu, 107
Hotkeys, 46
How to, 108
APOS into SIS, 347
Calibrate a dual head
system, 188
Calibration, 181
Change SIS language, 112

Collect the sound
velocity profile, 141
Configure survey, 113
Convert format using
macro in the SVP
Editor, 149
Convert format using
SVP Editor, 147
Convert SVP format, 143
Create and use a geotiff
background picture, 166
csv2asvp, 143
Display a smooth
surface, 165
Display planned lines, 206
Display realtime depths, 161
Display seabed imagery
data, 162
Display sound velocity
at transducer, 163
Enter survey parameters, 114
Exit SIS, 207
Export data, 206
Export survey results, 207
External sensors, 137
GPS clock and orbit, 478
Import a Neptune grid, 159
Installation parameters, 127
Interface an EA into SIS, 155
Interfaces to HWS, 137
Log stave data, 170
Log water column data, 170
Look for artefacts, 165
Modify and load a SVP, 151
Monitor the external
sensors, 160
Monitor the progress, 202
New survey, 118
Open the installation
parameters, 126
Open the runtime
parameters, 134
Plan a new job, 201
Precise Point
Positioning, 478
Projection and datum, 122
Retrieve a planned job, 202
Run the PU simulator, 203
Run the survey, 202
Runtime parameters, 134
Save data, 169
SeaCal, 184
Setup enter the waterline
for EA, 139
Setup the output to
external sensors, 139
SmartTalk, 142

Start and stop logging, 169
Start pinging, 160
Start SIS, 112
Start the echo sounder, 154
Start the remote
helmsman display,
206
Survey parameters, 114
SVP Logger, 143
SVP Manager, 145
Terrapos, 478
Use SIS on AUV/ROV, 460
Verify the EM main
functions, 161

Hypack ®, 22

I
Icons, 40
Import grids to SIS, 451
Installation parameters, 274
Active sensors
parameter settings,
287
Angular offsets EM
2040, 290
Attitude sensor
parameter settings,
285
BIST, 293
Clock setup, 281
COM port parameters, 275
Description, 94
How to, 127
Input setup, 275
Location of sensors, 288
Motion sensor parameter
settings, 285
Multicast, 278
Network addresses, 276
Output setup, 279
Positioning systems
parameter settings, 283
Procedures, 125
ROV specific EM 2040, 291
Sensor setup, 283
System parameters EM
2040, 292
System report, 296
UDP port parameters, 275
UDP5 – UDP6, 276

Instrument combinations, 377
Interface, 371
Auto pilot, 375
Barometer, 375
Depth below keel, 376
Dynamic positioning, 376
Geodimeter, 375
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Heading, 374
How to, 137
Instrument
combinations, 377
Position, 374
Real time tide, 373
Remove instruments, 378
Sound velocity, 373
SVP logger, 375

Intermediate File Format, 381
Introduction, 15

J
Javad
Details, 520

K
Keyboard, 43
Calibration, 46
Geographical, 44
Planning, 44
Sensor layout, 45
Sound velocity profile, 45
Water column, 46
Waterfall, 45

KSGPL, 453
Edit mode, 223
Load background data, 224
Object types, 222
SIS objects, 417

L
Level of detail, 225
Licences, 16
Line counter, 37
Logging, 169
Formats, 573
How to, 154
Notification, 570
Sound velocity data, 141
To PU disk, 461
Water column, 247

Logging utilities, 435
Command based PU
sockets logging, 440
Command based SIS
sockets logging, 436
SIS data logger for PU
sockets, 439
SIS data logger for SIS
sockets, 435
SIS sockets, 435

M
Main menu, 103

Main toolbar, 33
Mean sea surface, 515
Menu, 103
Configure, 382
Custom menu, 106
File menu, 104
Help, 107
Main menu, 103
Tools, 105
Tools menu, 371
View, 105

Message service, 69
Mouse, 43
Calibration, 46
Geographical, 44
Planning, 44
Sensor layout, 45
Sound velocity profile, 45
Water column, 46
Waterfall, 45

N
Neptune, 159
Network licence, 345
New survey, 89
Background data, 267
Basic parameters, 263
GridEngine parameters, 269
How to, 118
Parameters, 263
Projections, 269
Storage options, 265

Notification of pinging and
logging, 570
Numerical display, 68
Numerical Display
Parameters, 232

O
Objects, 417
Overview, 15
System information, 16

P
Palette controller, 41
Parameters, 209
Active sensors, 287
Angular offsets EM
2040, 290
ATH logging, 323, 325
Attitude sensors, 285
Attitude velocity, 276
BIST, 293
Calibration, 260
Clock setup, 281
COM port, 275

Data cleaning, 317
Datum, 384
Delayed heave, 323
File menu, 352
Filter and gains EM
2040, 310
Frames, 209
GPS, 323
Help menu, 390
Input setup, 275
Installation, 274
Motion sensors, 285
Multicast, 278
Network addresses, 276
New Survey, 263
Numerical display, 232
Output setup, 279
Positioning systems, 283
PPP logging, 327
Projection, 384
Projections, 269
ROV specific EM 2040, 291
RTCM logging, 324
Runtime, 297
Runtime Mini, 96
Scope display, 330
Secal, 261
Sensor locations, 288
Sensor setup, 283
Ship definition, 334
Simulator EM 2040, 329
SIS parameters, 333
Sound speed EM 2040, 305
Sounder main EM 2040, 297
SRH logging, 326
Survey administration, 263
Survey information, 332
System parameters EM
2040, 292
System report, 296
Tools menu, 371
UDP port, 275

Password, 338
Ping processing rules, 319
Pinging, 160
Notification, 570

Planning, 93
Edit mode, 224
File format, 538
How to, 199
Jobs, 251
Keyboard, 44
Mouse, 44
New jobs, 201
Object, 251
Remote, 251
Retrieve a job, 202

Playback, 449
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Port definitions, 576
Position, 335
Dead reckoning, 525
Input, 374
Jump filter, 525

Position under cursor, 223
PPP, 476
PPP logging, 323, 327
Precise Point Positioning, 476
General description, 476
Procedure, 478
SIS, 478
Terrapos, 477

Predicted tide file format, 518
Print, 51
Procedures, 108
Advanced survey
parameters, 119
Advanced survey
template parameters, 115
APOS into SIS, 347
Automatic BIST at echo
sounder startup, 154
Background data, 114
Basic survey parameters, 118
BIST, 133
Check echo sounder
main functions, 161
Check installation and
runtime parameters, 125
Check sensor input, 160
CUBE parameters, 117
Data cleaning, 136
Datum transformation, 122
Detecting the echo
sounder, 158
Enter a sound velocity
profile, 139
Enter operator
parameters, 113
Enter survey parameters,
113–114
Exit SIS, 207
Export data files, 359
Export survey results, 207
External sensor, 136
Filter and gains, 135
GPS clock and orbit, 478
Heading offset
calibration, 176
How to calibrate a dual
head system, 188
How to change language
of SIS, 112
How to collect the sound
velocity, 141
How to configure your
survey, 113

How to convert a profile
using SVP Editor, 147
How to convert the SVP
format, 143
How to create and use
a geotiff background
picture, 166
How to define a new
projection, 122
How to display a smooth
surface, 165
How to display planned
lines, 206
How to display realtime
depths, 161
How to display seabed
imagery data, 162
How to display sound
velocity at transducer, 163
How to do a calibration, 181
How to enter parameters
for a new survey, 118
How to enter survey
parameters, 114
How to export data, 206
How to export survey
results, 207
How to import a
Neptune grid, 159
How to interface an EA
into SIS, 155
How to log stave data, 170
How to log water
column data, 170
How to look for
artefacts, 165
How to modify and load
a SVP, 151
How to modify the
installation parameters, 127
How to modify the
runtime parameters, 134
How to monitor the
external sensors, 160
How to monitor the
progress, 202
How to open the
installation parameters, 126
How to open the runtime
parameters, 134
How to plan a new job, 201
How to retrieve a
planned job, 202
How to run the PU
simulator, 203
How to run the survey, 202
How to save data, 169

How to setup enter the
waterline for EA, 139
How to setup the input
from external sensors, 137
How to setup the output
to external sensors, 139
How to start pinging, 160
How to start SIS, 112
How to start the echo
sounder, 154
How to start the remote
helmsman display, 206
How to use csv2asvp, 143
How to use macros to
convert a profile using
SVP Editor, 149
How to use SeaCal, 184
How to use SIS
Calibration, 181
How to use SIS on
AUV/ROV, 460
How to use SmartTalk, 142
How to use start and
stop logging, 169
How to use SVP Logger, 143
How to use SVP
manager, 145
How to verify the EM
main functions, 161
Installation parameters
interface, 126
Interface, 136
Normal operational
sequence, 110
Outer beam angle
calibration, 179
Perform a system
calibration, 171
Pitch offset calibration, 174
Plan a survey, 199
Playback, 203
Precise Point
Positioning, 478
Projection definition, 122
PU communication, 127
Remote Helmsman
display, 206
Replay, 203
Roll offset calibration, 173
Runtime parameters
interface, 133
Sensor setup, 130
Set projection, 113
Sound speed, 135
Sound velocity interface, 137
Sound velocity quality
inspection, 178
Sounder main, 134
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Storage options, 119
Survey templates
handling, 114
System parameters, 132
Terrapos, 478
Time delay calibration, 174
User handling, 114

Projection, 384
Available ellipsoids, 386
Available projections, 387
How to, 122
Parameters, 269
Programming, 513
Reference, 513
Test, 385
Using PROJ.4, 513

PU, 86
Clock parameters, 281
Export, 364
Factory settings, 367
Import, 366
Input parameters, 275
Open, 366
Output parameters, 279
Save, 364
Sensor status, 86
Simulator, 449

Q
Qinsy ®, 22
Quick menu, 59
Quit, 370

R
Raypaths chart, 401
Real time data cleaning, 492
Real time tide, 373
Datagram format, 518

Registered trademarks, 14
Remote datagrams, 568
Remote Helmsman
display, 206
Remove instruments, 378
Replay, 449
Request datagrams, 559
Request datagrams
manually, 561
ROV specific
EM 2040, 291

RTCM logging, 324
Runtime parameters, 297
ATH logging, 323, 325
Data cleaning, 317
Description, 95
Filter and gains EM
2040, 310
GPS and delayed heave, 323

How to, 134
PPP logging, 327
Procedures, 125
RTCM logging, 324
Simulator EM 2040, 329
Sound speed EM 2040, 305
Sounder main EM 2040, 297
SRH logging, 326
Survey information, 332

Runtime parameters Mini, 96

S
Scale, 53
Auto scale once, 54
Fixed scale, 54

Scope display, 81
Buttons, 81
Show/Hide, 247
Toolbar, 81

Seabed image, 66
Buttons, 66
Show/Hide, 231
Toolbar, 66

Seabed Image Processing, 322
Seacal, 409
How to, 184
Results, 381
Wizard, 380

SeaCal
Parameters, 261

SeaCast, 405
Sensor layout, 98
Buttons, 98
Keyboard, 45
Mouse, 45
Show/Hide, 258
Toolbar, 98

Set parameters, 333
APOS, 347
Auto pilot, 343
Display, 339
Error model, 346
Logging, 341
Network licence, 345
Password, 338
Positions, 335
Projections, 351
Sensor options, 348
Ship, 334
Sound speed, 344
Startup options, 350
Turn, 337

Simulator, 297
EM 2040, 329

SIS, 15
About, 392
Architecture, 487

As a controller, 22
Basics, 15
Build info, 391
Central Command Unit, 489
Configure, 382
Data Distribution
System, 489
Database, 491
Graphical User
Interface, 488
GridEngine, 490
Handle Data
Distribution System, 489
Help, 391
Licences, 16
Logging formats, 573
Network licence, 345
OpenGL, 392
Operational principles, 21
Password, 338
Processes, 487
SISDB, 491
System drawing, 17
System information, 16
System overview, 18

SIS data logger
PU sockets, 439
SIS sockets, 435

SIS Objects, 417
SIS overview, 18
Geographical window, 19
GPS RTK input, 20
Instrument control, 18
MBE support, 18
Precise point
positioning, 21
Real time data cleaning, 19
ROV operations, 20
SBE support, 19
Seabed image, 20
SIS objects, 21
Water column imaging, 20

SIS parameters, 333
SIS sockets, 435
remarks, 437

SmartTalk
How to, 142

Sound speed, 297
EM 2040, 305

Sound speed and density
format, 548
Sound speed profile format, 544
Sound velocity, 79
Buttons, 79
Collect, 141
Convert SVP format, 143
Editor, 395
Formulas, 502
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How to, 139
Keyboard, 45
Logging, 141
Mouse, 45
Procedures, 139
Quality inspection, 178
SeaCast, 405
Set parameters, 344
Show/Hide, 247
SVP Logger, 406
Toolbar, 79

Sounder main, 297
EM 2040, 297

SRH data format, 555
SRH logging, 326
SSP datagrams, 539
Status bar, 42
Stave display, 83
Buttons, 83
Logging, 249
Show/Hide, 249
Toolbar, 83

Stop, 370
Survey administration, 91
CUBE parameters, 273
GridEngine parameters, 269
Parameters, 263
Projections, 269
User handling, 272

Survey information, 332
Survey parameters, 263
How to, 114

Survey plan file format, 538
SVP Editor, 395
Convert a profile, 147
Convert a profile using
macro, 149
Display, 396
File menu, 397
Modify and load to SIS, 151
Raypaths chart, 401
SVP effects, 401
Tools menu, 398

SVP Effects, 401
SVP logger, 375
SVP Logger, 406
How to, 143

System drawing, 17
System parameters, 274
EM 2040, 292

System report, 296

T
Tear-off windows, 39
Technical reference, 486
Terrain referenced
position, 536

Terrapos, 477
TerraPOS data format, 556
Tide, 518
Time series, 72
Buttons, 72
Clear plot, 241
Show/Hide, 238
Toolbar, 72

Timing, 498
Toolbar, 33
Beam intensity, 61
Calibration, 100
Colour coded depth, 63
Cross track, 64
Current echo sounder, 36
Frame toolbars, 35
Geographical, 57
Helmsman Display, 70
Line counter, 37
Main toolbar, 33
Not started, 35
Scope display, 81
Seabed image, 66
Sensor layout, 98
Sound velocity, 79
Status bar, 42
Stave display, 83
Time series, 72
Water column, 78
Waterfall, 73

Tools menu, 105
TPU format, 530
Trademarks, 14
Trimble
Details, 520

Turn parameters, 337

V
Vessel coordinate system, 496
View menu, 105

W
Water column, 75
Buttons, 78
Keyboard, 46
Logging, 247
Mouse, 46
Show/Hide, 243
Toolbar, 78

Waterfall, 73
Buttons, 73
Keyboard, 45
Mouse, 45
Show/Hide, 241
Toolbar, 73

Windows, 27
Contents, 55

Tear-off, 39

Z
Zoom, 51
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